Topics

Connecting FT450D for WJTX with SCU-17 #mfj-1234

Tony Lipari
 

I have looked through the treads not having much luck finding information on hooking up my Yaseu ft450. I would like to run this radio as a 2nd radio on the RigPi. I currently run the digital through the SCU-17 box which uses CAT controller function. So I have only 1 USB cable running to the computer . The error message I get is:

TEST MODE Radio: 2
User: FT450
Radio: 2
User: FT450
Radio from settings: 2
Port from settings: /dev/ttyUSB1
ID from settings: 127
RigDo.php rigDoPID from settings: 0
service_port: 4534
To see any error details, click Disconnect Radio then start rigctld in Terminal with this line:

rigctld -m 127 -r /dev/ttyUSB1 -t 4534 -s 4800 --set-conf stop_bits=1 --set-conf dtr_state=ON --set-conf rts_state=ON > /dev/null 2>&1 &

rigctld processes running:

www-data 1467 1.1 0.4 14728 3908 ? Sl 12:03 0:01 rigctld -m 373 -r /dev/ttyUSB0 -t 4532 -s 115200

Startup of FT-450 failed:
rigctld processes running:

www-data 1467 1.1 0.4 14728 3908 ? Sl 12:03 0:01 rigctld -m 373 -r /dev/ttyUSB0 -t 4532 -s 115200

socket_connect() failed (2).
Reason: () Connection refused

Connection failed (1), check radio port settings. Is the radio on?

can any one help me out?
Primary radio is working great, Thanks to Harold  W5ZTT.

--
Tony k2fpc

Larry
 

Hello,

I was able to get the Yaesu SCU-17 USB interface to work with the RigPi Station Server (RSS).  The initial setup to access the radio, in my case a FT-817ND (as well as a FT-857 which has the same connections), was accomplished through the RSS Express Setup feature.  The key thing to remember is that the SCU-17 has a two USB channels, and it's important that the "/dev/ttyUSB0" option is selected for the  "R Port" in the basic or advanced radio settings in the RSS.

Once I set up the basic radio configuration I was able to control the radio from my phone and a computer located on my home network.  I wasn't, however, able to hear any audio on my Android phone using the Plumble client software.  Knowing that Yaesu is including USB in some newer radios, and after a bit of digging, I found out that the SCU-17 is (mostly) the same circuit as what's used in the radios with built in USB, I followed Harold Rosee's instructions for setting up audio on the Yaesu FT-991(a) radio.  THANKS Harold!!!

Here is a copy of his instructions from the "Complete Yaesu FT-991/991a Setup Instructions" message thread so that you don't have to dig through the messages:

RigPi Audio Settings for USB Audio.
  1.  On the RigPi desktop RIGHT click on Speaker icon in the top right hand corner of the screen.  For the USB cable It needs to have a check mark by the "USB Audio CODEC".  Select it if not already checked.
  2. Your mumble menu should showing on the desk top.  If not click on the lips at the top right of the screen.  This will bring the main Mumble menu into view.
  3. On the Mumble menu go to Configure>settings>audio input tab on left.  Verify the Device to the right is set to default.  If not use the drop down menu to set it to default.
  4. Press Apply at the bottom . Do NOT press OK yet.
  5. Now on the left hand side of the menu move down to the next menu by selecting "Audio Output" and  as you did in step 3 verify the device is set to Default. If not set it to default.
  6. Set the Output delay slider to "50ms". This ensures no TX audio dropout's at some installations.
  7. Press Apply. This time press OK.  The configuration menu goes away.
  8. THIS Step IS IMPORTANT To save your Mumble changes you must Quit Mumble and Reboot. To do this,  on the main mumble screen now showing press Server>Quit Mumble.      *Mumble menu will go away*    
  9. Go to the Raspberry icon at the top left of the screen and after pressing on it select "Shutdown". It is the last selection and will bring up another menu usually in the middle of the screen.  Please select "Reboot"
  10. When the system comes back up Verify any changes you have made are still there. If not start over and take your time.

Once I performed the steps outlined in Harold's instructions I now have receive audio  Make sure to turn the receive volume control on the SCU-17 all the way up.

A few points to consider:

1.  The Yaesu SCU-17 configuration steps should be the same for any of the radios it supports since you are configuring the RSS to work with the SCU-17.  The only exception I see is the CAT interface rate, which should be set in the radio to the higest speed.

2.  The SCU-17 connects to the data jack and CAT jack on the Yaesu radios, and on some Yaesu radios transmitting through the data jack is only enabled when a data mode is selected.  I don't know if this is how your FT450D works, but in looking at the manual it appears to be the case.  There may, however, be a way to transmit audio by configuring the "D TYPE" menu to either USER-L or USER-U.  See the Packet information on Page 7, Miscellaneous AFSK-Based Date Modes on Page 76, and D TYPE menu options on Page 82 of the FT-450D manual for information on settign the data option to LSB or USB.

Good luck, and 737

Larry
K0LEJ










Larry
 

Hi,

One other thing:  You may not have a transmit issue since you are working with WJTX, which is a digital mode.  The issue with some Yaesu radios transmitting thought the data port is when the radio is set to SSB, AM, or FM.

73,

Larry
K0LEJ

Tony Lipari
 

Thank you I will try this later as I am not home.


From: RigPi@groups.io <RigPi@groups.io> on behalf of Larry <k0lejham@...>
Sent: Sunday, June 30, 2019 12:36:41 PM
To: RigPi@groups.io
Subject: Re: [RigPi] Connecting FT450D for WJTX with SCU-17 #mfj-1234
 
Hi,

One other thing:  You may not have a transmit issue since you are working with WJTX, which is a digital mode.  The issue with some Yaesu radios transmitting thought the data port is when the radio is set to SSB, AM, or FM.

73,

Larry
K0LEJ

--
Tony k2fpc