ICOM 7100 and Fldigi


jlwilliams03@...
 

I've  got my 7100 working with RigPi, Mumble, etc.  All is well there.

However, I'm having an issue with Fldigi regarding a "Port Audio Device Not Available" message.  (As an aside, WSJTX works great, no problems.)

Here is my workflow:
1.  Start off with a reboot.
2.  Quit the Mumble client.
3.  Bring up RigPi and connect to radio.
4.  Start Fldigi.
5.  Configure > Sound Card > Devices.

I see that USB Audio Codec -  (hw:1.0) is selected for capture and playback.  But the Port Audio checkbox is not selected; only File I/O is checked.

6.  Checked the Port Audio box and got a pop-up message "Port Audio Device is not Available".

I'm stuck there.  On the Fldigi googles I see that this has come up in the Windows world due to Windows updates.  I haven't found a smoking gun in the RPi/Linux world yet.

Has anyone else encountered this, either with a 7100 an Icom radio, or any radio?

73
Jeff/WJ5FF


Howard Nurse, W6HN
 

Hi Jeff,

Yes, I’m seeing the Port Audio issue with the audio from my IC7300. Fldigi works fine with the RigPi Audio board, but Fldigi is balking with audio from the 7300 CODECs. We may have to go to the Fldigi forum for assistance.  I’ve not had much time to troubleshoot yet.

Howard W6HN 

X

On May 26, 2019, at 8:41 AM, jlwilliams03@... wrote:

I've  got my 7100 working with RigPi, Mumble, etc.  All is well there.

However, I'm having an issue with Fldigi regarding a "Port Audio Device Not Available" message.  (As an aside, WSJTX works great, no problems.)

Here is my workflow:
1.  Start off with a reboot.
2.  Quit the Mumble client.
3.  Bring up RigPi and connect to radio.
4.  Start Fldigi.
5.  Configure > Sound Card > Devices.

I see that USB Audio Codec -  (hw:1.0) is selected for capture and playback.  But the Port Audio checkbox is not selected; only File I/O is checked.

6.  Checked the Port Audio box and got a pop-up message "Port Audio Device is not Available".

I'm stuck there.  On the Fldigi googles I see that this has come up in the Windows world due to Windows updates.  I haven't found a smoking gun in the RPi/Linux world yet.

Has anyone else encountered this, either with a 7100 an Icom radio, or any radio?

73
Jeff/WJ5FF


Howard Nurse, W6HN
 

Jeff, I posted the “Port Audio device” issue on the Fldigi forum, linuxhams.  No response yet, when I do hear I will report here.  I find that the Playback set to Default works correctly.  It is only Capture that has an issue.

—Howard


jlwilliams03@...
 

Thanks Howard.  I'll have a look.  I did run fldigi in debug mode and the message it is returning is 

'PaAlsaStreamComponent_InitialConfigure( &self->capture, inParams, self->primeBuffers, hwParamsCapture, &realSr )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 2719

Expression 'PaAlsaStream_Configure( stream, inputParameters, outputParameters, sampleRate, framesPerBuffer, &inputLatency, &outputLatency, &hostBufferSizeMode )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 2843

E: [13:08:00] trx/trx.cxx:751: Port Audio device not available: No such device or address


I haven't looked at the source to see what's going on there.  I'll share with the linuxham board. 


73

Jeff

WJ5FF 





On Mon, May 27, 2019, 10:25 AM Howard Nurse, W6HN <hlnurse@...> wrote:
Jeff, I posted the “Port Audio device” issue on the Fldigi forum, linuxhams.  No response yet, when I do hear I will report here.  I find that the Playback set to Default works correctly.  It is only Capture that has an issue.

—Howard


Jeff Williams <jlwilliams03@...>
 

I've been troubleshooting this to no avail.  So as a last straw I ran fldigi as root (sudo fldigi) and it worked-- I was able to select  PortAudio without any errors and I got signals in my waterfall.

So, this seems to be permissions related somewhere.

--Jeff 


Howard Nurse, W6HN
 

BINGO!

Thank you, Jeff, for your sleuthing to find this issue.  I have tested with my IC-7300 and Fldigi, and it is working as you describe.  I tried with both the Fldigi ‘default’ and ‘CODEC’ selections for audio devices and they appear to work with no issues.  This will require further testing, but note the audio is provided through my IC-7300 USB cable.

For those who want to experiment with Fldigi, you can start it using the Run... menu option in the Raspberry Pi desktop, program menu (click the Raspberry Pi).  Simply type sudo fldigi as Jeff recommends.

Now to find out why sudo (set permissions to root) is required.

73, Howard W6HN


On Jun 2, 2019, at 8:23 AM, Jeff Williams <jlwilliams03@...> wrote:

I've been troubleshooting this to no avail.  So as a last straw I ran fldigi as root (sudo fldigi) and it worked-- I was able to select  PortAudio without any errors and I got signals in my waterfall.

So, this seems to be permissions related somewhere.

--Jeff 


Dave Downing
 

Has anyone figured out the port audio permissions problem and what needs to be changed?

Thanks,
Dave


Howard Nurse, W6HN
 

Hi Dave,

There is a RigPi installation issue that is causing the fldigi port audio issue.  For the moment it is best to start Fldigi with sudo.  As you probably know, right-click over the Fldigi icon in the Ham Radiomenu, open the Desktop Entry tab and enter sudo fldigi in the Command box. 

The fix is complicated and needs to be thoroughly documented.

73, Howard W6HN