Rigpi with IC-718


Adam Hosa
 

Hi All!

Ahh the joy of living in a condo, and no radio. So I got my rigpi today and still have my ham setup at my moms house. Have the audio cable from the 718 I picked up from MFJ....My problem, the CI-V on the 718 is an 1/8", and I need to interface it with the USB on the rigpi I gather?

Any suggestions on what cable I should use? I had an old rigtalk usb interface that goes from usb to 1/8, but that I assume isnt going to work on the pi.

Thanks for your help
Adam N1AH


Howard Nurse, W6HN
 

Hi Harold,

There are a number of CI-V to USB adapters for sale.  Take a look on eBay to see a wide selection.  The only trouble with the CT-17 is that it provides a classic serial port interface, and you then need a serial to USB adapter.

Your rigtalk may work.  Did you use it to connect a PC to your radio?  If so, give it a try on RigPi before doing anything else.

—Howard


Adam Hosa
 
Edited



Here’s where I’m at...
Adam


Adam Hosa
 

Also tried this, looks like it connects?


Michael Young
 

Hi Adam,

At Hamvention but will try to help.  Also your screenshots get blurry when I zoom in with smartphone.

Goto Settings>System>there’s a button to power down the Pi.  Click it to gracefully power down the Pi. Then cycle the power to power/boot up.  

make sure the 718 is set to the highest baudrate it will support.  

Plugin the 718 to a RigPi USB port using the appropriate cable.

Goto Settings>Radio>Basic and set Manu to Icom, Model to IC-718,Port to dev/ttyUSB0.  Click the cloud to save settings.  

Then goto Settings>Radio>Advanced and click Test Radio.  Hopefully at the bottom of the output rigctl will show a connect.  If successful the tuner page will show the frequency and mode the 718 is tuned to and you should be able to control the radio.  

Sorry if I missed something. Doing this from (old) memory.  

Good Luck

Mike
WB8CXO



On May 18, 2019, at 12:04 PM, Adam Hosa via Groups.Io <Ifone@...> wrote:

<0C87905C-5276-4823-A431-7A64315288A4.png>

Here’s where I’m at...
Adam


Adam Hosa
 

So far no luck. If i try running some commands from the pi terminal (using 313 which is for a 718) Im getting a communication bus error. Saw some posts somewhere about having to turn off CI-V transceive on icom radios (which I did). Dont know if i need to maybe specifically set baud rate on the 718 and rigpi? Tinkering around with it. I had several cables laying around which i thought should work for CIV (have the USB end with that 'converter) and 1/8 " on the other for the rig. Enjoying myself, hasnt exactly been plug-n-play yet, but somehow i'll figure it out  :)


Michael Young
 

I’ve not used CI-V on an IC-718 myself so we’re both learning until someone else who has jumps in to help!

To learn more about it refer to the 718’s user manual and Hamlib.   User manual is easy so that’s what I looked at first.  I even looked at a couple you tube videos to see how it works.   I could not find in the manual exactly what RANGE of BAUD RATES the 718 supports but I did see an AUTO selection.   AUTO would be one thing to try but I just looked at Hamlib docs and they indicate max baud rate is 19,200, 8n1 BUT the 718 manual doesn’t specifically indicate how to to change baud rate to a specific speed.  Having a 718 to play with would possibly expose that unknown.   But I would try CI-V to AUTO on the 718... or if you can figure out with the radio how to set a specific speed to 19,200, do that. Set/verify the CI-V address to 5E, (the default), CI-V transceive to on (the default), CI-V 731 mode to off (the default).   For RigPi Settings>Radio>Basic>Manu Icom, model IC-718, port /dev/tty/USB0. Everything else to default.  Settings>Radio>Advanced use all the default settings for now.  Click test radio, see what happens.  I’m doing this from memory with no support hardware (RigPi) in front of me.  4 hours of HamVention left!

Can be easy, can be difficult...

Hopefully someone who has done this will jump in and help us...

73
Mike
WB8CXO

On May 18, 2019, at 7:45 PM, Adam Hosa via Groups.Io <Ifone@...> wrote:

So far no luck. If i try running some commands from the pi terminal (using 313 which is for a 718) Im getting a communication bus error. Saw some posts somewhere about having to turn off CI-V transceive on icom radios (which I did). Dont know if i need to maybe specifically set baud rate on the 718 and rigpi? Tinkering around with it. I had several cables laying around which i thought should work for CIV (have the USB end with that 'converter) and 1/8 " on the other for the rig. Enjoying myself, hasnt exactly been plug-n-play yet, but somehow i'll figure it out  :)


Howard Nurse, W6HN
 

Hi Adam,

(Thanks, Mike, for your help with the 718.)

Here is additional info:

1. The IC-718 Baud rate can be set using the menu selection for AutoBaud.  Default is “At” which is automatic.  Other fixed values can be found in the AutoBaud list.  Select the highest Baud rate in that list.  This is what Hamlib uses for their default.

2. The menu selection CI-V Transceive (which sends unsolicited data from the radio), must be OFF or RSS will get confused.

3. In other messages we have described how to use the Raspberry Pi Terminal to bypass RigPi.  You’ve done that, but try again after making the changes in 1 and 2.  If you get a prompt “Command:” you are good.  Type an F followed by a return to read the radio’s frequency.  If you see the frequency you can start celebrating.

4. Use Ctrl+C to exit the rigctl program.  Open a RigPi browser and go to Advanced Radio settings.  Make all boxes say Default.  Try Connect Radio.  If it fails, use Disconnect Radio, then try the Test button.  As Mike said, the images you sent need to be higher resolution so we can read them.

There is a possibility the cable you are using for CI-V to USB is not correct, or may be bad...

We WILL get you going!

73, Howard W6HN


Adam Hosa
 

There’s 9600 and ‘hi’ in the civ baud selection. Trying hi, even though I can’t find any documentation on what hi is haha


Adam Hosa
 

I have some good news! Finally got it connected! I can control the rig from my Ipad. 

Next question: Audio and Transmit

I have the cable from MFJ I purchased to go from the rig to the RJ45 on the Pi. Is that all i 'should' need? Tried keying up CW but doesnt key the rig. Do I need to also interface with some of the other 1/8" jacks on the pi, or should the MFJ cable handle that? Same question about audio out since I dont hear anything yet. 

Thanks Again!

Adam


Mark Weisheimer
 

You should be good with that cable for audio and keying.
There may be a configuration for the '718 to set audio to and from the DIN port.
For RigPi audio issues, the Help files are really a good way to work through those issues.

https://rigpi.net/help/

Go the Technical at the bottom, then Troubleshooting, then No RigPi audio.

Let us know if that doesn't get you there.

73 - Mark - K8MHW


Adam Hosa
 
Edited

I ran the command noted on that page to look for errors. Do these mean anything?


[    3.714059] audioinjector-stereo soc:sound: ASoC: CPU DAI (null) not registered - will retry
[    3.714078] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[    3.719910] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[    3.719929] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[    3.814529] audioinjector-stereo soc:sound: wm8731-hifi <-> 3f203000.i2s mapping ok


Mark Weisheimer
 

That is a very small screen shot...

The last line is the sound card that RigPi is using and it is fine.

Here is my listing and the audio works as it should. I did need to run Alsamixer (using Terminal) and set the input to Mic with 0db of boost using the F6 command.
After bringing up the menu via F6, use the cursor keys to select the Input Mux and cursor to Mic.

[    3.692649] audioinjector-stereo soc:sound: ASoC: CPU DAI (null) not registered - will retry
[    3.692668] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[    3.705695] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[    3.705715] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[    3.763471] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[    3.763490] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[    3.843223] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[    3.843244] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[    3.892172] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[    3.892189] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[    3.911719] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[    3.911736] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[    4.038800] audioinjector-stereo soc:sound: wm8731-hifi <-> 3f203000.i2s mapping ok

So try that and let us know...


Adam Hosa
 

No Luck, this is what I have now, looks like yours, still no sound

[    3.716001] audioinjector-stereo soc:sound: ASoC: CPU DAI (null) not registered - will retry
[    3.716022] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[    3.718583] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[    3.718605] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[    3.836339] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[    3.836358] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[    3.853167] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[    3.853181] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[    3.967566] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[    3.967583] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[    3.967865] audioinjector-stereo soc:sound: ASoC: CODEC DAI wm8731-hifi not registered - will retry
[    3.967876] audioinjector-stereo soc:sound: snd_soc_register_card failed (-517)
[    3.989109] audioinjector-stereo soc:sound: wm8731-hifi <-> 3f203000.i2s mapping ok
pi@rigpi:~ $


Mark Weisheimer
 

It appears that you should have sound if the radio is outputting sound.
Have you tested the audio output of the radio, perhaps by playing it through an amplified speaker from a PC?
--
73 - Mark - K8MHW


Adam Hosa
 

Ill have to try that next, still no luck. One thing Im confused of, do I need mumble running on my laptop along with the UI for the rig to get audio?


Manuel Maseda
 

Yes you do.

On May 19, 2019, at 11:04 PM, Adam Hosa via Groups.Io <Ifone@...> wrote:

Ill have to try that next, still no luck. One thing Im confused of, do I need mumble running on my laptop along with the UI for the rig to get audio?


Adam Hosa
 

Ahh, I thought once I bring up the Control page on my ipad and connect to the radio, I should be able to just PTT to talk or send CW from some macros right away. Didnt realize I needed to start mumble on the ipad then open the web interface. Of course I still have no sound that I'm working on. I did connect mumble to rss on the ipad last night but just heard myself echoing.


Michael Delaney
 

Has anyone gotten the IC-718 connected to the RigPi.  I updated to RigPi2 and have not had any luck.  Using the 13 pin to usb.  If I use the programming cable, it does connect, but that leaves Mic/Spkr connections yet.  I have other radios, but the Icom is my most recent purchase.  tnx & 73