Topics

Apache-Labs - 100D connection to PC


WA8KHP -
 

Has anyone connected the RigPi to a PC that has PowerSDR for an Apache-Labs 100D and doing remote communications?

Or a FLEX 6xxx series with SmartSDR and using an Android browser to communicate remotely?

What are the issues making these type of connection?  I have Virtual Serial Ports working.  Audio - Line In/Out needed?  Probably a USB to Serial cable for CAT control?

Will block diagrams of different radio connections be published on the RigPi.net/Help?

I have a RigPi on order but it maybe a very long time before MFJ ships and clears all of the backorders!

Thanks, looks to be a GREAT product.
73
David - WA8KHP


Howard Nurse, W6HN
 

Hi David,

Welcome to the RigPi Group!

I suspect the answer is to use a TCP connection to the radio rather than a USB port.  None of the Beta team has a Flex as far as I know, but you can connect RigPi to a TCP/Port just as easily as to a COM port.

--Howard


WA8KHP -
 

Thanks for quick response and GREAT hardware/software!

The Serial Port Redirector software for TCP  cost $100 vs $25 for a USB to serial port adapter using FTDI hardware and a Null modem cable.
https://www.fabulatech.com/serial-port-redirector.html

The Serial Port Redirector is over all a better solution but many hams will have the USB to serial adapter and Null modem cable in their junk box.

Looking forward to updated documentation for different hardware connections.

73

David - WA8KHP
 
 


Michael Young
 

Howard, sdrcat allows the user to map the radio serial data control to tcp.   All of the slices (equivalent to a receiver) the radio supports can be mapped   I’m wondering how to set up the RigPi for tcp.  

Flex 6000 owners for the most part would rather use Smartlink and a SDR client but RigPi could be a good backup, I guess.  

If there is a tcp VCP that would work for SDR’s that must be run from a pc.  

Mike
WB8CXO

On Apr 19, 2019, at 5:02 PM, Mike <wb8cxo@...> wrote:

Howard, I have a Flex 6000 series radio...  can you elaborate on how to use tcp to connect to the RigPi.   Do you use a port or something?  Thanks, Mike, WB8CXO

On Apr 19, 2019, at 4:25 PM, Howard Nurse <hlnurse@...> wrote:

Hi David,

Welcome to the RigPi Group!

I suspect the answer is to use a TCP connection to the radio rather than a USB port.  None of the Beta team has a Flex as far as I know, but you can connect RigPi to a TCP/Port just as easily as to a COM port.

--Howard


Michael Young
 

Howard, I have a Flex 6000 series radio...  can you elaborate on how to use tcp to connect to the RigPi.   Do you use a port or something?  Thanks, Mike, WB8CXO

On Apr 19, 2019, at 4:25 PM, Howard Nurse <hlnurse@...> wrote:

Hi David,

Welcome to the RigPi Group!

I suspect the answer is to use a TCP connection to the radio rather than a USB port.  None of the Beta team has a Flex as far as I know, but you can connect RigPi to a TCP/Port just as easily as to a COM port.

--Howard


Howard Nurse, W6HN
 

Hi Mike,

 

You can connect to any radio on the Internet, so long as it can be accessed through an IP and a port.  In Radio Settings, use the normal radio Manuf and Model.  In the port box put 192.168.1.xx:nnnn.  Substitute the radio IP and the radio port.  (If the radio is off site you will have to set up port forwarding in your router.)

 

If each slice has its own Port you can open as many slices as you want through their own browsers, until the RSS starts to choke.  It would be cool to try that!

 

--Howard

 

From: RigPi@groups.io [mailto:RigPi@groups.io] On Behalf Of Michael Young
Sent: Friday, April 19, 2019 2:02 PM
To: RigPi@groups.io
Subject: Re: [RigPi] Apache-Labs - 100D connection to PC

 

Howard, I have a Flex 6000 series radio...  can you elaborate on how to use tcp to connect to the RigPi.   Do you use a port or something?  Thanks, Mike, WB8CXO


On Apr 19, 2019, at 4:25 PM, Howard Nurse <hlnurse@...> wrote:

Hi David,

Welcome to the RigPi Group!

I suspect the answer is to use a TCP connection to the radio rather than a USB port.  None of the Beta team has a Flex as far as I know, but you can connect RigPi to a TCP/Port just as easily as to a COM port.

--Howard


HH Brakob
 

Does rigpi require a stable IP address?  

I would love to operate my home station from my snowbird RV in Arizona.


73, de Hans, KØHB
“Just a Boy and his Radio”
 


From: rigpi@groups.io on behalf of Howard Nurse <hlnurse@...>
Sent: Friday, April 19, 2019 6:14 PM
To: rigpi@groups.io
Subject: Re: [RigPi] Apache-Labs - 100D connection to PC
 

Hi Mike,

 

You can connect to any radio on the Internet, so long as it can be accessed through an IP and a port.  In Radio Settings, use the normal radio Manuf and Model.  In the port box put 192.168.1.xx:nnnn.  Substitute the radio IP and the radio port.  (If the radio is off site you will have to set up port forwarding in your router.)

 

If each slice has its own Port you can open as many slices as you want through their own browsers, until the RSS starts to choke.  It would be cool to try that!

 

--Howard

 

From: RigPi@groups.io [mailto:RigPi@groups.io] On Behalf Of Michael Young
Sent: Friday, April 19, 2019 2:02 PM
To: RigPi@groups.io
Subject: Re: [RigPi] Apache-Labs - 100D connection to PC

 

Howard, I have a Flex 6000 series radio...  can you elaborate on how to use tcp to connect to the RigPi.   Do you use a port or something?  Thanks, Mike, WB8CXO


On Apr 19, 2019, at 4:25 PM, Howard Nurse <hlnurse@...> wrote:

Hi David,

Welcome to the RigPi Group!

I suspect the answer is to use a TCP connection to the radio rather than a USB port.  None of the Beta team has a Flex as far as I know, but you can connect RigPi to a TCP/Port just as easily as to a COM port.

--Howard


WA8KHP -
 

Yes, you will need a DDNS service and a static IP address for RSS RigPi on UR router.  If U are lucky UR ISP might not change UR IP web address or give U a very long lease time.   Check out the RigPi.net/help for more information.

73
David + WA8KHP

On Sat, Apr 20, 2019, 2:36 PM HH Brakob <kzerohb@...> wrote:
Does rigpi require a stable IP address?  

I would love to operate my home station from my snowbird RV in Arizona.


73, de Hans, KØHB
“Just a Boy and his Radio”
 

From: rigpi@groups.io on behalf of Howard Nurse <hlnurse@...>
Sent: Friday, April 19, 2019 6:14 PM
To: rigpi@groups.io
Subject: Re: [RigPi] Apache-Labs - 100D connection to PC
 

Hi Mike,

 

You can connect to any radio on the Internet, so long as it can be accessed through an IP and a port.  In Radio Settings, use the normal radio Manuf and Model.  In the port box put 192.168.1.xx:nnnn.  Substitute the radio IP and the radio port.  (If the radio is off site you will have to set up port forwarding in your router.)

 

If each slice has its own Port you can open as many slices as you want through their own browsers, until the RSS starts to choke.  It would be cool to try that!

 

--Howard

 

From: RigPi@groups.io [mailto:RigPi@groups.io] On Behalf Of Michael Young
Sent: Friday, April 19, 2019 2:02 PM
To: RigPi@groups.io
Subject: Re: [RigPi] Apache-Labs - 100D connection to PC

 

Howard, I have a Flex 6000 series radio...  can you elaborate on how to use tcp to connect to the RigPi.   Do you use a port or something?  Thanks, Mike, WB8CXO


On Apr 19, 2019, at 4:25 PM, Howard Nurse <hlnurse@...> wrote:

Hi David,

Welcome to the RigPi Group!

I suspect the answer is to use a TCP connection to the radio rather than a USB port.  None of the Beta team has a Flex as far as I know, but you can connect RigPi to a TCP/Port just as easily as to a COM port.

--Howard


Howard Nurse, W6HN
 

Hi Hans,

Welcome to the group, nice to have you here.  You and I have talked much about CommCat in the past.

The answer to your question has several parts, but, yes, you need to know the IP of your home station when accessing from a remote location.

The first important IP is your home Internet IP.  You can use a dyn service to solve that.  (My IP here at home...Comcast...hasn’t changed in many years, but I still keep use a service.)

The IP of the RigPi box on your LAN also has to remain constant because you need to open a port on your router to that IP.  (Mine stays pretty constant despite rebooting frequently.) There are articles on the Internet showing how to make the raspberry pi stick to a static IP, with a link for one article in Help.

The final answer has to do with connecting while at home.  The RSS uses a domain name “rigpi.local” which can be used to connect when you are on your home network.  It uses a service called Bonjour to broadcast the name and IP to other computers on the same network.  (Android devices do not support Bonjour, so you have to use the IP.)

Bottom line:

1. Internet IP for your home must be known.
2. LAN IP for the RSS must be constant so the router can access it.
3. At home you may be able to I use rigpi.local depending on the computer you are using.

—Howard


Tom W5KUB <Tom@...>
 

To access the rigpi from outside your home network, you will need to open the port on your home router to the local ip address that rigpi has.  Plus you will need to know your public ip address.   You can get that by typing "whats my ip" in a google search and you can find your public ip.  Public IP address stay with you for up to months and months sometimes, but if your router rebooted etc, you may get a different public ip address.   the best way is to pay or find a free service that will always know your public ip even if it changes.  for example i use dyndns.org.      my address is now w5kub.dyndns.org     dyndns knows if your ip changes and it assigns the new address to your address such as w5kub.dyndns.org
Tom W5KUB


Host of live ham show called Amateur Radio Roundtable every Tues night at 8:00 PM central. All shows are recorded and can be watched at any time on on our website. Our audio is also simulcast on international shortwave on 5130 Khz.   We are also on every podcast carrier if you are looking for an audio version of our program.


On Sat, Apr 20, 2019 at 1:36 PM HH Brakob <kzerohb@...> wrote:
Does rigpi require a stable IP address?  

I would love to operate my home station from my snowbird RV in Arizona.


73, de Hans, KØHB
“Just a Boy and his Radio”
 

From: rigpi@groups.io on behalf of Howard Nurse <hlnurse@...>
Sent: Friday, April 19, 2019 6:14 PM
To: rigpi@groups.io
Subject: Re: [RigPi] Apache-Labs - 100D connection to PC
 

Hi Mike,

 

You can connect to any radio on the Internet, so long as it can be accessed through an IP and a port.  In Radio Settings, use the normal radio Manuf and Model.  In the port box put 192.168.1.xx:nnnn.  Substitute the radio IP and the radio port.  (If the radio is off site you will have to set up port forwarding in your router.)

 

If each slice has its own Port you can open as many slices as you want through their own browsers, until the RSS starts to choke.  It would be cool to try that!

 

--Howard

 

From: RigPi@groups.io [mailto:RigPi@groups.io] On Behalf Of Michael Young
Sent: Friday, April 19, 2019 2:02 PM
To: RigPi@groups.io
Subject: Re: [RigPi] Apache-Labs - 100D connection to PC

 

Howard, I have a Flex 6000 series radio...  can you elaborate on how to use tcp to connect to the RigPi.   Do you use a port or something?  Thanks, Mike, WB8CXO


On Apr 19, 2019, at 4:25 PM, Howard Nurse <hlnurse@...> wrote:

Hi David,

Welcome to the RigPi Group!

I suspect the answer is to use a TCP connection to the radio rather than a USB port.  None of the Beta team has a Flex as far as I know, but you can connect RigPi to a TCP/Port just as easily as to a COM port.

--Howard


WA8KHP -
 

I was successful  connecting a RigPi to a PC using two, USB to SERIAL cables with FTDI chips and a Null modem cable between the two cables.  This gave me a USB to USB connection between devices.  I was able to get CAT control to work on PowerSDR for my Apache-Labs 100D to change frequencies and bands from Android phone/Tablet or PC using the Browser interface.  I have no Audio board (RigPi on backorder just Raspberry  Pi) so could not get Analog audio working with my VAC.  I did not try rerouting the Raspberry Pi audio to the Headphone/Microphone jack.

Here are the issues that I found:

1.  Please add Apache-Labs to your Manuf list.  I had to use Kenwood.
2.  Please add PowerSDR Cat Command selection.  I had to use TS2000, TS480 or TS50S.
3.  The PTT button on the Browser would only give a temporary PTT to the radio.  I am sure incorrect CAT Command were issued.        I did not have a sniffer on the line to see what commands were issued.
4.  I was using the CAT+ selection at 115kbs on PowerSDR  for RigPi interface as I  use the main CAT selection for my VSPE interface.
5.  Would you please give me the Linux commands to switch Audio/Microphone ports or must I find them?

I have the PC software to do Serial to Ethernet connect (much better solution than the Serial to USB cables) but I could not figure out how to configure RigPi?  It is referenced in your HELP on Connecting to a Radio through a TCP port, but not implemented yet?

Thanks again for this great product.  Looking forward to meeting you at Dayton.

73
David - WA8KHP


Howard Nurse, W6HN
 

Thanks for the update, David.

 

(David is one of our Beta testers, so is wringing any pesky bugs out of the software.)

 

I can add “look alike” radios to RigPi, but if there are underlying problems with commands, we will have to go to the Hamlib folks.  The simplest way users can add a radio not in the list, but one that works using an existing radio, is to name the radio in Radio Settings appropriately.  For example, set up the Kenwood 2000 and enter the name PowerSDR in the Name box.  The radio will then show on screens and logs as PowerSDR.

 

Once you plug in an alternate audio device, it appears as a selection in the RPi Desktop audio device list you see by right-clicking the Speaker icon at the top right of the Desktop and selecting it to be the default.  You can also select from a list in any of the programs requiring an audio input.

 

To connect RigPi to a radio on another computer, use the Port box in Radio Settings.  It won’t be in the list of available ports, but you can simply type it into the box and it will be saved.  Use the formal 192.168.1.20:4500, substituting the real IP and port you want to use.

 

--Howard

 

From: RigPi@groups.io [mailto:RigPi@groups.io] On Behalf Of WA8KHP -
Sent: Thursday, April 25, 2019 7:29 PM
To: RigPi@groups.io
Subject: Re: [RigPi] Apache-Labs - 100D connection to PC

 

I was successful  connecting a RigPi to a PC using two, USB to SERIAL cables with FTDI chips and a Null modem cable between the two cables.  This gave me a USB to USB connection between devices.  I was able to get CAT control to work on PowerSDR for my Apache-Labs 100D to change frequencies and bands from Android phone/Tablet or PC using the Browser interface.  I have no Audio board (RigPi on backorder just Raspberry  Pi) so could not get Analog audio working with my VAC.  I did not try rerouting the Raspberry Pi audio to the Headphone/Microphone jack.

Here are the issues that I found:

1.  Please add Apache-Labs to your Manuf list.  I had to use Kenwood.
2.  Please add PowerSDR Cat Command selection.  I had to use TS2000, TS480 or TS50S.
3.  The PTT button on the Browser would only give a temporary PTT to the radio.  I am sure incorrect CAT Command were issued.        I did not have a sniffer on the line to see what commands were issued.
4.  I was using the CAT+ selection at 115kbs on PowerSDR  for RigPi interface as I  use the main CAT selection for my VSPE interface.
5.  Would you please give me the Linux commands to switch Audio/Microphone ports or must I find them?

I have the PC software to do Serial to Ethernet connect (much better solution than the Serial to USB cables) but I could not figure out how to configure RigPi?  It is referenced in your HELP on Connecting to a Radio through a TCP port, but not implemented yet?


Thanks again for this great product.  Looking forward to meeting you at Dayton.

73
David - WA8KHP


WA8KHP -
 

Howard,

As previously posted I have been successful connecting RigPi to my 100D Apache-Labs (running PowerSDR) using two USB to Serial cables with a Null Modem cable giving me a USB to USB connection.  My next test is trying to make a TCP connection.

1.  Have you connected your RigPi to a PC using a TCP connection?  Getting both CAT Commands and Audio to work?
2.  If successful TCP connection, what software did you use on PC?
3.  I have a demo version of  The Serial Port Redirector software which ONLY cost $5 for Amateur radio operators if you send them a copy of your license.
     https://www.fabulatech.com/serial-port-redirector.html
4.  In the RPORT on RigPi Radio Settings I use 192.168.1.13:4999 to connect to PC and on the PC I use 192.168.1.30:4999 to connect to RigPI. This is the only change I have done between USB to USB connection that works and trying TCP connection.

Any suggestions?

Thanks

David - WA8KHP


Howard Nurse, W6HN
 

Hi David,

I believe the connection problem may be a client vs server mismatch.  The TCP Port connection on RigPi is a client, not a server. My reading of the Serial Port Director is that it expects to connect to a server.

That said, there may be a solution. CommCat on a PC connects to a different TCP connection on RigPi that is a server.  The port number is 30001.  The downside is that it uses a slightly modified Kenwood/Elecraft command set, so whatever program is used on the PC must use the same.  I’ve tested a bunch with CommCat on a PC and CommCat Mobile for iOS connecting this way, but not with any other programs.

Another possibility is to run a program on the PC that uses Hamlib.  In this case you would connect to the rigctl running on the PC so you would get two-way control.  The port for this scenario on the PC would be 192.168.1.30:4532 assuming only one radio is connected at the PC end.

Obviously further experimentation is required!

Running a Mumble client on the PC connecting to the Murmur server on RigPi works well.  

—Howard


WA8KHP -
 

Thanks Howard,

The Serial Port Director can be configured as either a Client or a Server.

There are several options in SPD that need to be slected.
1.  PROTOCOL - Telenet (RFC2217) or RAW DATA (which gives me control over CTS, DSR, DCD and RING), which is correct?
2.  I have attached the ERROR REPORT that I get when pressing TEST RADIO and I try and connect to port 4999.  It is confusing as the error message references "service_port: 4532"?

I will look into RIGCTL and Hamlib later today.

Onto the Audio issues:

1.  Must I use the MUMBLE CLIENT on PC to get the audio from RigPi?
2.  Does ALL AUDIO from RigPi only goto MUMBLE on the web and then back to a Browser or a PC  audio Port?
3.  I have a USB audio board that I could plug into the RigPi and hardwire to a LINE IN/OUT on the PC.  Is this possible or recommended?
4.  What are my RigPi Audio options?

Thanks again

David - WA8KHP