Date   

Problems adding second account

Richard Gussow
 

Hi everyone,

I successfully connected my MFJ 1234 to my Icom 7300 under my account.  I then wanted to add my son to the account - I set up a user name and password, and tried to do the radio settings for the 7300 exactly as under my account and then tried to connect.  The RigPi keeps reverting to the Hamlib Dummy radio settings.  I have tried deleting the account and setting it up again, but I still get the same problem.  I would appreciate any help on this.

Thanks,

Rich 4Z1JJ 


Re: Rigpi stsrt up

jason kitchens
 

Not sure then since I'm still exploring the rigpi as well.
I know that I received a different error when the radio was turned off or disconnected but did get that error when the port was not selected.
Do you show any additional ports on the drop down menu?

What radio are you setting up?


Re: Rigpi stsrt up

DFP, WB5QEM <dpennisson@...>
 

Thanks Jason. I selected USB zero. Did not work. Thanks Darrell WB5QEM


Re: Rigpi stsrt up

jason kitchens
 

I'm just getting started as well so I may be off base, but do you have the "R" port selected in Settings>Basic Radio?


Rigpi stsrt up

DFP, WB5QEM <dpennisson@...>
 

I recently purchased a Rigpi and after waiting about 6 weeks for power suppl I am trying to get it working.  I am using ethernet connection to the router and a usb cable from the radio. I have completed all the information that I know. When I log in and hit the connect radio button I get an error message "Rig Control not started". The manual is quiet large but I have searched everywhere and cannot find out how to start Rig Control.   Any help will be appreciated.

Darrell WB5QEM


Database question.

Michael Bridak
 

Hi Howard, I got a question for you. First a little background.

When I first got my rpss, I did a dump of the database before adding any users or updating.
Some time later I updated to 1.05 then backed up the sdcard.
Then did a back up of just the html folder in case I wanted to mess around with the code.
The sdcard died. Ran from the backup for awhile but failed to back it up before that copy died... Palm to forehead...

Now the fun part. Started with a fresh PI image.
Loaded apache2, mariadb, php and mods.
Turned off console logging to ttyS0. 
Used visudo to allow the www-data user to do shutdowns reboots etc.
Added www-data to the video group so it can get the Pi temp etc.

pulled in the restored the station db from the original backup.
copied over the saved 1.05 html files made sure they were owned by www-data.

Mostly everything works fine now. Audio, rig-control cw keying etc. 

Only 2 thing that aren't working right are call sign lookups, I have qrz username and password saved but all lookups say they are from rigpi and looks like everyone has w1aw's address and stats.
The other thing is I can't save changes made to the advanced radio setting screen. I get  update failed: Incorrect integer value: 'none' for column `station`.`MySettings`.`Parity` at row 1

Was there a database change/update from the initial rpss release and the 1.05?

Thanks for your time.

Mike k6gte


Re: Wouxun KG-UV980P

BobGM3ZDH
 

You might be able to control the Wouxun using the Remoter equipment. The Wouxun is similar to the Yaesu FT8900 featured here 
http://www.remoterig.com/wp/?page_id=1602


Re: Wouxun KG-UV980P

Glenn VE9GJ
 

Does that radio have a CAT port? If it doesnt you will not be able to control it remotely. It would be audio only.

73
Glenn VE9GJ


On June 18, 2020 6:58:35 AM ADT, "Graham Postlethwaite via groups.io" <gpostlethwaite@...> wrote:
Has anyone used the Wouxun KG-UV980P with a RigPi, I am in the process of setting up a remote operation on my home network, and looking at the quad band Wouxun.


Wouxun KG-UV980P

Graham Postlethwaite
 

Has anyone used the Wouxun KG-UV980P with a RigPi, I am in the process of setting up a remote operation on my home network, and looking at the quad band Wouxun.


Re: Debouncing Macro Buttons

Howard Nurse, W6HN
 

Hi Steve,

You can always abort a CW transmission with the ESC key.

The buffered code is kept in a database field, so outgoing CW continues after a reboot (unless you use ESC).

--Howard


Re: Debouncing Macro Buttons

Steve_KE4LC
 

Hi Harold, I was using the integrated keyboard mouse on my Dell laptop when I observed the macro Keyer command repeats. If anyone was listening, they had to endure five back-to-back CQ calls! Per your request, I switched to a USB mouse and, after a dozen tests, I cannot repeat the phenomenon. Just file it as an observation please in case anyone else encounters it.

One Interesting observation was that the RigPi Keyer kept merrily sending CW to the rig even after I rebooted the RigPi Raspberry Pi from RSS - I guess the Keyer board, still powered, just kept processing buffered code! 😀

Thanks, Steve Wright/KE4LC


Re: Debouncing Macro Buttons

Howard Nurse, W6HN
 

Hi Steve,

Are you using a mouse?  If so, can you try a different mouse?  RigPi executes macros when the tap/click is released.  There currently is no debouncing done, but it can be added.  I've had no reports of repeating macros, but let's see if there are any others who have seen it.


Debouncing Macro Buttons

Steve_KE4LC
 

The RigPi is working great for my needs. One hiccup..
Especially when activating the RigPi Keyer from macro buttons, I notice an occasional disturbing event - one apparent mouse click will repeat the Keyer send string as many as five times.. I am wondering if others have observed this. I have to wonder if other macro events, i.e. CAT commands, etc may be repeating as well. Are there any click timing/debouncing routines in the code that could be added help prevent this from occurring?

Thanks and 73’s, Steve Wright/KE4LC


Re: RigPi allows mumble users to connect but no longer hears user audio #audio #rss #mumble #ft-991a #rigpi. All devices connected to the rigpi mumble server can hear audio streaming from the connected Uaesu 991a but the rigpi mumble server can no longer hear audio being sent from any device. The show connected in the rigpi mumble server window but do not show any activity when sending from any device. #mumble #ft-991a #audio #rss

Howard Nurse, W6HN
 

Mac, can you connect two devices, such as a phone and laptop, to the Mumble server?  Can they hear each other?

--Howard


Re: RigPi allows mumble users to connect but no longer hears user audio #audio #rss #mumble #ft-991a #rigpi. All devices connected to the rigpi mumble server can hear audio streaming from the connected Uaesu 991a but the rigpi mumble server can no longer hear audio being sent from any device. The show connected in the rigpi mumble server window but do not show any activity when sending from any device. #mumble #ft-991a #audio #rss

Mac Jedi
 





Sent from Samsung Galaxy smartphone.


Re: RigPi allows mumble users to connect but no longer hears user audio #ft-991a #rigpi #audio #rss #mumble

Howard Nurse, W6HN
 

Hi Mac,

You can certainly update Mumble to the latest version.  The latest Mumble client is 1.3.  However, it is unlikely the problem you are seeing is caused by using an older version.

Is receive audio working correctly?

If you connect two devices (phone/laptop) to the Mumble server, do they hear each other?

--Howard


Re: RigPi Image available for download from MFJ

Garry Chessen
 

Ok. Thank you. 


On Jun 16, 2020, at 3:52 PM, Howard Nurse, W6HN <hlnurse@...> wrote:

Hi Garry,

Normally one would expect a grace period when a new major update becomes available.  A decision for RigPi 2 has not been made.

--Howard


Re: RigPi Image available for download from MFJ

Howard Nurse, W6HN
 

Hi Garry,

Normally one would expect a grace period when a new major update becomes available.  A decision for RigPi 2 has not been made.

--Howard


RigPi allows mumble users to connect but no longer hears user audio #ft-991a #rigpi #audio #rss #mumble

Mac Jedi
 

RigPi allows mumble users to connect but no longer hears user audio.  Audio is being sent to the RigPi Mumble Server and they show as being connected but when the red lips are active on remote phones or computers, they show only grey inactive lips on the mumble server.  Tried using backup of RigPi and still the same.  Nothing seemingly changed in the setup but rigpi no longer receiving any audio incoming data.

H E L P  or Maybe it is time to abandon RigPi?  Maybe if there is a way to update the Mumble Server but I am at a loss.


Re: RigPi Image available for download from MFJ

Garry Chessen
 

Howard, for those of us who purchased the MFJ1234 this year, are we going to have to pay for the version 2 image or will that be free? I received mine about the 7th of Jan.

1941 - 1960 of 7838