Date   
Re: unable to connect remotely

john ni0k <jasimmons@...>
 

Do you have the required port(s) forwarded in your router?

-de John NI0K

robert sherman via Groups.Io wrote on 4/1/2020 11:16 AM:

At the station i connect fine to my iphone & make contacts ok with good reports. When i go to my remote location i am no longer able to connect to mumble. I may have now messed up the settings at my remote location. Can i get help in setting up mumble again remotely ? Thanks & 73, Bob K2SJP
--
Robert W Sherman

unable to connect remotely

robert sherman
 

At the station i connect fine to my iphone & make contacts ok with good reports. When i go to my remote location i am no longer able to connect to mumble. I may have now messed up the settings at my remote location. Can i get help in setting up mumble again remotely ? Thanks & 73, Bob K2SJP
--
Robert W Sherman

Re: mumble server

Ian McPhedran
 

Try 7388 , I use it every time
 73 Ian

On Mon, 30 Mar 2020 at 21:10, robert sherman via Groups.Io <marceno2=yahoo.com@groups.io> wrote:
all of a sudden i am unable to log into remote mumble server. it keeps saying my server password is incorrect. I tried all i know & still cannot log in remotely. Any ideas?
--
Robert W Sherman

Micom 2/3 support?

Jordan Hayes
 

Has anyone tackled this yet? I checked the archives, but didn't see anything.

/jordan KG6UAE

Re: Mumble not saving Audio Input/Output setting

Kevin K7ZS
 

I had the same issue, turns out the screen resolution was such that the OK / SAVE buttons were hidden. They are at bottom of the screen, and my screen settings caused them to be off screen.  Changed resolution to make the entire screen visible, then the SAVE option was right there 'in plain sight'!

73 Kevin K7ZS

Re: Dummy Not Disconnecting

Frank Wroblewski
 

Howard,

Thanks for your help.  I wasn't clicking the cloud.  I didn't know about clicking the cloud, but that;s no one's fault but my own as I see that info is published in the manual and I missed reading it.  Everything working fine now, thanks for the great product and the phenomenal support your provide.

Frank

Re: mumble server

Howard Nurse, W6HN
 

Hi Robert,

Here are some things to check.

1. Check that the audio settings are correct on the Raspberry Pi desktop by right-clicking the Speaker icon.
2. Check that the audio settings are correct in Mumble>Configure>Settings>Audio In and Audio Out.
3. Are the lips red for the Pi user and your phone user?
4. If not, make sure Mumble in both places is set to Transmission>Continuous.
5. In Mumble on the RPi desktop, go to Configure>Settings>Audio in and temporarily change Transmission to Audio Level, then click Applu.
6.  Dose the bar graph bounce around showing radio noise?

—Howard

Re: Dummy Not Disconnecting

Howard Nurse, W6HN
 

Hi Frank,

After entering the correct data for your radio, try clicking the Cloud icon at the top to save the settings.  Then when you try Test Radio, does it continue to connect to the Dummy radio?

—Howard

Re: How to program or even look at macros

Howard Nurse, W6HN
 

Hi Ken,

You should be able to tap a box in the Macro settings window to set the focus, then use arrow keys/type to change the contents.

—Howard

Re: Yaesu vx-8dr

Howard Nurse, W6HN
 

Hi James,

Welcome to the RigPi forum!

It is possible to use a VX-8dr in a limited way.  The radio does not have the ability to change frequency, etc, via CAT commands.  For single channel operation, you can use the Hamlib Dummy radio with hardware PTT.  Audio in/out and PTT are available on the radio through the Packet connector on the top.  You can use Mumble for audio via those connections.  Enable the Keyer for use with the Dummy radio so you will get PTT switching via the Keyer PTT connector.

73, Howard W6HN

Re: IC-706MIIG SETUP

Andy
 

Hi Dennis, 
Agreed on the CI-V port needs to be correct on RPORT. 
Your next challenge will be transmit control. If you have a solution please pass it on. 
Unless something has changed, using the PTT from the GPI/O 17 was found to be unstable
on my system, If you can get it to transmit, it is hard to get it back to RX. In most cases, you cannot 
rely on the PTT button red (TX) status because that is set by a command status read from the IC706mk2 which 
is not supported by the radio. if you have your manual, check the CIV command set you won't find a TX command or TX status READ command.  Be careful and use a dummy load, it could get stuck in TX. I have a post somewhere on the group discussing the above from sometime ago. 

If you want to use WJST, it works very well. You can modify the jumper board supplied with the cable assembly, 
and use a USB to RS232 serial converter cable. You will need a RS-232 connector or cut a cable to pick out 
the DTR signal on pin 4, pin 5 for ground.  DTR can be used by WSJT and FLDigi for TX control. Use a 2n222, 2n3904, general purpose transistor to pull down the PTT (actually the radio's HSEND) going to the radio, a resistor and diode are in there as well. 
Attached is a marked up schematic of the mod that I did to make it work. You will be taking the RigPi's GPIO17
PTT out of the path. 
From the old days, there was a CIV to RS232 Poor Man's converter using a couple of transistors.This might just be the method to provide the CIV command AND TX control using the RS232 DTR converter interface. I might try it out sometime.
 
The radio can be used with mumble, I am listening to the radio now, but no TX just yet. 

Rig Pi works with the RigPi CW Keyer, you just need to configure the Rig Pi Keyer as shown in the attachment 
and use a cable from the "KEY" jack in the rig pi to your 1/4" Key Jack on your 706. Just use the Tips and Shields on both. Of course, now your TX line is the Key Line. 

It took some time to get the kinks worked out and seems to be working and stable on my station, please use the information carefully and at your own risk. If anyone finds anything to enhance or correct please pass it along 

Have Fun 73 
Andy


 

Yaesu vx-8dr

jamesd.payne.forum@...
 

Is it possible to setup a Yaesu vx-8dr with the rigpi?

If yes, where do I start?

Dummy Not Disconnecting

Frank Wroblewski
 

My RigPi used to work with my Icom IC-7000, but has not stopped working.  I put all the correct values in the Advanced Settings, select CONNECT and get the result listed below.  Rebooting, updating, upgrading all had no effect.  Strangely enough, I have no problem getting FLRig to work.  WSJT-X also works, but without CAT displaying the proper frequency.  If I go to terminal mode and put in the rigctl commands, it tells me I have a communication bus error.  Any ideas anyone???
73,
Frank W2XYZ
TEST MODE Radio: 1
User: admin
Radio: 1
User: admin
Radio from settings: 1
Port from settings: None
ID from settings: 1
RigDo.php rigDoPID from settings: 4681
service_port: 4532
Hamlib Dummy radio 1 start attempt.
To see any error details, click Disconnect Radio, then start rigctld in Terminal with this line:

rigctld -m 1 -t 4532 > /dev/null 2>&1 &

rigctld processes running:

www-data 3689 0.0 0.2 5200 2364 ? S 22:34 0:00 rigctld -m 1 -t 4532

Now starting RigPi radio control link.
Congratulations, Dummy is connected!

Main frequency is 145.000.000 mHz

RigDo Processes:

www-data 3695 21.0 2.2 69616 21000 ? S 22:34 0:00 php /var/www/html/RigDo.php admin radio1 4532

RigDoPID: 3695; Radio: 1; User: admin; Keyer: rpk; CW Port: /dev/ttyS0

Now starting RigPi CW control link.
Now starting RigPi TCP remote control link on port 30001.
Now starting RigPi UDP server on port 12060.
Now starting RigPi Rotor control link on port 4533.

Now starting RigPi Rotor control link on port 4533.

Rotor: 1 (Dummy)
Rotor port: 4533
Rotor ID 1 (Dummy) start attempt.
To see any error details, click Disconnect Radio, then start rotctld in Terminal with this line:

rotctld -m 1 -T 127.0.0.1 -t 4533 > /dev/null 2>&1 &

rotctld processes running:

www-data 3707 0.0 0.2 5164 2372 ? S 22:34 0:00 rotctld -m 1 -T 127.0.0.1 -t 4533

Re: How to program or even look at macros

Kenneth A Christiansen
 

I have been in the macro window several times but can’t figure out how to change them. 
Ken W0CZ


On Mar 30, 2020, at 8:49 PM, Howard Nurse, W6HN <hlnurse@...> wrote:

way to backup and restore macros.

73, Howard W6HN
_._,_._,_

Groups

Re: How to program or even look at macros

Howard Nurse, W6HN
 

Hi Ken,

Welcome to the forum!

The Macro window in SETTINGS is currently the only way to edit and add macros.  RigPi 2, currently in Beta, has a new feature that provides a way to backup and restore macros.

73, Howard W6HN

How to program or even look at macros

Kenneth A Christiansen
 

I got my 1234 last Wednesday and have made a lot of progress so far. I may be back for other advice but for now I would like to figure out how to look at the macros and make changes or new ones. I have been doing programing for over 30 years so what I am asking is how to get to some type of editor to make the changes.

 

Thank you and I am looking forward to operating my ham radio when I am away from home camping.

 

Ken W0CZ

 

Sent from Mail for Windows 10

 

Re: LXDE-pi/run.log question (audio pop reason found)

tmeys@...
 
Edited

Hi Howard -

Running 1.3.0 on clients.  Same on RigPi (Buster) since you need to be at that level for updated Mumble.  To be very exact, the RigPi version is 1.3.0~git20190125.440b173+dfsg-2 on Buster.  A recent check for updates (a few days ago) indicated it was current on the Buster version.  (But as I mention, same issue using Stretch with 1.3.0 clients, and earlier versions of Mumble on RigPi because Stretch does not support 1.3.0.).

For those interested, I found this after I suspected the problem had to do with I/O contention on the microSD.  Used dstat to analyze what I/O was coming from where, which led me to this.  The dstat package was not installed by default, so that was a package I had to install.  

Hope this helps others if they have been seeing this problem.  I suspect if the RigPi was left running for a long period of time, this log file might fill the disk.  It gets deleted and restarted with a reboot, so that might be a lesser problem.  

'73 -- AE0AU

Re: mumble server

robert sherman
 

I mean i can log in with 7388 but no signal on my cell phone like before. No audio on receive & no transmit

mumble server

robert sherman
 

all of a sudden i am unable to log into remote mumble server. it keeps saying my server password is incorrect. I tried all i know & still cannot log in remotely. Any ideas?
--
Robert W Sherman

Re: WinKey access via external program

Howard Nurse, W6HN
 

Hi Randy,

Thanks for your nice comments about RigPi!

The new remote CW feature requires the addition of two simple jumpers in the CW boards.

Yes, RigPi 2 will be a field upgrade.   That's one of several items that has slowed down release.  The other is the current state of the Hamlib library.  The Hamlib folks have been hard at work creating a major update for the rig control libraries and I'd like to have their released version before we make RigPi 2 available.  Once these two issue are resolved we will be close to a release.

The extra time has allowed me to add some additional nifty features, including support for the Flic remote control switch for PTT.

--Howard