Date   
Re: IC-718 PTT does not function

Mark Weisheimer
 

Tim,

Try adding the check mark for "disable split polling" and saving the changes.
Any change with that?

--
73 - Mark - K8MHW
'A RigPi Enthusiast!' - I am not otherwise affiliated with MFJ or RigPi

Re: IC-718 PTT does not function

Tim Young
 

Hi Mark:

Do you have a browser open to the RigPi on the RigPi's Raspbian desktop? No. I closed it
If so, log out of that browser session and close that browser. Closed
Then bring up a browser on another device and try it again. Android Tablet: PTT works but hangs..Shows USB RCV on tablet after releasing PTT yet Transmitter is stuck in Transmit

One other thing to be certain is that you do NOT have a checkmark set for "Disable Split Polling" in Advanced Radio Settings. Not checked.

Thanks,

Tim


On 2019-08-26 17:15, Mark Weisheimer wrote:

Tim,
 
Jumper 2-3 on JP1 is correct for all users except KX3, and then 1-2 is the right choice.
 
Do you have a browser open to the RigPi on the RigPi's Raspbian desktop?
If so, log out of that browser session and close that browser.
Then bring up a browser on another device and try it again.
One other thing to be certain is that you do NOT have a checkmark set for "Disable Split Polling" in Advanced Radio Settings.


--
73 - Mark - K8MHW
'A RigPi Enthusiast!' - I am not otherwise affiliated with MFJ or RigPi


Re: IC-718 PTT does not function

Mark Weisheimer
 

Tim,
 
Jumper 2-3 on JP1 is correct for all users except KX3, and then 1-2 is the right choice.
 
Do you have a browser open to the RigPi on the RigPi's Raspbian desktop?
If so, log out of that browser session and close that browser.
Then bring up a browser on another device and try it again.
One other thing to be certain is that you do NOT have a checkmark set for "Disable Split Polling" in Advanced Radio Settings.


--
73 - Mark - K8MHW
'A RigPi Enthusiast!' - I am not otherwise affiliated with MFJ or RigPi

Re: IC-718 PTT does not function

Tim Young
 

Howard

I did not measure the voltages. I wasn't clear on pins to what potential point.

Page 32 of the user manual: "Connect the jumper between pins 2 and 3 for the KX-3 Power On position"

Page 129 of the user manual: "JP1: KX3/PTT (1-2 for KX3 Power On pulse, 2-3 for normal PTT)"

So there appears to be a conflict. I changed the jumper to 2-3. The goods news is that the RSS does switch the radio to Transmit. The bad news is that after the PTT button is released, the PTT on the RSS stays lit and the radio sticks in Transmit. Clicking the PTT button a few times releases it from Transmit. Not a good situation. 

Tim


On 2019-08-26 15:38, Howard Nurse, W6HN wrote:

Hi Tim,
 
Great!  Please check the two jumped pins.  Leave the jumper in.  Try without PTT and then with PTT.  (You can see the schematic for the Audio board in the Files section, RigPi Documentation folder.)
 
—Howard

 

On Aug 26, 2019, at 2:24 PM, Tim Young <tyoung@...> wrote:

Howard,

Yes I can test the voltage. Just get me the points you would like measured.

With and without the jumper?

Jump 1-2? Jump 2-3?

With PTT button on?

Nothing connected on TX Out

 Thx

Tim

On 2019-08-26 15:12, Howard Nurse, W6HN wrote:

Hi Tim,

That certainly narrows it down!  Do you have a voltmeter you can use to test the voltage on the 3-pin PTT jumper block?  With and without PTT.

I assume you don't have anything plugged into the TX OUT connector on RigPi...

—Howard



Re: IC-718 PTT does not function

Howard Nurse, W6HN
 

Hi Tim,

Great!  Please check the two jumped pins.  Leave the jumper in.  Try without PTT and then with PTT.  (You can see the schematic for the Audio board in the Files section, RigPi Documentation folder.)

—Howard


On Aug 26, 2019, at 2:24 PM, Tim Young <tyoung@...> wrote:

Howard,

Yes I can test the voltage. Just get me the points you would like measured.

With and without the jumper?

Jump 1-2? Jump 2-3?

With PTT button on?

Nothing connected on TX Out

 Thx

Tim

On 2019-08-26 15:12, Howard Nurse, W6HN wrote:

Hi Tim,

That certainly narrows it down!  Do you have a voltmeter you can use to test the voltage on the 3-pin PTT jumper block?  With and without PTT.

I assume you don’t have anything plugged into the TX OUT connector on RigPi...

—Howard


Re: IC-718 PTT does not function

Tim Young
 

Howard,

Yes I can test the voltage. Just get me the points you would like measured.

With and without the jumper?

Jump 1-2? Jump 2-3?

With PTT button on?

Nothing connected on TX Out

 Thx

Tim

On 2019-08-26 15:12, Howard Nurse, W6HN wrote:

Hi Tim,

That certainly narrows it down!  Do you have a voltmeter you can use to test the voltage on the 3-pin PTT jumper block?  With and without PTT.

I assume you don’t have anything plugged into the TX OUT connector on RigPi...

—Howard


Re: Macros for the Yaesu FT 991-A Help #ft-991a

Mitch Matteau N0DIM
 

Thanks, Howard. Your caution also noted about keeping a backup. 

I’ll let you know how it all works. 

73 

Mitch N0DIM 

On Aug 26, 2019, at 4:35 PM, Howard Nurse, W6HN <hlnurse@...> wrote:

Hi Mitch,

All macro and band buttons are contained in a php file named macroButtons.php.  It is located in the /var/www/html/includes folder.  Copy it to use as a backup, then open with a text editor.  You will see each button in a button class structure.  If you remove a button class the button won’t show.  You can delete them or surround them with an html comment.

—Howard

Re: IC-718 PTT does not function

johnpierce
 

How to get Mumble server to be a mumble client for use?

 

John

 

From: RigPi@groups.io [mailto:RigPi@groups.io] On Behalf Of Howard Nurse, W6HN
Sent: Monday, August 26, 2019 5:13 PM
To: RigPi@groups.io
Subject: Re: [RigPi] IC-718 PTT does not function

 

Hi Tim,

That certainly narrows it down!  Do you have a voltmeter you can use to test the voltage on the 3-pin PTT jumper block?  With and without PTT.

I assume you don’t have anything plugged into the TX OUT connector on RigPi...

—Howard

Re: IC-718 PTT does not function

Howard Nurse, W6HN
 

Hi Tim,

That certainly narrows it down!  Do you have a voltmeter you can use to test the voltage on the 3-pin PTT jumper block?  With and without PTT.

I assume you don’t have anything plugged into the TX OUT connector on RigPi...

—Howard

Re: IMPORTANT: Security Issues

Bruce Perens K6BP
 



On Thu, Aug 22, 2019 at 8:26 AM Bo Barry <bobarr@...> wrote:
What problems? Mine works fine!

It does indeed! But I have some comments about those files on your PC, and that stuff you were watching the other day.

:-) 

Re: IC-718 PTT does not function

Tim Young
 

Howard

Shorted PTT to GND on RSS Audio daughter board. Radio goes into Transmit! As you would likely expect, no indication on the RSS.

Tim

On 2019-08-26 13:56, Howard Nurse, W6HN wrote:

Hi Tim,

The next test is to short the PTT line to ground inside RigPi on the Audio daughter board to confirm the radio connection.

—Howard


Re: Macros for the Yaesu FT 991-A Help #ft-991a

Howard Nurse, W6HN
 

PS If a RigPi update includes that file, your changes will be lost.  So also keep a backup of your modified file.

—Howard

Re: Macros for the Yaesu FT 991-A Help #ft-991a

Howard Nurse, W6HN
 

Hi Mitch,

All macro and band buttons are contained in a php file named macroButtons.php.  It is located in the /var/www/html/includes folder.  Copy it to use as a backup, then open with a text editor.  You will see each button in a button class structure.  If you remove a button class the button won’t show.  You can delete them or surround them with an html comment.

—Howard

Re: IC-718 PTT does not function

Howard Nurse, W6HN
 

Hi Tim,

The next test is to short the PTT line to ground inside RigPi on the Audio daughter board to confirm the radio connection.

—Howard

Re: How to connect Mumble to MFJ 1234. Kenwood TS 590s

Howard Nurse, W6HN
 

Hi Loic,

I’m so glad to see your report of success!

Power On can take up to 20 seconds.  Could that be the issue?

73, Howard W6HN

Re: How to connect Mumble to MFJ 1234. Kenwood TS 590s

Loic SM5VFE
 

The MFJ 1234 works really good. Within 3 hours I´m up and running remote outside my local network. I like this box a lot. :-)

All is working exept Power ON button. Anyone have a solution? Power OFF works but not Power ON. 

Regards from Loic, SM5VFE

Re: IC-718 PTT does not function

Tim Young
 

Howard:

1. Closed PC browser access (LAN).

2. Rebooted RSS.

3. Opened Rig Pi through direct connection to RSS (HDMI Display and wireless kbd/mouse).

4. PTT button: Red LED on RSS lights up. displays USB XMIT, no action on radio, Red LED hangs in the on mode occasionally.

?

Thanks

Tim


On 2019-08-26 10:27, Howard Nurse, W6HN wrote:

OK, progress, thanks...

What browsers are you using to test PTT?  If using the Raspberry Pi Desktop browser with no others open on other computers, you are fine.  If you are testing from another computer, with the Desktop browser open, please try closing the Desktop browser to see if that makes a PTT difference.

With the Desktop browser closed, try opening 2 browsers on different computers/devices.  When you engage PTT, does the PTT show as ON on the other browser?


—Howard


Re: Macros for the Yaesu FT 991-A Help #ft-991a

Mitch Matteau N0DIM
 

Thanks, Howard.  Makes sense and the reference back to the RigPi helps – I wasn’t connecting those dots.  My bad.

 

Yes, I noted the need for Hex – not a problem.

 

I sure would like to give the file edit a try, and yes, I most definitely understand HTML coding (my first websites were coded manually).  You can reach me off list if necessary via the email I have on QRZ.com.

 

73

 

Mitch N0DIM

 

From: RigPi@groups.io <RigPi@groups.io> On Behalf Of Howard Nurse, W6HN
Sent: Monday, August 26, 2019 1:43 PM
To: RigPi@groups.io
Subject: Re: [RigPi] Macros for the Yaesu FT 991-A Help #ft-991a

 

Hi Mitch,

There is a topic in RigPi Help on how to format macros with examples.  “*0w “ is used to denote a macro using native radio CAT commands (for all radios) where the radio does not send back a reply.  “*1w “ is used when the radio does send back a reply.  (All Icom radios send back replies, even for SET commands.) As you have seen, the FT-991A requires that CAT commands be translated into their Hex equivalents, even though the CAT reference manual shows otherwise.

You can reduce the number of macros through a simple edit of a RigPi file.  If you want to give that a try, let me know and I will send along details.  (It helps to understand HTML coding to make the change.)

73, Howard W6HN

Re: How to connect Mumble to MFJ 1234. Kenwood TS 590s

Loic SM5VFE
 

I fixed the audio with Mumble. Not really sure what I did. But the video is really great for beginners like me. I will try some more tomorrow. I´m happy to get it up and running within a few hours. 

Thank you. Regards from Loic, SM5VFE

How to connect Mumble to MFJ 1234. Kenwood TS 590s

Loic SM5VFE
 

Hello All! 
Received the MFJ1234 today. I have read all PDF about TS 590 here. But I need some help to get it working. 

I use VNC Viewer to see the MFJ 1234. I have problem to connect with Mumble. I don´t know what to type in to connect to MFJ1234. I don´t see the same log in on Mumble that I see on the TS 590 video. 

Thanks in advance, 

Regards from Loic, SM5VFE