Date   

No RF Output in FT8 on my 7300 all of the sudden (would 1.0.5 have caused a problem?)

Adam Hosa
 

Hi Folks,

So for the majority of the day I was running FT8 remote, no problems. Towards the end of the work day, I saw the message come out about the update to 1.0.5 so I updated via the browser, PI restarted and I went home. I got to my rig, and was going to mess around with the audio settings (my other post out there) but figured Id make a few Q's first. When I started tx sitting in front of the radio, the rig was keying up but I didnt see any RF out on the meter of the rig or my auto tuner. Tried other modes (CW, FM, SSB with a mic) and have no problems - full power blasting away.

I even reset my 7300 to the default settings that I used from the doc in our files section, everythings been working fine all along, until today.

Any thoughts?

Thanks :)

Adam N1AH


Re: yaesu ft-891 #mfj-1234

Howard Nurse, W6HN
 

Sure, just click my name/call after the Pi, then click "Send Email."

--Howard


Re: yaesu ft-891 #mfj-1234

kc9flu@...
 

From here do I send it private? 


Re: yaesu ft-891 #mfj-1234

Howard Nurse, W6HN
 

Excellent!  In case you run into this again, Hamlib normally uses the highest Baud rate listed for a radio when you use 'Default.'  According to the Radio Capabilities you can show in the Advanced Radio settings window, the Baud rate can be set from 4800 to 38400.  Since you had your radio working, either the RigPi setting for Baud changed to Default or something must have changed the Baud rate in the radio to 4800.  (I have seen the Hamlib default NOT use the maximum in a few cases.)

Have you set up your router so you can use VNC to open the Raspberry Pi Desktop while away from home?  If so, I can log in and take a look at your audio settings.  Please send your VNC sign in info and WAN IP to me by private email.

73, Howard W6HN


Re: How do I change the RSS User and login Password on the server.

Howard Nurse, W6HN
 

Hi Bill,

You are right, the user name shouldn't change other than by changing it in the Account Editor.  When you looked at the Users table, how many records (lines of data) were there?  Am I interpreting correctly that what you saw was your password in the Username field?  I'd like to find out why that happened so we can prevent it in the future.

73, Howard W6HN


Re: yaesu ft-891 #mfj-1234

kc9flu@...
 

It worked !! I connected to my radio!! Thank you Howard... Now to check my audio  thank you again..


Re: How do I change the RSS User and login Password on the server.

Bill Hurlock <bill.hurlock@...>
 

So I went in and edited the user via phpMyAdmin on the PI and I'm able to get into RSS ok. Some how while I was out I must have entered the password in place of my User Name and the program modified the DB record with the new user name and no password. I have to tell you this has been a real challenge trying to get this program functioning. One day it is working the next day I have to fight mumble just to get ins and outs to work and today I had this very strange edit take place in the DB entry. I'm just about ready to hang this whole thing up. There is no way this should be this complicated to get and keep this program to working.  I will say when it works it is really nice but when anything stops working correctly it turns into a nightmare. I guess I jumped into this to early in development.
As a side note I'm using VPN to connect remotely and that is working great.

Bill Hurlock
WA2TQI


Re: Anyone running FT8 with RigPi and an IC-7300 - How do I lower the audio?

Aaron Jones
 

On my IC-7100 I was able to Open and Close the USB Audio SQL setting using this macro:

Open (squelch is on): *1w \0xFE\0xFE\0x88\0xE0\0x1A\0x05\0x00\0x83\0x01\0xFD

Closed(Squelch is off - or OPEN - you'll hear static in mumble):  *1w \0xFE\0xFE\0x88\0xE0\0x1A\0x05\0x00\0x83\0x00\0xFD


The commands are different for the 7300, 0x88 changes to 0x94 and the command values are different numbers.  Good luck.


AG7GK

On 7/25/2019 12:39 PM, N5VMO Pat wrote:
That is about the same location I us on my signal just keep it out of the RED ZONE =)

On Thu, Jul 25, 2019 at 2:29 PM Adam Hosa via Groups.Io <Ifone=me.com@groups.io> wrote:

Thanks Aaron!


So my big task/question would be to figure out if I can control the ACC/USB AF Level using a Macro from the RigPI :)


Adam



--
73's Pat  N5VMO



Re: yaesu ft-891 #mfj-1234

Howard Nurse, W6HN
 

OK, go to SETTINGS>Advanced Radio.  Change Baud from Default to 4800, and click the Cloud Up Arrow to save it.  Reboot RigPi and try connecting the radio again.

--Howard


Re: yaesu ft-891 #mfj-1234

kc9flu@...
 

My CAT rate is 4800 bps


How do I change the RSS User and login Password on the server.

Bill Hurlock <bill.hurlock@...>
 

Everything was working today. While I was out RSS dropped connection to me. I went to log back in and it won't except my login. When I got home I noticed that RSS server was also disconnected. I can no longer log into the RSS server. Where do I go on the PI to check the login values?

WA2TQI
Bill


Re: Anyone running FT8 with RigPi and an IC-7300 - How do I lower the audio?

Aaron Jones
 

Adam,


The easy way to control the RF level is to load FLRIG which has that was one of the slider options.  That's how I adjust it when working remotely, though it requires logging onto the PI and FLRIG loaded which cannot run simultaneously while the RigPI is controlling your rig.


On page 19-4 of the Advanced IC 7300 guide at the bottom there's a reference to send/reading the AF Output level.

Have you built a macro for your 7300 yet?

I have an IC-7100 and it's similar:

On 7/25/2019 12:39 PM, N5VMO Pat wrote:
That is about the same location I us on my signal just keep it out of the RED ZONE =)

On Thu, Jul 25, 2019 at 2:29 PM Adam Hosa via Groups.Io <Ifone=me.com@groups.io> wrote:

Thanks Aaron!


So my big task/question would be to figure out if I can control the ACC/USB AF Level using a Macro from the RigPI :)


Adam



--
73's Pat  N5VMO



Re: yaesu ft-891 #mfj-1234

Howard Nurse, W6HN
 

Please look in your radio menu to see what the current Baud rate is.  It is also noteworthy that it looks like there are 2 rigctld processes running in the Test Mode screen shot.  There should only be one.

--Howard


Re: yaesu ft-891 #mfj-1234

kc9flu@...
 

Settings ... Radio test


Re: RigPi version 1.05 available

Howard Nurse, W6HN
 
Edited

Adam, that shouldn’t be a problem.  Please make sure all is well, however.  I believe it is related to the issue from yesterday, updating from a “clean” 1.04 doesn’t show an index error.  (One other user reported it yesterday during the time 1.05 was still available.)

 

--Howard

 

From: RigPi@groups.io [mailto:RigPi@groups.io] On Behalf Of Adam Hosa via Groups.Io
Sent: Thursday, July 25, 2019 12:41 PM
To: RigPi@groups.io
Subject: Re: [RigPi] RigPi version 1.05 available

 

Howard, is this a problem? Upon update I see

"Notice: Undefined index: test in /var/www/html/my/getUpdate.php on line 5


Re: RigPi version 1.05 available

Harold Rosee <wa5zzt@...>
 

I am sure Howard will answer but ignore that.


Re: Anyone running FT8 with RigPi and an IC-7300 - How do I lower the audio?

Harold Rosee <wa5zzt@...>
 

Look in the IC-7300 advanced manual on page 19-3. 

Tells you how to adjust the AF level there.


Re: yaesu ft-891 #mfj-1234

Howard Nurse, W6HN
 

Unfortunately the info shown in the Terminal window doesn't show us much.  Please reboot RigPi, then go to SETTINGS>Advanced Radio.  Send a screen shot of that Window, then use the Test Radio button, and send a second screen shot showing the Test Radio results.

--Howard


Re: RigPi version 1.05 available

Adam Hosa
 

Howard, is this a problem? Upon update I see

"Notice: Undefined index: test in /var/www/html/my/getUpdate.php on line 5


Re: Anyone running FT8 with RigPi and an IC-7300 - How do I lower the audio?

N5VMO Pat <n5vmo00@...>
 

That is about the same location I us on my signal just keep it out of the RED ZONE =)

On Thu, Jul 25, 2019 at 2:29 PM Adam Hosa via Groups.Io <Ifone=me.com@groups.io> wrote:

Thanks Aaron!


So my big task/question would be to figure out if I can control the ACC/USB AF Level using a Macro from the RigPI :)


Adam



--
73's Pat  N5VMO