Topics

Yaesu 857D + SignaLink + Raspberry Pi / Direwolf ---> SignaLink keys but 857D does not


Grant Greenwell
 

I'm having some issues with trying to do packet mode with my 857D/SignaLink/Direwolf.  ARDOP works just fine for HF using Pat, but I can't get Direwolf to work for Packet.  

I am able to get FLRig to PTT even in packet mode.
Direwolf starts up, RIGCTL turns green, KISSATCH turns green, and Pat opens up.
When I try to initiate an AX.25 communication, SignaLink PTT will turn red, but does not key the radio.

I'm scratching my head on this one... why would FLRIG PTT key SignaLink and transmitter, but Pat/AX25/Direwolf only key the SignaLink and not the transmitter?  I am so frustrated because I know the answer has to be something simple that I'm missing.  I don't think it's a radio configuration issue because I've seen the radio transmit using FLRig.  And Pat opens up and gives the radio frequency for my-rig, and the AX.25 can key SignaLink... there's just something going on with PTT maybe?  (Do I have that right?  SignaLink provides the audio/tones but something else controls the PTT?)

I've been up most of the night trying to figure this out.  I'd really love to have the packet capability not only because it's a challenge, but also because my ARES group is trying to get everyone onboard with it.

Any suggestions?


David Ranch
 


Hello Grant,

I am able to get FLRig to PTT even in packet mode.
Direwolf starts up, RIGCTL turns green, KISSATCH turns green, and Pat opens up.
When I try to initiate an AX.25 communication, SignaLink PTT will turn red, but does not key the radio.

That's a new one.  If the Signalink's PTT LED lights up, your radio should key up too.  This is an issue with your Signalink, it's jumper configuration, or your cabling.  It's very strange it works for other applications though.

You mentioned a FT857.  What mode is the radio in?  Try PKT or DIG mode and try again.


And Pat opens up and gives the radio frequency for my-rig, and the AX.25 can key SignaLink... there's just something going on with PTT maybe?  (Do I have that right?  SignaLink provides the audio/tones but something else controls the PTT?)

Ok.. this doesn't make sense.  The Signalink only does audio and fakes out PTT.  If you're getting automatic frequency updates from the radio back to Pat, this means you have another connection to your radio doing CAT control.  This is ok but you need to be cleat that the Signalink should do the PTT.  Configure all your programs NOT to use CAT for PTT control.


--David
KI6ZHD


Grant Greenwell
 

David,

Would it be an issue with the SignaLink even if FLRIG, FLDIGI, ARDOP can all get the radio to transmit, or do you think it’s something in my Direwolf configuration?  I swapped the jumper module, the SignaLink, and the cables with known-good and I still have the symptoms.

I tried the radio in packet, FM, and digital - the same problem exists on each mode.

Any thoughts on how to get the SignaLink to not do CAT?  (I thought CAT was being done through FLRIG)

Very respectfully,

Grant

On Jun 14, 2020, at 12:50 PM, David Ranch <rpi4hamradio-groupsio@...> wrote:


Hello Grant,

I am able to get FLRig to PTT even in packet mode.
Direwolf starts up, RIGCTL turns green, KISSATCH turns green, and Pat opens up.
When I try to initiate an AX.25 communication, SignaLink PTT will turn red, but does not key the radio.

That's a new one.  If the Signalink's PTT LED lights up, your radio should key up too.  This is an issue with your Signalink, it's jumper configuration, or your cabling.  It's very strange it works for other applications though.

You mentioned a FT857.  What mode is the radio in?  Try PKT or DIG mode and try again.


And Pat opens up and gives the radio frequency for my-rig, and the AX.25 can key SignaLink... there's just something going on with PTT maybe?  (Do I have that right?  SignaLink provides the audio/tones but something else controls the PTT?)

Ok.. this doesn't make sense.  The Signalink only does audio and fakes out PTT.  If you're getting automatic frequency updates from the radio back to Pat, this means you have another connection to your radio doing CAT control.  This is ok but you need to be cleat that the Signalink should do the PTT.  Configure all your programs NOT to use CAT for PTT control.


--David
KI6ZHD


Don Poaps
 

Grant 

In KM4ACK Patmenu. I run a separate PI SD for VHF/UHF FM. I don't turn on Pat Configure Rig control.

 If I use my HF PI for Dual-band use.

 I run Flrig first, Then start Patmenu. Start Modem. Then Pat HTML load in the browser. I see my radio change when I go to action > AX 25 > manually add 144.430 for VA7DEP-10. I can now connect and I see no errors and radio TX. We use to go to Patmenu config at I'd change Jason radio setting for his radio to 122. Those configuration settings worked for me. My radio with a signalink worked. I had to add deirwolf -p -t 0 so that my signalink would connect the gateways.

As mentioned before, I hope you find your issues. 

I working on a fresh SD you use for Club Portable activities. It seems the GPS when I move isn't updated. Another thread.

73

Don va7dgp




 
Don Poaps
New Westminster, BC
VA7DGP DATA
VA7QU   VOICE


Winlink: va7qu@...
Subject://wl2k           



                    
  




 


On Sun, Jun 14, 2020 at 11:23 AM Grant Greenwell <grant.d.greenwell@...> wrote:
David,

Would it be an issue with the SignaLink even if FLRIG, FLDIGI, ARDOP can all get the radio to transmit, or do you think it’s something in my Direwolf configuration?  I swapped the jumper module, the SignaLink, and the cables with known-good and I still have the symptoms.

I tried the radio in packet, FM, and digital - the same problem exists on each mode.

Any thoughts on how to get the SignaLink to not do CAT?  (I thought CAT was being done through FLRIG)

Very respectfully,

Grant

On Jun 14, 2020, at 12:50 PM, David Ranch <rpi4hamradio-groupsio@...> wrote:


Hello Grant,

I am able to get FLRig to PTT even in packet mode.
Direwolf starts up, RIGCTL turns green, KISSATCH turns green, and Pat opens up.
When I try to initiate an AX.25 communication, SignaLink PTT will turn red, but does not key the radio.

That's a new one.  If the Signalink's PTT LED lights up, your radio should key up too.  This is an issue with your Signalink, it's jumper configuration, or your cabling.  It's very strange it works for other applications though.

You mentioned a FT857.  What mode is the radio in?  Try PKT or DIG mode and try again.


And Pat opens up and gives the radio frequency for my-rig, and the AX.25 can key SignaLink... there's just something going on with PTT maybe?  (Do I have that right?  SignaLink provides the audio/tones but something else controls the PTT?)

Ok.. this doesn't make sense.  The Signalink only does audio and fakes out PTT.  If you're getting automatic frequency updates from the radio back to Pat, this means you have another connection to your radio doing CAT control.  This is ok but you need to be cleat that the Signalink should do the PTT.  Configure all your programs NOT to use CAT for PTT control.


--David
KI6ZHD


Grant Greenwell
 

Don,

Okay, thanks for the feedback.  I will try to burn a separate image and work from the ground up, concentrating just on Direwolf and packet.  Maybe that will help sort out things.

Good luck with figuring out the GPS piece.

Very respectfully,

Grant

On Jun 14, 2020, at 3:15 PM, Don Poaps <va7dgp@...> wrote:

Grant 

In KM4ACK Patmenu. I run a separate PI SD for VHF/UHF FM. I don't turn on Pat Configure Rig control.

 If I use my HF PI for Dual-band use.

 I run Flrig first, Then start Patmenu. Start Modem. Then Pat HTML load in the browser. I see my radio change when I go to action > AX 25 > manually add 144.430 for VA7DEP-10. I can now connect and I see no errors and radio TX. We use to go to Patmenu config at I'd change Jason radio setting for his radio to 122. Those configuration settings worked for me. My radio with a signalink worked. I had to add deirwolf -p -t 0 so that my signalink would connect the gateways.

As mentioned before, I hope you find your issues. 

I working on a fresh SD you use for Club Portable activities. It seems the GPS when I move isn't updated. Another thread.

73

Don va7dgp




 
Don Poaps
New Westminster, BC
VA7DGP DATA
VA7QU   VOICE


Winlink: va7qu@...
Subject://wl2k           



                    
  




 


On Sun, Jun 14, 2020 at 11:23 AM Grant Greenwell <grant.d.greenwell@...> wrote:
David,

Would it be an issue with the SignaLink even if FLRIG, FLDIGI, ARDOP can all get the radio to transmit, or do you think it’s something in my Direwolf configuration?  I swapped the jumper module, the SignaLink, and the cables with known-good and I still have the symptoms.

I tried the radio in packet, FM, and digital - the same problem exists on each mode.

Any thoughts on how to get the SignaLink to not do CAT?  (I thought CAT was being done through FLRIG)

Very respectfully,

Grant

On Jun 14, 2020, at 12:50 PM, David Ranch <rpi4hamradio-groupsio@...> wrote:


Hello Grant,

I am able to get FLRig to PTT even in packet mode.
Direwolf starts up, RIGCTL turns green, KISSATCH turns green, and Pat opens up.
When I try to initiate an AX.25 communication, SignaLink PTT will turn red, but does not key the radio.

That's a new one.  If the Signalink's PTT LED lights up, your radio should key up too.  This is an issue with your Signalink, it's jumper configuration, or your cabling.  It's very strange it works for other applications though.

You mentioned a FT857.  What mode is the radio in?  Try PKT or DIG mode and try again.


And Pat opens up and gives the radio frequency for my-rig, and the AX.25 can key SignaLink... there's just something going on with PTT maybe?  (Do I have that right?  SignaLink provides the audio/tones but something else controls the PTT?)

Ok.. this doesn't make sense.  The Signalink only does audio and fakes out PTT.  If you're getting automatic frequency updates from the radio back to Pat, this means you have another connection to your radio doing CAT control.  This is ok but you need to be cleat that the Signalink should do the PTT.  Configure all your programs NOT to use CAT for PTT control.


--David
KI6ZHD





David Ranch
 


Hello Grant,

If you're just using a FT857 and a Signalink without a CAT connection, then Flrig should do nothing.  PTT control is completely handled by the Signalink device.  Flrig should not even be used as it won't have any function without CAT or some other control.

--David
KI6ZHD


David,

Would it be an issue with the SignaLink even if FLRIG, FLDIGI, ARDOP can all get the radio to transmit, or do you think it’s something in my Direwolf configuration?  I swapped the jumper module, the SignaLink, and the cables with known-good and I still have the symptoms.

I tried the radio in packet, FM, and digital - the same problem exists on each mode.

Any thoughts on how to get the SignaLink to not do CAT?  (I thought CAT was being done through FLRIG)

Very respectfully,

Grant

On Jun 14, 2020, at 12:50 PM, David Ranch <rpi4hamradio-groupsio@...> wrote:


Hello Grant,

I am able to get FLRig to PTT even in packet mode.
Direwolf starts up, RIGCTL turns green, KISSATCH turns green, and Pat opens up.
When I try to initiate an AX.25 communication, SignaLink PTT will turn red, but does not key the radio.

That's a new one.  If the Signalink's PTT LED lights up, your radio should key up too.  This is an issue with your Signalink, it's jumper configuration, or your cabling.  It's very strange it works for other applications though.

You mentioned a FT857.  What mode is the radio in?  Try PKT or DIG mode and try again.


And Pat opens up and gives the radio frequency for my-rig, and the AX.25 can key SignaLink... there's just something going on with PTT maybe?  (Do I have that right?  SignaLink provides the audio/tones but something else controls the PTT?)

Ok.. this doesn't make sense.  The Signalink only does audio and fakes out PTT.  If you're getting automatic frequency updates from the radio back to Pat, this means you have another connection to your radio doing CAT control.  This is ok but you need to be cleat that the Signalink should do the PTT.  Configure all your programs NOT to use CAT for PTT control.


--David
KI6ZHD



Grant Greenwell
 

David,

Thanks for your reply.  To clarify, I have the Pi with a cat control cable to the 857D via the tuner (so Pi to tuner to radio).  I also have Pi to SignaLink to radio.

When I press “tune” in FLRIG it keys the radio, but not SignaLink.

When I use FLDIGI, and press “tune” (or any other command), the SignaLink PTT illuminates, and the radio transmits.

Very respectfully,

Grant

On Jun 15, 2020, at 2:09 PM, David Ranch <rpi4hamradio-groupsio@...> wrote:


Hello Grant,

If you're just using a FT857 and a Signalink without a CAT connection, then Flrig should do nothing.  PTT control is completely handled by the Signalink device.  Flrig should not even be used as it won't have any function without CAT or some other control.

--David
KI6ZHD


David,

Would it be an issue with the SignaLink even if FLRIG, FLDIGI, ARDOP can all get the radio to transmit, or do you think it’s something in my Direwolf configuration?  I swapped the jumper module, the SignaLink, and the cables with known-good and I still have the symptoms.

I tried the radio in packet, FM, and digital - the same problem exists on each mode.

Any thoughts on how to get the SignaLink to not do CAT?  (I thought CAT was being done through FLRIG)

Very respectfully,

Grant

On Jun 14, 2020, at 12:50 PM, David Ranch <rpi4hamradio-groupsio@...> wrote:


Hello Grant,

I am able to get FLRig to PTT even in packet mode.
Direwolf starts up, RIGCTL turns green, KISSATCH turns green, and Pat opens up.
When I try to initiate an AX.25 communication, SignaLink PTT will turn red, but does not key the radio.

That's a new one.  If the Signalink's PTT LED lights up, your radio should key up too.  This is an issue with your Signalink, it's jumper configuration, or your cabling.  It's very strange it works for other applications though.

You mentioned a FT857.  What mode is the radio in?  Try PKT or DIG mode and try again.


And Pat opens up and gives the radio frequency for my-rig, and the AX.25 can key SignaLink... there's just something going on with PTT maybe?  (Do I have that right?  SignaLink provides the audio/tones but something else controls the PTT?)

Ok.. this doesn't make sense.  The Signalink only does audio and fakes out PTT.  If you're getting automatic frequency updates from the radio back to Pat, this means you have another connection to your radio doing CAT control.  This is ok but you need to be cleat that the Signalink should do the PTT.  Configure all your programs NOT to use CAT for PTT control.


--David
KI6ZHD




David Ranch
 


Hello Grant,

For now, remove the CAT cable so you're only using your Raspberry Pi, Direwolf, the Signalink, and the radio.

For your Fldigi / Flrig setup, that's potentially something configured very differently potentially asserting PTT via CAT control (bypassing the Signalink based PTT control)

--David
KI6ZHD


On 06/15/2020 06:33 PM, Grant Greenwell wrote:
David,

Thanks for your reply.  To clarify, I have the Pi with a cat control cable to the 857D via the tuner (so Pi to tuner to radio).  I also have Pi to SignaLink to radio.

When I press “tune” in FLRIG it keys the radio, but not SignaLink.

When I use FLDIGI, and press “tune” (or any other command), the SignaLink PTT illuminates, and the radio transmits.

Very respectfully,

Grant

On Jun 15, 2020, at 2:09 PM, David Ranch <rpi4hamradio-groupsio@...> wrote:


Hello Grant,

If you're just using a FT857 and a Signalink without a CAT connection, then Flrig should do nothing.  PTT control is completely handled by the Signalink device.  Flrig should not even be used as it won't have any function without CAT or some other control.

--David
KI6ZHD


David,

Would it be an issue with the SignaLink even if FLRIG, FLDIGI, ARDOP can all get the radio to transmit, or do you think it’s something in my Direwolf configuration?  I swapped the jumper module, the SignaLink, and the cables with known-good and I still have the symptoms.

I tried the radio in packet, FM, and digital - the same problem exists on each mode.

Any thoughts on how to get the SignaLink to not do CAT?  (I thought CAT was being done through FLRIG)

Very respectfully,

Grant

On Jun 14, 2020, at 12:50 PM, David Ranch <rpi4hamradio-groupsio@...> wrote:


Hello Grant,

I am able to get FLRig to PTT even in packet mode.
Direwolf starts up, RIGCTL turns green, KISSATCH turns green, and Pat opens up.
When I try to initiate an AX.25 communication, SignaLink PTT will turn red, but does not key the radio.

That's a new one.  If the Signalink's PTT LED lights up, your radio should key up too.  This is an issue with your Signalink, it's jumper configuration, or your cabling.  It's very strange it works for other applications though.

You mentioned a FT857.  What mode is the radio in?  Try PKT or DIG mode and try again.


And Pat opens up and gives the radio frequency for my-rig, and the AX.25 can key SignaLink... there's just something going on with PTT maybe?  (Do I have that right?  SignaLink provides the audio/tones but something else controls the PTT?)

Ok.. this doesn't make sense.  The Signalink only does audio and fakes out PTT.  If you're getting automatic frequency updates from the radio back to Pat, this means you have another connection to your radio doing CAT control.  This is ok but you need to be cleat that the Signalink should do the PTT.  Configure all your programs NOT to use CAT for PTT control.


--David
KI6ZHD





Grant Greenwell
 

David,

Now I’m completely lost - if I don’t have a cat cable going from Pi to Radio, then how is FlRig going to run?  Don’t you need FlRig to run Direwolf and packet?

I unplugged the cable as suggested - now FLRIG doesn’t know what comms path to take to the radio.  There are no readily-identifiable ports, so I tried every tty and ama/amo.  No joy.

Very respectfully,

Grant

On Jun 16, 2020, at 4:58 PM, David Ranch <rpi4hamradio-groupsio@...> wrote:


Hello Grant,

For now, remove the CAT cable so you're only using your Raspberry Pi, Direwolf, the Signalink, and the radio.

For your Fldigi / Flrig setup, that's potentially something configured very differently potentially asserting PTT via CAT control (bypassing the Signalink based PTT control)

--David
KI6ZHD


On 06/15/2020 06:33 PM, Grant Greenwell wrote:
David,

Thanks for your reply.  To clarify, I have the Pi with a cat control cable to the 857D via the tuner (so Pi to tuner to radio).  I also have Pi to SignaLink to radio.

When I press “tune” in FLRIG it keys the radio, but not SignaLink.

When I use FLDIGI, and press “tune” (or any other command), the SignaLink PTT illuminates, and the radio transmits.

Very respectfully,

Grant

On Jun 15, 2020, at 2:09 PM, David Ranch <rpi4hamradio-groupsio@...> wrote:


Hello Grant,

If you're just using a FT857 and a Signalink without a CAT connection, then Flrig should do nothing.  PTT control is completely handled by the Signalink device.  Flrig should not even be used as it won't have any function without CAT or some other control.

--David
KI6ZHD


David,

Would it be an issue with the SignaLink even if FLRIG, FLDIGI, ARDOP can all get the radio to transmit, or do you think it’s something in my Direwolf configuration?  I swapped the jumper module, the SignaLink, and the cables with known-good and I still have the symptoms.

I tried the radio in packet, FM, and digital - the same problem exists on each mode.

Any thoughts on how to get the SignaLink to not do CAT?  (I thought CAT was being done through FLRIG)

Very respectfully,

Grant

On Jun 14, 2020, at 12:50 PM, David Ranch <rpi4hamradio-groupsio@...> wrote:


Hello Grant,

I am able to get FLRig to PTT even in packet mode.
Direwolf starts up, RIGCTL turns green, KISSATCH turns green, and Pat opens up.
When I try to initiate an AX.25 communication, SignaLink PTT will turn red, but does not key the radio.

That's a new one.  If the Signalink's PTT LED lights up, your radio should key up too.  This is an issue with your Signalink, it's jumper configuration, or your cabling.  It's very strange it works for other applications though.

You mentioned a FT857.  What mode is the radio in?  Try PKT or DIG mode and try again.


And Pat opens up and gives the radio frequency for my-rig, and the AX.25 can key SignaLink... there's just something going on with PTT maybe?  (Do I have that right?  SignaLink provides the audio/tones but something else controls the PTT?)

Ok.. this doesn't make sense.  The Signalink only does audio and fakes out PTT.  If you're getting automatic frequency updates from the radio back to Pat, this means you have another connection to your radio doing CAT control.  This is ok but you need to be cleat that the Signalink should do the PTT.  Configure all your programs NOT to use CAT for PTT control.


--David
KI6ZHD






Grant Greenwell
 

Putting out a blanket call again - I’ve tried all the suggestions and can’t get this thing up and running.  I think I’m down to a few options.

- Would anyone be willing to zoom / FaceTime to help me troubleshoot or build from the ground up who also has the 857D and SignaLink?  I’m really trying to get 2M packet up and running for Field Day demonstrations with ARES.
- If not, would anyone be willing to share their image with me so I can burn it and run it on my setup?

Very respectfully,

Grant

On Jun 16, 2020, at 8:40 PM, Grant Greenwell via groups.io <grant.d.greenwell@...> wrote:

David,

Now I’m completely lost - if I don’t have a cat cable going from Pi to Radio, then how is FlRig going to run?  Don’t you need FlRig to run Direwolf and packet?

I unplugged the cable as suggested - now FLRIG doesn’t know what comms path to take to the radio.  There are no readily-identifiable ports, so I tried every tty and ama/amo.  No joy.

Very respectfully,

Grant

On Jun 16, 2020, at 4:58 PM, David Ranch <rpi4hamradio-groupsio@...> wrote:


Hello Grant,

For now, remove the CAT cable so you're only using your Raspberry Pi, Direwolf, the Signalink, and the radio.

For your Fldigi / Flrig setup, that's potentially something configured very differently potentially asserting PTT via CAT control (bypassing the Signalink based PTT control)

--David
KI6ZHD


On 06/15/2020 06:33 PM, Grant Greenwell wrote:
David,

Thanks for your reply.  To clarify, I have the Pi with a cat control cable to the 857D via the tuner (so Pi to tuner to radio).  I also have Pi to SignaLink to radio.

When I press “tune” in FLRIG it keys the radio, but not SignaLink.

When I use FLDIGI, and press “tune” (or any other command), the SignaLink PTT illuminates, and the radio transmits.

Very respectfully,

Grant

On Jun 15, 2020, at 2:09 PM, David Ranch <rpi4hamradio-groupsio@...> wrote:


Hello Grant,

If you're just using a FT857 and a Signalink without a CAT connection, then Flrig should do nothing.  PTT control is completely handled by the Signalink device.  Flrig should not even be used as it won't have any function without CAT or some other control.

--David
KI6ZHD


David,

Would it be an issue with the SignaLink even if FLRIG, FLDIGI, ARDOP can all get the radio to transmit, or do you think it’s something in my Direwolf configuration?  I swapped the jumper module, the SignaLink, and the cables with known-good and I still have the symptoms.

I tried the radio in packet, FM, and digital - the same problem exists on each mode.

Any thoughts on how to get the SignaLink to not do CAT?  (I thought CAT was being done through FLRIG)

Very respectfully,

Grant

On Jun 14, 2020, at 12:50 PM, David Ranch <rpi4hamradio-groupsio@...> wrote:


Hello Grant,

I am able to get FLRig to PTT even in packet mode.
Direwolf starts up, RIGCTL turns green, KISSATCH turns green, and Pat opens up.
When I try to initiate an AX.25 communication, SignaLink PTT will turn red, but does not key the radio.

That's a new one.  If the Signalink's PTT LED lights up, your radio should key up too.  This is an issue with your Signalink, it's jumper configuration, or your cabling.  It's very strange it works for other applications though.

You mentioned a FT857.  What mode is the radio in?  Try PKT or DIG mode and try again.


And Pat opens up and gives the radio frequency for my-rig, and the AX.25 can key SignaLink... there's just something going on with PTT maybe?  (Do I have that right?  SignaLink provides the audio/tones but something else controls the PTT?)

Ok.. this doesn't make sense.  The Signalink only does audio and fakes out PTT.  If you're getting automatic frequency updates from the radio back to Pat, this means you have another connection to your radio doing CAT control.  This is ok but you need to be cleat that the Signalink should do the PTT.  Configure all your programs NOT to use CAT for PTT control.


--David
KI6ZHD







David Ranch
 


Hello Grant,

Now I’m completely lost - if I don’t have a cat cable going from Pi to Radio, then how is FlRig going to run?  Don’t you need FlRig to run Direwolf and packet?

Direwolf does not need Flrig to run at all and especially since you're using a Signalink which takes care of the PTT signal within itself.  Putting that another way, if the SIgnalink sound chip is told to play audio and if it's loud enough, it will assert PTT automatically.  In theory, it makes things much simpler.   Btw, even Fldigi doesn't need Flrig to run as it has many self-contained ways to control radios, etc.  Flrig just exposes a lot more of the deeper controls of your radio to your computer.


I unplugged the cable as suggested - now FLRIG doesn’t know what comms path to take to the radio.  There are no readily-identifiable ports, so I tried every tty and ama/amo.  No joy.

For Direwolf and packet radio.. ignore Flrig.  Not needed.   Once you get Direwolf working with your Signalink and NO CAT connection, we can then consider looking at CAT controls which could give you other controls like frequency control, setting power levels, etc. but those are all OPTIONAL.

Make sense?

--David
KI6ZHD


August Johnson KG7BZ
 

If the red light on the SignaLink is coming on but the radio does not key, check your wiring between the SignaLink and the radio. The PTT line must be connected for the SignaLink to key the radio.

August KG7BZ


Grant Greenwell
 

August,

Okay, thanks.  I’ll replace the cables again.  Thanks for the suggestion.

Very respectfully,

Grant

On Jun 17, 2020, at 11:58 AM, August Johnson <augjohnson@...> wrote:

If the red light on the SignaLink is coming on but the radio does not key, check your wiring between the SignaLink and the radio. The PTT line must be connected for the SignaLink to key the radio.

August KG7BZ





Grant Greenwell
 

David,

Okay, that makes sense.  Let me play around with it.  Jason also suggested another path separately - I’ll get back to y’all hopefully tonight (depends on underway schedules)

Very respectfully,

Grant

On Jun 17, 2020, at 11:37 AM, David Ranch <rpi4hamradio-groupsio@...> wrote:


Hello Grant,

Now I’m completely lost - if I don’t have a cat cable going from Pi to Radio, then how is FlRig going to run?  Don’t you need FlRig to run Direwolf and packet?

Direwolf does not need Flrig to run at all and especially since you're using a Signalink which takes care of the PTT signal within itself.  Putting that another way, if the SIgnalink sound chip is told to play audio and if it's loud enough, it will assert PTT automatically.  In theory, it makes things much simpler.   Btw, even Fldigi doesn't need Flrig to run as it has many self-contained ways to control radios, etc.  Flrig just exposes a lot more of the deeper controls of your radio to your computer.


I unplugged the cable as suggested - now FLRIG doesn’t know what comms path to take to the radio.  There are no readily-identifiable ports, so I tried every tty and ama/amo.  No joy.

For Direwolf and packet radio.. ignore Flrig.  Not needed.   Once you get Direwolf working with your Signalink and NO CAT connection, we can then consider looking at CAT controls which could give you other controls like frequency control, setting power levels, etc. but those are all OPTIONAL.

Make sense?

--David
KI6ZHD



dkc2030@...
 

Don't forget the obvious.  Check the jumper plug inside the Signalink to make sure that the PTT line is patched to the correct wire on the 857 plug.  While there check the others out too.


Neil Katin
 

I have a similar setup.  Even more obvious thing to check: make sure the mini-din 6 plug into the radio is completely seated.

Every few weeks it slips out enough that the radio won't transmit when the signalink tells it to.

It is hopefully not your issue, but its easy to check and you should make sure its not your problem.

Neil


Grant Greenwell
 

Neil,

You are not alone with that suggestion. While one was a little loose, even when fully seated I still had the same issues. Thank you for the thought however sir. 

Very respectfully,

Grant

G.D. Greenwell
grant.d.greenwell@...
+1.240.472.3941

On Jun 18, 2020, at 15:54, Neil Katin <groups-io@...> wrote:

I have a similar setup.  Even more obvious thing to check: make sure the mini-din 6 plug into the radio is completely seated.

Every few weeks it slips out enough that the radio won't transmit when the signalink tells it to.

It is hopefully not your issue, but its easy to check and you should make sure its not your problem.

Neil


August Johnson KG7BZ
 

One thing I've found on the FT-857, there's often a ridge or even a larger diameter section of the non-Yaesu connectors that prevents full insertion of the connector. I've had to use a razor knife to trim the plastic on the connector shell to permit the connector to fully seat in the radio connector. If you are running up against the plastic on the connector shell, check to make sure this isn't stopping the connector from fully seating.

August KG7BZ

On Thu, Jun 18, 2020 at 4:57 PM Grant Greenwell <grant.d.greenwell@...> wrote:
Neil,

You are not alone with that suggestion. While one was a little loose, even when fully seated I still had the same issues. Thank you for the thought however sir. 

Very respectfully,

Grant

G.D. Greenwell
+1.240.472.3941

On Jun 18, 2020, at 15:54, Neil Katin <groups-io@...> wrote:

I have a similar setup.  Even more obvious thing to check: make sure the mini-din 6 plug into the radio is completely seated.

Every few weeks it slips out enough that the radio won't transmit when the signalink tells it to.

It is hopefully not your issue, but its easy to check and you should make sure its not your problem.

Neil


Grant Greenwell
 

August,

Great point for all using Yaesu to consider.  I actually had most of the cables trimmed that way already because of my FT-818 that I used to have - but you’re absolutely correct, the cables won’t go in unless trimmed.

Thanks for pointing that out.

Very respectfully,

Grant

On Jun 18, 2020, at 8:09 PM, August Johnson <augjohnson@...> wrote:

One thing I've found on the FT-857, there's often a ridge or even a larger diameter section of the non-Yaesu connectors that prevents full insertion of the connector. I've had to use a razor knife to trim the plastic on the connector shell to permit the connector to fully seat in the radio connector. If you are running up against the plastic on the connector shell, check to make sure this isn't stopping the connector from fully seating.

August KG7BZ

On Thu, Jun 18, 2020 at 4:57 PM Grant Greenwell <grant.d.greenwell@...> wrote:
Neil,

You are not alone with that suggestion. While one was a little loose, even when fully seated I still had the same issues. Thank you for the thought however sir. 

Very respectfully,

Grant

G.D. Greenwell
+1.240.472.3941

On Jun 18, 2020, at 15:54, Neil Katin <groups-io@...> wrote:

I have a similar setup.  Even more obvious thing to check: make sure the mini-din 6 plug into the radio is completely seated.

Every few weeks it slips out enough that the radio won't transmit when the signalink tells it to.

It is hopefully not your issue, but its easy to check and you should make sure its not your problem.

Neil