Topics

USB Codecs


Phil
 

Thank you for reading my first post.

I had the digital modes working perfectly until I replaced my radio and interface with an FT-991A. Now a USB codec is not showing in the list of audio devices. FS8CALL, for example, shows "alsa-input.usb-Burr_Brown" as the correct codec for my Linux laptop.

I've searched for an answer but haven't found anything. Is there a codec file that I need to install?

--

Regards,
Phil


David Ranch
 


Different sound devices will have different names so that's perfectly fine.  I assume you're using Raspbian here but what does commands like "aplay -l" and "arecord -l" say?  Are you using vanilla ALSA or are you trying to use say PulseAudio, etc?

--David
KI6ZHD


On 08/30/2020 01:25 AM, Phil wrote:
Thank you for reading my first post.

I had the digital modes working perfectly until I replaced my radio and interface with an FT-991A. Now a USB codec is not showing in the list of audio devices. FS8CALL, for example, shows "alsa-input.usb-Burr_Brown" as the correct codec for my Linux laptop.

I've searched for an answer but haven't found anything. Is there a codec file that I need to install?



Phil
 

On 31/8/20 3:37 am, David Ranch wrote:

Different sound devices will have different names so that's perfectly fine.  I assume you're using Raspbian here but what does commands like "aplay -l" and "arecord -l" say?  Are you using vanilla ALSA or are you trying to use say PulseAudio, etc?
Thank you for your reply David,

I had already listed the Alsa audio devices but only the default device was shown. I decided to do an update and then turned the Raspberry pi off for the night. The next day and now the Burr-Brown codecs are listed so at least I can select the codecs that I previously had.

However I have a new problem, no capture control only an output control which does vary the transmitter power. AlsaMixer reports that "This device does not have any capture controls" . JS8CALL and Fldigi (as well as WSJTX, which I don't use) function but the input is a little high at 60dB. As I type this I now remember that was the case previously but the interface had it's own control which solved the problem.

So the question now is, how do I create a capture control? More Internet searching has not revealed an answer.

--

Regards,
Phil


David Ranch
 


Hello Phil,

Going back to your first post, it seems you're doing this on "a Linux laptop" which I assume is running PulseAudio.   Is that correct?

--David
KI6ZHD


On 08/30/2020 09:58 PM, Phil wrote:
On 31/8/20 3:37 am, David Ranch wrote:

Different sound devices will have different names so that's perfectly fine.  I assume you're using Raspbian here but what does commands like "aplay -l" and "arecord -l" say?  Are you using vanilla ALSA or are you trying to use say PulseAudio, etc?

Thank you for your reply David,

I had already listed the Alsa audio devices but only the default device was shown. I decided to do an update and then turned the Raspberry pi off for the night. The next day and now the Burr-Brown codecs are listed so at least I can select the codecs that I previously had.

However I have a new problem, no capture control only an output control which does vary the transmitter power. AlsaMixer reports that "This device does not have any capture controls" . JS8CALL and Fldigi (as well as WSJTX, which I don't use) function but the input is a little high at 60dB. As I type this I now remember that was the case previously but the interface had it's own control which solved the problem.

So the question now is, how do I create a capture control? More Internet searching has not revealed an answer.



Phil
 

On 1/9/20 1:32 am, David Ranch wrote:

Hello Phil,

Going back to your first post, it seems you're doing this on "a Linux laptop" which I assume is running PulseAudio.
Thanks again David for your reply,

No, the laptop uses Alsa audio. Perhaps there's no reason for me to be concerned about the audio input level to the Raspberry pi? I just thought that others might be using a Raspberry pi and an FT-991A together and had found a way to create a level control.

By the way, the laptop runs under Kubuntu and the Raspberry runs under the standard Raspberry OS.

--

Regards,
Phil


David Ranch
 


Hello Phil,

I don't have any experience of how the USB audio connection works on a FT991 but if the radio doesn't present anything adjustable in the alsa mixer, all those "audio" level settings are probably adjusted in the FT991 menus.  Anyway, this email list is focused on the Raspberry Pi and not X86 laptops as they are going to behave in different and unique ways.

--David
KI6ZHD



On 08/31/2020 04:21 PM, Phil wrote:
On 1/9/20 1:32 am, David Ranch wrote:

Hello Phil,

Going back to your first post, it seems you're doing this on "a Linux laptop" which I assume is running PulseAudio.

Thanks again David for your reply,

No, the laptop uses Alsa audio. Perhaps there's no reason for me to be concerned about the audio input level to the Raspberry pi? I just thought that others might be using a Raspberry pi and an FT-991A together and had found a way to create a level control.

By the way, the laptop runs under Kubuntu and the Raspberry runs under the standard Raspberry OS.