Topics

TT4 delays about 15 seconds as KISS modem


Bill AA6BD
 

I have a TT4 connected to a Raspberry Pi running PAT Winlink client and ax.25 and kissattach.  I can connect the TT4 to PAT client when I use the kissattach command.  After I power up my Raspberry Pi, the first time that I try to connect PAT to a gateway, there is about a 15 second delay when it seems nothing is happening, and then the TT4 issues a PTT and the radio connects to the gateway and all works as expected.

If I try again to connect PAT to the gateway, there is no delay.  The PTT happens almost immediately and the session proceeds.

Is there some setting in the TT4 or in the Raspberry Pi (PAT or ax.25 or kissattach?) that can reduce or eliminate the 15 second delay the first time?
--
Bill AA6BD


David Ranch
 


This is a known behavior of the mkiss kernel module creating a one-time delay.  There are a few ways to address this (crc_force=1) this be it just be patient for your first connection attempt OR change the options used when the mkiss kernel module is installed.  This later approach is the way I do it on my system via my packetrig.sh startup script:

   http://www.trinityos.com/HAM/CentosDigitalModes/usr/local/sbin/packetrig.sh
   --

   #Attempt to set the crcmode to NONE :: this can also be done with kissparm's -c option
   echo -e "\nLoading mkiss kernel module with CRC-mode: none" >> $LOG 2>&1
   $MODPROBE -q mkiss crc_force=1 >> $LOG 2>&1
   --

--David
KI6ZHD


On 09/03/2020 10:26 AM, Bill AA6BD wrote:
I have a TT4 connected to a Raspberry Pi running PAT Winlink client and ax.25 and kissattach.  I can connect the TT4 to PAT client when I use the kissattach command.  After I power up my Raspberry Pi, the first time that I try to connect PAT to a gateway, there is about a 15 second delay when it seems nothing is happening, and then the TT4 issues a PTT and the radio connects to the gateway and all works as expected.

If I try again to connect PAT to the gateway, there is no delay.  The PTT happens almost immediately and the session proceeds.

Is there some setting in the TT4 or in the Raspberry Pi (PAT or ax.25 or kissattach?) that can reduce or eliminate the 15 second delay the first time?
--
Bill AA6BD


Mark Griffith
 

I'm not sure if it the kissattach or just starting the AX.25 service.  This may have appeared in early kernels, it wasn't in Wheezy, but when Buster was released, this delay showed up.  May have been in Stretch too.  Annoying, but that is what you get with open sourced software.  I notice it as every time AX.25 is started.

My answer was every time I start the AX.25 service, I run a little program to wake it up.

#!/bin/sh

ADMIN=`grep ^mycall /usr/local/etc/wl2k.conf | cut -d\= -f2`
/usr/sbin/beacon tnc $ADMIN -s -t1 "Test"
/usr/sbin/beacon tnc $ADMIN -s -t1 "Test"
/usr/sbin/beacon tnc $ADMIN -s -t1 "Test"

This just sends a very small beacon signal and every AX.25 transmission after that will not have a delay.  The first two "tests" are not normally transmitted, but the third will.

You would have to modify the script for your call sign and the tnc name in axports.

Mark
KD0QYN


On Thursday, September 3, 2020, 1:20:53 PM CDT, David Ranch <rpi4hamradio-groupsio@...> wrote:



This is a known behavior of the mkiss kernel module creating a one-time delay.  There are a few ways to address this (crc_force=1) this be it just be patient for your first connection attempt OR change the options used when the mkiss kernel module is installed.  This later approach is the way I do it on my system via my packetrig.sh startup script:

   http://www.trinityos.com/HAM/CentosDigitalModes/usr/local/sbin/packetrig.sh
   --

   #Attempt to set the crcmode to NONE :: this can also be done with kissparm's -c option
   echo -e "\nLoading mkiss kernel module with CRC-mode: none" >> $LOG 2>&1
   $MODPROBE -q mkiss crc_force=1 >> $LOG 2>&1
   --

--David
KI6ZHD


On 09/03/2020 10:26 AM, Bill AA6BD wrote:
I have a TT4 connected to a Raspberry Pi running PAT Winlink client and ax.25 and kissattach.  I can connect the TT4 to PAT client when I use the kissattach command.  After I power up my Raspberry Pi, the first time that I try to connect PAT to a gateway, there is about a 15 second delay when it seems nothing is happening, and then the TT4 issues a PTT and the radio connects to the gateway and all works as expected.

If I try again to connect PAT to the gateway, there is no delay.  The PTT happens almost immediately and the session proceeds.

Is there some setting in the TT4 or in the Raspberry Pi (PAT or ax.25 or kissattach?) that can reduce or eliminate the 15 second delay the first time?
--
Bill AA6BD


Bill AA6BD
 

Mark,
In your little program, I understand substituting my callsign and tnc name in axports.  I don't have a file wl2k.conf.  I have a directory /etc/ax25 which is where axports and a bunch of ax25....conf files are stored but there is no wl2k.conf file in that directory.  What is this file?
--
Bill AA6BD


Mark Griffith
 

It's just grabbing the call sign, so just replace $ADMIN with your call sign.

Mark
KD0QYN


On Friday, September 4, 2020, 5:59:06 PM CDT, Bill AA6BD <bill@...> wrote:


Mark,
In your little program, I understand substituting my callsign and tnc name in axports.  I don't have a file wl2k.conf.  I have a directory /etc/ax25 which is where axports and a bunch of ax25....conf files are stored but there is no wl2k.conf file in that directory.  What is this file?
--
Bill AA6BD


Bill AA6BD
 

Thanks, Mark, for the clarification.  I removed the line starting with "ADMIN=", replaced "$ADMIN" with my call sign, replaced "tnc" with my axport name as specified in /etc/ax25/axports and it works fine now.
--
Bill AA6BD