Topics

Tnc-x PI


Don Poaps
 

I've been reading the setup from tncpi pdf from off the tnc-x website.

I've downloaded the zipped files,  there are now in the folder pitnc.
Both files permission are for Owner 

I keep getting retrying.

If I do ls /dev/serial*
It shows /dev/serial0 and /dev/serial1



So sort of lost as to where to go next

73 

Don



 

Try doing sudo before the command.   


On Jun 23, 2020, at 3:58 PM, Don Poaps <va7dgp@...> wrote:

I've been reading the setup from tncpi pdf from off the tnc-x website.

I've downloaded the zipped files,  there are now in the folder pitnc.
Both files permission are for Owner 

I keep getting retrying.

If I do ls /dev/serial*
It shows /dev/serial0 and /dev/serial1



So sort of lost as to where to go next

73 

Don




Siegfried Jackstien
 

hmm could we get such a thingy run on a pluto??

yes i know not a raspi but it is a linux box (kind of) ... and a wideband transceiver

here in germany a few guys planning to make the pluto a user access point for hamnet ... THAT could be really a nice idea for replacing the packet net (or the rest of that we still have) all to hamnet ...

dg9bfc sigi

Am 23.06.2020 um 19:59 schrieb Tadd KA2DEW in NC via groups.io:

Try doing sudo before the command.   


On Jun 23, 2020, at 3:58 PM, Don Poaps <va7dgp@...> wrote:

I've been reading the setup from tncpi pdf from off the tnc-x website.

I've downloaded the zipped files,  there are now in the folder pitnc.
Both files permission are for Owner 

I keep getting retrying.

If I do ls /dev/serial*
It shows /dev/serial0 and /dev/serial1



So sort of lost as to where to go next

73 

Don




nfg
 

Did you try the Note added 12/4/2018 stuff?


Don Poaps
 

Tad 

that's one of the first syntaxes I used. The yellow light is flashing on the Pi Hat. All of the lights blink when power is applied.

Putting it to bed for a while. If I plugged my USB tnc-x I get it to start in not type.

later

Don va7dgp/va7qu


On Tue., Jun. 23, 2020, 1:00 p.m. Tadd KA2DEW in NC via groups.io <tadd=mac.com@groups.io> wrote:
Try doing sudo before the command.   


On Jun 23, 2020, at 3:58 PM, Don Poaps <va7dgp@...> wrote:

I've been reading the setup from tncpi pdf from off the tnc-x website.

I've downloaded the zipped files,  there are now in the folder pitnc.
Both files permission are for Owner 

I keep getting retrying.

If I do ls /dev/serial*
It shows /dev/serial0 and /dev/serial1



So sort of lost as to where to go next

73 

Don




Don Poaps
 

Sorry, my big screen TV died. Trying to read this with bad eyes and a very small screen https://tnc-x.com/TNCPi.pdf this is what I'm going by. So far have seen any notes.
73
Don Poaps
New Westminster, BC
VA7DGP DATA
VA7QU   VOICE


Winlink: va7qu@...
Subject://wl2k           



                    
  




 


On Tue, Jun 23, 2020 at 1:47 PM Tim via groups.io <the_fro_god=yahoo.com@groups.io> wrote:
Did you try the Note added 12/4/2018 stuff?


Mark Griffith
 

Don,

If your RED LED power light is flashing, your power supply is very weak.  It needs to be steady on all the time.  If adding an external USB device like a TNC-X causes it to start flashing, then again, the power supply is too weak.

Mark
KD0QYN


On Tuesday, June 23, 2020, 5:21:32 PM CDT, Don Poaps <va7dgp@...> wrote:


Tad 

that's one of the first syntaxes I used. The yellow light is flashing on the Pi Hat. All of the lights blink when power is applied.

Putting it to bed for a while. If I plugged my USB tnc-x I get it to start in not type.

later

Don va7dgp/va7qu

On Tue., Jun. 23, 2020, 1:00 p.m. Tadd KA2DEW in NC via groups.io <tadd=mac.com@groups.io> wrote:
Try doing sudo before the command.   


On Jun 23, 2020, at 3:58 PM, Don Poaps <va7dgp@...> wrote:

I've been reading the setup from tncpi pdf from off the tnc-x website.

I've downloaded the zipped files,  there are now in the folder pitnc.
Both files permission are for Owner 

I keep getting retrying.

If I do ls /dev/serial*
It shows /dev/serial0 and /dev/serial1



So sort of lost as to where to go next

73 

Don




Don Poaps
 

The Red light is not steady. It's Off

Thank You


Don Poaps
New Westminster, BC
VA7DGP DATA
VA7QU   VOICE


Winlink: va7qu@...
Subject://wl2k           



                    
  




 


On Tue, Jun 23, 2020 at 4:06 PM Mark Griffith via groups.io <mdgriffith2003=yahoo.com@groups.io> wrote:
Don,

If your RED LED power light is flashing, your power supply is very weak.  It needs to be steady on all the time.  If adding an external USB device like a TNC-X causes it to start flashing, then again, the power supply is too weak.

Mark
KD0QYN


On Tuesday, June 23, 2020, 5:21:32 PM CDT, Don Poaps <va7dgp@...> wrote:


Tad 

that's one of the first syntaxes I used. The yellow light is flashing on the Pi Hat. All of the lights blink when power is applied.

Putting it to bed for a while. If I plugged my USB tnc-x I get it to start in not type.

later

Don va7dgp/va7qu

On Tue., Jun. 23, 2020, 1:00 p.m. Tadd KA2DEW in NC via groups.io <tadd=mac.com@groups.io> wrote:
Try doing sudo before the command.   


On Jun 23, 2020, at 3:58 PM, Don Poaps <va7dgp@...> wrote:

I've been reading the setup from tncpi pdf from off the tnc-x website.

I've downloaded the zipped files,  there are now in the folder pitnc.
Both files permission are for Owner 

I keep getting retrying.

If I do ls /dev/serial*
It shows /dev/serial0 and /dev/serial1



So sort of lost as to where to go next

73 

Don




Don Poaps
 

Tim I finally see what you meant by Note

  Note added 12/4/2018: Some individuals have reported that there is a problem with the November, 2018 revision of Raspbian that results in the serial port not being accessible. You would notice this, for example, if you run pitnc_getparams and you keep getting “retrying…” instead of the menu. In this case you need to edit the config.txt file in the /boot/ directory. You can do this by running the following from the command line: sudo leafpad /boot/config.txt Add the following line at the bottom of this file: dtoverlay=pi3-miniuart-bt This problem seems to be fixed with more recent versions of the Stretch version of Raspian.   

Thank You.

I thought Buster would have fixed that issue. 

73

Don va7dgp/va7qu
Don Poaps
New Westminster, BC
VA7DGP DATA
VA7QU   VOICE


Winlink: va7qu@...
Subject://wl2k           



                    
  




 


On Tue, Jun 23, 2020 at 1:47 PM Tim via groups.io <the_fro_god=yahoo.com@groups.io> wrote:
Did you try the Note added 12/4/2018 stuff?


John Wiseman
 

Unfortunately that instruction is also now out of date.

The correct way is now to use raspi-config Interfacing Options/Serial to disable login on the serial port and enable the port.

73,
John G8BBPQ



On 24/06/2020 05:55, Don Poaps wrote:
Tim I finally see what you meant by Note

  Note added 12/4/2018: Some individuals have reported that there is a problem with the November, 2018 revision of Raspbian that results in the serial port not being accessible. You would notice this, for example, if you run pitnc_getparams and you keep getting “retrying…” instead of the menu. In this case you need to edit the config.txt file in the /boot/ directory. You can do this by running the following from the command line: sudo leafpad /boot/config.txt Add the following line at the bottom of this file: dtoverlay=pi3-miniuart-bt This problem seems to be fixed with more recent versions of the Stretch version of Raspian.   

Thank You.

I thought Buster would have fixed that issue. 

73

Don va7dgp/va7qu
Don Poaps
New Westminster, BC
VA7DGP DATA
VA7QU   VOICE


Winlink: va7qu@...
Subject://wl2k           



                    
  




 


On Tue, Jun 23, 2020 at 1:47 PM Tim via groups.io <the_fro_god=yahoo.com@groups.io> wrote:
Did you try the Note added 12/4/2018 stuff?


Don Poaps
 

I redid the sudo raspi-config > serial Etc.

pi@raspberrypi:~/pitnc $ sudo ./pitnc_getparams /dev/serial0 0

Using Serial port /dev/serial0
retrying...

   TNC Software Version           8
01 TXDelay - Zero means use ADC  50
02 Persistance                  255
03 Slottime (in 10 mS)          255
04 TXTail                       255
05 Full Duplex - Not used       255
06 Our Channel (Hex)             ff
07 I2C Address (0 = async) Hex   ff
08 Mode Speed                  25500
09 RX Level (Config)            255
10 TX Level                     255
11 RX Level (Actual)            255
13 Centre Freq                 2550
8 8 32 ff ff ff ff ff ff ff ff ff ff ff cd c0 sum 0
pi@raspberrypi:~/pitnc $

Not all I need is to get APRS and Figure out Pat Configure, 

73

Don va7dgp/va7qu
Don Poaps
New Westminster, BC
VA7DGP DATA
VA7QU   VOICE


Winlink: va7qu@...
Subject://wl2k           



                    
  




 


On Wed, Jun 24, 2020 at 12:32 AM John Wiseman <john.wiseman@...> wrote:
Unfortunately that instruction is also now out of date.

The correct way is now to use raspi-config Interfacing Options/Serial to disable login on the serial port and enable the port.

73,
John G8BBPQ



On 24/06/2020 05:55, Don Poaps wrote:
Tim I finally see what you meant by Note

  Note added 12/4/2018: Some individuals have reported that there is a problem with the November, 2018 revision of Raspbian that results in the serial port not being accessible. You would notice this, for example, if you run pitnc_getparams and you keep getting “retrying…” instead of the menu. In this case you need to edit the config.txt file in the /boot/ directory. You can do this by running the following from the command line: sudo leafpad /boot/config.txt Add the following line at the bottom of this file: dtoverlay=pi3-miniuart-bt This problem seems to be fixed with more recent versions of the Stretch version of Raspian.   

Thank You.

I thought Buster would have fixed that issue. 

73

Don va7dgp/va7qu
Don Poaps
New Westminster, BC
VA7DGP DATA
VA7QU   VOICE


Winlink: va7qu@...
Subject://wl2k           



                    
  




 


On Tue, Jun 23, 2020 at 1:47 PM Tim via groups.io <the_fro_god=yahoo.com@groups.io> wrote:
Did you try the Note added 12/4/2018 stuff?


N5XMT
 

changes with pitnc_setparams:

pi@HamPi8:~/pitnc $ pitnc_getparams 1 30

   TNC Software Version          11
01 TXDelay - Zero means use ADC  50
02 Persistance                   64
03 Slottime (in 10 mS)           40
04 TXTail                        30
05 Full Duplex - Not used         0
06 Our Channel (Hex)             00
07 I2C Address (0 = async) Hex   00
08 Mode Speed                  1200
09 RX Level (Config)            128
10 TX Level                     255
11 RX Level (Actual)            128
13 Centre Freq                 1700


On Wed, Jun 24, 2020 at 9:36 AM Don Poaps <va7dgp@...> wrote:
I redid the sudo raspi-config > serial Etc.

pi@raspberrypi:~/pitnc $ sudo ./pitnc_getparams /dev/serial0 0

Using Serial port /dev/serial0
retrying...

   TNC Software Version           8
01 TXDelay - Zero means use ADC  50
02 Persistance                  255
03 Slottime (in 10 mS)          255
04 TXTail                       255
05 Full Duplex - Not used       255
06 Our Channel (Hex)             ff
07 I2C Address (0 = async) Hex   ff
08 Mode Speed                  25500
09 RX Level (Config)            255
10 TX Level                     255
11 RX Level (Actual)            255
13 Centre Freq                 2550
8 8 32 ff ff ff ff ff ff ff ff ff ff ff cd c0 sum 0
pi@raspberrypi:~/pitnc $

Not all I need is to get APRS and Figure out Pat Configure, 

73

Don va7dgp/va7qu
Don Poaps
New Westminster, BC
VA7DGP DATA
VA7QU   VOICE


Winlink: va7qu@...
Subject://wl2k           



                    
  




 


On Wed, Jun 24, 2020 at 12:32 AM John Wiseman <john.wiseman@...> wrote:
Unfortunately that instruction is also now out of date.

The correct way is now to use raspi-config Interfacing Options/Serial to disable login on the serial port and enable the port.

73,
John G8BBPQ



On 24/06/2020 05:55, Don Poaps wrote:
Tim I finally see what you meant by Note

  Note added 12/4/2018: Some individuals have reported that there is a problem with the November, 2018 revision of Raspbian that results in the serial port not being accessible. You would notice this, for example, if you run pitnc_getparams and you keep getting “retrying…” instead of the menu. In this case you need to edit the config.txt file in the /boot/ directory. You can do this by running the following from the command line: sudo leafpad /boot/config.txt Add the following line at the bottom of this file: dtoverlay=pi3-miniuart-bt This problem seems to be fixed with more recent versions of the Stretch version of Raspian.   

Thank You.

I thought Buster would have fixed that issue. 

73

Don va7dgp/va7qu
Don Poaps
New Westminster, BC
VA7DGP DATA
VA7QU   VOICE


Winlink: va7qu@...
Subject://wl2k           



                    
  




 


On Tue, Jun 23, 2020 at 1:47 PM Tim via groups.io <the_fro_god=yahoo.com@groups.io> wrote:
Did you try the Note added 12/4/2018 stuff?


N5XMT
 

My command was different as I'm using i2c to communicate with the TNC... so still use the /dev/serial0 0


On Wed, Jun 24, 2020 at 9:51 AM N5XMT via groups.io <dacooley=gmail.com@groups.io> wrote:
changes with pitnc_setparams:

pi@HamPi8:~/pitnc $ pitnc_getparams 1 30

   TNC Software Version          11
01 TXDelay - Zero means use ADC  50
02 Persistance                   64
03 Slottime (in 10 mS)           40
04 TXTail                        30
05 Full Duplex - Not used         0
06 Our Channel (Hex)             00
07 I2C Address (0 = async) Hex   00
08 Mode Speed                  1200
09 RX Level (Config)            128
10 TX Level                     255
11 RX Level (Actual)            128
13 Centre Freq                 1700

On Wed, Jun 24, 2020 at 9:36 AM Don Poaps <va7dgp@...> wrote:
I redid the sudo raspi-config > serial Etc.

pi@raspberrypi:~/pitnc $ sudo ./pitnc_getparams /dev/serial0 0

Using Serial port /dev/serial0
retrying...

   TNC Software Version           8
01 TXDelay - Zero means use ADC  50
02 Persistance                  255
03 Slottime (in 10 mS)          255
04 TXTail                       255
05 Full Duplex - Not used       255
06 Our Channel (Hex)             ff
07 I2C Address (0 = async) Hex   ff
08 Mode Speed                  25500
09 RX Level (Config)            255
10 TX Level                     255
11 RX Level (Actual)            255
13 Centre Freq                 2550
8 8 32 ff ff ff ff ff ff ff ff ff ff ff cd c0 sum 0
pi@raspberrypi:~/pitnc $

Not all I need is to get APRS and Figure out Pat Configure, 

73

Don va7dgp/va7qu
Don Poaps
New Westminster, BC
VA7DGP DATA
VA7QU   VOICE


Winlink: va7qu@...
Subject://wl2k           



                    
  




 


On Wed, Jun 24, 2020 at 12:32 AM John Wiseman <john.wiseman@...> wrote:
Unfortunately that instruction is also now out of date.

The correct way is now to use raspi-config Interfacing Options/Serial to disable login on the serial port and enable the port.

73,
John G8BBPQ



On 24/06/2020 05:55, Don Poaps wrote:
Tim I finally see what you meant by Note

  Note added 12/4/2018: Some individuals have reported that there is a problem with the November, 2018 revision of Raspbian that results in the serial port not being accessible. You would notice this, for example, if you run pitnc_getparams and you keep getting “retrying…” instead of the menu. In this case you need to edit the config.txt file in the /boot/ directory. You can do this by running the following from the command line: sudo leafpad /boot/config.txt Add the following line at the bottom of this file: dtoverlay=pi3-miniuart-bt This problem seems to be fixed with more recent versions of the Stretch version of Raspian.   

Thank You.

I thought Buster would have fixed that issue. 

73

Don va7dgp/va7qu
Don Poaps
New Westminster, BC
VA7DGP DATA
VA7QU   VOICE


Winlink: va7qu@...
Subject://wl2k           



                    
  




 


On Tue, Jun 23, 2020 at 1:47 PM Tim via groups.io <the_fro_god=yahoo.com@groups.io> wrote:
Did you try the Note added 12/4/2018 stuff?