timedatectl not working on Buster


David Ranch
 


Hello Everyone,

I'm bringing over this topic that K0OIL started on the Fldigi centric linuxham@groups.io list and I'm also seeing this issue on one Raspberry Pi.  I think something is broken deep in the bowels of Systemd and/or DBUS but I can't find it so far.  I'm curious if anyone else has seen something like this.

--David
KI6ZHD


Interestingly enough, I have a Raspberry Pi Zero W running Buster with the same issue:

   $ timedatectl show-timesync
   Failed to parse bus message: Connection timed out

   $ timedatectl timesync-status
   Failed to query server: Connection timed out


It's interesting that it's showing a 'bus" message.  Looking further:

   sudo journalctl | tail --lines=100
   --
   Jun 01 13:59:11 rpi0w-2 dbus-daemon[1099]: [system] Activating via systemd: service name='org.freedesktop.timesync1' unit='dbus-org.freedesktop.timesync1.service' requested by ':1.4' (uid=1001 pid=1120 comm="timedatectl timesync-status ")
   Jun 01 13:59:11 rpi0w-2 systemd[1]: Condition check resulted in Network Time Synchronization being skipped.
   Jun 01 13:59:36 rpi0w-2 dbus-daemon[1099]: [system] Failed to activate service 'org.freedesktop.timesync1': timed out (service_start_timeout=25000ms)
   --


I tried disabling the IPv4 iptables firewall, I tried disabling the entire IPv6 protocol and rebooted, etc.  I've tried explicitly configuring primary and backup NTP servers in /etc/systemd/timesyncd.conf and making Systemd was happy with the new config, etc.  Nothing has fixed this issue on this one Raspberry Pi but I have many other Rpis running Buster w/o this issue.  I have to do more testing here to figure out what might be happening here.

--David
KI6ZHD



On 05/31/2021 04:40 PM, S Johnson, K0OIL wrote:
David, when I run "timedatectl timesync-status" I get a timeout, no data as you have.

Internet seems stable for everything else. 

Also tried Danny's "timedatectl set-ntp true" which ran without error but didn't change anything. 

I wrote a little script:

sudo service ntp stop
sudo ntpdate -s time.nist.gov
sudo service ntp start
sudo hwclock -w

Which seems to correct the clock to the "Exact" time, so I can this at will now, but I was hoping to not have to reset the clock each session. 

--

K0OIL