Topics

Sending Winlink Express through Direwolf sound modem

Robert Ambrose, N7GET
 

I realize that this is may be more of a Winlink Express issue rather than a RPi issue, but I’m hoping that somebody has had experience with this scenario.

The RPi is a WM4ACK automated build (great work, big fan) with Dirwolf 1.5 running. I can send and receive Winlink messages using pat via a local RMS packet node.

I’m trying to send a message from Winlink Express on a Windows 10 PC. The connection on Winlink Express is ‘Packet Winlink’ with the following settings:

Packet TNC Type: KISS
Packet TNC Model: Normal
Serial Port: TCP
TCP Host/Port: 192.168.11.121 8001

The rest of the settings were unchanged.

When I tried to send a message from Winlink the RMS station rejects it with the following message: '*** B2 Command '[RMS Express-1.5.28.0-B2FHM$]' not recognized - Disconnecting (162.251.236.5)’.

What I’m looking for right now is this doable and is all I need is a configuration change or do I not have a clue (pretty much) and I need to dig deeper into the details of how Winlink works?

One issue I’m not sure about is callsign SSIDs on the Winlink vs the RPi. Is this the problem? Should they match? Do I need to register my callsign with multiple SSIDs?

---
Robert Ambrose, N7GET

David Ranch
 


Hello Robert,

This doesn't seem to be a Direwolf or a Raspberry Pi issue.  This seems to be a Winlink Express application problem.  Few ideas:

   - Have you tried connecting to a different remote RMS station to see if you have that same prompting problem?

   - Have you tried using the AGW interface from Direwolf instead of using the TCP-KISS as an alternative?


--David



Troy - K4JDA
 

I’m betting it’s a Pi firewall blocking the port.