Topics

Raspberry PI "hears" its own transmission


rvnash@...
 

Hi All,

I have set up a new iGate/Digipeater as KC3ARY-7. It all seems to going well using a Raspberry PI with a Kenwood rig. You can see my documentations, such as it is, here.

The one remaining oddity seems to be that the USB sound card echos back the FSK packet from its speaker output back through its own microphone, and Direwolf interprets it as if it heard the packet over the air. It really doesn't cause any issues, but I would like to eliminate this problem.

The reason I want to fix it is that my posting of the packet to APRS-IS occurs slightly before any other iGate that actually does hear my packet, so usually it shows up as if it was an direct post to the iGate, rather than ever going out over the air.

I think it might have something to do with a purposeful feature of these USB sound cards, or maybe the alsa drivers where sound output deliberately gets fed back? Anyone else encountering this?

Thanks and 73s,
Rich KC3ARY


David Ranch
 


Hello Rich,

If you search the Direwolf email list and probably this email list, you'll find other similar reports.  Various found issues and resolutions boil down to:

   - You have RFI issues
      - move the Raspberry Pi and sound card as FAR away from the radio and the antenna as possible
      - add ferrite chokes to both sides of all cables on all devices (including power cables)
      - One way to test this is to turn off your radio and then beacon.  Do you still hear your own packets?
         - No?  Turn on the radio but put the radio on low power.  Do you still hear your own packets?  Repeat for all power levels

   - You have a sound card mixer issue:
      - your sound levels are too high
      - your mixer has "monitors" or other features enabled

--David
KI6ZHD


On 09/08/2020 12:33 PM, rvnash@... wrote:
Hi All,

I have set up a new iGate/Digipeater as KC3ARY-7. It all seems to going well using a Raspberry PI with a Kenwood rig. You can see my documentations, such as it is, here.

The one remaining oddity seems to be that the USB sound card echos back the FSK packet from its speaker output back through its own microphone, and Direwolf interprets it as if it heard the packet over the air. It really doesn't cause any issues, but I would like to eliminate this problem.

The reason I want to fix it is that my posting of the packet to APRS-IS occurs slightly before any other iGate that actually does hear my packet, so usually it shows up as if it was an direct post to the iGate, rather than ever going out over the air.

I think it might have something to do with a purposeful feature of these USB sound cards, or maybe the alsa drivers where sound output deliberately gets fed back? Anyone else encountering this?

Thanks and 73s,
Rich KC3ARY


 

Sometimes it is cross talk.  Adjusting alsamixer so that only the left or right channel is active (depending on your wiring), may be a solution, as well as David's list.  Direwolf is extremely sensitive so it will work to decode the faintest signal.

On Tue, Sep 8, 2020 at 12:41 PM <rvnash@...> wrote:
Hi All,

I have set up a new iGate/Digipeater as KC3ARY-7. It all seems to going well using a Raspberry PI with a Kenwood rig. You can see my documentations, such as it is, here.

The one remaining oddity seems to be that the USB sound card echos back the FSK packet from its speaker output back through its own microphone, and Direwolf interprets it as if it heard the packet over the air. It really doesn't cause any issues, but I would like to eliminate this problem.

The reason I want to fix it is that my posting of the packet to APRS-IS occurs slightly before any other iGate that actually does hear my packet, so usually it shows up as if it was an direct post to the iGate, rather than ever going out over the air.

I think it might have something to do with a purposeful feature of these USB sound cards, or maybe the alsa drivers where sound output deliberately gets fed back? Anyone else encountering this?

Thanks and 73s,
Rich KC3ARY



--
John D. Hays
Kingston, WA
K7VE

 


rvnash@...
 

Thank you gentlemen. I took John's advice first because it was easy to do. I turned down the unconnected Right channel to 0 volume, and the problem went away. So, I'll take that as a win and not try the other good suggestions from David.

Thanks again,
-- Rich
KC3ARY