Topics

Pi-4 Buster - Fatal error whilst making FLDIGI 4.1.08

MIKE RICHARDS
 

Hi All,

I'm trying to install FLDIGI 4.1.08 from source on a 1GB Pi-4 running the latest Raspbian with all updates.

The make process fails with a g++ fatal error. Immediately before this, there's a warning that "end of file is not at end of a line; new line inserted". See attached screenshot of the failure.

Can anyone help solve this?

Mike - G4WNC

Harry Bloomberg <hbloomb@...>
 

I'll take a wild guess...did you increase the virtual RAM on your Pi?


And, are you following this build instruction from W1HKJ?


73,
Harry Bloomberg W3YJ


On Thu, Dec 19, 2019 at 2:34 PM MIKE RICHARDS <mike@...> wrote:
Hi All,

I'm trying to install FLDIGI 4.1.08 from source on a 1GB Pi-4 running the latest Raspbian with all updates.

The make process fails with a g++ fatal error. Immediately before this, there's a warning that "end of file is not at end of a line; new line inserted". See attached screenshot of the failure.

Can anyone help solve this?

Mike - G4WNC

MIKE RICHARDS
 

Harry,

Thanks for the quick response. That did the trick! I had been working from the instructions in the INSTALL file and didn't check the wiki. I did expand the swap space but probably not enough for this build.

Thanks again,


Mike - G4WNC

Harry Bloomberg <hbloomb@...>
 

Glad to help!  I ran into the same problem building Fldigi on a Raspberry Pi 3B+.  Wish the default configuration for the Pi was for more virtual memory.

73,
Harry W3YJ


On Thu, Dec 19, 2019 at 5:37 PM MIKE RICHARDS <mike@...> wrote:
Harry,

Thanks for the quick response. That did the trick! I had been working from the instructions in the INSTALL file and didn't check the wiki. I did expand the swap space but probably not enough for this build.

Thanks again,


Mike - G4WNC