Topics

pi9k6 Winlink Pat ARDOP

Bill AA6BD
 

Thanks for this thread.  I was struggling to get PAT to work with ax.25 in the Linux kernel as it was timing out on large messages.  I was going to get a Signalink or equivalent and try Direwolf, but I had not discovered that PAT could work with LinBPQ until I found this thread.  This is a much better solution for me as LinBPQ has been rock solid when I use it as a Webmail client or as an RMS gateway on another Pi with TNC-Pi.

I loaded the beta of LinBPQ v 6.0.20.10 onto my Pi that also has PAT working and made it executable.
I copied linbpq.conf from my Pi that has worked as a Webmail client using a Byonics TT4 TNC.  In it, Port 01 is the Telnet port, and Port 02 is the TT4 port.
Port 01 is configured as:

PORT
 ID=Telnet Server
 DRIVER=TELNET
 CONFIG
 LOGGING=1
 CMS=1 ; Enable CMS Gateway
 HTTPPORT=8080 ; Port used for Web Management/WebMail
 TCPPORT=8010 ; Port for Telnet Access
 FBBPORT=8011 ; Not required, but allows monitoring using BPQTermTCP
 MAXSESSIONS=10
 CloseOnDisconnect=1 ; Close Telnet Session when Node disconnects
 USER=aa6bd,(password),AA6BD,"",SYSOP
 
 ENDPORT

I added a connect alias to PAT so that my aliases section of the config.json file now is

  "connect_aliases": {
    "telnet": "telnet://{mycall}:CMSTelnet@...:8772/wl2k",
    "mytelnet": "telnet://{mycall}:CMSTelnet$1$aa6bd-10@....0.1:8772/wl2k",

When I try to use BPQ32 through telnet to connect from PAT, I get:

Connecting to WL2K (telnet)...
Unable to establish connection to remote: dial tcp 127.0.0.1:8772: connect: connection refused

How should mytelnet be configured?  Or am I missing something else?

--
Bill AA6BD

John Wiseman
 

See http://www.cantab.net/users/john.wiseman/Documents/PATSupport.html

PAT connections to or via LinBPQ use the RMS Relay emulation feature, so you need to set RELAYAPPL in the Telnet Server configuration.

The connect string embedded in the CMSPass field should include the number of the port you want to call out on. As your radio port is port 2 you need "telnet://{mycall}:CMSTelnet$2$aa6bd-10@....0.1:8772/wl2k"

73,
John G8BPQ

On 02/06/2020 01:18, Bill AA6BD wrote:
Thanks for this thread.  I was struggling to get PAT to work with ax.25 in the Linux kernel as it was timing out on large messages.  I was going to get a Signalink or equivalent and try Direwolf, but I had not discovered that PAT could work with LinBPQ until I found this thread.  This is a much better solution for me as LinBPQ has been rock solid when I use it as a Webmail client or as an RMS gateway on another Pi with TNC-Pi.

I loaded the beta of LinBPQ v 6.0.20.10 onto my Pi that also has PAT working and made it executable.
I copied linbpq.conf from my Pi that has worked as a Webmail client using a Byonics TT4 TNC.  In it, Port 01 is the Telnet port, and Port 02 is the TT4 port.
Port 01 is configured as:

PORT
 ID=Telnet Server
 DRIVER=TELNET
 CONFIG
 LOGGING=1
 CMS=1 ; Enable CMS Gateway
 HTTPPORT=8080 ; Port used for Web Management/WebMail
 TCPPORT=8010 ; Port for Telnet Access
 FBBPORT=8011 ; Not required, but allows monitoring using BPQTermTCP
 MAXSESSIONS=10
 CloseOnDisconnect=1 ; Close Telnet Session when Node disconnects
 USER=aa6bd,(password),AA6BD,"",SYSOP
 
 ENDPORT

I added a connect alias to PAT so that my aliases section of the config.json file now is

  "connect_aliases": {
    "mytelnet": "telnet://{mycall}:CMSTelnet$1$aa6bd-10@....0.1:8772/wl2k",

When I try to use BPQ32 through telnet to connect from PAT, I get:

Connecting to WL2K (telnet)...
Unable to establish connection to remote: dial tcp 127.0.0.1:8772: connect: connection refused

How should mytelnet be configured?  Or am I missing something else?

--
Bill AA6BD

Bill AA6BD
 

John,
Thanks for your patience with me as I work through getting this working so I can use PAT with linbpq as its ax.25 transport to my radio.

I changed the Telnet server configuration to include setting RELAYAPPL as follows:

; Basic Webmail configuration
 
SIMPLE ; This set a whole load of paramters to reasonable defaults
 
LOCATOR=CM88PL ; Set to your Grid Square to send reports to the BPQ32 Node Map system
NODECALL=AA6BD-2
 
INFOMSG:
AA6BD's LinBPQ Gateway
***
 
PORT
 ID=Telnet Server
 DRIVER=TELNET
 CONFIG
 LOGGING=1
 CMS=1 ; Enable CMS Gateway
 HTTPPORT=8080 ; Port used for Web Management/WebMail
 TCPPORT=8010 ; Port for Telnet Access
 FBBPORT=8011 ; Not required, but allows monitoring using BPQTermTCP
 MAXSESSIONS=10
 CloseOnDisconnect=1 ; Close Telnet Session when Node disconnects
 USER=aa6bd,{password},AA6BD,"",SYSOP
 RELAYAPPL=BBS
 
 ENDPORT
 
 ; Add Radio Port(s) Here
 
PORT
 ID=1200 Baud 144.xxx
 TYPE=ASYNC
 PROTOCOL=KISS
 CHANNEL=A
 COMPORT=/dev/ttyUSB0
 SPEED=19200 ; Change as required
 MAXFRAME=4
 FRACK=8000
 RESPTIME=1500
 RETRIES=10
 PACLEN=120
 TXDELAY=300
 SLOTTIME=100
 PERSIST=64
 
 WL2KREPORT PUBLIC, www.winlink.org, 8778, AA6BD-10, CM86PL, 00-23, 144960000, PKT1200, 10, 20, 5, 0
 
ENDPORT
 
APPLICATION 1,BBS,,AA6BD
APPLICATION 2,RMS,C 1 CMS,AA6BD-10
 
LINMAIL ; Enable BBS
 
Then I changed the PAT config.json connect_alias to use $2 which should point to using the ASYNC TNC port.

  "connect_aliases": {
    "telnet": "telnet://{mycall}:CMSTelnet@...:8772/wl2k",
    "mytelnet": "telnet://{mycall}:CMSTelnet$2$AA6BD-10@....0.1:8772/wl2k",

When I use BPQ Webmail, all works as I would suspect.  I create an email which is forwarded through my ASYNC port and my radio.  And I set up forwarding on RMS to connect every 600 seconds to check for email which it does nicely.

But when I use PAT and select the connect_alias of "mytelnet," BPQ sends the email through telnet port 1 rather than through radio port 2, even though "mytelnet" is configured with $2 which should select port 2, right?  How do I get BPQ to select port 2?

The CMSAccess.log is:

20:48:04 10 AA6BD Connected to CMS
20:48:05 10 Callsign :
20:48:05 10 AA6BD
20:48:05 10 Password :
20:48:05 10 CMSTELNET
 
20:48:05 10 [WL2K-5.0-B2FWIHJM$]<cr>
20:48:05 10 ;PQ: 28364100<cr>
20:48:05 10 CMS><cr>
20:48:06 10 ;FW: AA6BD<cr>
20:48:06 10 [Pat-0.9.0-B2FHMG$]<cr>
20:48:06 10 ;PR: 35315818<cr>
20:48:06 10 ; WL2K DE AA6BD (CM88pl)<cr>
20:48:06 10 FC EM ITB2X6NKNNKF 255 220 0<cr>
20:48:06 10 F> 73<cr>
20:48:06 10 FS Y<cr>
20:48:06 10 test new pat under linbpq
20:48:07 10 FF<cr>
20:48:08 10 Disconnected. Bytes Sent = 361 Bytes Received 48 Time 4 Seconds

Am I running into some problem because both BPQ webmail and PAT mail are active at the same time?  Something else?
--
Bill AA6BD

Bill AA6BD
 

Correction, when I post the connect_aliases, this system changes the values.  

  "connect_aliases": {
    "telnet": "telnet://{mycall}:CMSTelnet@...:8772/wl2k",
    "mytelnet": "telnet://{mycall}:CMSTelnet$2$AA6BD-10@....0.1:8772/wl2k",

The values after the @ are
cms.winlink.org
and 
127.0.0.1
--
Bill AA6BD

John Wiseman
 

This is probable because you are connecting to your own call. BPQ will normally ignore the port in a connect command if the station you are calling is one of your applications or a station in your Nodes list. It connects you to AA6BD-10, your RMS application.

You can override this by prepending an ! to the call, eg

"telnet://{mycall}:CMSTelnet$2$!AA6BD-10@....0.1:8772/wl2k"

This won't be needed if connecting to a remote station.

You can confirm that the system is interpreting the password string correctly in your Telnet Server log You should see something like this

03/06/2020 07:33:23 1 127.0.0.1 Incoming Connect on Port 8772
03/06/2020 07:33:27 1 127.0.0.1 User=G8BPQ
03/06/2020 07:33:38 1 127.0.0.1 Password=CMSTelnet$9$G8BPQ-2
03/06/2020 07:33:38 1 127.0.0.1 Gateway Connect Call=G8BPQ Command=C 9 G8BPQ-2

73,
John



On 02/06/2020 22:45, Bill AA6BD wrote:
John,
Thanks for your patience with me as I work through getting this working so I can use PAT with linbpq as its ax.25 transport to my radio.

I changed the Telnet server configuration to include setting RELAYAPPL as follows:

; Basic Webmail configuration
 
SIMPLE ; This set a whole load of paramters to reasonable defaults
 
LOCATOR=CM88PL ; Set to your Grid Square to send reports to the BPQ32 Node Map system
NODECALL=AA6BD-2
 
INFOMSG:
AA6BD's LinBPQ Gateway
***
 
PORT
 ID=Telnet Server
 DRIVER=TELNET
 CONFIG
 LOGGING=1
 CMS=1 ; Enable CMS Gateway
 HTTPPORT=8080 ; Port used for Web Management/WebMail
 TCPPORT=8010 ; Port for Telnet Access
 FBBPORT=8011 ; Not required, but allows monitoring using BPQTermTCP
 MAXSESSIONS=10
 CloseOnDisconnect=1 ; Close Telnet Session when Node disconnects
 USER=aa6bd,{password},AA6BD,"",SYSOP
 RELAYAPPL=BBS
 
 ENDPORT
 
 ; Add Radio Port(s) Here
 
PORT
 ID=1200 Baud 144.xxx
 TYPE=ASYNC
 PROTOCOL=KISS
 CHANNEL=A
 COMPORT=/dev/ttyUSB0
 SPEED=19200 ; Change as required
 MAXFRAME=4
 FRACK=8000
 RESPTIME=1500
 RETRIES=10
 PACLEN=120
 TXDELAY=300
 SLOTTIME=100
 PERSIST=64
 
 WL2KREPORT PUBLIC, www.winlink.org, 8778, AA6BD-10, CM86PL, 00-23, 144960000, PKT1200, 10, 20, 5, 0
 
ENDPORT
 
APPLICATION 1,BBS,,AA6BD
APPLICATION 2,RMS,C 1 CMS,AA6BD-10
 
LINMAIL ; Enable BBS
 
Then I changed the PAT config.json connect_alias to use $2 which should point to using the ASYNC TNC port.

  "connect_aliases": {

When I use BPQ Webmail, all works as I would suspect.  I create an email which is forwarded through my ASYNC port and my radio.  And I set up forwarding on RMS to connect every 600 seconds to check for email which it does nicely.

But when I use PAT and select the connect_alias of "mytelnet," BPQ sends the email through telnet port 1 rather than through radio port 2, even though "mytelnet" is configured with $2 which should select port 2, right?  How do I get BPQ to select port 2?

The CMSAccess.log is:

20:48:04 10 AA6BD Connected to CMS
20:48:05 10 Callsign :
20:48:05 10 AA6BD
20:48:05 10 Password :
20:48:05 10 CMSTELNET
 
20:48:05 10 [WL2K-5.0-B2FWIHJM$]<cr>
20:48:05 10 ;PQ: 28364100<cr>
20:48:05 10 CMS><cr>
20:48:06 10 ;FW: AA6BD<cr>
20:48:06 10 [Pat-0.9.0-B2FHMG$]<cr>
20:48:06 10 ;PR: 35315818<cr>
20:48:06 10 ; WL2K DE AA6BD (CM88pl)<cr>
20:48:06 10 FC EM ITB2X6NKNNKF 255 220 0<cr>
20:48:06 10 F> 73<cr>
20:48:06 10 FS Y<cr>
20:48:06 10 test new pat under linbpq
20:48:07 10 FF<cr>
20:48:08 10 Disconnected. Bytes Sent = 361 Bytes Received 48 Time 4 Seconds

Am I running into some problem because both BPQ webmail and PAT mail are active at the same time?  Something else?
--
Bill AA6BD

Bill AA6BD
 

Thanks, John.  The ! worked.

--
Bill AA6BD