Topics

ipconfig command not found - alternative?

David KD4E <dcolburn@...>
 

In a Buster - Raspian install on a RPi4 ipconfig isn't recognized when used in Terminal.

Wlan0 works fine there & I wanted to view the settings ...

Because ... in the pre-packaged W3DJS Raspberry Pi Ham Radio Image v2.0
wlan0 doesn't respond and I can't find the reason (ipconfig works when that's booted).

Thanks, David KD4E

Jim Hudson
 

Linux uses ifconfig. ipconfig is a windows thing.

On Nov 6, 2019, at 18:17, David KD4E <dcolburn@...> wrote:

In a Buster - Raspian install on a RPi4 ipconfig isn't recognized when used in Terminal.

Wlan0 works fine there & I wanted to view the settings ...

Because ... in the pre-packaged W3DJS Raspberry Pi Ham Radio Image v2.0
wlan0 doesn't respond and I can't find the reason (ipconfig works when that's booted).

Thanks, David KD4E

steve rasbach
 

I think you want ifconfig perhaps?


On Wed, Nov 6, 2019 at 7:17 PM David KD4E <dcolburn@...> wrote:
In a Buster - Raspian install on a RPi4 ipconfig isn't recognized when used in Terminal.

Wlan0 works fine there & I wanted to view the settings ...

Because ... in the pre-packaged W3DJS Raspberry Pi Ham Radio Image v2.0
wlan0 doesn't respond and I can't find the reason (ipconfig works when that's booted).

Thanks, David KD4E

Vince A
 

David

Its ifconfig in buster RASP Pi. In winders it's ipconfig
73 Vince KD7TWW

On Nov 6 2019, at 5:17 pm, David KD4E via Groups.Io <dcolburn@...> wrote:
In a Buster - Raspian install on a RPi4 ipconfig isn't recognized when used in Terminal.

Wlan0 works fine there & I wanted to view the settings ...

Because ... in the pre-packaged W3DJS Raspberry Pi Ham Radio Image v2.0
wlan0 doesn't respond and I can't find the reason (ipconfig works when that's booted).

Thanks, David KD4E
Sent from Mailspring

Jeff Palmer
 

As others have mentioned, it's ifconfig in linux.  However,  ifconfig is a deprecated command and may be removed in a future version.

the new hotness is 'ip'    for example 'ip addr show'



On Wed, Nov 6, 2019 at 7:17 PM David KD4E <dcolburn@...> wrote:
In a Buster - Raspian install on a RPi4 ipconfig isn't recognized when used in Terminal.

Wlan0 works fine there & I wanted to view the settings ...

Because ... in the pre-packaged W3DJS Raspberry Pi Ham Radio Image v2.0
wlan0 doesn't respond and I can't find the reason (ipconfig works when that's booted).

Thanks, David KD4E



--
Jeff Palmer
Palmer IT Consulting, LLC.

David KD4E <dcolburn@...>
 

Just for fun I tried 'if addr show' and 'ip addr show' in the W3DJS load - neither returned any data nor any errors. David KD4E
> On 11/6/19 8:13 PM, Jeff Palmer wrote:
> As others have mentioned, it's ifconfig in linux. However, ifconfig > is a deprecated command and may be removed in a future version. > > the new hotness is 'ip' for example 'ip addr show'

David KD4E <dcolburn@...>
 

ADDITION:

Just tried 'sudo ip addr show' in the W3DJS load ... It returned for wlan0 ... "<NO-CARRIER, BROADCAST, MULTICAST, UP> mtu 1500 qdisc mq state DOWN group default qlen 1000 /link/ether ... [followed by a bunch of alphanumerics that looks like a MAC address] ... then "brd ff:ff:ff:ff:ff:ff"

Just for fun I tried 'if addr show' and 'ip addr show' in the W3DJS load - neither returned any data nor any errors. David KD4E
> On 11/6/19 8:13 PM, Jeff Palmer wrote:
> As others have mentioned, it's ifconfig in linux. However, ifconfig > is a deprecated command and may be removed in a future version. > > the new hotness is 'ip' for example 'ip addr show'

David KD4E <dcolburn@...>
 

OK ...

RPi 4 w/Buster-Raspian in a bundle with some applications.

"iw dev" - shows the wlan0 device

"ip link show wlan0" - shows wlan0 is in the "DOWN" state

ip link set wlan0 up - "Operation not permitted"

"sudo ip link set wlan0 up" - no error message

"ip link show wlan0" - shows wlan0 is still in the "DOWN" state

Questions:

1. How can the state not change?

2. How do I fix that?

Thanks, David KD4E

David KD4E <dcolburn@...>
 

Why does this command trigger a ""Permission denied" error, please?

"sudo wpa_password SSIDHERE >> /etc/wpa_supplicant/wpa_supplicant.conf passwordhere"

Thanks, David KD4E

OK ...

RPi 4 w/Buster-Raspian in a bundle with some applications.

"iw dev" - shows the wlan0 device

"ip link show wlan0" - shows wlan0 is in the "DOWN" state

ip link set wlan0 up - "Operation not permitted"

"sudo ip link set wlan0 up" - no error message

"ip link show wlan0" - shows wlan0 is still in the "DOWN" state

Questions:

1. How can the state not change?

2. How do I fix that?

Thanks, David KD4E

chuck gelm <rpi4ham@...>
 

On 11/6/19 7:17 PM, David KD4E wrote:
In a Buster - Raspian install on a RPi4 ipconfig isn't recognized when used in Terminal.
In Unix, Linux, and Mac; ifconfig
In Windows®; ipconfig

chuck gelm <rpi4ham@...>
 

On 11/6/19 10:09 PM, David KD4E wrote:
"ip link show wlan0" - shows wlan0 is still in the "DOWN" state

Questions:

1. How can the state not change?
Cuz it does not know what to change to. To dangle a participle.

2. How do I fix that?
Define (configure) a state for wlan0.

Hope this helps, Chuck

Thanks, David KD4E

chuck gelm <rpi4ham@...>
 

On 11/6/19 8:39 PM, David KD4E wrote:
Just for fun I tried 'if addr show' and 'ip addr show' in the W3DJS load - neither returned any data nor any errors. David KD4E

man ip

Michael WA7SKG
 

Chuck,
You obviously did not see
"sudo ip link set wlan0 up" - no error message

where he commanded the link up. That is how it knew what to change to.

Sending
ip link show wlan0" - shows wlan0 is still in the "DOWN" state

was merely asking for link status and determining whether the link up command worked.

So, he did define a state for wlan0. He is trying to figure out why his command did not work.

Unfortunately, it all looks good to me. I have tried the commands David used and they work fine on my machine. I find no issue with his command syntax. If there was, there should have been an error message of some type.

Hopefully, someone else can offer a reason why his wlan0 is not responding to the UP command to enable it. It sounds like a real problem and I am interested in an actual answer myself.

Michael WA7SKG


chuck gelm wrote on 11/7/19 6:17 AM:

On 11/6/19 10:09 PM, David KD4E wrote:
"ip link show wlan0" - shows wlan0 is still in the "DOWN" state

Questions:

1. How can the state not change?
Cuz it does not know what to change to. To dangle a participle.

2. How do I fix that?
Define (configure) a state for wlan0.
Hope this helps, Chuck

Thanks, David KD4E

Jeff Palmer
 



On Wed, Nov 6, 2019 at 11:02 PM David KD4E <dcolburn@...> wrote:
Why does this command trigger a ""Permission denied" error, please?

"sudo wpa_password SSIDHERE >> /etc/wpa_supplicant/wpa_supplicant.conf
passwordhere"


sudo enables elevated privileges to the command that follows.  As written,  you are running wpa_password with elevated privileges. however, you are piping the output to /etc/wpa_supplicant/wpa_supplicant.conf as your normal user (it doesn't inherit the elevated privileges.

Aside from that,  you have the syntax slightly incorrect.   I'd recommend:

sudo bash
wpa_password YOURSSID YOURWIFIPASSWORD >> /etc/wpa_supplicant/wpa_supplicant.conf
exit

("sudo bash" will allow any further command to be run with escalated privileges.. but be careful, this is a security concern, as a simple typo in future commands can do a lot of harm.  This essentially violates the "least privilege" security tenant. that is why I have the "exit" afterwards.  Please be sure to exit the shell with elevated privileges immediately when it's done)



Question for the community at large:    things like this that are more "how do I use linux" rather than "I have this issue with a ham radio app on the pi"  are they outside of scope here (in this thread or group)
It seems like there are tons of resources dedicated to "how do I use linux" and I'm not sure the etiquette for asking such questions here?





 

Thanks, David KD4E

> OK ...
>
> RPi 4 w/Buster-Raspian in a bundle with some applications.
>
> "iw dev" - shows the wlan0 device
>
> "ip link show wlan0" - shows wlan0 is in the "DOWN" state
>
> ip link set wlan0 up - "Operation not permitted"
>
> "sudo ip link set wlan0 up" - no error message
>
> "ip link show wlan0" - shows wlan0 is still in the "DOWN" state
>
> Questions:
>
> 1. How can the state not change?
>
> 2. How do I fix that?
>
> Thanks, David KD4E







--
Jeff Palmer
Palmer IT Consulting, LLC.

Niels Ruiter
 

Hi,

You can install net-tools (sudo apt-get install net-tools) so you can use ifconfig again.

73 Niels PD9Q

-----Original Message-----
From: RaspberryPi-4-HamRadio@groups.io [mailto:RaspberryPi-4-HamRadio@groups.io] On Behalf Of David KD4E
Sent: Thursday, November 07, 2019 1:17 AM
To: RaspberryPi-4-HamRadio@groups.io
Subject: [RaspberryPi-4-HamRadio] ipconfig command not found - alternative?

In a Buster - Raspian install on a RPi4 ipconfig isn't recognized when used in Terminal.

Wlan0 works fine there & I wanted to view the settings ...

Because ... in the pre-packaged W3DJS Raspberry Pi Ham Radio Image v2.0
wlan0 doesn't respond and I can't find the reason (ipconfig works when that's booted).

Thanks, David KD4E

Mark Griffith
 

(Niels, this is not directed at you, I didn't reply to the original message)

I'm sorry, this is not correct.  Ifconfig works perfectly on Raspbian Buster.

root@PiGatePi4: ifconfig
ax0: flags=67<UP,BROADCAST,RUNNING>  mtu 256
        ax25 KD0QYN-1  txqueuelen 10  (AMPR AX.25)
        RX packets 3850  bytes 79624 (77.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 195  bytes 15746 (15.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether dc:a6:32:0d:a1:4c  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 82  bytes 4784 (4.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 82  bytes 4784 (4.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.142  netmask 255.255.255.0  broadcast 192.168.1.255
        ether dc:a6:32:0d:a1:4d  txqueuelen 1000  (Ethernet)
        RX packets 201922  bytes 22474084 (21.4 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 105004  bytes 32035606 (30.5 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


I'm not plugged in with an Ethernet cable, so am using the WiFi to connect to my home WiFi network.

Mark
KD0QYN


On Thursday, November 7, 2019, 1:02:17 PM CST, Niels Ruiter <pd9q@...> wrote:


Hi,

You can install net-tools (sudo apt-get install net-tools) so you can use ifconfig again.

73 Niels PD9Q


-----Original Message-----
From: RaspberryPi-4-HamRadio@groups.io [mailto:RaspberryPi-4-HamRadio@groups.io] On Behalf Of David KD4E
Sent: Thursday, November 07, 2019 1:17 AM
To: RaspberryPi-4-HamRadio@groups.io
Subject: [RaspberryPi-4-HamRadio] ipconfig command not found - alternative?

In a Buster - Raspian install on a RPi4 ipconfig isn't recognized when used in Terminal.

Wlan0 works fine there & I wanted to view the settings ...

Because ... in the pre-packaged W3DJS Raspberry Pi Ham Radio Image v2.0
wlan0 doesn't respond and I can't find the reason (ipconfig works when that's booted).

Thanks, David KD4E




David KD4E <dcolburn@...>
 

"wpa_password" isn't recognized in Bash, at least not on my RPi4.
Thanks, David KD4E

> On 11/7/19 12:38 PM, Jeff Palmer wrote: > > sudo enables elevated privileges to the command that follows. As > written, you are running wpa_password with elevated privileges. > however, you are piping the output to > /etc/wpa_supplicant/wpa_supplicant.conf as your normal user (it > doesn't inherit the elevated privileges. > > Aside from that, you have the syntax slightly incorrect. I'd > recommend: > > sudo bash wpa_password YOURSSID YOURWIFIPASSWORD >> > /etc/wpa_supplicant/wpa_supplicant.conf exit > > ("sudo bash" will allow any further command to be run with escalated > privileges.. but be careful, this is a security concern, as a simple > typo in future commands can do a lot of harm. This essentially > violates the "least privilege" security tenant. that is why I have > the "exit" afterwards. Please be sure to exit the shell with > elevated privileges immediately when it's done)

David KD4E <dcolburn@...>
 

I looked at a ton of Linux "resources" and those that weren't way out of
date - lacked the information I needed.

I also searched a bunch of Raspberry Pi, especially (but not exclusively)
Raspian sites, and same problem.

There's something unique to the bundled package, that includes Buster
Raspberry, that responds differently than a vanilla Buster Raspian install.

I've wasted several hours on what should have been plug & play wifi.

It would be cool if someone would create an app/script that systematically
checked all of the wifi-relevant installed pieces in a Raspian install and
then flags those that might interfere with wifi - and then to recommend
changes.

IMHO: I think we need to be able to solve problems here - especially
where they're rarely limited to one user's experience & could save
10, 50, 100 users from chasing the same needle in a haystack across
the Internet - or just give up.

> On 11/7/19 12:38 PM, Jeff Palmer wrote> Question for the community at > large: things like this that are more "how do I use linux" rather > than "I have this issue with a ham radio app on the pi" are they > outside of scope here (in this thread or group) It seems like there > are tons of resources dedicated to "how do I use linux" and I'm not > sure the etiquette for asking such questions here?