Topics

Icom IC-207 + TNC-PI9K6 issue RX/TX

VA3ZUK
 

SETUP
  1. ICOM IC-207 
  2. TNC-PI9K6
  3. 6 pin mini-din 
  4. Raspberry Pi 3 Model B Rev 1.2 
  5. Raspbian GNU/Linux 10 (buster) 
  6. Linux Kernel 4.19.97-v7+
  7. 9600 & 1200 baud
ISSUE
Unable to RX or TX on 9600 or 1200 with ax25

I recently put together my tnc-pi9k6 kit from and connected it to my ic-207 radio via the mini-din connector. 

When the raspberry pi startup the TNC hat LEDs momentarily illuminate. With the radio tuned to 144.390mhz, `kissattach`ed to /dev/serial0. I can hear data being received on the radio, the yellow LED illuminates on the TNC but no data is displayed on `axlisten`. I have attempted to send a beacon and the radio does not click into TX and no sound is emitted from the radio speaker.

DETAILS
  • The jumper is set to the outside of the board
  • Radio is set to 9600 baud
  • Jump link, no capacitor.
sudo kissattach /dev/serial0 wl2k
sudo kissparms -p wl2k -t 50 -l 10 -s 12 -r 80 -f n

output from `sudo axlisten -cart` while performing a `beacon` test.

wl2k: TX Delay: 50 ms
wl2k: TX Tail time: 10 ms
wl2k: Persistence: 81/256
wl2k: Slot time: 10 ms
wl2k: Duplex: Half
wl2k: fm VA3ZUK to VA3ZUK-1 ctl UI^ pid=F0(Text) len 12 13:57:52
test message
Link to radio manual: https://www.icomamerica.com/en/downloads/DownloadDocument.aspx?Document=4
View page: 63 

Thank you for your time, i appreciate it.

Brian Webster
 

On the mini din plug there are separate connections for 9600 and 1200 audio. That setting you change in the radio switches between the different pins and routes discriminator audio to the connector vs filtered audio for 1200 baud.

 

Brian N2KGC

 

From: RaspberryPi-4-HamRadio@groups.io [mailto:RaspberryPi-4-HamRadio@groups.io] On Behalf Of VA3ZUK
Sent: Thursday, February 20, 2020 2:03 PM
To: RaspberryPi-4-HamRadio@groups.io
Subject: [RaspberryPi-4-HamRadio] Icom IC-207 + TNC-PI9K6 issue RX/TX

 

SETUP

  1. ICOM IC-207 
  2. TNC-PI9K6
  3. 6 pin mini-din 
  4. Raspberry Pi 3 Model B Rev 1.2 
  5. Raspbian GNU/Linux 10 (buster) 
  6. Linux Kernel 4.19.97-v7+
  7. 9600 & 1200 baud

ISSUE
Unable to RX or TX on 9600 or 1200 with ax25

I recently put together my tnc-pi9k6 kit from and connected it to my ic-207 radio via the mini-din connector. 

When the raspberry pi startup the TNC hat LEDs momentarily illuminate. With the radio tuned to 144.390mhz, `kissattach`ed to /dev/serial0. I can hear data being received on the radio, the yellow LED illuminates on the TNC but no data is displayed on `axlisten`. I have attempted to send a beacon and the radio does not click into TX and no sound is emitted from the radio speaker.

DETAILS

  • The jumper is set to the outside of the board
  • Radio is set to 9600 baud
  • Jump link, no capacitor.

sudo kissattach /dev/serial0 wl2k
sudo kissparms -p wl2k -t 50 -l 10 -s 12 -r 80 -f n

output from `sudo axlisten -cart` while performing a `beacon` test.

wl2k: TX Delay: 50 ms

wl2k: TX Tail time: 10 ms

wl2k: Persistence: 81/256

wl2k: Slot time: 10 ms

wl2k: Duplex: Half

wl2k: fm VA3ZUK to VA3ZUK-1 ctl UI^ pid=F0(Text) len 12 13:57:52

test message

Link to radio manual: https://www.icomamerica.com/en/downloads/DownloadDocument.aspx?Document=4
View page: 63 

Thank you for your time, i appreciate it.

Mark Griffith
 

You realize that you need to make changes on the TNC using the pitnc_setparams program?

For 9600 baud
-------------
pitnc_setparams 0 0 8 96        set 9600 baud
pitnc_setparams 0 0 10 200    set transmit audio level
pitnc_setparams 0 0 9 0          set receive audio level
pitnc_setparams 0 0 15 2        reset TNC


Then to go back to 1200 baud:
-------------
pitnc_setparams 0 0 8 12    set 1200 baud
pitnc_setparams 0 0 10 4    set transmit audio level
pitnc_setparams 0 0 9 0      set receive audio level
pitnc_setparams 0 0 15 2    reset TNC

The settings for the transmit audio level depend upon your radio.  The radio docs should tell you what levels are needed.

Of course, you'll have to change the settings on the radio to 9600 baud.

No need to change the jumper settings, it can stay the same for 1200 or 9600 baud.

Mark
KD0QYN



On Thursday, February 20, 2020, 3:11:44 PM CST, Brian Webster via Groups.Io <radiowebst@...> wrote:


On the mini din plug there are separate connections for 9600 and 1200 audio. That setting you change in the radio switches between the different pins and routes discriminator audio to the connector vs filtered audio for 1200 baud.

 

Brian N2KGC

 

From: RaspberryPi-4-HamRadio@groups.io [mailto:RaspberryPi-4-HamRadio@groups.io] On Behalf Of VA3ZUK
Sent: Thursday, February 20, 2020 2:03 PM
To: RaspberryPi-4-HamRadio@groups.io
Subject: [RaspberryPi-4-HamRadio] Icom IC-207 + TNC-PI9K6 issue RX/TX

 

SETUP

  1. ICOM IC-207 
  2. TNC-PI9K6
  3. 6 pin mini-din 
  4. Raspberry Pi 3 Model B Rev 1.2 
  5. Raspbian GNU/Linux 10 (buster) 
  6. Linux Kernel 4.19.97-v7+
  7. 9600 & 1200 baud

ISSUE
Unable to RX or TX on 9600 or 1200 with ax25

I recently put together my tnc-pi9k6 kit from and connected it to my ic-207 radio via the mini-din connector. 

When the raspberry pi startup the TNC hat LEDs momentarily illuminate. With the radio tuned to 144.390mhz, `kissattach`ed to /dev/serial0. I can hear data being received on the radio, the yellow LED illuminates on the TNC but no data is displayed on `axlisten`. I have attempted to send a beacon and the radio does not click into TX and no sound is emitted from the radio speaker.

DETAILS

  • The jumper is set to the outside of the board
  • Radio is set to 9600 baud
  • Jump link, no capacitor.

sudo kissattach /dev/serial0 wl2k
sudo kissparms -p wl2k -t 50 -l 10 -s 12 -r 80 -f n

output from `sudo axlisten -cart` while performing a `beacon` test.

wl2k: TX Delay: 50 ms

wl2k: TX Tail time: 10 ms

wl2k: Persistence: 81/256

wl2k: Slot time: 10 ms

wl2k: Duplex: Half

wl2k: fm VA3ZUK to VA3ZUK-1 ctl UI^ pid=F0(Text) len 12 13:57:52

test message

Link to radio manual: https://www.icomamerica.com/en/downloads/DownloadDocument.aspx?Document=4
View page: 63 

Thank you for your time, i appreciate it.

Jim Hudson
 

kissattach need an IP number after the port, even though you aren't using the IP protocol.

Does the PTT LED flicker when you attempt to send a packet?

73,
Jim

VA3ZUK
 

Hello Mark,

Yes, I should have included that information in the original email. I have used the settings you have given and still no RX or TX.

=====
pitnc_getparams Version 0.0.0.5

Using Serial port /dev/serial0

TNC Software Version 8
01 TXDelay - Zero means use ADC 50
02 Persistance 255
03 Slottime (in 10 mS) 255
04 TXTail 255
05 Full Duplex - Not used 255
06 Our Channel (Hex) ff
07 I2C Address (0 = async) Hex ff
08 Mode Speed 9600
09 RX Level (Config) 0
10 TX Level 200
11 RX Level (Actual) 140
13 Centre Freq 2550
8 8 32 ff ff ff ff ff ff 60 0 c8 8c ff e9 c0 sum 0
====

From the manual
"1. When using a level meter or synchroscope, adjust the TX
audio output level (DATA IN level) from the TNC as follows.
0.4 Vp-p (0.2 Vrms): recommended level
0.2 Vp-p–0.5 Vp-p (0.1 Vrms–0.25 Vrms): acceptable level"

From http://www.tnc-x.com/TNCPi9K6.pdf

===============================
0.2 Vp-p–0.5 Vp-p (0.1 Vrms–0.25 Vrms): acceptable level

RX/TX levels and line voltage:
------------------------------
255 = 3000mV P-P
192 = 2250mV P-P
160 = 2000mV P-P
128 = 1500mV P-P
64 = 750mV P-P
32 = 375mV P-P
16 = 188mV P-P
8 = 94mV P-P
4 = 47mV P-P
2 = 24mV P-P
0 = 0mV (auto-set level for RX only)
===============================

So "32" should be around the correct value

===========
pi@r3:~ $ ./pitnc_setparams /dev/serial0 0 10 32
pitnc_setparams Version 0.0.0.5

PIC Software Version 8
01 TXDelay - Zero means use ADC 50
02 Persistance 255
03 Slottime (in 10 mS) 255
04 TXTail 255
05 Full Duplex - Not used 255
06 Our Channel (Hex) ff
07 I2C Address (0 = async) Hex ff
08 Mode Speed 9600
09 RX Level (Config) 0
10 TX Level 32
11 RX Level (Actual) 140
13 Centre Freq 2550
8 8 32 ff ff ff ff ff ff 60 0 20 8c ff 1 c0 sum 0

This does not seem to change anything

Ash Palmer
VA3ZUK

On 2020-02-20 16:45, Mark Griffith via Groups.Io wrote:
You realize that you need to make changes on the TNC using the
pitnc_setparams program?
For 9600 baud
-------------
pitnc_setparams 0 0 8 96 set 9600 baud
pitnc_setparams 0 0 10 200 set transmit audio level
pitnc_setparams 0 0 9 0 set receive audio level
pitnc_setparams 0 0 15 2 reset TNC
Then to go back to 1200 baud:-------------
pitnc_setparams 0 0 8 12 set 1200 baud
pitnc_setparams 0 0 10 4 set transmit audio level
pitnc_setparams 0 0 9 0 set receive audio level
pitnc_setparams 0 0 15 2 reset TNC
The settings for the transmit audio level depend upon your radio. The
radio docs should tell you what levels are needed.
Of course, you'll have to change the settings on the radio to 9600
baud.
No need to change the jumper settings, it can stay the same for 1200
or 9600 baud.
Mark
KD0QYN
On Thursday, February 20, 2020, 3:11:44 PM CST, Brian Webster via
Groups.Io <radiowebst=yahoo.com@groups.io> wrote:
On the mini din plug there are separate connections for 9600 and 1200
audio. That setting you change in the radio switches between the
different pins and routes discriminator audio to the connector vs
filtered audio for 1200 baud.
Brian N2KGC
FROM: RaspberryPi-4-HamRadio@groups.io
[mailto:RaspberryPi-4-HamRadio@groups.io] ON BEHALF OF VA3ZUK
SENT: Thursday, February 20, 2020 2:03 PM
TO: RaspberryPi-4-HamRadio@groups.io
SUBJECT: [RaspberryPi-4-HamRadio] Icom IC-207 + TNC-PI9K6 issue RX/TX
SETUP
* ICOM IC-207
* TNC-PI9K6
* 6 pin mini-din
* Raspberry Pi 3 Model B Rev 1.2
* Raspbian GNU/Linux 10 (buster)
* Linux Kernel 4.19.97-v7+
* 9600 & 1200 baud
ISSUE
Unable to RX or TX on 9600 or 1200 with ax25
I recently put together my tnc-pi9k6 kit from and connected it to my
ic-207 radio via the mini-din connector.
When the raspberry pi startup the TNC hat LEDs momentarily illuminate.
With the radio tuned to 144.390mhz, `kissattach`ed to /dev/serial0. I
can hear data being received on the radio, the yellow LED illuminates
on the TNC but no data is displayed on `axlisten`. I have attempted to
send a beacon and the radio does not click into TX and no sound is
emitted from the radio speaker.
DETAILS
* The jumper is set to the outside of the board
* Radio is set to 9600 baud
* Jump link, no capacitor.
sudo kissattach /dev/serial0 wl2k
sudo kissparms -p wl2k -t 50 -l 10 -s 12 -r 80 -f n
output from `sudo axlisten -cart` while performing a `beacon` test.

wl2k: TX Delay: 50 ms
wl2k: TX Tail time: 10 ms
wl2k: Persistence: 81/256
wl2k: Slot time: 10 ms
wl2k: Duplex: Half
wl2k: fm VA3ZUK to VA3ZUK-1 ctl UI^ pid=F0(Text) len 12 13:57:52
test message
Link to radio manual:
https://www.icomamerica.com/en/downloads/DownloadDocument.aspx?Document=4
View page: 63
Thank you for your time, i appreciate it.
Links:
------
[1] https://groups.io/g/RaspberryPi-4-HamRadio/message/10287
[2] https://groups.io/mt/71435451/4357074
[3] https://groups.io/g/RaspberryPi-4-HamRadio/post
[4] https://groups.io/g/RaspberryPi-4-HamRadio/editsub/4357074
[5] https://groups.io/g/RaspberryPi-4-HamRadio/leave/defanged

VA3ZUK
 

The baud rate has been set on the radio to correspond with the baud rate configured on the TNC.

Ash VA3ZUK

On 2020-02-20 16:11, Brian Webster via Groups.Io wrote:
On the mini din plug there are separate connections for 9600 and 1200
audio. That setting you change in the radio switches between the
different pins and routes discriminator audio to the connector vs
filtered audio for 1200 baud.
Brian N2KGC
FROM: RaspberryPi-4-HamRadio@groups.io
[mailto:RaspberryPi-4-HamRadio@groups.io] ON BEHALF OF VA3ZUK
SENT: Thursday, February 20, 2020 2:03 PM
TO: RaspberryPi-4-HamRadio@groups.io
SUBJECT: [RaspberryPi-4-HamRadio] Icom IC-207 + TNC-PI9K6 issue RX/TX
SETUP
* ICOM IC-207
* TNC-PI9K6
* 6 pin mini-din
* Raspberry Pi 3 Model B Rev 1.2
* Raspbian GNU/Linux 10 (buster)
* Linux Kernel 4.19.97-v7+
* 9600 & 1200 baud
ISSUE
Unable to RX or TX on 9600 or 1200 with ax25
I recently put together my tnc-pi9k6 kit from and connected it to my
ic-207 radio via the mini-din connector.
When the raspberry pi startup the TNC hat LEDs momentarily illuminate.
With the radio tuned to 144.390mhz, `kissattach`ed to /dev/serial0. I
can hear data being received on the radio, the yellow LED illuminates
on the TNC but no data is displayed on `axlisten`. I have attempted to
send a beacon and the radio does not click into TX and no sound is
emitted from the radio speaker.
DETAILS
* The jumper is set to the outside of the board
* Radio is set to 9600 baud
* Jump link, no capacitor.
sudo kissattach /dev/serial0 wl2k
sudo kissparms -p wl2k -t 50 -l 10 -s 12 -r 80 -f n
output from `sudo axlisten -cart` while performing a `beacon` test.

wl2k: TX Delay: 50 ms
wl2k: TX Tail time: 10 ms
wl2k: Persistence: 81/256
wl2k: Slot time: 10 ms
wl2k: Duplex: Half
wl2k: fm VA3ZUK to VA3ZUK-1 ctl UI^ pid=F0(Text) len 12 13:57:52
test message
Link to radio manual:
https://www.icomamerica.com/en/downloads/DownloadDocument.aspx?Document=4
View page: 63
Thank you for your time, i appreciate it.
Links:
------
[1] https://groups.io/g/RaspberryPi-4-HamRadio/message/10286
[2] https://groups.io/mt/71435451/4357074
[3] https://groups.io/g/RaspberryPi-4-HamRadio/post
[4] https://groups.io/g/RaspberryPi-4-HamRadio/editsub/4357074
[5] https://groups.io/g/RaspberryPi-4-HamRadio/leave/defanged

Brian Webster
 

Depending on which baud rate you are using however the radio will use the different audio pin off of the mini DIN plug for 9600 or 1200 baud. If your cable to the radio does not have the proper pin connected no audio will be sent. Pin 4 is receive audio for 9600 baud where Pin 5 is used for receive audio at 1200 baud.

 

From the Icom manual page 63, 64 and 65:

 

 

 

-----Original Message-----
From: RaspberryPi-4-HamRadio@groups.io [mailto:RaspberryPi-4-HamRadio@groups.io] On Behalf Of VA3ZUK
Sent: Thursday, February 20, 2020 7:04 PM
To: RaspberryPi-4-HamRadio@groups.io
Cc: Brian Webster via Groups.Io
Subject: Re: [RaspberryPi-4-HamRadio] Icom IC-207 + TNC-PI9K6 issue RX/TX

 

The baud rate has been set on the radio to correspond with the baud rate

configured on the TNC.

 

Ash VA3ZUK

 

On 2020-02-20 16:11, Brian Webster via Groups.Io wrote:

> On the mini din plug there are separate connections for 9600 and 1200

> audio. That setting you change in the radio switches between the

> different pins and routes discriminator audio to the connector vs

> filtered audio for 1200 baud.

>

> Brian N2KGC

>

> FROM: RaspberryPi-4-HamRadio@groups.io

> [mailto:RaspberryPi-4-HamRadio@groups.io] ON BEHALF OF VA3ZUK

> SENT: Thursday, February 20, 2020 2:03 PM

> TO: RaspberryPi-4-HamRadio@groups.io

> SUBJECT: [RaspberryPi-4-HamRadio] Icom IC-207 + TNC-PI9K6 issue RX/TX

>

> SETUP

>

>             * ICOM IC-207

>             * TNC-PI9K6

>             * 6 pin mini-din

>             * Raspberry Pi 3 Model B Rev 1.2

>             * Raspbian GNU/Linux 10 (buster)

>             * Linux Kernel 4.19.97-v7+

>             * 9600 & 1200 baud

>

> ISSUE

> Unable to RX or TX on 9600 or 1200 with ax25

>

> I recently put together my tnc-pi9k6 kit from and connected it to my

> ic-207 radio via the mini-din connector.

>

> When the raspberry pi startup the TNC hat LEDs momentarily illuminate.

> With the radio tuned to 144.390mhz, `kissattach`ed to /dev/serial0. I

> can hear data being received on the radio, the yellow LED illuminates

> on the TNC but no data is displayed on `axlisten`. I have attempted to

> send a beacon and the radio does not click into TX and no sound is

> emitted from the radio speaker.

>

> DETAILS

>

>             * The jumper is set to the outside of the board

>             * Radio is set to 9600 baud

>             * Jump link, no capacitor.

>

> sudo kissattach /dev/serial0 wl2k

> sudo kissparms -p wl2k -t 50 -l 10 -s 12 -r 80 -f n

>

> output from `sudo axlisten -cart` while performing a `beacon` test.

>

>> wl2k: TX Delay: 50 ms

>>

>> wl2k: TX Tail time: 10 ms

>>

>> wl2k: Persistence: 81/256

>>

>> wl2k: Slot time: 10 ms

>>

>> wl2k: Duplex: Half

>>

>> wl2k: fm VA3ZUK to VA3ZUK-1 ctl UI^ pid=F0(Text) len 12 13:57:52

>>

>> test message

>

> Link to radio manual:

> https://www.icomamerica.com/en/downloads/DownloadDocument.aspx?Document=4

> View page: 63

>

> Thank you for your time, i appreciate it.

>

>

>

> Links:

> ------

> [1] https://groups.io/g/RaspberryPi-4-HamRadio/message/10286

> [2] https://groups.io/mt/71435451/4357074

> [3] https://groups.io/g/RaspberryPi-4-HamRadio/post

> [4] https://groups.io/g/RaspberryPi-4-HamRadio/editsub/4357074

> [5]

> https://groups.io/g/RaspberryPi-4-HamRadio/leave/defanged

 

Mark Griffith
 

Well, either the board is bad, or the cable, probably something on the board.  OR there is a lot of RF in the shack that is messing it up.

Can't think of anything else at the moment.  Sorry.

Mark
KD0QYN

On Thursday, February 20, 2020, 6:02:18 PM CST, VA3ZUK <ash.palmer@...> wrote:


Hello Mark,

Yes, I should have included that information in the original email. I
have used the settings you have given and still no RX or TX.

=====
pitnc_getparams Version 0.0.0.5

Using Serial port /dev/serial0

    TNC Software Version          8
01 TXDelay - Zero means use ADC  50
02 Persistance                  255
03 Slottime (in 10 mS)          255
04 TXTail                      255
05 Full Duplex - Not used      255
06 Our Channel (Hex)            ff
07 I2C Address (0 = async) Hex  ff
08 Mode Speed                  9600
09 RX Level (Config)              0
10 TX Level                    200
11 RX Level (Actual)            140
13 Centre Freq                2550
8 8 32 ff ff ff ff ff ff 60 0 c8 8c ff e9 c0 sum 0
====

From the manual
"1. When using a level meter or synchroscope, adjust the TX
audio output level (DATA IN level) from the TNC as follows.
0.4 Vp-p (0.2 Vrms): recommended level
0.2 Vp-p–0.5 Vp-p (0.1 Vrms–0.25 Vrms): acceptable level"

From http://www.tnc-x.com/TNCPi9K6.pdf

===============================
0.2 Vp-p–0.5 Vp-p (0.1 Vrms–0.25 Vrms): acceptable level

RX/TX levels and line voltage:
------------------------------
255 = 3000mV P-P
192 = 2250mV P-P
160 = 2000mV P-P
128 = 1500mV P-P
64 = 750mV P-P
32 = 375mV P-P
16 = 188mV P-P
8 = 94mV P-P
4 = 47mV P-P
2 = 24mV P-P
0 = 0mV (auto-set level for RX only)
===============================

So "32" should be around the correct value

===========
pi@r3:~ $ ./pitnc_setparams /dev/serial0 0 10 32
pitnc_setparams Version 0.0.0.5

    PIC Software Version          8
01 TXDelay - Zero means use ADC  50
02 Persistance                  255
03 Slottime (in 10 mS)          255
04 TXTail                      255
05 Full Duplex - Not used      255
06 Our Channel (Hex)            ff
07 I2C Address (0 = async) Hex  ff
08 Mode Speed                  9600
09 RX Level (Config)              0
10 TX Level                      32
11 RX Level (Actual)            140
13 Centre Freq                2550
8 8 32 ff ff ff ff ff ff 60 0 20 8c ff 1 c0 sum 0

This does not seem to change anything

Ash Palmer
VA3ZUK

On 2020-02-20 16:45, Mark Griffith via Groups.Io wrote:
> You realize that you need to make changes on the TNC using the
> pitnc_setparams program?
>
> For 9600 baud
> -------------
> pitnc_setparams 0 0 8 96        set 9600 baud
> pitnc_setparams 0 0 10 200    set transmit audio level
> pitnc_setparams 0 0 9 0          set receive audio level
> pitnc_setparams 0 0 15 2        reset TNC
>
> Then to go back to 1200 baud:-------------
> pitnc_setparams 0 0 8 12    set 1200 baud
> pitnc_setparams 0 0 10 4    set transmit audio level
> pitnc_setparams 0 0 9 0      set receive audio level
> pitnc_setparams 0 0 15 2    reset TNC
>
> The settings for the transmit audio level depend upon your radio.  The
> radio docs should tell you what levels are needed.
>
> Of course, you'll have to change the settings on the radio to 9600
> baud.
>
> No need to change the jumper settings, it can stay the same for 1200
> or 9600 baud.
>
> Mark
> KD0QYN
>
>  On Thursday, February 20, 2020, 3:11:44 PM CST, Brian Webster via
> Groups.Io <radiowebst=yahoo.com@groups.io> wrote:
>
> On the mini din plug there are separate connections for 9600 and 1200
> audio. That setting you change in the radio switches between the
> different pins and routes discriminator audio to the connector vs
> filtered audio for 1200 baud.
>
> Brian N2KGC
>
> FROM: RaspberryPi-4-HamRadio@groups.io
> [mailto:RaspberryPi-4-HamRadio@groups.io] ON BEHALF OF VA3ZUK
> SENT: Thursday, February 20, 2020 2:03 PM
> TO: RaspberryPi-4-HamRadio@groups.io
> SUBJECT: [RaspberryPi-4-HamRadio] Icom IC-207 + TNC-PI9K6 issue RX/TX
>
> SETUP
>
>     * ICOM IC-207
>     * TNC-PI9K6
>     * 6 pin mini-din
>     * Raspberry Pi 3 Model B Rev 1.2
>     * Raspbian GNU/Linux 10 (buster)
>     * Linux Kernel 4.19.97-v7+
>     * 9600 & 1200 baud
>
> ISSUE
> Unable to RX or TX on 9600 or 1200 with ax25
>
> I recently put together my tnc-pi9k6 kit from and connected it to my
> ic-207 radio via the mini-din connector.
>
> When the raspberry pi startup the TNC hat LEDs momentarily illuminate.
> With the radio tuned to 144.390mhz, `kissattach`ed to /dev/serial0. I
> can hear data being received on the radio, the yellow LED illuminates
> on the TNC but no data is displayed on `axlisten`. I have attempted to
> send a beacon and the radio does not click into TX and no sound is
> emitted from the radio speaker.
>
> DETAILS
>
>     * The jumper is set to the outside of the board
>     * Radio is set to 9600 baud
>     * Jump link, no capacitor.
>
> sudo kissattach /dev/serial0 wl2k
> sudo kissparms -p wl2k -t 50 -l 10 -s 12 -r 80 -f n
>
> output from `sudo axlisten -cart` while performing a `beacon` test.
>
>> wl2k: TX Delay: 50 ms
>>
>> wl2k: TX Tail time: 10 ms
>>
>> wl2k: Persistence: 81/256
>>
>> wl2k: Slot time: 10 ms
>>
>> wl2k: Duplex: Half
>>
>> wl2k: fm VA3ZUK to VA3ZUK-1 ctl UI^ pid=F0(Text) len 12 13:57:52
>>
>> test message
>
> Link to radio manual:
> https://www.icomamerica.com/en/downloads/DownloadDocument.aspx?Document=4
> View page: 63
>
> Thank you for your time, i appreciate it.
>
>
>
> Links:
> ------
> [1] https://groups.io/g/RaspberryPi-4-HamRadio/message/10287
> [2] https://groups.io/mt/71435451/4357074
> [3] https://groups.io/g/RaspberryPi-4-HamRadio/post
> [4] https://groups.io/g/RaspberryPi-4-HamRadio/editsub/4357074
> [5]
> https://groups.io/g/RaspberryPi-4-HamRadio/leave/defanged



Mat Murdock
 

When testing a new TNC I will do what you have done and set my radio 144.390 mhz.  Set the TNC to 1200 baud.  Put the jumper on the TNC to 1200 baud as well (pair of pins closest to the the db9 connector.  I think the default baud rate for the serial connection between the TNC and your Pi needs to be set to 19200 in the axports file as well.

Mat

On Thu, Feb 20, 2020 at 5:03 PM VA3ZUK <ash.palmer@...> wrote:
The baud rate has been set on the radio to correspond with the baud rate
configured on the TNC.

Ash VA3ZUK

On 2020-02-20 16:11, Brian Webster via Groups.Io wrote:
> On the mini din plug there are separate connections for 9600 and 1200
> audio. That setting you change in the radio switches between the
> different pins and routes discriminator audio to the connector vs
> filtered audio for 1200 baud.
>
> Brian N2KGC
>
> FROM: RaspberryPi-4-HamRadio@groups.io
> [mailto:RaspberryPi-4-HamRadio@groups.io] ON BEHALF OF VA3ZUK
> SENT: Thursday, February 20, 2020 2:03 PM
> TO: RaspberryPi-4-HamRadio@groups.io
> SUBJECT: [RaspberryPi-4-HamRadio] Icom IC-207 + TNC-PI9K6 issue RX/TX
>
> SETUP
>
>       * ICOM IC-207
>       * TNC-PI9K6
>       * 6 pin mini-din
>       * Raspberry Pi 3 Model B Rev 1.2
>       * Raspbian GNU/Linux 10 (buster)
>       * Linux Kernel 4.19.97-v7+
>       * 9600 & 1200 baud
>
> ISSUE
> Unable to RX or TX on 9600 or 1200 with ax25
>
> I recently put together my tnc-pi9k6 kit from and connected it to my
> ic-207 radio via the mini-din connector.
>
> When the raspberry pi startup the TNC hat LEDs momentarily illuminate.
> With the radio tuned to 144.390mhz, `kissattach`ed to /dev/serial0. I
> can hear data being received on the radio, the yellow LED illuminates
> on the TNC but no data is displayed on `axlisten`. I have attempted to
> send a beacon and the radio does not click into TX and no sound is
> emitted from the radio speaker.
>
> DETAILS
>
>       * The jumper is set to the outside of the board
>       * Radio is set to 9600 baud
>       * Jump link, no capacitor.
>
> sudo kissattach /dev/serial0 wl2k
> sudo kissparms -p wl2k -t 50 -l 10 -s 12 -r 80 -f n
>
> output from `sudo axlisten -cart` while performing a `beacon` test.
>
>> wl2k: TX Delay: 50 ms
>>
>> wl2k: TX Tail time: 10 ms
>>
>> wl2k: Persistence: 81/256
>>
>> wl2k: Slot time: 10 ms
>>
>> wl2k: Duplex: Half
>>
>> wl2k: fm VA3ZUK to VA3ZUK-1 ctl UI^ pid=F0(Text) len 12 13:57:52
>>
>> test message
>
> Link to radio manual:
> https://www.icomamerica.com/en/downloads/DownloadDocument.aspx?Document=4
> View page: 63
>
> Thank you for your time, i appreciate it.
>
>
>
> Links:
> ------
> [1] https://groups.io/g/RaspberryPi-4-HamRadio/message/10286
> [2] https://groups.io/mt/71435451/4357074
> [3] https://groups.io/g/RaspberryPi-4-HamRadio/post
> [4] https://groups.io/g/RaspberryPi-4-HamRadio/editsub/4357074
> [5]
> https://groups.io/g/RaspberryPi-4-HamRadio/leave/defanged



Mat Murdock
 

If you want to run your TNC stand alone you can load up this firmware assuming you are using a Teensy 3.6.


Pull the TNC off the PI and connect the TNC directly to your computer via the micro usb connection on the Teensy.  If running Windows you can then fire up something like Winlink and do a test transmission.

These are the default settings I load.

pitnc_setparams com1:115200 0 1 100
pitnc_setparams com1:115200 0 2 200
pitnc_setparams com1:115200 0 3 4
pitnc_setparams com1:115200 0 4 4
pitnc_setparams com1:115200 0 8 12
pitnc_setparams com1:115200 0 9 200
pitnc_setparams com1:115200 0 10 255
pitnc_setparams com1:115200 0 15 2

Mat






On Thu, Feb 20, 2020 at 5:31 PM Mark Griffith via Groups.Io <mdgriffith2003=yahoo.com@groups.io> wrote:
Well, either the board is bad, or the cable, probably something on the board.  OR there is a lot of RF in the shack that is messing it up.

Can't think of anything else at the moment.  Sorry.

Mark
KD0QYN

On Thursday, February 20, 2020, 6:02:18 PM CST, VA3ZUK <ash.palmer@...> wrote:


Hello Mark,

Yes, I should have included that information in the original email. I
have used the settings you have given and still no RX or TX.

=====
pitnc_getparams Version 0.0.0.5

Using Serial port /dev/serial0

    TNC Software Version          8
01 TXDelay - Zero means use ADC  50
02 Persistance                  255
03 Slottime (in 10 mS)          255
04 TXTail                      255
05 Full Duplex - Not used      255
06 Our Channel (Hex)            ff
07 I2C Address (0 = async) Hex  ff
08 Mode Speed                  9600
09 RX Level (Config)              0
10 TX Level                    200
11 RX Level (Actual)            140
13 Centre Freq                2550
8 8 32 ff ff ff ff ff ff 60 0 c8 8c ff e9 c0 sum 0
====

From the manual
"1. When using a level meter or synchroscope, adjust the TX
audio output level (DATA IN level) from the TNC as follows.
0.4 Vp-p (0.2 Vrms): recommended level
0.2 Vp-p–0.5 Vp-p (0.1 Vrms–0.25 Vrms): acceptable level"

From http://www.tnc-x.com/TNCPi9K6.pdf

===============================
0.2 Vp-p–0.5 Vp-p (0.1 Vrms–0.25 Vrms): acceptable level

RX/TX levels and line voltage:
------------------------------
255 = 3000mV P-P
192 = 2250mV P-P
160 = 2000mV P-P
128 = 1500mV P-P
64 = 750mV P-P
32 = 375mV P-P
16 = 188mV P-P
8 = 94mV P-P
4 = 47mV P-P
2 = 24mV P-P
0 = 0mV (auto-set level for RX only)
===============================

So "32" should be around the correct value

===========
pi@r3:~ $ ./pitnc_setparams /dev/serial0 0 10 32
pitnc_setparams Version 0.0.0.5

    PIC Software Version          8
01 TXDelay - Zero means use ADC  50
02 Persistance                  255
03 Slottime (in 10 mS)          255
04 TXTail                      255
05 Full Duplex - Not used      255
06 Our Channel (Hex)            ff
07 I2C Address (0 = async) Hex  ff
08 Mode Speed                  9600
09 RX Level (Config)              0
10 TX Level                      32
11 RX Level (Actual)            140
13 Centre Freq                2550
8 8 32 ff ff ff ff ff ff 60 0 20 8c ff 1 c0 sum 0

This does not seem to change anything

Ash Palmer
VA3ZUK

On 2020-02-20 16:45, Mark Griffith via Groups.Io wrote:
> You realize that you need to make changes on the TNC using the
> pitnc_setparams program?
>
> For 9600 baud
> -------------
> pitnc_setparams 0 0 8 96        set 9600 baud
> pitnc_setparams 0 0 10 200    set transmit audio level
> pitnc_setparams 0 0 9 0          set receive audio level
> pitnc_setparams 0 0 15 2        reset TNC
>
> Then to go back to 1200 baud:-------------
> pitnc_setparams 0 0 8 12    set 1200 baud
> pitnc_setparams 0 0 10 4    set transmit audio level
> pitnc_setparams 0 0 9 0      set receive audio level
> pitnc_setparams 0 0 15 2    reset TNC
>
> The settings for the transmit audio level depend upon your radio.  The
> radio docs should tell you what levels are needed.
>
> Of course, you'll have to change the settings on the radio to 9600
> baud.
>
> No need to change the jumper settings, it can stay the same for 1200
> or 9600 baud.
>
> Mark
> KD0QYN
>
>  On Thursday, February 20, 2020, 3:11:44 PM CST, Brian Webster via
> Groups.Io <radiowebst=yahoo.com@groups.io> wrote:
>
> On the mini din plug there are separate connections for 9600 and 1200
> audio. That setting you change in the radio switches between the
> different pins and routes discriminator audio to the connector vs
> filtered audio for 1200 baud.
>
> Brian N2KGC
>
> FROM: RaspberryPi-4-HamRadio@groups.io
> [mailto:RaspberryPi-4-HamRadio@groups.io] ON BEHALF OF VA3ZUK
> SENT: Thursday, February 20, 2020 2:03 PM
> TO: RaspberryPi-4-HamRadio@groups.io
> SUBJECT: [RaspberryPi-4-HamRadio] Icom IC-207 + TNC-PI9K6 issue RX/TX
>
> SETUP
>
>     * ICOM IC-207
>     * TNC-PI9K6
>     * 6 pin mini-din
>     * Raspberry Pi 3 Model B Rev 1.2
>     * Raspbian GNU/Linux 10 (buster)
>     * Linux Kernel 4.19.97-v7+
>     * 9600 & 1200 baud
>
> ISSUE
> Unable to RX or TX on 9600 or 1200 with ax25
>
> I recently put together my tnc-pi9k6 kit from and connected it to my
> ic-207 radio via the mini-din connector.
>
> When the raspberry pi startup the TNC hat LEDs momentarily illuminate.
> With the radio tuned to 144.390mhz, `kissattach`ed to /dev/serial0. I
> can hear data being received on the radio, the yellow LED illuminates
> on the TNC but no data is displayed on `axlisten`. I have attempted to
> send a beacon and the radio does not click into TX and no sound is
> emitted from the radio speaker.
>
> DETAILS
>
>     * The jumper is set to the outside of the board
>     * Radio is set to 9600 baud
>     * Jump link, no capacitor.
>
> sudo kissattach /dev/serial0 wl2k
> sudo kissparms -p wl2k -t 50 -l 10 -s 12 -r 80 -f n
>
> output from `sudo axlisten -cart` while performing a `beacon` test.
>
>> wl2k: TX Delay: 50 ms
>>
>> wl2k: TX Tail time: 10 ms
>>
>> wl2k: Persistence: 81/256
>>
>> wl2k: Slot time: 10 ms
>>
>> wl2k: Duplex: Half
>>
>> wl2k: fm VA3ZUK to VA3ZUK-1 ctl UI^ pid=F0(Text) len 12 13:57:52
>>
>> test message
>
> Link to radio manual:
> https://www.icomamerica.com/en/downloads/DownloadDocument.aspx?Document=4
> View page: 63
>
> Thank you for your time, i appreciate it.
>
>
>
> Links:
> ------
> [1] https://groups.io/g/RaspberryPi-4-HamRadio/message/10287
> [2] https://groups.io/mt/71435451/4357074
> [3] https://groups.io/g/RaspberryPi-4-HamRadio/post
> [4] https://groups.io/g/RaspberryPi-4-HamRadio/editsub/4357074
> [5]
> https://groups.io/g/RaspberryPi-4-HamRadio/leave/defanged



VA3ZUK
 

Mat,

19200 not 9200?

Thanks,
Ash Palmer


On February 20, 2020 7:31:18 p.m. EST, Mat Murdock <mat.murdock@...> wrote:
When testing a new TNC I will do what you have done and set my radio 144.390 mhz.  Set the TNC to 1200 baud.  Put the jumper on the TNC to 1200 baud as well (pair of pins closest to the the db9 connector.  I think the default baud rate for the serial connection between the TNC and your Pi needs to be set to 19200 in the axports file as well.

Mat

On Thu, Feb 20, 2020 at 5:03 PM VA3ZUK <ash.palmer@...> wrote:
The baud rate has been set on the radio to correspond with the baud rate
configured on the TNC.

Ash VA3ZUK

On 2020-02-20 16:11, Brian Webster via Groups.Io wrote:
> On the mini din plug there are separate connections for 9600 and 1200
> audio. That setting you change in the radio switches between the
> different pins and routes discriminator audio to the connector vs
> filtered audio for 1200 baud.
>
> Brian N2KGC
>
> FROM: RaspberryPi-4-HamRadio@groups.io
> [mailto:RaspberryPi-4-HamRadio@groups.io] ON BEHALF OF VA3ZUK
> SENT: Thursday, February 20, 2020 2:03 PM
> TO: RaspberryPi-4-HamRadio@groups.io
> SUBJECT: [RaspberryPi-4-HamRadio] Icom IC-207 + TNC-PI9K6 issue RX/TX
>
> SETUP
>
>       * ICOM IC-207
>       * TNC-PI9K6
>       * 6 pin mini-din
>       * Raspberry Pi 3 Model B Rev 1.2
>       * Raspbian GNU/Linux 10 (buster)
>       * Linux Kernel 4.19.97-v7+
>       * 9600 & 1200 baud
>
> ISSUE
> Unable to RX or TX on 9600 or 1200 with ax25
>
> I recently put together my tnc-pi9k6 kit from and connected it to my
> ic-207 radio via the mini-din connector.
>
> When the raspberry pi startup the TNC hat LEDs momentarily illuminate.
> With the radio tuned to 144.390mhz, `kissattach`ed to /dev/serial0. I
> can hear data being received on the radio, the yellow LED illuminates
> on the TNC but no data is displayed on `axlisten`. I have attempted to
> send a beacon and the radio does not click into TX and no sound is
> emitted from the radio speaker.
>
> DETAILS
>
>       * The jumper is set to the outside of the board
>       * Radio is set to 9600 baud
>       * Jump link, no capacitor.
>
> sudo kissattach /dev/serial0 wl2k
> sudo kissparms -p wl2k -t 50 -l 10 -s 12 -r 80 -f n
>
> output from `sudo axlisten -cart` while performing a `beacon` test.
>
>> wl2k: TX Delay: 50 ms
>>
>> wl2k: TX Tail time: 10 ms
>>
>> wl2k: Persistence: 81/256
>>
>> wl2k: Slot time: 10 ms
>>
>> wl2k: Duplex: Half
>>
>> wl2k: fm VA3ZUK to VA3ZUK-1 ctl UI^ pid=F0(Text) len 12 13:57:52
>>
>> test message
>
> Link to radio manual:
> https://www.icomamerica.com/en/downloads/DownloadDocument.aspx?Document=4
> View page: 63
>
> Thank you for your time, i appreciate it.
>
>
>
> Links:
> ------
> [1] https://groups.io/g/RaspberryPi-4-HamRadio/message/10286
> [2] https://groups.io/mt/71435451/4357074
> [3] https://groups.io/g/RaspberryPi-4-HamRadio/post
> [4] https://groups.io/g/RaspberryPi-4-HamRadio/editsub/4357074
> [5]
> https://groups.io/g/RaspberryPi-4-HamRadio/leave/defanged




--
Sent from my Android device with K-9 Mail. Please excuse my brevity.

VA3ZUK
 

Mat,

The link you shared is no longer available.

Thanks
Ash


On February 20, 2020 10:56:02 p.m. EST, Mat Murdock <mat.murdock@...> wrote:
If you want to run your TNC stand alone you can load up this firmware assuming you are using a Teensy 3.6.


Pull the TNC off the PI and connect the TNC directly to your computer via the micro usb connection on the Teensy.  If running Windows you can then fire up something like Winlink and do a test transmission.

These are the default settings I load.

pitnc_setparams com1:115200 0 1 100
pitnc_setparams com1:115200 0 2 200
pitnc_setparams com1:115200 0 3 4
pitnc_setparams com1:115200 0 4 4
pitnc_setparams com1:115200 0 8 12
pitnc_setparams com1:115200 0 9 200
pitnc_setparams com1:115200 0 10 255
pitnc_setparams com1:115200 0 15 2

Mat






On Thu, Feb 20, 2020 at 5:31 PM Mark Griffith via Groups.Io <mdgriffith2003=yahoo.com@groups.io> wrote:
Well, either the board is bad, or the cable, probably something on the board.  OR there is a lot of RF in the shack that is messing it up.

Can't think of anything else at the moment.  Sorry.

Mark
KD0QYN

On Thursday, February 20, 2020, 6:02:18 PM CST, VA3ZUK <ash.palmer@...> wrote:


Hello Mark,

Yes, I should have included that information in the original email. I
have used the settings you have given and still no RX or TX.

=====
pitnc_getparams Version 0.0.0.5

Using Serial port /dev/serial0

    TNC Software Version          8
01 TXDelay - Zero means use ADC  50
02 Persistance                  255
03 Slottime (in 10 mS)          255
04 TXTail                      255
05 Full Duplex - Not used      255
06 Our Channel (Hex)            ff
07 I2C Address (0 = async) Hex  ff
08 Mode Speed                  9600
09 RX Level (Config)              0
10 TX Level                    200
11 RX Level (Actual)            140
13 Centre Freq                2550
8 8 32 ff ff ff ff ff ff 60 0 c8 8c ff e9 c0 sum 0
====

From the manual
"1. When using a level meter or synchroscope, adjust the TX
audio output level (DATA IN level) from the TNC as follows.
0.4 Vp-p (0.2 Vrms): recommended level
0.2 Vp-p–0.5 Vp-p (0.1 Vrms–0.25 Vrms): acceptable level"

From http://www.tnc-x.com/TNCPi9K6.pdf

===============================
0.2 Vp-p–0.5 Vp-p (0.1 Vrms–0.25 Vrms): acceptable level

RX/TX levels and line voltage:
------------------------------
255 = 3000mV P-P
192 = 2250mV P-P
160 = 2000mV P-P
128 = 1500mV P-P
64 = 750mV P-P
32 = 375mV P-P
16 = 188mV P-P
8 = 94mV P-P
4 = 47mV P-P
2 = 24mV P-P
0 = 0mV (auto-set level for RX only)
===============================

So "32" should be around the correct value

===========
pi@r3:~ $ ./pitnc_setparams /dev/serial0 0 10 32
pitnc_setparams Version 0.0.0.5

    PIC Software Version          8
01 TXDelay - Zero means use ADC  50
02 Persistance                  255
03 Slottime (in 10 mS)          255
04 TXTail                      255
05 Full Duplex - Not used      255
06 Our Channel (Hex)            ff
07 I2C Address (0 = async) Hex  ff
08 Mode Speed                  9600
09 RX Level (Config)              0
10 TX Level                      32
11 RX Level (Actual)            140
13 Centre Freq                2550
8 8 32 ff ff ff ff ff ff 60 0 20 8c ff 1 c0 sum 0

This does not seem to change anything

Ash Palmer
VA3ZUK

On 2020-02-20 16:45, Mark Griffith via Groups.Io wrote:
> You realize that you need to make changes on the TNC using the
> pitnc_setparams program?
>
> For 9600 baud
> -------------
> pitnc_setparams 0 0 8 96        set 9600 baud
> pitnc_setparams 0 0 10 200    set transmit audio level
> pitnc_setparams 0 0 9 0          set receive audio level
> pitnc_setparams 0 0 15 2        reset TNC
>
> Then to go back to 1200 baud:-------------
> pitnc_setparams 0 0 8 12    set 1200 baud
> pitnc_setparams 0 0 10 4    set transmit audio level
> pitnc_setparams 0 0 9 0      set receive audio level
> pitnc_setparams 0 0 15 2    reset TNC
>
> The settings for the transmit audio level depend upon your radio.  The
> radio docs should tell you what levels are needed.
>
> Of course, you'll have to change the settings on the radio to 9600
> baud.
>
> No need to change the jumper settings, it can stay the same for 1200
> or 9600 baud.
>
> Mark
> KD0QYN
>
>  On Thursday, February 20, 2020, 3:11:44 PM CST, Brian Webster via
> Groups.Io <radiowebst=yahoo.com@groups.io> wrote:
>
> On the mini din plug there are separate connections for 9600 and 1200
> audio. That setting you change in the radio switches between the
> different pins and routes discriminator audio to the connector vs
> filtered audio for 1200 baud.
>
> Brian N2KGC
>
> FROM: RaspberryPi-4-HamRadio@groups.io
> [mailto:RaspberryPi-4-HamRadio@groups.io] ON BEHALF OF VA3ZUK
> SENT: Thursday, February 20, 2020 2:03 PM
> TO: RaspberryPi-4-HamRadio@groups.io
> SUBJECT: [RaspberryPi-4-HamRadio] Icom IC-207 + TNC-PI9K6 issue RX/TX
>
> SETUP
>
>     * ICOM IC-207
>     * TNC-PI9K6
>     * 6 pin mini-din
>     * Raspberry Pi 3 Model B Rev 1.2
>     * Raspbian GNU/Linux 10 (buster)
>     * Linux Kernel 4.19.97-v7+
>     * 9600 & 1200 baud
>
> ISSUE
> Unable to RX or TX on 9600 or 1200 with ax25
>
> I recently put together my tnc-pi9k6 kit from and connected it to my
> ic-207 radio via the mini-din connector.
>
> When the raspberry pi startup the TNC hat LEDs momentarily illuminate.
> With the radio tuned to 144.390mhz, `kissattach`ed to /dev/serial0. I
> can hear data being received on the radio, the yellow LED illuminates
> on the TNC but no data is displayed on `axlisten`. I have attempted to
> send a beacon and the radio does not click into TX and no sound is
> emitted from the radio speaker.
>
> DETAILS
>
>     * The jumper is set to the outside of the board
>     * Radio is set to 9600 baud
>     * Jump link, no capacitor.
>
> sudo kissattach /dev/serial0 wl2k
> sudo kissparms -p wl2k -t 50 -l 10 -s 12 -r 80 -f n
>
> output from `sudo axlisten -cart` while performing a `beacon` test.
>
>> wl2k: TX Delay: 50 ms
>>
>> wl2k: TX Tail time: 10 ms
>>
>> wl2k: Persistence: 81/256
>>
>> wl2k: Slot time: 10 ms
>>
>> wl2k: Duplex: Half
>>
>> wl2k: fm VA3ZUK to VA3ZUK-1 ctl UI^ pid=F0(Text) len 12 13:57:52
>>
>> test message
>
> Link to radio manual:
> https://www.icomamerica.com/en/downloads/DownloadDocument.aspx?Document=4
> View page: 63
>
> Thank you for your time, i appreciate it.
>
>
>
> Links:
> ------
> [1] https://groups.io/g/RaspberryPi-4-HamRadio/message/10287
> [2] https://groups.io/mt/71435451/4357074
> [3] https://groups.io/g/RaspberryPi-4-HamRadio/post
> [4] https://groups.io/g/RaspberryPi-4-HamRadio/editsub/4357074
> [5]
> https://groups.io/g/RaspberryPi-4-HamRadio/leave/defanged




--
Sent from my Android device with K-9 Mail. Please excuse my brevity.

Hank Riley
 

Ash,

It's there.  I just downloaded 200K of valid hex code.

You might want to carefully copy that whole link and try that way, even though it's clickable the way Mat posted.

HR

VA3ZUK
 

Hello Mat,

Thank you for your assistance.

I'm able rx and tx with 9600 baud via ax.25 on linux via usb using your firmware.

Can you provide me some documentation on how I change the tnc settings in this configuration? The pitnc_ utilities are compiled against ARM and I can't find the source, I'm assuming it's closed source?

Are you the developer of the board?

I will spend some time wrapping my head around this new-to-me world of packet radio but eventually I'd like to use the Raspberry Pi and the pre-installed firmware isn't linked anywhere in the documentation.

Thanks again,
Ash Palmer VA3ZUK


On February 20, 2020 10:56:02 p.m. EST, Mat Murdock <mat.murdock@...> wrote:
If you want to run your TNC stand alone you can load up this firmware assuming you are using a Teensy 3.6.


Pull the TNC off the PI and connect the TNC directly to your computer via the micro usb connection on the Teensy.  If running Windows you can then fire up something like Winlink and do a test transmission.

These are the default settings I load.

pitnc_setparams com1:115200 0 1 100
pitnc_setparams com1:115200 0 2 200
pitnc_setparams com1:115200 0 3 4
pitnc_setparams com1:115200 0 4 4
pitnc_setparams com1:115200 0 8 12
pitnc_setparams com1:115200 0 9 200
pitnc_setparams com1:115200 0 10 255
pitnc_setparams com1:115200 0 15 2

Mat






On Thu, Feb 20, 2020 at 5:31 PM Mark Griffith via Groups.Io <mdgriffith2003=yahoo.com@groups.io> wrote:
Well, either the board is bad, or the cable, probably something on the board.  OR there is a lot of RF in the shack that is messing it up.

Can't think of anything else at the moment.  Sorry.

Mark
KD0QYN

On Thursday, February 20, 2020, 6:02:18 PM CST, VA3ZUK <ash.palmer@...> wrote:


Hello Mark,

Yes, I should have included that information in the original email. I
have used the settings you have given and still no RX or TX.

=====
pitnc_getparams Version 0.0.0.5

Using Serial port /dev/serial0

    TNC Software Version          8
01 TXDelay - Zero means use ADC  50
02 Persistance                  255
03 Slottime (in 10 mS)          255
04 TXTail                      255
05 Full Duplex - Not used      255
06 Our Channel (Hex)            ff
07 I2C Address (0 = async) Hex  ff
08 Mode Speed                  9600
09 RX Level (Config)              0
10 TX Level                    200
11 RX Level (Actual)            140
13 Centre Freq                2550
8 8 32 ff ff ff ff ff ff 60 0 c8 8c ff e9 c0 sum 0
====

From the manual
"1. When using a level meter or synchroscope, adjust the TX
audio output level (DATA IN level) from the TNC as follows.
0.4 Vp-p (0.2 Vrms): recommended level
0.2 Vp-p–0.5 Vp-p (0.1 Vrms–0.25 Vrms): acceptable level"

From http://www.tnc-x.com/TNCPi9K6.pdf

===============================
0.2 Vp-p–0.5 Vp-p (0.1 Vrms–0.25 Vrms): acceptable level

RX/TX levels and line voltage:
------------------------------
255 = 3000mV P-P
192 = 2250mV P-P
160 = 2000mV P-P
128 = 1500mV P-P
64 = 750mV P-P
32 = 375mV P-P
16 = 188mV P-P
8 = 94mV P-P
4 = 47mV P-P
2 = 24mV P-P
0 = 0mV (auto-set level for RX only)
===============================

So "32" should be around the correct value

RX/TX levels and line voltage:pi@r3:~ $ ./pitnc_setparams /dev/serial0 0 10 32
pitnc_setparams Version 0.0.0.5

    PIC Software Version          8
01 TXDelay - Zero means use ADC  50
02 Persistance                  255
03 Slottime (in 10 mS)          255
04 TXTail                      255
05 Full Duplex - Not used      255
06 Our Channel (Hex)            ff
07 I2C Address (0 = async) Hex  ff
08 Mode Speed                  9600
09 RX Level (Config)              0
10 TX Level                      32
11 RX Level (Actual)            140
13 Centre Freq                2550
8 8 32 ff ff ff ff ff ff 60 0 20 8c ff 1 c0 sum 0

This does not seem to change anything

Ash Palmer
VA3ZUK

On 2020-02-20 16:45, Mark Griffith via Groups.Io wrote:
> You realize that you need to make changes on the TNC using the
> pitnc_setparams program?
>
> For 9600 baud
> -------------
> pitnc_setparams 0 0 8 96        set 9600 baud
> pitnc_setparams 0 0 10 200    set transmit audio level
> pitnc_setparams 0 0 9 0          set receive audio level
> pitnc_setparams 0 0 15 2        reset TNC
>
> Then to go back to 1200 baud:-------------
> pitnc_setparams 0 0 8 12    set 1200 baud
> pitnc_setparams 0 0 10 4    set transmit audio level
> pitnc_setparams 0 0 9 0      set receive audio level
> pitnc_setparams 0 0 15 2    reset TNC
>
> The settings for the transmit audio level depend upon your radio.  The
> radio docs should tell you what levels are needed.
>
> Of course, you'll have to change the settings on the radio to 9600
> baud.
>
> No need to change the jumper settings, it can stay the same for 1200
> or 9600 baud.
>
> Mark
> KD0QYN
>
>  On Thursday, February 20, 2020, 3:11:44 PM CST, Brian Webster via
> Groups.Io <radiowebst=yahoo.com@groups.io> wrote:
>
> On the mini din plug there are separate connections for 9600 and 1200
> audio. That setting you change in the radio switches between the
> different pins and routes discriminator audio to the connector vs
> filtered audio for 1200 baud.
>
> Brian N2KGC
>
> FROM: RaspberryPi-4-HamRadio@groups.io
> [mailto:RaspberryPi-4-HamRadio@groups.io] ON BEHALF OF VA3ZUK
> SENT: Thursday, February 20, 2020 2:03 PM
> TO: RaspberryPi-4-HamRadio@groups.io
> SUBJECT: [RaspberryPi-4-HamRadio] Icom IC-207 + TNC-PI9K6 issue RX/TX
>
> SETUP
>
>     * ICOM IC-207
>     * TNC-PI9K6
>     * 6 pin mini-din
>     * Raspberry Pi 3 Model B Rev 1.2
>     * Raspbian GNU/Linux 10 (buster)
>     * Linux Kernel 4.19.97-v7+
>     * 9600 & 1200 baud
>
> ISSUE
> Unable to RX or TX on 9600 or 1200 with ax25
>
> I recently put together my tnc-pi9k6 kit from and connected it to my
> ic-207 radio via the mini-din connector.
>
> When the raspberry pi startup the TNC hat LEDs momentarily illuminate.
> With the radio tuned to 144.390mhz, `kissattach`ed to /dev/serial0. I
> can hear data being received on the radio, the yellow LED illuminates
> on the TNC but no data is displayed on `axlisten`. I have attempted to
> send a beacon and the radio does not click into TX and no sound is
> emitted from the radio speaker.
>
> DETAILS
>
>     * The jumper is set to the outside of the board
>     * Radio is set to 9600 baud
>     * Jump link, no capacitor.
>
> sudo kissattach /dev/serial0 wl2k
> sudo kissparms -p wl2k -t 50 -l 10 -s 12 -r 80 -f n
>
> output from `sudo axlisten -cart` while performing a `beacon` test.
>
>> wl2k: TX Delay: 50 ms
>>
>> wl2k: TX Tail time: 10 ms
>>
>> wl2k: Persistence: 81/256
>>
>> wl2k: Slot time: 10 ms
>>
>> wl2k: Duplex: Half
>>
>> wl2k: fm VA3ZUK to VA3ZUK-1 ctl UI^ pid=F0(Text) len 12 13:57:52
>>
>> test message
>
> Link to radio manual:
> https://www.icomamerica.com/en/downloads/DownloadDocument.aspx?Document=4
> View page: 63
>
> Thank you for your time, i appreciate it.
>
>
>
> Links:
> ------
> [1] https://groups.io/g/RaspberryPi-4-HamRadio/message/10287
> [2] https://groups.io/mt/71435451/4357074
> [3] https://groups.io/g/RaspberryPi-4-HamRadio/post
> [4] https://groups.io/g/RaspberryPi-4-HamRadio/editsub/4357074
> [5]
> https://groups.io/g/RaspberryPi-4-HamRadio/leave/defanged




--
Sent from my Android device with K-9 Mail. Please excuse my brevity.

Hank Riley
 

Posters here please keep in mind to trim to a minimum of material quoted from earlier posts.  Posts in this thread was getting very long just because of them not being trimmed a lot earlier in the series.

The web interface takes care of removing from view the superfuous quoted material, but it all comes through in email.

christian BARTHOD
 

Dear group,

Her is another good project based on RPI :
https://dl1gkk.com/small-portable-digital-amateur-radio-station-v2/

73s Christian F8GHE

On 22/02/2020 08:09, VA3ZUK wrote:
Hello Mat,

Thank you for your assistance.

I'm able rx and tx with 9600 baud via ax.25 on linux via usb using your firmware.

Can you provide me some documentation on how I change the tnc settings in this configuration? The pitnc_ utilities are compiled against ARM and I can't find the source, I'm assuming it's closed source?

Are you the developer of the board?

I will spend some time wrapping my head around this new-to-me world of packet radio but eventually I'd like to use the Raspberry Pi and the pre-installed firmware isn't linked anywhere in the documentation.

Thanks again,
Ash Palmer VA3ZUK

On February 20, 2020 10:56:02 p.m. EST, Mat Murdock <mat.murdock@...> wrote:

If you want to run your TNC stand alone you can load up this
firmware assuming you are using a Teensy 3.6.

https://drive.google.com/file/d/1Bot_OAkwhm04pb4J843MmR40Lj2z7GAc/view?usp=sharing

Pull the TNC off the PI and connect the TNC directly to your
computer via the micro usb connection on the Teensy. If running
Windows you can then fire up something like Winlink and do a test
transmission.

These are the default settings I load.

pitnc_setparams com1:115200 0 1 100
pitnc_setparams com1:115200 0 2 200
pitnc_setparams com1:115200 0 3 4
pitnc_setparams com1:115200 0 4 4
pitnc_setparams com1:115200 0 8 12
pitnc_setparams com1:115200 0 9 200
pitnc_setparams com1:115200 0 10 255
pitnc_setparams com1:115200 0 15 2

Mat






On Thu, Feb 20, 2020 at 5:31 PM Mark Griffith via Groups.Io
<mdgriffith2003=yahoo.com@groups.io <mailto:yahoo.com@groups.io>>
wrote:

Well, either the board is bad, or the cable, probably
something on the board.  OR there is a lot of RF in the shack
that is messing it up.

Can't think of anything else at the moment.  Sorry.

Mark
KD0QYN

On Thursday, February 20, 2020, 6:02:18 PM CST, VA3ZUK
<@VA3ZUK <mailto:@VA3ZUK>> wrote:


Hello Mark,

Yes, I should have included that information in the original
email. I
have used the settings you have given and still no RX or TX.

=====
pitnc_getparams Version 0.0.0.5

Using Serial port /dev/serial0

    TNC Software Version          8
01 TXDelay - Zero means use ADC  50
02 Persistance                  255
03 Slottime (in 10 mS)          255
04 TXTail                      255
05 Full Duplex - Not used      255
06 Our Channel (Hex)            ff
07 I2C Address (0 = async) Hex  ff
08 Mode Speed                  9600
09 RX Level (Config)              0
10 TX Level                    200
11 RX Level (Actual)            140
13 Centre Freq                2550
8 8 32 ff ff ff ff ff ff 60 0 c8 8c ff e9 c0 sum 0
====

From the manual
"1. When using a level meter or synchroscope, adjust the TX
audio output level (DATA IN level) from the TNC as follows.
0.4 Vp-p (0.2 Vrms): recommended level
0.2 Vp-p–0.5 Vp-p (0.1 Vrms–0.25 Vrms): acceptable level"

From http://www.tnc-x.com/TNCPi9K6.pdf

===============================
0.2 Vp-p–0.5 Vp-p (0.1 Vrms–0.25 Vrms): acceptable level

RX/TX levels and line voltage:
------------------------------
255 = 3000mV P-P
192 = 2250mV P-P
160 = 2000mV P-P
128 = 1500mV P-P
64 = 750mV P-P
32 = 375mV P-P
16 = 188mV P-P
8 = 94mV P-P
4 = 47mV P-P
2 = 24mV P-P
0 = 0mV (auto-set level for RX only)
===============================

So "32" should be around the correct value

RX/TX levels and line voltage:pi@r3:~ $ ./pitnc_setparams
/dev/serial0 0 10 32
pitnc_setparams Version 0.0.0.5

    PIC Software Version          8
01 TXDelay - Zero means use ADC  50
02 Persistance                  255
03 Slottime (in 10 mS)          255
04 TXTail                      255
05 Full Duplex - Not used      255
06 Our Channel (Hex)            ff
07 I2C Address (0 = async) Hex  ff
08 Mode Speed                  9600
09 RX Level (Config)              0
10 TX Level                      32
11 RX Level (Actual)            140
13 Centre Freq                2550
8 8 32 ff ff ff ff ff ff 60 0 20 8c ff 1 c0 sum 0

This does not seem to change anything

Ash Palmer
VA3ZUK

On 2020-02-20 16:45, Mark Griffith via Groups.Io wrote:
> You realize that you need to make changes on the TNC using the
> pitnc_setparams program?
>
> For 9600 baud
> -------------
> pitnc_setparams 0 0 8 96        set 9600 baud
> pitnc_setparams 0 0 10 200    set transmit audio level
> pitnc_setparams 0 0 9 0          set receive audio level
> pitnc_setparams 0 0 15 2        reset TNC
>
> Then to go back to 1200 baud:-------------
> pitnc_setparams 0 0 8 12    set 1200 baud
> pitnc_setparams 0 0 10 4    set transmit audio level
> pitnc_setparams 0 0 9 0      set receive audio level
> pitnc_setparams 0 0 15 2    reset TNC
>
> The settings for the transmit audio level depend upon your
radio.  The
> radio docs should tell you what levels are needed.
>
> Of course, you'll have to change the settings on the radio
to 9600
> baud.
>
> No need to change the jumper settings, it can stay the same
for 1200
> or 9600 baud.
>
> Mark
> KD0QYN
>
>  On Thursday, February 20, 2020, 3:11:44 PM CST, Brian
Webster via
> Groups.Io <radiowebst=yahoo.com@groups.io
<mailto:yahoo.com@groups.io>> wrote:
>
> On the mini din plug there are separate connections for 9600
and 1200
> audio. That setting you change in the radio switches between the
> different pins and routes discriminator audio to the
connector vs
> filtered audio for 1200 baud.
>
> Brian N2KGC
>
> FROM: RaspberryPi-4-HamRadio@groups.io
<mailto:RaspberryPi-4-HamRadio@groups.io>
> [mailto:RaspberryPi-4-HamRadio@groups.io
<mailto:RaspberryPi-4-HamRadio@groups.io>] ON BEHALF OF VA3ZUK
> SENT: Thursday, February 20, 2020 2:03 PM
> TO: RaspberryPi-4-HamRadio@groups.io
<mailto:RaspberryPi-4-HamRadio@groups.io>
> SUBJECT: [RaspberryPi-4-HamRadio] Icom IC-207 + TNC-PI9K6
issue RX/TX
>
> SETUP
>
>     * ICOM IC-207
>     * TNC-PI9K6
>     * 6 pin mini-din
>     * Raspberry Pi 3 Model B Rev 1.2
>     * Raspbian GNU/Linux 10 (buster)
>     * Linux Kernel 4.19.97-v7+
>     * 9600 & 1200 baud
>
> ISSUE
> Unable to RX or TX on 9600 or 1200 with ax25
>
> I recently put together my tnc-pi9k6 kit from and connected
it to my
> ic-207 radio via the mini-din connector.
>
> When the raspberry pi startup the TNC hat LEDs momentarily
illuminate.
> With the radio tuned to 144.390mhz, `kissattach`ed to
/dev/serial0. I
> can hear data being received on the radio, the yellow LED
illuminates
> on the TNC but no data is displayed on `axlisten`. I have
attempted to
> send a beacon and the radio does not click into TX and no
sound is
> emitted from the radio speaker.
>
> DETAILS
>
>     * The jumper is set to the outside of the board
>     * Radio is set to 9600 baud
>     * Jump link, no capacitor.
>
> sudo kissattach /dev/serial0 wl2k
> sudo kissparms -p wl2k -t 50 -l 10 -s 12 -r 80 -f n
>
> output from `sudo axlisten -cart` while performing a
`beacon` test.
>
>> wl2k: TX Delay: 50 ms
>>
>> wl2k: TX Tail time: 10 ms
>>
>> wl2k: Persistence: 81/256
>>
>> wl2k: Slot time: 10 ms
>>
>> wl2k: Duplex: Half
>>
>> wl2k: fm VA3ZUK to VA3ZUK-1 ctl UI^ pid=F0(Text) len 12
13:57:52
>>
>> test message
>
> Link to radio manual:
>
https://www.icomamerica.com/en/downloads/DownloadDocument.aspx?Document=4
> View page: 63
>
> Thank you for your time, i appreciate it.
>
>
>
> Links:
> ------
> [1] https://groups.io/g/RaspberryPi-4-HamRadio/message/10287
> [2] https://groups.io/mt/71435451/4357074
> [3] https://groups.io/g/RaspberryPi-4-HamRadio/post
> [4] https://groups.io/g/RaspberryPi-4-HamRadio/editsub/4357074
> [5]
> https://groups.io/g/RaspberryPi-4-HamRadio/leave/defanged




--
Sent from my Android device with K-9 Mail. Please excuse my brevity.

Mat Murdock
 

No, I am not the developer of the board.  That would be John Wiseman.  My club does produced TNC's based on his design and we have a page setup with different firmware and information for them here: https://www.wvcarc.com/p/tnc-96k-resources.html.

Mat

 




Thanks for doing this.  It's a lot of work .

Is there a radio(radios) that work well for 9600?

Will these units support the new FEC packet modes?

Thanks again!
Bill

Mark Griffith
 

Bill,

The TNC-Pi9k6 does not do the FEC mode.  I suppose someone could take the software and add that to it, but for now it is not there.

There are a number of radios that work well with 9600 baud, but not all are equal.  I would watch this video I made on this subject so you don't waste you money on a radio that will not work.

Mark
KD0QYN





On Monday, March 9, 2020, 11:51:47 PM CDT, Bill Vodall <wa7nwp@...> wrote:





Thanks for doing this.  It's a lot of work .

Is there a radio(radios) that work well for 9600?

Will these units support the new FEC packet modes?

Thanks again!
Bill