Topics

GPS looses FIX when HDMI is in use...

Mike Erstad
 

Hello All,
I've been following KM4ACK's instructions with regards to using the GPS/GLONASS U-blox7 USB dongle...
https://www.youtube.com/watch?v=blYpYMm8MVE&t=11s
The short version is that everything works fine if I run headless and using VNC Connect (without using one of the two HDMI Pi-4 ports)  I get a Fix on 7 Satellites...I can bring up cpgs which gives me my Lot and Lan.... all works fine...

But If I either plug in a monitor or just turn on a connected monitor through the HDMI port I loose the Fix, and the Satellites go from 7 to 3 or less and the GPS dongle stops flashing (if flashing, it indicates a lock or Fix to the Satellites)

I returned the GPS dongle back to Amazon and received a new one....Same problem....... I tried the other HDMI port....Same problem....   I tried different monitors....Same problem....   I made sure I was using the 3.5 amp power supply for the Pi-4....   disconnected mouse and keyboard.....

Anyway if you click on the line above to KM4ACK for installation of the GPS you can read further comments...  

Any ideas would be appreciated....   The GPS is for use when out in the field where you need correct time for doing like JS8call, etc...

Thanks for your help,
Mike
Eagle River, Wi.
K9BBN

Mike
 
Edited

Hi Mike,
I have noticed that my ublox glonass dongle is sensitive to nearby metal objects.  The hdmi cable could be affecting it. If you have a means to separate the gps like adding an extension cable or a usb hub, you could test for proximity effect.
73 KV4TT Mike

Clark Martin
 

There is a problem with the RPi jamming it’s own WiFi, the source… the HDMI ports.  I suspect the same thing is happening to your GPS.  Try hanging the GPS dongle on a 2 foot or longer USB extension cable.


Article on RPi jamming it’s own WiFi:

Clark Martin
KK6ISP

On Feb 3, 2020, at 4:32 PM, Mike Erstad <erstadmr@...> wrote:

Hello All,
I've been following KM4ACK's instructions with regards to using the GPS/GLONASS U-blox7 USB dongle...
https://www.youtube.com/watch?v=blYpYMm8MVE&t=11s
The short version is that everything works fine if I run headless and using VNC Connect (without using one of the two HDMI Pi-4 ports)  I get a Fix on 7 Satellites...I can bring up cpgs which gives me my Lot and Lan.... all works fine...

But If I either plug in a monitor or just turn on a connected monitor through the HDMI port I loose the Fix, and the Satellites go from 7 to 3 or less and the GPS dongle stops flashing (if flashing, it indicates a lock or Fix to the Satellites)

I returned the GPS dongle back to Amazon and received a new one....Same problem....... I tried the other HDMI port....Same problem....   I tried different monitors....Same problem....   I made sure I was using the 3.5 amp power supply for the Pi-4....   disconnected mouse and keyboard.....

Anyway if you click on the line above to KM4ACK for installation of the GPS you can read further comments...  

Any ideas would be appreciated....   The GPS is for use when out in the field where you need correct time for doing like JS8call, etc...


Mike Erstad
 

All I can say is WOW!!!   
     
     That did it!  
Moving the GPS dongle 12 inches away from the HDMI cables that come out of the Pi-4 allowed the GPS to quickly lock onto the Satellites...

A big Thanks You to Mike and Clark for posting.... 

Thanks Again,
Mike 
Eagle River, Wisconsin   

Chris Weiss KJ7GST
 

According to this article, the interference is affected by the resolution of the HDMI output. If you are using the HDMI for a display, you could try changing the screen resolution. There are some other things to try at the bottom of the article.
 
Supposedly, this will be fixed in a firmware update (that would be included in the base Raspbian distribution), but I can't find any information about if/when that will be released.

Mike
 

:<)

John Brent - VA7WPN
 

IS this affecting the GPS even if there is no HDMI connected? I only use VNC, and I have been having issues where GPSD is running, but when I use gpsmon -n to view it, its intermittent. Some times I get output, other times I get a black window. I have it set to the highest resolution for my VNC.

John Brent
 VA7WPN

Chris Weiss KJ7GST
 

From what little info I can find, the Raspberry Pi 4 output is always active. On previous boards, there was a configuration option to disable it, but that's not (yet) implemented on the Pi 4. (Reference: https://www.raspberrypi.org/documentation/configuration/config-txt/video.md)

Since it's basically acting like an antenna, keeping the GPS as far away from the HDMI ports as possible would be helpful, and of course, don't plug any HDMI cables in.

If your Pi4 is in a case, you could try getting some adhesive copper foil and putting it on the part of the case near the HDMI ports. I'd be curious to know if that makes a difference, assuming that interference from the HDMI port is what's causing the sporadic GPS issues for you).

stephen shearer
 

I am using my RPi4 with HDMI and GPS.
I have used both a USB dongle GPS and a USB cabled GPS - with no problems.

I AM using a metal case for my RPi.
I am using a FLIRC case: https://www.amazon.com/gp/product/B07WG4DW52/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1
With the RPi at "idle" it is 43C.  I did add a few stick-on heat sinks inside the Flirc case, in addition to the CPU that the case sinks...

This "should" work too;
https://www.amazon.com/gp/product/B07ZX4NTCN/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1
I have one, but haven't tried it yet.  I think it will run cooler (the way it is built) than the Flirc.

73, steve WB3LGC


On 2/23/20 11:47 AM, Chris Weiss KJ7GST wrote:
>From what little info I can find, the Raspberry Pi 4 output is always active. On previous boards, there was a configuration option to disable it, but that's not (yet) implemented on the Pi 4. (Reference: https://www.raspberrypi.org/documentation/configuration/config-txt/video.md)

Since it's basically acting like an antenna, keeping the GPS as far away from the HDMI ports as possible would be helpful, and of course, don't plug any HDMI cables in.

If your Pi4 is in a case, you could try getting some adhesive copper foil and putting it on the part of the case near the HDMI ports. I'd be curious to know if that makes a difference, assuming that interference from the HDMI port is what's causing the sporadic GPS issues for you).

bbillp
 

HDMI puts out enough RF noise to block the sensitive input to the GPS, move the GPS away from the Pi and cables as far as possible or test it by taking everything outside for a stronger GPS satellite signal. I had this problem with a GPS disciplined oscillator putting out a strong signal and had to move the GPS antenna about 10 feet away.
Bill acj

stephen shearer
 

BTW, I did have a 6" USB extension cable for the GPS dongle on the output USB port for the RPi4.

"This "should" work too;
https://www.amazon.com/gp/product/B07ZX4NTCN/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1
I have one, but haven't tried it yet.  I think it will run cooler (the way it is built) than the Flirc."

Not true if you watch this video... (running cooler)
https://www.youtube.com/watch?v=VJC6OpGpq0Y
BUT, I think I will attach a fan blowing on the heat sink fins.

73, steve WB3LGC

On 2/24/20 9:42 AM, stephen shearer wrote:

I am using my RPi4 with HDMI and GPS.
I have used both a USB dongle GPS and a USB cabled GPS - with no problems.

I AM using a metal case for my RPi.
I am using a FLIRC case: https://www.amazon.com/gp/product/B07WG4DW52/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1
With the RPi at "idle" it is 43C.  I did add a few stick-on heat sinks inside the Flirc case, in addition to the CPU that the case sinks...

This "should" work too;
https://www.amazon.com/gp/product/B07ZX4NTCN/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1
I have one, but haven't tried it yet.  I think it will run cooler (the way it is built) than the Flirc.

73, steve WB3LGC


On 2/23/20 11:47 AM, Chris Weiss KJ7GST wrote:
>From what little info I can find, the Raspberry Pi 4 output is always active. On previous boards, there was a configuration option to disable it, but that's not (yet) implemented on the Pi 4. (Reference: https://www.raspberrypi.org/documentation/configuration/config-txt/video.md)

Since it's basically acting like an antenna, keeping the GPS as far away from the HDMI ports as possible would be helpful, and of course, don't plug any HDMI cables in.

If your Pi4 is in a case, you could try getting some adhesive copper foil and putting it on the part of the case near the HDMI ports. I'd be curious to know if that makes a difference, assuming that interference from the HDMI port is what's causing the sporadic GPS issues for you).