Topics

Finding USB0 port on fldigi


Charles Albert
 

I have successfully installed fldigi on the Raspberry Pi 3B+, and it
receives fine, but I finally learned that in order to tx, the device
file should be /dev/ttyUSB0. I have unsuccessfully tried the
instructions in the KK5JY manual which is nicely written to build the
/dev/ttyUSB0. I don't need rig control since the rig is a Icom 737,
and I am using a Signalink USB sound card. Help! Does anyone know the
proper way to get /dev/ttyUSB0 done? I see that many of you are using
the Rasp 3B+ with the Signalink. What is the trick??


Chuck M
 

On Thu, Sep 10, 2020 at 7:53 PM, Charles Albert
<mrcwa2@...> wrote:
I have successfully installed fldigi on the Raspberry Pi 3B+, and it
receives fine, but I finally learned that in order to tx, the device
file should be /dev/ttyUSB0. I have unsuccessfully tried the
instructions in the KK5JY manual which is nicely written to build the
/dev/ttyUSB0.  I don't need rig control since the rig is a Icom 737,
and I am using a Signalink USB sound card. Help! Does anyone know the
proper way to get /dev/ttyUSB0 done? I see that many of you are using
the Rasp 3B+ with the Signalink. What is the trick??




David Ranch
 


Hello Charles,

The Signalink USB device doesn't create any serial devices (/dev/ttyUSB*) as it's only a sound device.  It automatically keys up your radio based upon the presence of an audio signal.  If the PTT LED on the Signalink isn't coming on, turn up the TX knob on the Signalink box and/or check your mixer settings in Linux.  If the PTT LED is coming on the Signalink but it's not keying your radio, check your cabling and/or the jumper block inside your Signalink.

--David
KI6ZHD


I have successfully installed fldigi on the Raspberry Pi 3B+, and it
receives fine, but I finally learned that in order to tx, the device
file should be /dev/ttyUSB0. I have unsuccessfully tried the
instructions in the KK5JY manual which is nicely written to build the
/dev/ttyUSB0.  I don't need rig control since the rig is a Icom 737,
and I am using a Signalink USB sound card. Help! Does anyone know the
proper way to get /dev/ttyUSB0 done? I see that many of you are using
the Rasp 3B+ with the Signalink. What is the trick??




Charles Albert
 

thanks for your response, I'll keep on plugging!

On Fri, Sep 11, 2020 at 12:02 AM David Ranch
<rpi4hamradio-groupsio@...> wrote:


Hello Charles,

The Signalink USB device doesn't create any serial devices (/dev/ttyUSB*) as it's only a sound device. It automatically keys up your radio based upon the presence of an audio signal. If the PTT LED on the Signalink isn't coming on, turn up the TX knob on the Signalink box and/or check your mixer settings in Linux. If the PTT LED is coming on the Signalink but it's not keying your radio, check your cabling and/or the jumper block inside your Signalink.

--David
KI6ZHD


I have successfully installed fldigi on the Raspberry Pi 3B+, and it
receives fine, but I finally learned that in order to tx, the device
file should be /dev/ttyUSB0. I have unsuccessfully tried the
instructions in the KK5JY manual which is nicely written to build the
/dev/ttyUSB0. I don't need rig control since the rig is a Icom 737,
and I am using a Signalink USB sound card. Help! Does anyone know the
proper way to get /dev/ttyUSB0 done? I see that many of you are using
the Rasp 3B+ with the Signalink. What is the trick??