MiniProSC sound card info for BAP 3.0.8


Dinoburb
 

I have been attempting to set-up a G90, MiniProSC, Raspberry Pi remote set-up and I am flummoxed (technical term) on what the MiniPro returns as the sound card.  When attempting to set-up WSJX I use the Icom 7100 as the radio and cannot figure out which of the 23 options presented.  Having tried anything the indicated a USB sound card resulted in no successful set-up.

I have the G90 set-up with VOX and I/O via LINE.  The program cannot/will not read the radio.

I’ve tried Julian’s set-up for FLRIG and here I cab select the Xeigu G90 but when it comes to the the sound card I’m presented with over 50 options starting with  /dev/tty, /dev/tty0 on to /tty9 then its /dev/ttyAMAO  and  /dev/ttyprintk.  Nothing seems to work and no data sent to the program AND the USB audio switch is grayed out under the XCVR Configuration!
i need help in getting out of this rabbit hole!


Phil Culmer 2E0HGU
 

I would suggest getting a terminal window up, and typing aplay -l and seeing what you get, and then arecord -l and looking at the output from that.

 

The output can still take a bit of deciphering, but it will hopefully give you a better idea of what to look for for your USB Audio.

 

73

Phil

2E0HGU


km4ack
 

Most of the BAP users running the G90 hang out in this forum https://groups.io/g/KM4ACK-Pi/topics

I don't own the MiniProSC but I believe it is similar to the Signalink. Look for the sound card that has "Codec" in the name.

73, de KM4ACK


Dave R
 

On Tue, Aug 17, 2021, 02:45 Dinoburb <fsgorman@...> wrote:
I have been attempting to set-up a G90, MiniProSC, Raspberry Pi remote set-up and I am flummoxed (technical term) on what the MiniPro returns as the sound card.  When attempting to set-up WSJX I use the Icom 7100 as the radio and cannot figure out which of the 23 options presented.  Having tried anything the indicated a USB sound card resulted in no successful set-up.

I have the G90 set-up with VOX and I/O via LINE.  The program cannot/will not read the radio.

I’ve tried Julian’s set-up for FLRIG and here I cab select the Xeigu G90 but when it comes to the the sound card I’m presented with over 50 options starting with  /dev/tty, /dev/tty0 on to /tty9 then its /dev/ttyAMAO  and  /dev/ttyprintk.  Nothing seems to work and no data sent to the program AND the USB audio switch is grayed out under the XCVR Configuration!
i need help in getting out of this rabbit hole!


David AJ6RE
 

Hi Dinoburb,

I had the same experience, with the exact same configuration: G90, MiniProSC, Rpi mobile. I did the same thing, trying to emulate Julian's setup. In the end it turned out the addition of the CAT cable (USB) between the G90 and the Rpi was necessary. I was pulling my hair out for about 2 weeks until I figured that out.

Good luck!

73's
David
AJ6RE


David AJ6RE
 

Hi Dinoburb,

Just to clarify, you should add a CAT cable and then you will see the USB inputs you are looking for in FLRIG.

73

David
AJ6RE


Don Poaps
 

I use a Digirig interface for my G 90. (digirig.net) when I get a chance to go portable.
I have had to use the blue USB vfo control in the past when USB ports got messed up. 

73
Don Poaps
New Westminster, BC
VA7DGP DATA
VA7QU   VOICE


Winlink: va7qu@...
Subject://wl2k    
     

ALLSTAR  530780
HH# 5971
HH# 11384
Alberta Mesh# 5404

                   


On Wed, Aug 18, 2021 at 3:12 PM David AJ6RE <dc1@...> wrote:
Hi Dinoburb,

Just to clarify, you should add a CAT cable and then you will see the USB inputs you are looking for in FLRIG.

73

David
AJ6RE


Dinoburb
 

Thanks Dave, I’ll try that when I get back to my rig.  I, too, was trying to replicate Julian’s set-up and having no luck.  Again, thanks.

I appreciate all the help that referred me to the MiniPro information on how to set it up with Windows, however, Raspberry Pi is not running Windows and I do have all of the MiniPro info.


Dinoburb
 

I have added the CAT cable and have carefully watched Julian’s G90 Digital Modes Setup and I finally figured it out.  FLRIG is your friend. Additionally,  watching what nondescript audio codec he selected, and locating it among the 20+ options, I was finally able to get full access to my radio and digital modes through my RaspberryPi.  The proper audio selection is:  plughw:CARD=CODEC,dev=0
Once selected, my MiniPro worked like a champ and digital modes are ready to go!

Thank you Julian, OH8STN.