JTDX screen size too large - how to correct? #pi #jtdx


Alf Blomqvist
 

Hi,

I got problems when I set up my remote station headless.

With a monitor connected at the remote qth there is no problems with the size of JTDX main screen.

I have tried both Raspberry Pi 3B and Raspberry Pi 4B with same problem - the screen is too large and I'm not able to make the text on the screen smaller - I cannot press ok on setting screen!!

I don't no if this is a Raspberry Pi problem or a JTDX problem.

73 Alf
OH6IH


Jonathan Magee
 

Hi Alf
These are the steps I used. They may be different steps depending on the version of Raspbian you have installed.

Press Raspberry icon to get up the menu
Select menu option Preference -> Screen Configuration

In the Screen Layout application
Goto the Configure menu
Select Screens -> HDMI -> Resolution
Select the resolution you want and then press the green tick to apply the change
You will then be asked to Hit OK to keep the new setting

Hope this helps
73 Jonathan GI7KMC

On Tue, 3 Nov 2020 at 15:32, Alf Blomqvist <oh6ih@...> wrote:
Hi,

I got problems when I set up my remote station headless.

With a monitor connected at the remote qth there is no problems with the size of JTDX main screen.

I have tried both Raspberry Pi 3B and Raspberry Pi 4B with same problem - the screen is too large and I'm not able to make the text on the screen smaller - I cannot press ok on setting screen!!

I don't no if this is a Raspberry Pi problem or a JTDX problem.

73 Alf
OH6IH


David Ranch
 


Hello Alf,

One thing you can try is to force the HDMI port always on.  To do this, edit the /boot/config.txt and enable the following feature:

   hdmi_force_hotplug=1

Save the file and reboot.  Does that help?  If not, I would then research how to force the desired screen resolution that your current monitor supports and also put that into the config.txt file.

Ultimately, there is probably a more elegant way to achieve what you're looking for without forcing the HDMI port to be on and maybe someone on the list can offer that up.

--David
KI6ZHD


On 11/03/2020 07:31 AM, Alf Blomqvist wrote:
Hi,

I got problems when I set up my remote station headless.

With a monitor connected at the remote qth there is no problems with the size of JTDX main screen.

I have tried both Raspberry Pi 3B and Raspberry Pi 4B with same problem - the screen is too large and I'm not able to make the text on the screen smaller - I cannot press ok on setting screen!!

I don't no if this is a Raspberry Pi problem or a JTDX problem.

73 Alf
OH6IH


Alf Blomqvist
 

Hi David 

tnx fer advice.

An other problem is that I don't have permission to change the file you mention.

So how do I get permission?

73 Alf
OH6IH



Skickat från min Samsung Galaxy-smartphone.


-------- Originalmeddelande --------
Från: David Ranch <rpi4hamradio-groupsio@...>
Datum: 03-11-2020 18:27 (GMT+02:00)
Till: RaspberryPi-4-HamRadio@groups.io
Ämne: Re: [RaspberryPi-4-HamRadio] JTDX screen size too large - how to correct? #jtdx #pi


Hello Alf,

One thing you can try is to force the HDMI port always on.  To do this, edit the /boot/config.txt and enable the following feature:

   hdmi_force_hotplug=1

Save the file and reboot.  Does that help?  If not, I would then research how to force the desired screen resolution that your current monitor supports and also put that into the config.txt file.

Ultimately, there is probably a more elegant way to achieve what you're looking for without forcing the HDMI port to be on and maybe someone on the list can offer that up.

--David
KI6ZHD


On 11/03/2020 07:31 AM, Alf Blomqvist wrote:
Hi,

I got problems when I set up my remote station headless.

With a monitor connected at the remote qth there is no problems with the size of JTDX main screen.

I have tried both Raspberry Pi 3B and Raspberry Pi 4B with same problem - the screen is too large and I'm not able to make the text on the screen smaller - I cannot press ok on setting screen!!

I don't no if this is a Raspberry Pi problem or a JTDX problem.

73 Alf
OH6IH


Fred Hillhouse
 

I use VNC Viewer for headless operation. In it, I set the scaling to Scale to fit window”. Go to Properties (gear icon) and then the Scaling section.

 

In the RPi, go to Preferences, Display Settings. Select your Default Monitor. I use 1920x1080. You may have to reboot.

 

On my 4:3 monitor, I can see the whole 1920x1080 display regardless of how large the window is.

 

Fred N7FMH

 

 

From: RaspberryPi-4-HamRadio@groups.io [mailto:RaspberryPi-4-HamRadio@groups.io] On Behalf Of Alf Blomqvist
Sent: Tuesday, November 03, 2020 10:32 AM
To: RaspberryPi-4-HamRadio@groups.io
Subject: [RaspberryPi-4-HamRadio] JTDX screen size too large - how to correct? #jtdx #pi

 

Hi,

I got problems when I set up my remote station headless.

With a monitor connected at the remote qth there is no problems with the size of JTDX main screen.

I have tried both Raspberry Pi 3B and Raspberry Pi 4B with same problem - the screen is too large and I'm not able to make the text on the screen smaller - I cannot press ok on setting screen!!

I don't no if this is a Raspberry Pi problem or a JTDX problem.

73 Alf
OH6IH




Avast logo

This email has been checked for viruses by Avast antivirus software.
www.avast.com



Alf Blomqvist
 

Hi Fred and tnx fer the answer!

I also use VNCviewer.

I understand you talking of VNCviewer settings?

73 Alf

OH6IH

On 03/11/2020 19:43, Fred Hillhouse wrote:

I use VNC Viewer for headless operation. In it, I set the scaling to Scale to fit window”. Go to Properties (gear icon) and then the Scaling section.

 

In the RPi, go to Preferences, Display Settings. Select your Default Monitor. I use 1920x1080. You may have to reboot.

 

On my 4:3 monitor, I can see the whole 1920x1080 display regardless of how large the window is.

 

Fred N7FMH

 

 

From: RaspberryPi-4-HamRadio@groups.io [mailto:RaspberryPi-4-HamRadio@groups.io] On Behalf Of Alf Blomqvist
Sent: Tuesday, November 03, 2020 10:32 AM
To: RaspberryPi-4-HamRadio@groups.io
Subject: [RaspberryPi-4-HamRadio] JTDX screen size too large - how to correct? #jtdx #pi

 

Hi,

I got problems when I set up my remote station headless.

With a monitor connected at the remote qth there is no problems with the size of JTDX main screen.

I have tried both Raspberry Pi 3B and Raspberry Pi 4B with same problem - the screen is too large and I'm not able to make the text on the screen smaller - I cannot press ok on setting screen!!

I don't no if this is a Raspberry Pi problem or a JTDX problem.

73 Alf
OH6IH




Avast logo

This email has been checked for viruses by Avast antivirus software.
www.avast.com



Mark Griffith
 

Use raspi-config from the command line to set the resolution. 

Mark 
KD0QYN 


On Tue, Nov 3, 2020 at 11:50 AM, Alf Blomqvist
<oh6ih@...> wrote:

Hi Fred and tnx fer the answer!

I also use VNCviewer.

I understand you talking of VNCviewer settings?

73 Alf

OH6IH

On 03/11/2020 19:43, Fred Hillhouse wrote:

I use VNC Viewer for headless operation. In it, I set the scaling to Scale to fit window”. Go to Properties (gear icon) and then the Scaling section.

 

In the RPi, go to Preferences, Display Settings. Select your Default Monitor. I use 1920x1080. You may have to reboot.

 

On my 4:3 monitor, I can see the whole 1920x1080 display regardless of how large the window is.

 

Fred N7FMH

 

 

From: RaspberryPi-4-HamRadio@groups.io [mailto:RaspberryPi-4-HamRadio@groups.io] On Behalf Of Alf Blomqvist
Sent: Tuesday, November 03, 2020 10:32 AM
To: RaspberryPi-4-HamRadio@groups.io
Subject: [RaspberryPi-4-HamRadio] JTDX screen size too large - how to correct? #jtdx #pi

 

Hi,

I got problems when I set up my remote station headless.

With a monitor connected at the remote qth there is no problems with the size of JTDX main screen.

I have tried both Raspberry Pi 3B and Raspberry Pi 4B with same problem - the screen is too large and I'm not able to make the text on the screen smaller - I cannot press ok on setting screen!!

I don't no if this is a Raspberry Pi problem or a JTDX problem.

73 Alf
OH6IH




Avast logo

This email has been checked for viruses by Avast antivirus software.
www.avast.com



 

Put sudo in front of the editor command. 


On Tue, Nov 3, 2020, 09:30 Alf Blomqvist <oh6ih@...> wrote:
Hi David 

tnx fer advice.

An other problem is that I don't have permission to change the file you mention.

So how do I get permission?

73 Alf
OH6IH



Skickat från min Samsung Galaxy-smartphone.


-------- Originalmeddelande --------
Från: David Ranch <rpi4hamradio-groupsio@...>
Datum: 03-11-2020 18:27 (GMT+02:00)
Ämne: Re: [RaspberryPi-4-HamRadio] JTDX screen size too large - how to correct? #jtdx #pi


Hello Alf,

One thing you can try is to force the HDMI port always on.  To do this, edit the /boot/config.txt and enable the following feature:

   hdmi_force_hotplug=1

Save the file and reboot.  Does that help?  If not, I would then research how to force the desired screen resolution that your current monitor supports and also put that into the config.txt file.

Ultimately, there is probably a more elegant way to achieve what you're looking for without forcing the HDMI port to be on and maybe someone on the list can offer that up.

--David
KI6ZHD


On 11/03/2020 07:31 AM, Alf Blomqvist wrote:
Hi,

I got problems when I set up my remote station headless.

With a monitor connected at the remote qth there is no problems with the size of JTDX main screen.

I have tried both Raspberry Pi 3B and Raspberry Pi 4B with same problem - the screen is too large and I'm not able to make the text on the screen smaller - I cannot press ok on setting screen!!

I don't no if this is a Raspberry Pi problem or a JTDX problem.

73 Alf
OH6IH


Fred Hillhouse
 

There are settings for both.

 

VNC Viewer:

Go to Properties (gear icon) and then the Scaling section.

 

Raspberry Pi:

Go to Preferences, Display Settings. Select your Default Monitor. I use 1920x1080. You may have to reboot.

 

Fred N7FMH

 

 

 

From: RaspberryPi-4-HamRadio@groups.io [mailto:RaspberryPi-4-HamRadio@groups.io] On Behalf Of Alf Blomqvist
Sent: Tuesday, November 03, 2020 12:50 PM
To: RaspberryPi-4-HamRadio@groups.io
Subject: Re: [RaspberryPi-4-HamRadio] JTDX screen size too large - how to correct? #jtdx #pi

 

Hi Fred and tnx fer the answer!

I also use VNCviewer.

I understand you talking of VNCviewer settings?

73 Alf

OH6IH

On 03/11/2020 19:43, Fred Hillhouse wrote:

I use VNC Viewer for headless operation. In it, I set the scaling to Scale to fit window”. Go to Properties (gear icon) and then the Scaling section.

 

In the RPi, go to Preferences, Display Settings. Select your Default Monitor. I use 1920x1080. You may have to reboot.

 

On my 4:3 monitor, I can see the whole 1920x1080 display regardless of how large the window is.

 

Fred N7FMH

 

 

From: RaspberryPi-4-HamRadio@groups.io [mailto:RaspberryPi-4-HamRadio@groups.io] On Behalf Of Alf Blomqvist
Sent: Tuesday, November 03, 2020 10:32 AM
To: RaspberryPi-4-HamRadio@groups.io
Subject: [RaspberryPi-4-HamRadio] JTDX screen size too large - how to correct? #jtdx #pi

 

Hi,

I got problems when I set up my remote station headless.

With a monitor connected at the remote qth there is no problems with the size of JTDX main screen.

I have tried both Raspberry Pi 3B and Raspberry Pi 4B with same problem - the screen is too large and I'm not able to make the text on the screen smaller - I cannot press ok on setting screen!!

I don't no if this is a Raspberry Pi problem or a JTDX problem.

73 Alf
OH6IH

 


Avast logo

This email has been checked for viruses by Avast antivirus software.
www.avast.com




N5XMT
 

Put sudo in front of the command

On Nov 3, 2020, at 09:30, Alf Blomqvist <oh6ih@...> wrote:
Hi David 

tnx fer advice.

An other problem is that I don't have permission to change the file you mention.

So how do I get permission?

73 Alf
OH6IH



Skickat från min Samsung Galaxy-smartphone.


-------- Originalmeddelande --------
Från: David Ranch <rpi4hamradio-groupsio@...>
Datum: 03-11-2020 18:27 (GMT+02:00)
Till: RaspberryPi-4-HamRadio@groups.io
Ämne: Re: [RaspberryPi-4-HamRadio] JTDX screen size too large - how to correct? #jtdx #pi


Hello Alf,

One thing you can try is to force the HDMI port always on.  To do this, edit the /boot/config.txt and enable the following feature:

   hdmi_force_hotplug=1

Save the file and reboot.  Does that help?  If not, I would then research how to force the desired screen resolution that your current monitor supports and also put that into the config.txt file.

Ultimately, there is probably a more elegant way to achieve what you're looking for without forcing the HDMI port to be on and maybe someone on the list can offer that up.

--David
KI6ZHD


On 11/03/2020 07:31 AM, Alf Blomqvist wrote:
Hi,

I got problems when I set up my remote station headless.

With a monitor connected at the remote qth there is no problems with the size of JTDX main screen.

I have tried both Raspberry Pi 3B and Raspberry Pi 4B with same problem - the screen is too large and I'm not able to make the text on the screen smaller - I cannot press ok on setting screen!!

I don't no if this is a Raspberry Pi problem or a JTDX problem.

73 Alf
OH6IH


Alf Blomqvist
 

Good Morning !

Now I have got my size issue solved.

I found Raspbery Pi settings for resolution and now I may handle the size of screens.

Thank you for all advices!

73 Alf
OH6IH



Skickat från min Samsung Galaxy-smartphone.


-------- Originalmeddelande --------
Från: N5XMT <dacooley@...>
Datum: 03-11-2020 21:55 (GMT+02:00)
Till: raspberrypi-4-hamradio@groups.io
Ämne: Re: [RaspberryPi-4-HamRadio] JTDX screen size too large - how to correct? #jtdx #pi

Put sudo in front of the command

On Nov 3, 2020, at 09:30, Alf Blomqvist <oh6ih@...> wrote:
Hi David 

tnx fer advice.

An other problem is that I don't have permission to change the file you mention.

So how do I get permission?

73 Alf
OH6IH



Skickat från min Samsung Galaxy-smartphone.


-------- Originalmeddelande --------
Från: David Ranch <rpi4hamradio-groupsio@...>
Datum: 03-11-2020 18:27 (GMT+02:00)
Till: RaspberryPi-4-HamRadio@groups.io
Ämne: Re: [RaspberryPi-4-HamRadio] JTDX screen size too large - how to correct? #jtdx #pi


Hello Alf,

One thing you can try is to force the HDMI port always on.  To do this, edit the /boot/config.txt and enable the following feature:

   hdmi_force_hotplug=1

Save the file and reboot.  Does that help?  If not, I would then research how to force the desired screen resolution that your current monitor supports and also put that into the config.txt file.

Ultimately, there is probably a more elegant way to achieve what you're looking for without forcing the HDMI port to be on and maybe someone on the list can offer that up.

--David
KI6ZHD


On 11/03/2020 07:31 AM, Alf Blomqvist wrote:
Hi,

I got problems when I set up my remote station headless.

With a monitor connected at the remote qth there is no problems with the size of JTDX main screen.

I have tried both Raspberry Pi 3B and Raspberry Pi 4B with same problem - the screen is too large and I'm not able to make the text on the screen smaller - I cannot press ok on setting screen!!

I don't no if this is a Raspberry Pi problem or a JTDX problem.

73 Alf
OH6IH


Alf Blomqvist
 

Good Morning and tnx fer advice,

I finally change config.txt to force Hdmi with nano.

I found Raspberry Pi resolution settings in Preferences.

So I solved the issue.

73 Alf
OH6IH



Skickat från min Samsung Galaxy-smartphone.


-------- Originalmeddelande --------
Från: David Ranch <rpi4hamradio-groupsio@...>
Datum: 03-11-2020 18:27 (GMT+02:00)
Till: RaspberryPi-4-HamRadio@groups.io
Ämne: Re: [RaspberryPi-4-HamRadio] JTDX screen size too large - how to correct? #jtdx #pi


Hello Alf,

One thing you can try is to force the HDMI port always on.  To do this, edit the /boot/config.txt and enable the following feature:

   hdmi_force_hotplug=1

Save the file and reboot.  Does that help?  If not, I would then research how to force the desired screen resolution that your current monitor supports and also put that into the config.txt file.

Ultimately, there is probably a more elegant way to achieve what you're looking for without forcing the HDMI port to be on and maybe someone on the list can offer that up.

--David
KI6ZHD


On 11/03/2020 07:31 AM, Alf Blomqvist wrote:
Hi,

I got problems when I set up my remote station headless.

With a monitor connected at the remote qth there is no problems with the size of JTDX main screen.

I have tried both Raspberry Pi 3B and Raspberry Pi 4B with same problem - the screen is too large and I'm not able to make the text on the screen smaller - I cannot press ok on setting screen!!

I don't no if this is a Raspberry Pi problem or a JTDX problem.

73 Alf
OH6IH