Topics

Pi-4, Dire Wolf and Signal Link---Where did the "Audio Device Settings" Go?


Mike Erstad
 

Hello All,

I've been running Dire Wolf using a Signal Link on a Pi 3....and you have to use the Audio Device Settings found in Preferences to select USB AUDIO CODEC....but the ADS app is missing on the Pi-4
What am I missing?
Thanks much for the help,
Mike


Mike Erstad
 

Maybe I should be asking:  How do you install the "Audio Device Setting" found in Preferences...

There missing whether I use a Pi-3 or Pi-4

Thanks Much,
Mike


Mike Erstad
 

Found It.....

I believe pimixer may have been removed from latest Raspbian for some reason.
You can install it with:

Code: Select all

sudo apt install -y pimixer
And then to launch it:

Code: Select all

pimixer


John
 

Hi Mike,

My setup is also Pi4, Direwolf, xastir and Signalink USB.  I'm not sure I understand your question, though.  Is the Pi4 trying to play system sounds out of your Signalink or are you trying to configure direwolf to use the Signalink?  If the former, use raspi-config as described here (https://www.raspberrypi.org/documentation/configuration/audio-config.md) to send system sounds out of your HDMI or headphones output.  If the latter, use the"arecord -l" and "aplay -l" commands to discover which device number your Signalink was assigned and "alsamixer" to adjust the settings (if needed). Portions of this video (https://youtu.be/9Ya0C308TQA) are helpful in figuring out how to configure the direwolf.conf file based on the values returned from the"arecord -l" and "aplay -l" commands.

I hope this helps.  73
John - W9EN


On Sun, Oct 25, 2020 at 9:42 AM Mike Erstad <erstadmr@...> wrote:
Maybe I should be asking:  How do you install the "Audio Device Setting" found in Preferences...

There missing whether I use a Pi-3 or Pi-4

Thanks Much,
Mike


Mike Erstad
 

Hi John,
I’m trying to configure direwolf to use my Signal Link usb and I need the “Audio Device Settings” that are normally found in Preferences…

I just recently found how to install the Audio Device Settings back into the Raspberry Pi…

Code: Select all

sudo apt install -y pimixer
And then to launch it:

Code: Select all

pimixer
This allows me to choose and set up Audio Codec Device…
But as you mentioned in the “latter” I’ll try that to see if I don’t need this Audio Device Settings application or Preference and use your method...

Thanks Very Much
Mike

On Oct 25, 2020, at 12:23 PM, John <jbelstner@...> wrote:

Hi Mike,

My setup is also Pi4, Direwolf, xastir and Signalink USB.  I'm not sure I understand your question, though.  Is the Pi4 trying to play system sounds out of your Signalink or are you trying to configure direwolf to use the Signalink?  If the former, use raspi-config as described here (https://www.raspberrypi.org/documentation/configuration/audio-config.md) to send system sounds out of your HDMI or headphones output.  If the latter, use the"arecord -l" and "aplay -l" commands to discover which device number your Signalink was assigned and "alsamixer" to adjust the settings (if needed). Portions of this video (https://youtu.be/9Ya0C308TQA) are helpful in figuring out how to configure the direwolf.conf file based on the values returned from the"arecord -l" and "aplay -l" commands.

I hope this helps.  73
John - W9EN


On Sun, Oct 25, 2020 at 9:42 AM Mike Erstad <erstadmr@...> wrote:
Maybe I should be asking:  How do you install the "Audio Device Setting" found in Preferences...

There missing whether I use a Pi-3 or Pi-4

Thanks Much,
Mike




Mark Griffith
 

It's pretty simple.  You run aplay -l or arecord -l with the Signalink connected and it will find it.

root@PiGateDev:~# arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: CODEC [USB Audio CODEC], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

It shows the hardware device number, card 1, subdevice 0.  Aplay -l will show a similar result but with more items:

root@PiGateDev:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 7/7
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: ALSA [bcm2835 ALSA], device 2: bcm2835 IEC958/HDMI1 [bcm2835 IEC958/HDMI1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: CODEC [USB Audio CODEC], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Again, the Signalink shows up as card 1, subdevice 0.

The entry in the direwolf.conf file should be:

ADEVICE  plughw:1,0

Mark
KD0QYN


On Sunday, October 25, 2020, 1:20:08 PM CDT, Mike Erstad <erstadmr@...> wrote:


Hi John,
I’m trying to configure direwolf to use my Signal Link usb and I need the “Audio Device Settings” that are normally found in Preferences…

I just recently found how to install the Audio Device Settings back into the Raspberry Pi…

Code: Select all

sudo apt install -y pimixer
And then to launch it:

Code: Select all

pimixer
This allows me to choose and set up Audio Codec Device…
But as you mentioned in the “latter” I’ll try that to see if I don’t need this Audio Device Settings application or Preference and use your method...

Thanks Very Much
Mike

On Oct 25, 2020, at 12:23 PM, John <jbelstner@...> wrote:

Hi Mike,

My setup is also Pi4, Direwolf, xastir and Signalink USB.  I'm not sure I understand your question, though.  Is the Pi4 trying to play system sounds out of your Signalink or are you trying to configure direwolf to use the Signalink?  If the former, use raspi-config as described here (https://www.raspberrypi.org/documentation/configuration/audio-config.md) to send system sounds out of your HDMI or headphones output.  If the latter, use the"arecord -l" and "aplay -l" commands to discover which device number your Signalink was assigned and "alsamixer" to adjust the settings (if needed). Portions of this video (https://youtu.be/9Ya0C308TQA) are helpful in figuring out how to configure the direwolf.conf file based on the values returned from the"arecord -l" and "aplay -l" commands.

I hope this helps.  73
John - W9EN


On Sun, Oct 25, 2020 at 9:42 AM Mike Erstad <erstadmr@...> wrote:
Maybe I should be asking:  How do you install the "Audio Device Setting" found in Preferences...

There missing whether I use a Pi-3 or Pi-4

Thanks Much,
Mike




Mike Erstad
 

Thanks for the help on this…..So, I don’t need the Audio Device Settings at all….I just need to query the pi using arecord -l and make a note of the Card number and device number and add that into the DireWolfs ADEVICE  plughw:1,0 and un-comment the hash tag (#)

Thanks to all for the help…..worked perfect….

One more question…let me know if I should start a new thread…..

Does anyone know why when I start Dire Wolf the text just keeps flashing On/Off/On/Off/On and it works fine but just keep flashing and driving me nuts…

Thanks Again,
Mike

On Oct 25, 2020, at 6:36 PM, Mark Griffith via groups.io <mdgriffith2003@...> wrote:

It's pretty simple.  You run aplay -l or arecord -l with the Signalink connected and it will find it.

root@PiGateDev:~# arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: CODEC [USB Audio CODEC], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

It shows the hardware device number, card 1, subdevice 0.  Aplay -l will show a similar result but with more items:

root@PiGateDev:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 7/7
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 IEC958/HDMI [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: ALSA [bcm2835 ALSA], device 2: bcm2835 IEC958/HDMI1 [bcm2835 IEC958/HDMI1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: CODEC [USB Audio CODEC], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Again, the Signalink shows up as card 1, subdevice 0.

The entry in the direwolf.conf file should be:

ADEVICE  plughw:1,0

Mark
KD0QYN


On Sunday, October 25, 2020, 1:20:08 PM CDT, Mike Erstad <erstadmr@...> wrote:


Hi John,
I’m trying to configure direwolf to use my Signal Link usb and I need the “Audio Device Settings” that are normally found in Preferences…

I just recently found how to install the Audio Device Settings back into the Raspberry Pi…

Code: Select all

sudo apt install -y pimixer
And then to launch it:

Code: Select all

pimixer
This allows me to choose and set up Audio Codec Device…
But as you mentioned in the “latter” I’ll try that to see if I don’t need this Audio Device Settings application or Preference and use your method...

Thanks Very Much
Mike

On Oct 25, 2020, at 12:23 PM, John <jbelstner@...> wrote:

Hi Mike,

My setup is also Pi4, Direwolf, xastir and Signalink USB.  I'm not sure I understand your question, though.  Is the Pi4 trying to play system sounds out of your Signalink or are you trying to configure direwolf to use the Signalink?  If the former, use raspi-config as described here (https://www.raspberrypi.org/documentation/configuration/audio-config.md) to send system sounds out of your HDMI or headphones output.  If the latter, use the"arecord -l" and "aplay -l" commands to discover which device number your Signalink was assigned and "alsamixer" to adjust the settings (if needed). Portions of this video (https://youtu.be/9Ya0C308TQA) are helpful in figuring out how to configure the direwolf.conf file based on the values returned from the"arecord -l" and "aplay -l" commands.

I hope this helps.  73
John - W9EN


On Sun, Oct 25, 2020 at 9:42 AM Mike Erstad <erstadmr@...> wrote:
Maybe I should be asking:  How do you install the "Audio Device Setting" found in Preferences...

There missing whether I use a Pi-3 or Pi-4

Thanks Much,
Mike





David Ranch
 


Hello Mike,

Does anyone know why when I start Dire Wolf the text just keeps flashing On/Off/On/Off/On and it works fine but just keep flashing and driving me nuts…

Known issue with Raspbian Buster.  You need to upgrade to Direwolf 1.6 which requires you build it from source today (this is covered in the Direwolf User Guide).

--David
KI6ZHD


Mark Griffith
 

Or, you can run Direwolf with some command line options:

/usr/local/bin/direwolf -t 0 -p

If you want a log of what was going on:

/usr/local/bin/direwolf -t 0 -p > /var/tmp/dirwolf.log 2>&1

Mark
KD0QYN


On Monday, October 26, 2020, 6:17:49 PM CDT, David Ranch <rpi4hamradio-groupsio@...> wrote:



Hello Mike,

Does anyone know why when I start Dire Wolf the text just keeps flashing On/Off/On/Off/On and it works fine but just keep flashing and driving me nuts…

Known issue with Raspbian Buster.  You need to upgrade to Direwolf 1.6 which requires you build it from source today (this is covered in the Direwolf User Guide).

--David
KI6ZHD


Mark Griffith
 

And if you want it to run in the background without taking up a terminal:

/usr/local/bin/direwolf -t 0 -p > /var/tmp/dirwolf.log 2>&1 &

Then to stop direwolf, just do this command in any terminal:

pkill direwolf

This is all std Linux/Unix stuff.

Mark
KD0QYN



On Monday, October 26, 2020, 6:24:35 PM CDT, Mark Griffith via groups.io <mdgriffith2003@...> wrote:


Or, you can run Direwolf with some command line options:

/usr/local/bin/direwolf -t 0 -p

If you want a log of what was going on:

/usr/local/bin/direwolf -t 0 -p > /var/tmp/dirwolf.log 2>&1

Mark
KD0QYN


On Monday, October 26, 2020, 6:17:49 PM CDT, David Ranch <rpi4hamradio-groupsio@...> wrote:



Hello Mike,

Does anyone know why when I start Dire Wolf the text just keeps flashing On/Off/On/Off/On and it works fine but just keep flashing and driving me nuts…

Known issue with Raspbian Buster.  You need to upgrade to Direwolf 1.6 which requires you build it from source today (this is covered in the Direwolf User Guide).

--David
KI6ZHD


David Ranch
 


I might have partially jumped the gun and Mark is correct.  Using "-t 0" will turn off all colors and blinking but if you want color coding without blinking, there was a newer bug introduced in Raspberry Pi OS (buster) and a work around was added into Direwolf v1.6:

   https://github.com/wb2osz/direwolf/issues/270

--David
KI6ZHD


On 10/26/2020 04:28 PM, Mark Griffith via groups.io wrote:
And if you want it to run in the background without taking up a terminal:

/usr/local/bin/direwolf -t 0 -p > /var/tmp/dirwolf.log 2>&1 &

Then to stop direwolf, just do this command in any terminal:

pkill direwolf

This is all std Linux/Unix stuff.

Mark
KD0QYN



On Monday, October 26, 2020, 6:24:35 PM CDT, Mark Griffith via groups.io <mdgriffith2003@...> wrote:


Or, you can run Direwolf with some command line options:

/usr/local/bin/direwolf -t 0 -p

If you want a log of what was going on:

/usr/local/bin/direwolf -t 0 -p > /var/tmp/dirwolf.log 2>&1

Mark
KD0QYN


On Monday, October 26, 2020, 6:17:49 PM CDT, David Ranch <rpi4hamradio-groupsio@...> wrote:



Hello Mike,

Does anyone know why when I start Dire Wolf the text just keeps flashing On/Off/On/Off/On and it works fine but just keep flashing and driving me nuts…

Known issue with Raspbian Buster.  You need to upgrade to Direwolf 1.6 which requires you build it from source today (this is covered in the Direwolf User Guide).

--David
KI6ZHD


Mike Erstad
 

I've solved my crazy flashing problem:
I followed EtoTen's advice but, there still has been some changes since his posting in 2019...but the changes are right there in text during installation!
Thanks Again Members...I'm very weak in this area and appreciate all the help....
Mike


On Mon, Oct 26, 2020 at 6:49 PM David Ranch <rpi4hamradio-groupsio@...> wrote:

I might have partially jumped the gun and Mark is correct.  Using "-t 0" will turn off all colors and blinking but if you want color coding without blinking, there was a newer bug introduced in Raspberry Pi OS (buster) and a work around was added into Direwolf v1.6:

   https://github.com/wb2osz/direwolf/issues/270

--David
KI6ZHD


On 10/26/2020 04:28 PM, Mark Griffith via groups.io wrote:
And if you want it to run in the background without taking up a terminal:

/usr/local/bin/direwolf -t 0 -p > /var/tmp/dirwolf.log 2>&1 &

Then to stop direwolf, just do this command in any terminal:

pkill direwolf

This is all std Linux/Unix stuff.

Mark
KD0QYN



On Monday, October 26, 2020, 6:24:35 PM CDT, Mark Griffith via groups.io <mdgriffith2003@...> wrote:


Or, you can run Direwolf with some command line options:

/usr/local/bin/direwolf -t 0 -p

If you want a log of what was going on:

/usr/local/bin/direwolf -t 0 -p > /var/tmp/dirwolf.log 2>&1

Mark
KD0QYN


On Monday, October 26, 2020, 6:17:49 PM CDT, David Ranch <rpi4hamradio-groupsio@...> wrote:



Hello Mike,

Does anyone know why when I start Dire Wolf the text just keeps flashing On/Off/On/Off/On and it works fine but just keep flashing and driving me nuts…

Known issue with Raspbian Buster.  You need to upgrade to Direwolf 1.6 which requires you build it from source today (this is covered in the Direwolf User Guide).

--David
KI6ZHD