Topics

IC-7300 for ARDOP / WinLink with Pi4

Ken Crouse
 

Good afternoon, group - I recently picked up my first Pi (Raspberry Pi 4, Model B, 4GB) and have been working through several initial set-up videos.

One of my end goals is to be able to sit at my desk indoors and send e-mail on the HF bands using Pat and my Icom IC-7300 radio attached to my Pi 4 which are in the garage. Also would like to use Flrig, Fldigi to control the radio to move between ARDOP stations and frequencies.

I'm able to control the Pi using VNC server / connect and have Flrig / Fldigi installed and working somewhat well. I've been able to send messages using Telnet (essentially, just using WiFi). However, not able to get things working as I'd like and the error message that keeps coming back when I try to send via ARDOP reads as follows:

"2020/01/13 13:29:54 ARDOP TNC initialization failed: dial tcp [::1]:8515: connect: connection refused"

I've been using several of Jason Olham's KM4ACK videos (which have been quite helpful), but his video working through installation of ARDOP (  https://www.youtube.com/watch?v=BgqsTbxzR4E&t=238s  ) was made using a Yaesu model of radio and a Signalink sound card. The Icom IC-7300 has an internal sound card - there appears to be enough of a difference between Mr. Oleham's station and mine that I'm not able to get past the "  ./piardopc 8515 plughw;1,0 plughw:1,0 " command about 3:45 into the video.  I've gone back and made sure the 1 and 0 are correct.  I've also looked back through several other Settings recommendation for the radio and Fldigi but nothing that I do appears to be making any difference.

I posed this basic question to Mr. Oleham and he was kind enough to direct me to this group for possible assistance.

Thank you for your thoughts / recommendations.

P.S. I can get the Icom IC-7300 to communicate with my laptop computer and perform the tasks I'm trying to do with the Pi.

John Wiseman
 

I'm not clear form your description if you are running PAT on your local pc and trying to connect to ARDOP on the PI, or running both on the PI.

The message "2020/01/13 13:29:54 ARDOP TNC initialization failed: dial tcp [::1]:8515: connect: connection refused" shows that PAT is trying to connect to an IPv6 address ( ::1 is the IPv6 loopback address, same as  127.0.0.1 on IPv4). ARDOP doesn't support IPv6, so you need to use an IPv4 address wherever PAT is running, 127.0.0.1 for a local connection or the IP address of the PI for remote.

I suspect you have to configured  to connect to localhost. Normally on a PI localhost resolves to the IPv6 address ::1.

73,
John G8BPQ


shows that PAT is trying to connect to ARDOP on your local PC, not on the PI ( the [::1] is the IPv6 loopback address, similar to 127.0.0.1 on IPv4). You need to configure PAT to connect to the IP address of the PI.

On 14/01/2020 00:13, Ken Crouse wrote:
Good afternoon, group - I recently picked up my first Pi (Raspberry Pi 4, Model B, 4GB) and have been working through several initial set-up videos.

One of my end goals is to be able to sit at my desk indoors and send e-mail on the HF bands using Pat and my Icom IC-7300 radio attached to my Pi 4 which are in the garage. Also would like to use Flrig, Fldigi to control the radio to move between ARDOP stations and frequencies.

I'm able to control the Pi using VNC server / connect and have Flrig / Fldigi installed and working somewhat well. I've been able to send messages using Telnet (essentially, just using WiFi). However, not able to get things working as I'd like and the error message that keeps coming back when I try to send via ARDOP reads as follows:

"2020/01/13 13:29:54 ARDOP TNC initialization failed: dial tcp [::1]:8515: connect: connection refused"

I've been using several of Jason Olham's KM4ACK videos (which have been quite helpful), but his video working through installation of ARDOP (  https://www.youtube.com/watch?v=BgqsTbxzR4E&t=238s  ) was made using a Yaesu model of radio and a Signalink sound card. The Icom IC-7300 has an internal sound card - there appears to be enough of a difference between Mr. Oleham's station and mine that I'm not able to get past the "  ./piardopc 8515 plughw;1,0 plughw:1,0 " command about 3:45 into the video.  I've gone back and made sure the 1 and 0 are correct.  I've also looked back through several other Settings recommendation for the radio and Fldigi but nothing that I do appears to be making any difference.

I posed this basic question to Mr. Oleham and he was kind enough to direct me to this group for possible assistance.

Thank you for your thoughts / recommendations.

P.S. I can get the Icom IC-7300 to communicate with my laptop computer and perform the tasks I'm trying to do with the Pi.

N3RDR
 

You are describing the same use I want to give to my Pi but I’m not as far along as you. I got wrapped around trying to make it compact for my go bag. 

To your question, it seems to me it is failing on a TCP connection before transmission occurs. Is that correct? How fast does the error comes? I’ll admit a a total newbie on this but the syntax makes me think it is trying to use IPv6 instead of IPv4 to connect (or to configure ARDOP?). Is that a possibility?

Sent from my 📲

On Jan 13, 2020, at 7:14 PM, Ken Crouse <k6kec@...> wrote:

Good afternoon, group - I recently picked up my first Pi (Raspberry Pi 4, Model B, 4GB) and have been working through several initial set-up videos.

One of my end goals is to be able to sit at my desk indoors and send e-mail on the HF bands using Pat and my Icom IC-7300 radio attached to my Pi 4 which are in the garage. Also would like to use Flrig, Fldigi to control the radio to move between ARDOP stations and frequencies.

I'm able to control the Pi using VNC server / connect and have Flrig / Fldigi installed and working somewhat well. I've been able to send messages using Telnet (essentially, just using WiFi). However, not able to get things working as I'd like and the error message that keeps coming back when I try to send via ARDOP reads as follows:

"2020/01/13 13:29:54 ARDOP TNC initialization failed: dial tcp [::1]:8515: connect: connection refused"

I've been using several of Jason Olham's KM4ACK videos (which have been quite helpful), but his video working through installation of ARDOP (  https://www.youtube.com/watch?v=BgqsTbxzR4E&t=238s  ) was made using a Yaesu model of radio and a Signalink sound card. The Icom IC-7300 has an internal sound card - there appears to be enough of a difference between Mr. Oleham's station and mine that I'm not able to get past the "  ./piardopc 8515 plughw;1,0 plughw:1,0 " command about 3:45 into the video.  I've gone back and made sure the 1 and 0 are correct.  I've also looked back through several other Settings recommendation for the radio and Fldigi but nothing that I do appears to be making any difference.

I posed this basic question to Mr. Oleham and he was kind enough to direct me to this group for possible assistance.

Thank you for your thoughts / recommendations.

P.S. I can get the Icom IC-7300 to communicate with my laptop computer and perform the tasks I'm trying to do with the Pi.

Bo W4GHV
 

i too saw that message but just got rid of it tonight.
I think I fixed it by putting the correct hamlib info in the pat configure file and starting hamlib first.

--
73, Bo W4GHV since '54