Topics

Network Preferences Settings


David KD4E <dcolburn@...>
 

This is the Network Settings window.

I'm not sure if even filling these fields out correctly will work,
but it's worth a try.

Problem is that the field names are unfamiliar to me - do some
routers use different labels?

Thanks

rpi4 network
      preferences blank


Bill Buhler
 


Ok, I think your best bet would be to check the automatically configure blank fields. Then it should get the settings from your router.

Otherwise the regular IP address is put in the ipv4 field followed by a slash / and the number of bits in the subnet mask, normally/24 is correct on a home network. 

Router is the same as the gateway field. For most networks there isn't a ipv6 address to issue. 

Dns servers are the last options. 

I hope that helps. 

73 
af7sj


-------- Original message --------
From: David KD4E <dcolburn@...>
Date: 11/5/19 20:23 (GMT-07:00)
To: RaspberryPi-4-HamRadio@groups.io
Subject: [RaspberryPi-4-HamRadio] Network Preferences Settings

This is the Network Settings window.

I'm not sure if even filling these fields out correctly will work,
but it's worth a try.

Problem is that the field names are unfamiliar to me - do some
routers use different labels?

Thanks



Vince A
 

David
It's not a label
Do you have access to your router's admin? Have you ever logged to your router where you connect to the net?
Or do you have a windows machine? If so open the command prompt "cmd" and type without quotes "ipcong" with the black dos looking screen...
For example my router's address is 192.168.0.1. you will see that from the ipconfig command an output of a few lines.  Router means it would be the Default Gateway. Your mileage may very.  Type that set of numbers into the "Router" part and for dns use google if you in the USA of 8.8.8.8 and for dns search use the default gateway again and then apply.  Vince 73 KD7TWW

On Nov 5 2019, at 8:23 pm, David KD4E via Groups.Io <dcolburn@...> wrote:
This is the Network Settings window.

I'm not sure if even filling these fields out correctly will work,
but it's worth a try.

Problem is that the field names are unfamiliar to me - do some
routers use different labels?

Thanks


Sent from Mailspring


chuck gelm <rpi4ham@...>
 

On 11/6/19 2:43 AM, Vince A wrote:
"ipcong"
ipconfig


Vince A
 

Chuck
I am blind in one eye. Forgive me. Thanks 73 Vince KD7TWW

On Nov 6 2019, at 2:58 am, chuck gelm via Groups.Io <rpi4ham@...> wrote:
On 11/6/19 2:43 AM, Vince A wrote:
"ipcong"
ipconfig


Sent from Mailspring


Brian Webster
 

If when you start or reboot your Pi you go in to terminal windows and type the command KillHotspot (case sensitive as all Linux stuff is) then it will kill the hot spot and allow the automatic settings to work on the wired Ethernet port properly. I have not seen a post on how to get the wireless to work as a regular client radio yet. I drove myself nuts trying to get the Ethernet port to work properly not realizing that keeping the hotspot enabled also affected the network settings and functionality of the wired port as well.

 

Thank You,

Brian N2KGC

 

From: RaspberryPi-4-HamRadio@groups.io [mailto:RaspberryPi-4-HamRadio@groups.io] On Behalf Of Vince A
Sent: Wednesday, November 06, 2019 6:44 AM
To: RaspberryPi-4-HamRadio@groups.io
Subject: Re: [RaspberryPi-4-HamRadio] Network Preferences Settings

 

Chuck

I am blind in one eye. Forgive me. Thanks 73 Vince KD7TWW

 

On Nov 6 2019, at 2:58 am, chuck gelm via Groups.Io <rpi4ham@...> wrote:

On 11/6/19 2:43 AM, Vince A wrote:

"ipcong"

ipconfig

 

Sent from Mailspring


DavidC KD4E
 

Automatic fill doesn't work.

I tried turning off OpenDNS as the DNS servers & used the default - no change -
networking is still double-x'd out in red.

I used the Gateway field values 104.xxx.xx.xxx for Router.

The IVp4 address I used is 192.168.1.1/24

I left "DNS Search" blank & "Automatically configure empty options" checked.

It seems that Internet Preferences is simply not responding.

ipconfig - a shows "inet 10.x.x.5" rather than the expected 192.xxx.x.x for wlan0

Also, "flags=4163<UP, BROADCAST,RUNNING,MULTICAST> mtu 1500"

I seem to recall the mtu setting creating a connection problem for a device
some time in the distant past - no idea if that's relevant here - and no idea
how to change it in Raspian.

WDYT ... David kd4e


Ok, I think your best bet would be to check the automatically configure blank fields. Then it should get the settings from your router.

Otherwise the regular IP address is put in the ipv4 field followed by a slash / and the number of bits in the subnet mask, normally/24 is correct on a home network. 

Router is the same as the gateway field. For most networks there isn't a ipv6 address to issue. 

Dns servers are the last options. 

I hope that helps. 

73 
af7sj


-------- Original message --------
From: David KD4E <dcolburn@...>
Date: 11/5/19 20:23 (GMT-07:00)
Subject: [RaspberryPi-4-HamRadio] Network Preferences Settings

This is the Network Settings window.

I'm not sure if even filling these fields out correctly will work,
but it's worth a try.

Problem is that the field names are unfamiliar to me - do some
routers use different labels?

Thanks


_._,_._,_



Dave Slotter, W3DJS
 

Hi Brian,

Thank you for helping to spread the instructions to use "KillHotspot" from the terminal...

I installed the auto-hotspot capability based on some information from Jason, KM4ACK, who has an excellent YouTube channel about the Raspberry Pi with Ham Radio. In fact, his channel gave me ideas on some software to include that I would have skipped over for lack of knowledge about...

If you run "KillHotspot" and connect the Raspberry Pi's WiFi (for those so equipped) to your home wireless router, then the auto-hotspot software will never activate.

I'll point you to the website with the instructions I used, in case you want to manually "undo" the auto-hotspot changes: https://www.raspberryconnect.com/projects/65-raspberrypi-hotspot-accesspoints/157-raspberry-pi-auto-wifi-hotspot-switch-internet


Good luck and 73,

--
- Dave
  W3DJS


David KD4E <dcolburn@...>
 

I found this ...

--------------------------------------------------------------------------------------------
https://jamesachambers.com/raspberry-pi-ubuntu-server-18-04-2-installation-guide/
Wireless Fix

The current non-free Raspberry Pi firmware had the wrong bootflags3 for quite a
while for the Raspberry Pi 4 and these firmware files are definitely out there.
Here is a one liner I wrote to replace the Raspberry Pi 3 boot flags in this driver
with the Raspberry Pi 4 one:

"sudo sed -i "s:0x48200100:0x44200100:g" /lib/firmware/brcm/brcmfmac43455-sdio.txt"

Restart the system afterward.
--------------------------------------------------------------------------------------------

This finally caused the wifi to "associate" with my router.

However, when I open Chromium and try to visit a Web site it complains ...

"This site can't be reached"

What's the likely cause & cure for this, please?

The router is working fine on this laptop and other devices here.

Thanks, David KD4E


Mark Griffith
 

Dave,

There is nothing special that needs to be done to the Raspbian OS to get it to work with a WiFi network.  Everything is already there, no need to edit boot config files, anything.  There is also no need to edit different bootflags for a Raspberry Pi 3 or a Pi 4.  I have the exact same image that I've built that works on all Raspberry Pi hardware that I've tested, which is the Pi 3, Pi 3B+ and Pi 4.

It gets really dangerous when you start playing with the system config files because they can change within the same software release and without any notice.  If you do, anytime you do an apt-get upgrade or update, something may change and you're suddenly hung.

I have no idea what you've done with the routing tables or other OS config stuff so it could be something else.  If I were you, I would start with a clean install of the latest Buster image and refrain from making too many changes.  Less is good.

This is all pretty easy if you can stick to "the rules".

For more info, google Raspbian "This site can't be reached".  You'll get more help than you will here.

Hope this helps.

Mark
KD0QYN



On Thursday, November 7, 2019, 7:59:09 PM CST, David KD4E <dcolburn@...> wrote:


I found this ...

--------------------------------------------------------------------------------------------
https://jamesachambers.com/raspberry-pi-ubuntu-server-18-04-2-installation-guide/
Wireless Fix

The current non-free Raspberry Pi firmware had the wrong bootflags3 for
quite a
while for the Raspberry Pi 4 and these firmware files are definitely out
there.
Here is a one liner I wrote to replace the Raspberry Pi 3 boot flags in
this driver
with the Raspberry Pi 4 one:

"sudo sed -i "s:0x48200100:0x44200100:g"
/lib/firmware/brcm/brcmfmac43455-sdio.txt"

Restart the system afterward.
--------------------------------------------------------------------------------------------

This finally caused the wifi to "associate" with my router.

However, when I open Chromium and try to visit a Web site it complains ...

"This site can't be reached"

What's the likely cause & cure for this, please?

The router is working fine on this laptop and other devices here.

Thanks, David KD4E





David KD4E <dcolburn@...>
 

A Search (duckduckgo because the google search engine manipulates results)
on Raspbian "This site can't be reached" brings up the usual argumentative,
convoluted, and skipped steps clutter common to Linux discussion sites
(I've been using Linux for 20 years), e.g.
"https://raspberrypi.stackexchange.com/questions/60091/chromium-cant-reach-site-when-i-am-connected-to-my-wifi-network"

I'm not using a SD card with the plain vanilla Buster Raspian but rather
one bundled with Ham apps.

BTW: Wifi works on the plain vanilla load - but I had some trouble loading
Ham apps with it - which is why I tried the bundled one.

QUESTION: What is the supported wifi/wlan0 driver name for the RPi4, please?

I tried "bcm2711" and it flags that as Unsupported.

Thanks, David KD4E

> There is nothing special that needs to be done to the Raspbian OS to > get it to work with a WiFi network. Everything is already there, no > need to edit boot config files, anything. There is also no need to > edit different bootflags for a Raspberry Pi 3 or a Pi 4. I have the > exact same image that I've built that works on all Raspberry Pi > hardware that I've tested, which is the Pi 3, Pi 3B+ and Pi 4. > > It gets really dangerous when you start playing with the system > config files because they can change within the same software > release and without any notice. If you do, anytime you do an apt-get > upgrade or update, something may change and you're suddenly hung. > > I have no idea what you've done with the routing tables or other OS > config stuff so it could be something else. If I were you, I would > start with a clean install of the latest Buster image and refrain > from making too many changes. Less is good. > > This is all pretty easy if you can stick to "the rules". > > For more info, google Raspbian "This site can't be reached". You'll > get more help than you will here. > > Hope this helps. > > Mark KD0QYN


David KD4E <dcolburn@...>
 

It required multiple steps but wifi/wlan0 is now working
with the W3DJS Raspberry Pi Ham Radio Image v2.0
loaded on my RPi 4B.

I'll be happy to share the steps - if anyone else faces the
same challenge.

David KD4E


Stan
 

Please, please, please upload your steps. I have been fighting it for days.

 

Stan Sjol

W0KP

 

Sent from Mail for Windows 10

 

From: David KD4E
Sent: Friday, November 8, 2019 12:00 AM
To: RaspberryPi-4-HamRadio@groups.io
Subject: Re: [RaspberryPi-4-HamRadio] Network Preferences Settings

 

It required multiple steps but wifi/wlan0 is now working

with the W3DJS Raspberry Pi Ham Radio Image v2.0

loaded on my RPi 4B.

 

I'll be happy to share the steps - if anyone else faces the

same challenge.

 

David KD4E

 

 

 

 


David KD4E <dcolburn@...>
 

I stuffed everything into this text file ...

http://nevils-station.com/stuff/raspberrypi/rpi4b-wififix1.txt

I invite helpful/thoughtful, scrutiny, suggestions, & corrections.

I've also posted it to a couple of Raspberry Pi Facebook groups
to invite them to take a look - hopefully to improve it.

All I know is that nothing else worked & I hope it (as-is or modified)
can help others.

(I've been using Linux for 20 years and started with computers in
the late-'70s - but haven't invested this much time and detail in
chasing a problem like this for a while ... it was a good brain exercise!)

David KD4E

Please, please, please upload your steps. I have been fighting it for days.

 

Stan Sjol

W0KP

 

Sent from Mail for Windows 10

 

From: David KD4E
Sent: Friday, November 8, 2019 12:00 AM
To: RaspberryPi-4-HamRadio@groups.io
Subject: Re: [RaspberryPi-4-HamRadio] Network Preferences Settings

 

It required multiple steps but wifi/wlan0 is now working

with the W3DJS Raspberry Pi Ham Radio Image v2.0

loaded on my RPi 4B.

 

I'll be happy to share the steps - if anyone else faces the

same challenge.

 

David KD4E




Mark_VK3EME
 

Please share as I have tried without success, maybe holding my tongue in the wrong side of my mouth 🤣


Mark_VK3EME
 

Thank you for the efforts, it is very much appreciated by many of us.