TNC-Pi/Raspberry Pi 3


Larrie
 

I recently switched out my Raspberry Pi 2 hooked to the 7 inch touch screen for a Raspberry Pi 3.  All seems to be working but I am having trouble getting the Pi 3 to talk to the TNC-Pi.  The TNC-Pi was working fine with the Raspberry Pi 2 and Xastir.  When running Xastir, selecting interface control menu option and adding a KISS mode TNC to the /dev/ttyAMA0 port, results in it always being "down".  I have made all of the changes to the cmdline.txt, config.txt, and the hciattach.service files as listed in the TNC-Pi instructions for the Raspberry Pi3 (and doubled and tripled checked that all changes are correct).  The TNC is working, as the yellow LED lights when incoming packets are detected.  Any ideas on how I might trouble shoot this?
--
Larrie
AF7NU


Stacy Olivas
 

On 03/21/2018 08:54 PM, Larrie wrote:
I recently switched out my Raspberry Pi 2 hooked to the 7 inch touch screen for a Raspberry Pi 3.  All seems to be working but I am having trouble getting the Pi 3 to talk to the TNC-Pi.  The TNC-Pi was working fine with the Raspberry Pi 2 and Xastir.  When running Xastir, selecting interface control menu option and adding a KISS mode TNC to the /dev/ttyAMA0 port, results in it always being "down".  I have made all of the changes to the cmdline.txt, config.txt, and the hciattach.service files as listed in the TNC-Pi instructions for the Raspberry Pi3 (and doubled and tripled checked that all changes are correct).  The TNC is working, as the yellow LED lights when incoming packets are detected.  Any ideas on how I might trouble shoot this?

Larrie,
Take a look at the /dev directory and check to make sure that the /dev/ttyAMA0 port is correct.  It is possible that the device is being called something else.  Check dmesg output and see if the device is detected.  (I don't have a TNC-Pi to be able to help you more on this part)

If the device exists, check to make sure that the user you are running Xastir under has permissions to read and write to this device.

-Stacy
KG7QIN

--
Larrie
AF7NU




John G8BPQ
 

Larrie,

I f you are using a reasonably recent Raspian image I suggest you ignore all the instructions about config changes (undo any you've made), and use raspi-config Interfacing Options/Serial menu to disable login shell and enable serial port hardware. Then use /dev/serial0 instead of /dev/ttyAMA0

73, John G8BPQ

On 22/03/2018 03:54, Larrie wrote:
I recently switched out my Raspberry Pi 2 hooked to the 7 inch touch screen for a Raspberry Pi 3.  All seems to be working but I am having trouble getting the Pi 3 to talk to the TNC-Pi.  The TNC-Pi was working fine with the Raspberry Pi 2 and Xastir.  When running Xastir, selecting interface control menu option and adding a KISS mode TNC to the /dev/ttyAMA0 port, results in it always being "down".  I have made all of the changes to the cmdline.txt, config.txt, and the hciattach.service files as listed in the TNC-Pi instructions for the Raspberry Pi3 (and doubled and tripled checked that all changes are correct).  The TNC is working, as the yellow LED lights when incoming packets are detected.  Any ideas on how I might trouble shoot this?
--
Larrie
AF7NU


John Mathieson
 

Along with what others have written, the  Pi 3 made some changes from the Pi 2.  Specifically, ttyAMA0 is used by bluetooth. So take a look at John Hansen's setup  page for the TNC-Pi to switch the serial port back to tty/AMA0. 


Jim Darrough
 

I am using Raspbian Stretch with the Pi-Tnc from Coastal Chipworks. I accidentally (stupidly) unpowered the system when Xastir was writing to the SD and corrupted the thing. After reinstall, no transmit. Found out that I had to select KISS TNC rather than just TNC in Xastir Interface and I THINK it works now.

YMMV

73  Jim KI7AY


JJ
 

Yes Jim, it has to be kiss TNC....

I, for one, actually like the ability to use a "regular" TNC within xastir, as I have a kantronics MT-1200, and it's kiss mode is NO GOOD..it inserts control characters when in kiss mode..kantronics suggested new firmware, sent it to me, I applied it, and still same problem so it's shelved for now...

On 2019-02-05 12:30 a.m., Jim Darrough wrote:
I am using Raspbian Stretch with the Pi-Tnc from Coastal Chipworks. I accidentally (stupidly) unpowered the system when Xastir was writing to the SD and corrupted the thing. After reinstall, no transmit. Found out that I had to select KISS TNC rather than just TNC in Xastir Interface and I THINK it works now.

YMMV

73  Jim KI7AY


dkc2030@...
 

Go back and redownload the config document for TNC-Pi.  I found a major change between revisions of the OS that was resolved and documented in the instructions.  It had to do with the overlay command in config.txt