Autostart Xastir on boot


ramsatphones@...
 

Can anyone recommend the best way to make Xastir automatically run when the raspberry Pi starts up or reboots? I have been using the .config/autostart/xastir.desktop method. Sometimes it works, sometimes not


what is the best way to make xastir autostart everytime?


woz VK4LEG


pmooney22@...
 

Try using a script:

sudo nano autostart.run

#!/bin/bash
# script to autostart xastir
echo "starting Xastir"
sudo /path/to/Xastir &

save , then make executable 

sudo chmod +x autostart.run

To test type: ./autostart.run

Then: sudo nano /etc/rc.local

add:  /path/to/autostart.run 

Then reboot.

Or if using Arch Linux:

sudo systemctl enable xastir.service


HTH

Paul, 5B8BA


Ray Wells
 

xastir won't start if ~/.xastir/xastir.pid exists.

If xastir is not shut down correctly xastir.pid is not deleted hence, xastir won't restart.
Modify the script to delete xastir.pid


On 26/04/14 01:52, pmooney22@... wrote:
 
Try using a script:

sudo nano autostart.run

##!/bin/bash
## script to autostart xastir
#echo "starting Xastir"
#sudo /path/to/Xastir &

Script modified to kill xastir.pid

#!/bin/bash
#kill xastir.pid
cd ~/.xastir
[[ -f "xastir.pid" ]] && rm "xastir.pid"
# script to autostart xastir
echo "starting Xastir"
sudo /path/to/Xastir &

Ray vk2tv


save , then make executable 

sudo chmod +x autostart.run

To test type: ./autostart.run

Then: sudo nano /etc/rc.local

add:  /path/to/autostart.run 

Then reboot.

Or if using Arch Linux:

sudo systemctl enable xastir.service


HTH

Paul, 5B8BA


ramsatphones@...
 

Hi
When I read the documentation its says don't run xastir as root. Wouldn't the example here runs as the root user by using sudo?

My pi boots into the startx gui. I want xastir to start on boot but after startx gui is up. Otherwise xastir starts but runs in the background. I have to kill the service and restart it to make visible on the desktop.

thanks

Woz