Re: Problem with TNC-PI96K


 

The command is:

chmod +x pitnc_getparams
chmod +x pitnc_setparams

It is adding the "executable" bit to the file permissions for pitnc_getparams and pitnc_setparams. You are missing the "x".

Bob AF9W



From: Don Poaps
Sent: Tuesday, February 19, 8:35 AM
Subject: Re: [RaspberryPi-4-HamRadio] Problem with TNC-PI96K
To: raspberrypi-4-hamradio@groups.io


Not knowing what I'm doing with the PI and TNC-PI. If Windoze I know what to do. Here my errors


pi@HamradioPI:~ $ cd /home/pi
pi@HamradioPI:~ $ chmod +pitnc_getparams
chmod: missing operand after ‘+pitnc_getparams’
Try 'chmod --help' for more information.
pi@HamradioPI:~ $ chmod +pitnc_setparams
chmod: missing operand after ‘+pitnc_setparams’
Try 'chmod --help' for more information.
pi@HamradioPI:~ $

It's probably something simple but I don't have a clue.

later

73







Don Poaps
New Westminster, BC
VA7DGP DATA
VA7QU   VOICE


Winlink: va7qu@...
Subject://wl2k           



                    
  




 


On Sun, Feb 17, 2019 at 5:46 PM Bob AF9W <af9w@...> wrote:
I am trying to get a TNC-PI96K running with PAT to create a 9600 baud Winlink. When I first installed this I could run .pitnc_getparams and pitnc_setparams and I would get results.  I turned off the Pi to try 1200baud, moved the JP1 jumper, and rebooted the Pi.  Now when I try to run ./pitnc_getparams I get an error:

pi@af9w-pat:~/tnc-x $ ./pitnc_getparams 0 0
pitnc_getparams Version 0.0.0.5
 
Using Serial port /dev/ttyAMA0
tty_speed: tcgetattr: Inappropriate ioctl for device

Any ideas on how to get past this or even find out what the problem is?  Is this the correct forum to ask?

Bob AF9W



--
Bob AF9W

Join RaspberryPi-4-HamRadio@groups.io to automatically receive all group messages.