Re: Qt5 Libraries on RPi2

David Ranch <dranch@...>

Hey Mitch,

If you want the newest, greatest of packages, Raspbian Stable aka Debian Stable aka Stretch is not for you.  You should look using Debian (not Raspbian) Testing which will have newer packages which will still be somewhat older or Debian Unstable which will usually have the newest everything (but might have bugs, etc).  Btw, where are ways to pull some of those new packages into the Stable distros but sometimes the dependencies get very complex.

You also might consider looking at Ubuntu 18.04 for the Raspberry Pi which is generally more bleeding edge that Debian Stable.


On 09/01/2018 08:36 AM, Mitch wrote:
Folks, if anyone does programming using Qt version 5 (Qt5), you may know how hard it is to get up to date libraries for the RPi2.  Raspbian Stretch is only up to version 5.7.1 at this point in the package repository.  The current Qt5 version is 5.11.1.  This means the tedium of compiling your own directly on the Pi or by using a cross-compiler.  I find setting up the cross-complier worse than just letting the Pi compile them, so I have a way to get that done.

I have successfully compiled the 5.10.1 libraries (not all libs, but the most important ones for a Pi) and I would be happy to share my notes if you would like them.  I used the same notes to successfully compile 5.9.6 as well.  5.11.1 has some issue in the configure script whereby it bombs out during it's build of the Makefile.

Email me if you would like a copy.


Mitch, AB4MW

Join to automatically receive all group messages.