Re: apt-get install libncursesw5-dev not found


Laurent R.
 

Hi all

After updating my distribution, I have an error on the installation of AX25 TOOLS.

See my selection:


Making install in man
make[1]: Entering directory '/usr/local/src/ax25/linuxax25-master/ax25tools/man'
make[2]: Entering directory '/usr/local/src/ax25/linuxax25-master/ax25tools/man'
make[2]: Nothing to be done for 'install-exec-am'.
/bin/mkdir -p '/usr/local/share/man/man1'
/usr/bin/install -c -m 644 axgetput.1 dmascc_cfg.1 mheard.1 '/usr/local/share/man/man1'
/bin/mkdir -p '/usr/local/share/man/man4'
/usr/bin/install -c -m 644 ax25.4 netrom.4 rose.4 '/usr/local/share/man/man4'
/bin/mkdir -p '/usr/local/share/man/man5'
/bin/mkdir: cannot create directory ‘/usr/local/share/man/man5’: File exists
Makefile:422: recipe for target 'install-man5' failed
make[2]: *** [install-man5] Error 1
make[2]: Leaving directory '/usr/local/src/ax25/linuxax25-master/ax25tools/man'
Makefile:600: recipe for target 'install-am' failed
make[1]: *** [install-am] Error 2
make[1]: Leaving directory '/usr/local/src/ax25/linuxax25-master/ax25tools/man'
Makefile:370: recipe for target 'install-recursive' failed
make: *** [install-recursive] Error 1
AX.25 tools Install error - See toolserror.txt

root@Raspi-F4BWT:/usr/local/src/ax25# uname -a
Linux Raspi-F4BWT 4.14.67-v7+ #1139 SMP Wed Aug 29 15:17:05 BST 2018 armv7l GNU/Linux

root@Raspi-F4BWT:/usr/local/src/ax25# lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 8.0 (jessie)
Release: 8.0
Codename: jessie

Who can help me finalize the installation of the AX25?

Thanks for your answer.

73 QRO Laurent F4BWT

----- Mail original -----
De: "Mark J Culross" <kd5rxt@arrl.net>
À: RaspberryPi-4-HamRadio@groups.io
Envoyé: Mercredi 29 Août 2018 14:55:38
Objet: Re: [RaspberryPi-4-HamRadio] apt-get install libncursesw5-dev not found

Bernard (F6BVP):


If you're adventurous & there's not something else keeping you from updating, you could get yours fully updated in place with the following commands:


sudo apt-get update && sudo apt-get -y dist-upgrade [ENTER]


Good luck & have fun !!


Mark J Culross
KD5RXT

On Wed, Aug 29, 2018 at 5:54 AM, f6bvp
<f6bvp@free.fr> wrote:

Hi All,

In tried to install new ve7fet/linuxax25] ax25apps-2.0.0 on raspbian.
Lee VE7FET wrote on https://github.com/ve7fet/linuxax25/releases/tag/ax25apps-2.0.0


------
This release patches our source with nearly all the changes in the upstream official source from 2015-2017, inclusive.

NOTE: As of this version, ncursesw libraries (ie libncursesw5-dev) are required to compile the call binary. This is due to the addition of UTF-8 support.

Also, a reminder, this version of ax25ipd is NOT the same as the upstream official source. This version supports dynamic hosts/DNS and the ability to route packets over axip links that are not from the gateway callsign. That said, we've incorporated all the upstream patches from the official source, where possible.

With all the significant changes, we'll release this as version 2.0.0, as it may break compatibility with previous versions.
-----------------
My distro is two years old and not the last stretch raspbian (wheezy probably ???).
Does anyone know if package libncursesw5-dev is available for stretch raspbian distro ?

Bernard, f6bvp

Join RaspberryPi-4-HamRadio@groups.io to automatically receive all group messages.