Re: apt-get install libncursesw5-dev not found


Mark J Culross
 

Bernard (F6BVP):

If you're adventurous & there's not something else keeping you from updating, you could get yours fully updated in place with the following commands:

   sudo apt-get update && sudo apt-get -y dist-upgrade [ENTER]

Good luck & have fun !!

Mark J Culross
KD5RXT


On Wed, Aug 29, 2018 at 5:54 AM, f6bvp
<f6bvp@...> wrote:
Hi All,

In tried to install new ve7fet/linuxax25] ax25apps-2.0.0 on raspbian.
Lee VE7FET wrote on https://github.com/ve7fet/linuxax25/releases/tag/ax25apps-2.0.0

------
This release patches our source with nearly all the changes in the upstream official source from 2015-2017, inclusive.

NOTE: As of this version, ncursesw libraries (ie libncursesw5-dev) are required to compile the call binary. This is due to the addition of UTF-8 support.

Also, a reminder, this version of ax25ipd is NOT the same as the upstream official source. This version supports dynamic hosts/DNS and the ability to route packets over axip links that are not from the gateway callsign. That said, we've incorporated all the upstream patches from the official source, where possible.

With all the significant changes, we'll release this as version 2.0.0, as it may break compatibility with previous versions.
-----------------
My distro is two years old and not the last stretch raspbian (wheezy probably ???).
Does anyone know if package libncursesw5-dev is available for stretch raspbian distro ?

Bernard, f6bvp


Join RaspberryPi-4-HamRadio@groups.io to automatically receive all group messages.