Re: Install problem w/putty


David Lane
 

So, first question is why are you installing putty? SSH is already installed and the default secure shell.

The error is a problem with the GTK toolkit and a quick Google search shows: https://bugzilla.redhat.com/show_bug.cgi?id=1905268

And a couple of upstream fixes on the Red Hat stream and a fix for it with an X hack. It seems to be a common error for anything using GTK. Not sure there is an easy fix, based on this conversation: https://groups.google.com/g/wx-users/c/VRO0OORxJno

Did you do an update/upgrade before you installed putty? Might want to do that first. 

$ sudo apt-get update
$ sudo apt-get upgrade

May not fix the problem though. Stick with SSH. 

David

---
David A. Lane, KG4GIY
EC/RO Prince William County ARES®/RACES
+1.703.628.3868
http://www.pwcares.org/
IM: kg4giy

On Nov 22, 2021, at 17:03, John <radio@...> wrote:

After installing putty, when I try starting it this appears:

pi@hampi:~ $ sudo putty
 
(putty:2651): Gtk-CRITICAL **: 15:44:33.286: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar
 
(putty:2651): Gtk-CRITICAL **: 15:44:33.298: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar
 
(putty:2651): Gtk-CRITICAL **: 15:44:33.307: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar
pi@hampi:~ $ 
------------------------------------

What does this mean?  How can I fix it?

John, W0GN

Join RaspberryPi-4-HamRadio@groups.io to automatically receive all group messages.