Re: 64bit testing


Steve WB3LGC
 

I have loaded wsjtx_2.4.0...  It runs fine. 

I can't get Audio {C-Media does not show either wsjt-x or Pulse} to work... {works fine 32 bit}

pi@rasp64:~ $ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port  <--- GPS
Bus 001 Device 007: ID 0d8c:0014 C-Media Electronics, Inc. Audio Adapter (Unitek Y-247A)  <--- AUDIO
Bus 001 Device 006: ID 0403:6001 Future Technology Devices International, Ltd FT232 Serial (UART) IC  <--- CAT
Bus 001 Device 005: ID 046d:c52b Logitech, Inc. Unifying Receiver  <--- keyboard/mouse
Bus 001 Device 003: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

any ideas?? I have tried with/without Pulse Audio... 
The only thing I have NOT tried is to swap the USB audio module.  BUT, it shows (see above).
All I have changed is 32 bit to 64 bit...   (all 64 bit packages are up to date)
AND I thought I had audio working with Raspian.  I have also tried ubuntu 64 bit...

BAP: BTW, conky does not show temp.   I have added temp to the status bar.

73, steve WB3LGC

On 5/22/21 2:50 PM, David Ranch wrote:

Pre-built ARM64 packages of Raspberry Pi OS is posted on the WSJT-X website:

   https://physics.princeton.edu/pulsar/k1jt/wsjtx_2.3.1_arm64.deb
   https://physics.princeton.edu/pulsar/k1jt/wsjtx_2.4.0-rc4_arm64.deb


An interesting write up on deep decode times on various Raspberry Pi hardware versions can be seen here but all results there are 32bit only:

   https://wsjtx.groups.io/g/main/topic/performance_test_of_raspberry/76022856

--David
KI6ZHD


On 05/22/2021 10:37 AM, N5XMT wrote:
Be curious to see back to back tests of the 32 bit build and the 64 bit for any differences in speed on the FT8.  The libraries you had to download to make the compile scripts work were all 32 bit.
On May 22, 2021, at 00:33, "Kelly Keeton via groups.io" <yahoo.com@groups.io target=_blank>kellykeeton=yahoo.com@groups.io> wrote:

I downloaded the latest May2021 raspberry64bOS (still in beta) and ran the script things seem to work for the most part

 

FL-suite needed a manual install of

> libfltk1.3-dev Libjpeg-dev libxcursor-dev libfontconfig1-dev libxinerama-dev libxft-dev libsamplerate-dev libsndfile1-dev libportaudio19-dev 

to run the automated compile scripts, after added things seem ok!


qsstv has a hamlib-dev problem and JS8 package has issues it appears.

anyway I went down the path for better performance with FT8

Join RaspberryPi-4-HamRadio@groups.io to automatically receive all group messages.