PiTNC9k6 and BTECH UV25X4 mobile


N5XMT
 

I'm about  to toss it all in the trash.  
Xmit perfect.  Everyone hears me, I see myself coming thru APRSDroid on my phone when I send my position from Xastir.  I can hear very cleanly the local digi after my TX terminates.  when I hear it, the DCD LED comes on like its receiving the data properly, but nothing at all comes back thru into Xastir, not even an ACK.
Volume on the BTECH UV25X4 is about 70%.  RX level on the PITNC9k6 is set to 200, after several receives it sets anywhere between 72 and 127 in the rx(Actual) param.  Using a NEW cable from the radio headset (4 conn 3.5mm, spk, mic, PTT and gnd.  
I have used the V11 firmware for the Teensy3.6, the V11 firmware, I have used Kissattach and set it to AX25 TNC, used i2ckiss and symlinked it, and used KISS TNC over serial direct to /dev/serial0.  There has to be something I am doing wrong or missing somewhere.
My Current Params:

pi@hampi:~/pitnc ./pitnc_getparams 1 30.1
pitnc_getparams Version 0.0.0.5
 
   TNC Software Version           6
01 TXDelay - Zero means use ADC  40
02 Persistance                   63
03 Slottime (in 10 mS)           20
04 TXTail                        30
05 Full Duplex - Not used         0
06 Our Channel (Hex)             00
07 I2C Address (0 = async) Hex   00
08 Mode Speed                  1200
09 RX Level (Config)            200
10 TX Level                     255
11 RX Level (Actual)             72
13 Centre Freq                 1700
8 6 28 3f 14 1e 0 0 0 c c8 ff 48 aa ca c0 sum 0

Any and all help appreciated

Join RaspberryPi-4-HamRadio@groups.io to automatically receive all group messages.