Unable to read Mfg ID, Status = 1


John Burkhardt
 

Had a frustrating day, trying to get past an error message when programming QSI Q1 decoders. I'm working on a swap for 2 customers, the first want his locos freed of OEM QSI Q1 decoders and replaced by TSU2 while the second is prepared to take them over and for me to fit into his analogue locos. In this process I've found contradictory behaviour/failures and frankly I'm stumped.

Trying to keep two customers satisfied at the same time did, to some extent, prevent me from following the safe route resulting in some locos stripped and storing the salvaged QSI and first completing the TSU replacement, but every one of these locos was test run on DCC before stripping to ensure that the loco operates as expected with the QSI decoder still fitted.  

To complicate matters, the first loco stripped, a Walthers P2K E8 has a decoder fitted with an upgrade CPU sporting the hologram label, which was requested by the new owner for self fitment in his loco. Of course a few days later he returned it stating that it is not working. I connected it up to my ESU test stand connected to the QSI programmer and could read the decoder in Q1 Upgrade to confirm that it was indeed loaded with project 136 E8/9 (Life Like) Diesel, and when switching to QProgrammer I could reprogram the address and run the motor, but still got no sound. Tested the speaker, reloaded the project, but no sound – assuming the amp is blown for some reason or other. The successful reading of the decoder and reloading the project as well as changing the address would suggest that programmer and software is functioning as it should – it has not seen a change/upgrade since years ago I’ve upgraded Q1s, Revolutions and Titans successfully.

Then I took a set of decoders that came out of a brace of P2K GP9 with the original chip and connected it up to the test stand and tried to read the decoder info in Q1 Upgrade and the counter moved up to 40% and then bombed out with the subject line message. I still have some spare upgrade chips so inserted one in the decoder and tried to read that, all bombed out with above error message after 40%. Remove the chip from that decoder fitted it into the E8 decoder and got same result!?  

It feels like these chips are getting or have been bricked – I quite accept that I might be doing something wrong, but I’m sure I’ve not deviated from the method I had success with in past?

--
John Burkhardt
South Africa
Where the sun always shines
and Steam still reigns!


Greg Elmassian
 

Strange / unlikely that all your Q1 decoders quit.

the 40% is misleading, it could not read the decoder at all.

I've never run Q1 upgrade (just Q2) does it have the facility to read the QSI programmer firmware version, and base current like the Q2 software can?

Greg


John Burkhardt
 

Greg,

 

I can use Q2 but thought that was only for TITAN projects, will try tomorrow afternoon too late now.

 

Thanks and warm regards,

 

John Burkhardt

South Africa

where the sun always shines,

and steam still reigns!

 

 

 

 

From: QSIndustries@groups.io [mailto:QSIndustries@groups.io] On Behalf Of Greg Elmassian
Sent: 05 May 2021 10:20 PM
To: QSIndustries@groups.io
Subject: Re: [QSIndustries] Unable to read Mfg ID, Status = 1

 

Strange / unlikely that all your Q1 decoders quit.

the 40% is misleading, it could not read the decoder at all.

I've never run Q1 upgrade (just Q2) does it have the facility to read the QSI programmer firmware version, and base current like the Q2 software can?

Greg


--
John Burkhardt
South Africa
Where the sun always shines
and Steam still reigns!


Greg Elmassian
 
Edited

Actually Q2 works on the revolution and other Q2 decoders and the Titan (Q3).

But I was asking if the QSI programmer diagnostics are in the Q1 software, thus verifying that the programmer is/is not the issue, as opposed to the decoders.

You right click on the top left of the windows title bar and a new menu pops up that lets you verify the programmer..

Procedure outlined on this page: https://elmassian.com/index.php/dcc/specific-manufacturers/qsi-equipment/qsi-programmer-hw-a-sw

Update: I found the Q1Upgrade program, and it indeed has the programmer diagnostic menu just like I described.

Use this to validate the connection to the programmer first is my best advice... when you measure the baseline current, please report the number here (after checking the programmer firmware version)

This technique will zero in on your problem.


Greg


John Burkhardt
 

Greg,

 

This is what I get from my QSI PC software:

 

Quantum 1a Firmware Update Application

Version 1.5.0.0

December 29.2009

 

And

 

Quantum 2 and 3 Firmware Update Application

Version 2.5.0.9

April 18.2014

 

And

 

CV Programmer

Version 2.5.0.90

April 20.2014

 

Unfortunately I can’t open the link you provided on my PC (as ancient as myself) though I had a quick look on my smart phone and later will try on my tablet.

 

Thanks and warm regards,

 

John Burkhardt

South Africa

where the sun always shines,

and steam still reigns!

 

 

 

 

From: QSIndustries@groups.io [mailto:QSIndustries@groups.io] On Behalf Of Greg Elmassian
Sent: 05 May 2021 10:59 PM
To: QSIndustries@groups.io
Subject: Re: [QSIndustries] Unable to read Mfg ID, Status = 1

 

[Edited Message Follows]

Actually Q2 works on the revolution and other Q2 decoders and the Titan (Q3).

But I was asking if the QSI programmer diagnostics are in the Q1 software, thus verifying that the programmer is/is not the issue, as opposed to the decoders.

You right click on the top left of the windows title bar and a new menu pops up that lets you verify the programmer..

Procedure outlined on this page: https://elmassian.com/index.php/dcc/specific-manufacturers/qsi-equipment/qsi-programmer-hw-a-sw


Greg


--
John Burkhardt
South Africa
Where the sun always shines
and Steam still reigns!


Greg Elmassian
 
Edited

first, looking for the firmware version of the programmer, in the menu as I describe.

my site is www.elmassian.com, I guess your email cut off the link I sent...

1. the link is fine here on the groups.io site... so perhaps go to https://groups.io/g/QSIndustries/topics

or

2. get to my web site, go under DCC, then under the manufacturers page, pick QSI

3. under QSI there is a menu for the programmer h/w & s/w the page I tried to get you to with the original link...

Bottom line: (in the Q1Upgrade program):

When you RIGHT click on the top left corner of the window (there is nothing special there by eye) an additional menu pops up.

This allows you to verify the connection to the programmer, read PROGRAMMER firmware version, and "base current"..

All this things will help isolate where your problem is. It's really strange and unfortunate that QSI made a "hidden menu" that is really useful.

Greg


citaro_o530
 

I also had this problem with Q1 decoders in my ESU ECOS. I solved this problem by adding a 27 Ohm resistor in series with one of the programming track wires.


John Burkhardt
 

Greg, In message 18866 I stated what I get when RH click on the bar the select properties:

 

Quantum 1a Firmware Update Application

Version 1.5.0.0

December 29.2009

 

And

 

Quantum 2 and 3 Firmware Update Application

Version 2.5.0.9

April 18.2014

 

And

 

CV Programmer

Version 2.5.0.90

April 20.2014

--
John Burkhardt
South Africa
Where the sun always shines
and Steam still reigns!


Greg Elmassian
 
Edited

John, you are still not understanding...

You have listed everything except what I am asking about.

Were you able to read my page? if not, please email me greg@... and I will send an email that the link will work for you.

I added pictures to my site:  CLICK HERE

I really hate to copy sections of my site, as there is an entire page covering the whole situation...

here are the instructions to read the PROGRAMMER FIRMWARE VERSION (not the CV Manager software version which is what you keep showing)

Firmware version/upgrading

After installation, you should check for upgrade of the firmware in the programming "dongle" at least when you get one. It's in a really weird place in the programming software.

  • right click on the upper left of the title bar of the Quantum Upgrade window  (Q1 or Q2), right on the words "Q2Upgrade"
  • Yes, there is nothing up there, but when you do it, you get a menu you cannot get any other way.
  • There's a selection: "Quantum Programmer...", click that, and then you get another menu.
  • Click "retrieve firmware version".. you will then see the version in your dongle. 
  • Beneath that, there's a box that says "Upgrade firmware to version xxx"... if your firmware is older, then do the upgrade.

The firmware version as of 2021 is 2.0.5



Hope this works...