OEM version 6.32 in Atlas MP15DC - unresponsive


Hello all,

  This one is a head scratcher (at least to me).    I was asked by a club member to have a look at an OEM Atlas MP15DC that had suddenly died - i.e.  completely unresponsive.    I tried bringing it to the programming track and couldn't even read a single CV.   I tried to force a complete reset and the unit refused even that.    The loco sat for a few weeks before the owner asked if I would mind taking it home and having a look (using my QSI Programmer).

  I brought it home and fired up CV Manager.    I opened a "New" page and selected the OEM soundset #129.    I then pressed the button on the bottom left (I've forgotten the exact title) to find out the details (version number, soundset number, date of build etc.).    The decoder then magically came to life (sounds) and 'spoke'.

  When I completed that page I opened the CV manipulation page.   The page opened in default (Programming On Main) and responded with loco address 3.     I could easily 'query' various CVs and all the sounds, lights and motor controls were working.

  However, when I switched to the Programming Track mode, to have the software fill in all the CV values, the decoder locked up again.   I not only could not determine the value of any CV, I could no longer go back to POM and use the built in throttle.   It's as if the decoder encountered the same issue as when I first tried troublshooting.

  Eventually, I had to go through the entire process (from "New" file) to get the loco to work again.   

  Why did the decoder 'die'?    And why could I not read any CV using Programming Track mode?



Another puzzle piece?   When the loco had died, it would not accept any commands - not even the soft reset commands (CV changes).   The only thing that restored the loco was described above.

  Once I had the loco running, I tried to remap the Front and Rear headlights to independent control.    Then I had no working headlights.     The CV Manager did not grey out the function mapping area so I assumed remapping was possible.    Am I wrong?