Date   

Re: Decoders

 

Thanks Leonard. I thought I was clearer than you think. And yes, you are totally correct. However. When anyone contacts BLI about those old QSI decoders as used in the PRR PCM L1sa Decapod, BLI responds that they have nothing to do with them anymore and they will not give you/or me any pertinent info. The ONLY source for QSI is this forum. And as you've noticed, my original problem was not diagnosed as a Digitrax bug until the last few days. I admit I didn't contact Digitrax about this, thinking it was a decoder problem. And for that I apologize. In my defense, when we think back upon it. If I had contacted Digitrax, do you honestly think they would admit to it being their bug? Somehow, I doubt. And if it hadn't been for Nick Kulp's solution, I and the rest of us - would never have solved this - looking only at SPROG and JMRI.
Morgan F Bilbo, DCS50, UT4D, UR93, SPROGIIv4, JMRI 4.24, Pennsy modeler 1952


Re: Decoders

Leonard Stern
 

TO: Dave and others; I have been reading these posts and wish to clear up some understandings.

When Broadway LTD introduced sound some many years ago they used QSI decoders version 1 to 7 . BLI for economy or other reasons introduced their own priority decoders and called then Paragon 2, then 3,then 4 .
These decoders are not produced by QSI and have completely different manuals that QSI decoders use.
 
The discussion recently has really got off the rails.
 
For non-believers, I suggest you call Broadway and get the info from them. They will confirm what I stated in the paragraph above.
 
Thank you for reading this Email.
 
Leonard Stern
Home of the Montreal Belt Line 


Re: Q

 

OK. You are right. This case is closed. A final note. I'm sure you've noticed that a lot of people hate QSI. Probably just as many that hate Digitrax.  And both groups can do 1 of 2 things. Keep what they got and work around any problems. Or get rid of what they hate and spend a lot more money buying something they think is better.
Morgan F Bilbo, DCS50, UT4D, UR93, SPROGIIv4, JMRI 4.24, Pennsy modeler 1952


Re: Q

peteski7
 

Morgan,
I was not asking to "run" the loco using SPROG - just press F2 on its throttle to see how the whistle behaved.  But that's now water under the bridge. The main thing is that the QSI decoder is not misbehaving. It was a bug in your DCC system.

Peteski


Re: Q

 

I must have missed your mentioning use SPROG's throttle. That is a major pain in my posterior. I do not like trying to run a train from the PC when it's not easy to see what the loco is doing. That's the reason I got the UT4D and UR93. So I can control the loco where it's at. My layout is 24' long and the command station is in the middle. So 10' away is too far in an emergency. Having the controller in hand makes it easier. I think I mentioned how I use the SPROG on the pt only and the Zephyr for POM. Again, that's convenience. The SPROG has to be conformed to be a command station, it's not a clickable choice. I believe SPROG changed that from earlier versions. Nevertheless. Digitrax is what I have and like probably a majority of users, have had it for a while and hate to have to spend big bucks switching over. I find that to be the problem with all systems. Once you start with one, to switch is many times just too expensive. Shucks, had I know earlier, I'd have bought SPROG 3 and not any Digitrax at all. And for control, found something else with a knob so I wouldn't be stuck with the throttle on the PC. There's a lot of newer options today. (Calculate what I've spent on my system. Probably over $400. That's too much to just dump.) And let's face it, selling on ebay may not be feasible in today's market - I suspect there's a ton of Digitrax on ebay. I don't shop there so have no real idea.
--
Morgan F Bilbo, DCS50, UT4D, UR93, SPROGIIv4, JMRI 4.24, Pennsy modeler 1952


Re: Q

peteski7
 

Morgan,
Digitrax is not announcing the "latchign F2" problem because it is a bug, not a feature.  They don't want the world to know they stuff is buggy.  I've been doing DCC for quite some time, but this is the first time I have heard of that problem. However I really dislike Digitrax DCC (both their hardware and crappy manuals), so I try to stay away from it. But since it is the most popular (and most feature-rich) DCC system in North America , I often have to hold my nose and use it. For example some friends use it on their layouts, and my NTRAK club also uses Digitrax.  Still, every time I use the system I cringe!  I do have to admit however that their latest versions of throttles are finally designed not to be more ergonomic and intuitive, and they no longer look like cheap pocket calculators from the '70s. 

Anyways, I'm glad your F2/whistle problem is explained.  What I don't understand is why the problem also showed up when you used SPROG?  That doesn't use a Digitrax throttle, doesn't it? I specifically asked you to try  the F2 button using SPROG.  That would have speeded up troubleshooting.

Ad to reiterate what we have been telling you all along:  decoders have no concept of  (or ability to set) latching or non-latching functions.  It is, and always has been done in the DCC system (throttle/command station).  This fact is very clear when you understand how DCC works.

Peteski


Re: Q

 

To All, again: I was addressing the problem I encountered between the manual and the paper I had copied from the original manual. That manual was lost, but the paper is in my file. That paper states shows CV35&36 as different than the pdf dated 8/5/15. And that confused me. So I now ignore the paper and rely only on this latest (2015?) manual. The other situation arose between f1,2&3. Bell,whistle,coupler. The bell and coupler have nothing to do with all this. So, I do understand how some of you may have gotten confused too. I apologize if I did that - it was unintentional. I think I'm OK with my loco now. Lets close this. And if I have future questions, will open a new thread. (It's just a darn shame that my problem was Digitrax. It never occurred to me to contact the Digitrax forum. It seemed to be a QSI only. And it wasn't. Phooey!)
Morgan F Bilbo, DCS50, UT4D, UR93, SPROGIIv4, JMRI 4.24, Pennsy modeler 1952


Re: Q

 
Edited

Nick: You nailed it. It was the DCS50 & UT4D. They both do the same thing.  Yes, I was "moving" the loco. So, I just did what you said. Simply blew the whistle while standing still and it is NON-latching - the way it is supposed to be. Egads. How can such a simple explanation be missed? It's NOWHERE in any manual. And the fact that it has existed for years is a really stupid thing. Why hasn't DIgitrax issued a statement to that solution?
For Dave and John: BLI had this I1sa produced as a PCM with a QSI decoder in. Somewhere along the way, BLI quit their business with QSI, but bought the rights to use some of the technology. Hence Paragon is a descendent of QSI using some of the CVs. So, there is some minor similarity between Paragon and QSI. But they are not the same nor the same producer. So what I said about BLI is that I was able to program the CV's with minor problems. All overcome easily with experience. It's just that QSI got way way over my head and started all my confusion. This matter of f2 is now closed. I have it working.
Morgan F Bilbo, DCS50, UT4D, UR93, SPROGIIv4, JMRI 4.24, Pennsy modeler 1952


Re: Q

Nick
 

Morgan,

In my reply, I stressed that the problem was in the decoder and unfortunately failed to directly reference your statement below. As I said, QSI did NOT set the decoder up to "latch" the whistle / horn. By factory default, the normal DCC standards are met as far as how the functions work. One thing you might not comprehend is that Digitrax did add a truly STUPID feature in their system. If you MOVE the throttle while blowing the "horn / Whistle" The SYSTEM will LATCH the function until you "Unlatch" it by pushing it again without moving the throttle.

It is unique to Digitrax and is part of their firmware since the days of the Big Boy system.

Perhaps THAT is where you are having the problem.

Regards,
Nick Kulp


And that's the real problem. QSI configured f2 to be latching somehow bypassing the "standard" that all command stations have f2 as non-latching. 
 
--
Morgan F Bilbo, DCS50, UT4D, UR93, SPROGIIv4, JMRI 4.24, Pennsy modeler 1952


Re: Q

Dave Hastings
 

This reply is meant for John Burkhardt. Paragon is made up of QSI decoders. Paragon 2,3 and 4 are BLI proprietary decoders. At least in the States.
  
Dave Hastings

On Thursday, August 12, 2021, 11:37:40 AM EDT, John Burkhardt <burkhj@icon.co.za> wrote:






Morgan,
 
Please accept that nothing is further from my mind than to confuse you other than illustrate that latching or momentary function keys are solely a function of the throttle, hence my statement that this is only available on some throttles, but not on the ones in your arsenal.
 
I was simply trying to explain the reason for QSI’s statement, which was only meant for NCE users, you and I who have DIGITRAX are not addressed by that.
 
But now I’m confused after reading the replies from Marcus. Morgan, I thought you started this thread because you have a problem with a BLI loco that is fitted an QSI decoder where when pressing F2 the whistle  stays on till you press F2 again. If that is correct then why is Marcus talking about Paragon which is an entirely different animal. The OEM QSI are Quantum Q1 or Q2?
 
 
Thanks and warm regards,
 
John Burkhardt
South Africa
where the sun always shines,
and steam still reigns!
 
 
 
 
From: QSIndustries@groups.io [mailto:QSIndustries@groups.io] On Behalf Of PennsyNutSent: 12 August 2021 03:33 AMTo: QSIndustries@groups.ioSubject: Re: [QSIndustries] Q
 
John: Now you have me totally confused - again! I do not have a UT402. So that is immaterial.  You mention f3. That is also immaterial. That is a "coupler" sound. And you state that all your QSI f2 are non latching. But mine is latching! THAT IS THE PROBLEM.
Morgan F Bilbo, DCS50, UT4D, UR93, SPROGIIv4, JMRI 4.24, Pennsy modeler 1952


--
John Burkhardt
South Africa
Where the sun always shines
and Steam still reigns!


Re: Q

John Burkhardt
 

Morgan,

 

Please accept that nothing is further from my mind than to confuse you other than illustrate that latching or momentary function keys are solely a function of the throttle, hence my statement that this is only available on some throttles, but not on the ones in your arsenal.

 

I was simply trying to explain the reason for QSI’s statement, which was only meant for NCE users, you and I who have DIGITRAX are not addressed by that.

 

But now I’m confused after reading the replies from Marcus. Morgan, I thought you started this thread because you have a problem with a BLI loco that is fitted an QSI decoder where when pressing F2 the whistle  stays on till you press F2 again. If that is correct then why is Marcus talking about Paragon which is an entirely different animal. The OEM QSI are Quantum Q1 or Q2?

 

 

Thanks and warm regards,

 

John Burkhardt

South Africa

where the sun always shines,

and steam still reigns!

 

 

 

 

From: QSIndustries@groups.io [mailto:QSIndustries@groups.io] On Behalf Of PennsyNut
Sent: 12 August 2021 03:33 AM
To: QSIndustries@groups.io
Subject: Re: [QSIndustries] Q

 

John: Now you have me totally confused - again! I do not have a UT402. So that is immaterial.  You mention f3. That is also immaterial. That is a "coupler" sound. And you state that all your QSI f2 are non latching. But mine is latching! THAT IS THE PROBLEM.
Morgan F Bilbo, DCS50, UT4D, UR93, SPROGIIv4, JMRI 4.24, Pennsy modeler 1952


--
John Burkhardt
South Africa
Where the sun always shines
and Steam still reigns!


Re: Q

peteski7
 

Morgan,
The manual I use is also v 5.2.0.  The function mapping in CV33 - 46 is specifically defined in the NMRA DCC standard, and it is the standard all decoders adhere to.
CV35 is for F1 and is supposed to be 04 for controlling bell.  Page 72 confirms it.
CV36 is for F2 and is supposed to be 08 for controlling horn/whistle (not sure where in the manual you came up with the coupler sound). Page 74 confirms this.

The other info you found (CV35=3 and CV36=17) makes no sense. These are unsupported values on QSI decoders described in the v 5.2.0 manual.
I never asked for any information about the coupler sound, and please just humor me about the bell sound.

I do have another place to check, but those are indexed CV registers (things get complicated), so you will need to use JMRI DecoderPro. I don't have it handy, so I can't give you step-by-step instructions.

You need to check CV53.3.0, CV53.3.1, CV53.4.0 and CV53.4.1.  If you can read those 4 CVs, let me know what the values are.
If you don't know how to access indexed CV registers in DecoderPro, I'll show you how to check them manually, but it is a bit cumbersome.  This is the stuff that makes manually programming complex sound decoders a chore.

Peteski


On Wed, Aug 11, 2021 at 10:24 PM, PennsyNut wrote:
And now Peteski: The QSI loco on the pt, CV35 is 04 and per manual relates to f2 the whistle. CV36 is 08 and per manual relates to f3 or the coupler. These two readings are what was in the original from JMRI. They have never been touched. i.e. Never changed.
Now comes my surprise. Background - I lost the original paper manual that came with the loco. But did copy on 8.5x11 paper the CV's. And that shows CV35 should be 3 and CV36 should be 17. So this is just another confusion to me.
And now to make matters even worse. In the pdf manual dated 8/5/15. Referring to v 5.2.0: Page 72 shows CV35 as for f1 and page 74 shows CV36 as for f2. ??? In other words. We have conflicting information. And all this does is confuse the heck for me. And you all tell me to RTFM. And I have written material for many manuals. I mention 8/5/15. I also have 8/4/09 v 4.5.0 and that shows the same as the 8/5/15. i.e Both pdf manuals read the same.
So at this point. I don't know what f1/bell and f3/coupler have to do with this situation. My simple mind tells me that the only problem is f2/whistle. So I respect y'all and wait for responses.

Morgan F Bilbo, DCS50, UT4D, UR93, SPROGIIv4, JMRI 4.24, Pennsy modeler 1952


Re: Q

Marcus Ammann
 

Hi Morgan

 

Thanks for the details.

 

Thinking aloud as they’re all Paragons, is there something different with the way the Whistles works when pressing F2, as Morgan is seeing, I’m just curious.

Apart from that, I cannot offer any more help.

 

Regards

Marcus

 

From: QSIndustries@groups.io <QSIndustries@groups.io> On Behalf Of PennsyNut
Sent: Thursday, 12 August 2021 12:35 PM
To: QSIndustries@groups.io
Subject: Re: [QSIndustries] Q

 

Marcus: I have 4 BLI w/Paragon 2, 1 BLI w/Paragon 3, 1 diesel, JMRI defined as "Tsunami Diesel Bachmann Sound Value". I have other locos that I don't use, or don't have sound. All the BLI are steam and are pretty much all programmed the same. No major differences. With the P3, I never noticed any differences compared to the P2s. The cheap diesel has limited CV's and was a pain to program. But once I got that done, I've left it alone. The only thing I use the diesel for is testing track. Otherwise, it just sits aside. The 6 steamers/5 BLI & 1 QSI are the sum total I have on the layout. My layout is designed so that all engines are parked on dead sidings until I throw the turnout for that siding. So, there's usually only one engine running at a time. I found it awkward to try running 2 locos at the same time. The UT4D is primary so that I can walk the 24' of layout with the engine. Turnouts hand thrown.
--
Morgan F Bilbo, DCS50, UT4D, UR93, SPROGIIv4, JMRI 4.24, Pennsy modeler 1952


Re: Q

 

Marcus: I have 4 BLI w/Paragon 2, 1 BLI w/Paragon 3, 1 diesel, JMRI defined as "Tsunami Diesel Bachmann Sound Value". I have other locos that I don't use, or don't have sound. All the BLI are steam and are pretty much all programmed the same. No major differences. With the P3, I never noticed any differences compared to the P2s. The cheap diesel has limited CV's and was a pain to program. But once I got that done, I've left it alone. The only thing I use the diesel for is testing track. Otherwise, it just sits aside. The 6 steamers/5 BLI & 1 QSI are the sum total I have on the layout. My layout is designed so that all engines are parked on dead sidings until I throw the turnout for that siding. So, there's usually only one engine running at a time. I found it awkward to try running 2 locos at the same time. The UT4D is primary so that I can walk the 24' of layout with the engine. Turnouts hand thrown.
--
Morgan F Bilbo, DCS50, UT4D, UR93, SPROGIIv4, JMRI 4.24, Pennsy modeler 1952


Q

 

And now Peteski: The QSI loco on the pt, CV35 is 04 and per manual relates to f2 the whistle. CV36 is 08 and per manual relates to f3 or the coupler. These two readings are what was in the original from JMRI. They have never been touched. i.e. Never changed.
Now comes my surprise. Background - I lost the original paper manual that came with the loco. But did copy on 8.5x11 paper the CV's. And that shows CV35 should be 3 and CV36 should be 17. So this is just another confusion to me.
And now to make matters even worse. In the pdf manual dated 8/5/15. Referring to v 5.2.0: Page 72 shows CV35 as for f1 and page 74 shows CV36 as for f2. ??? In other words. We have conflicting information. And all this does is confuse the heck for me. And you all tell me to RTFM. And I have written material for many manuals. I mention 8/5/15. I also have 8/4/09 v 4.5.0 and that shows the same as the 8/5/15. i.e Both pdf manuals read the same.
So at this point. I don't know what f1/bell and f3/coupler have to do with this situation. My simple mind tells me that the only problem is f2/whistle. So I respect y'all and wait for responses.

Morgan F Bilbo, DCS50, UT4D, UR93, SPROGIIv4, JMRI 4.24, Pennsy modeler 1952


Re: Q

Marcus Ammann
 

Hi Morgan

 

You have the Latching and NON Latching logic exactly right.

 

What brand sound decoders are in the other sound locos?  

 

Regards

Marcus

 

 

 

 

 

From: QSIndustries@groups.io <QSIndustries@groups.io> On Behalf Of PennsyNut
Sent: Thursday, 12 August 2021 11:28 AM
To: QSIndustries@groups.io
Subject: Re: [QSIndustries] Q

 

I have to reply one at a time. Marcus: I define latching as when you press f2 and the whistle blows and keeps on blowing until you push f2 again. That is what the QSI loco does. On all other locos, when I press f2, the whistle blows and as soon as I release it, the whistle stops. That is NON latching. Correct? Or do I have this backwards? The opposite is what happens with f1, the bell. You press the bell and it just keeps on ringing. When you press it the second time, it stops. That is what I call "latching". The button latches on and stays on until pressed again. And that's why I think the QSI whistle was created backwards.
Now for all. My signature shows what I have. I have Digitrax. Both my DCS50 and the UT4D have only an f2. They do not have a "horn" button. If NCE and/or others do, that don't help me. So, please do not confuse me with what others have. I am confused enough as it is.
Morgan F Bilbo, DCS50, UT4D, UR93, SPROGIIv4, JMRI 4.24, Pennsy modeler 1952


Re: Q

 

John: Now you have me totally confused - again! I do not have a UT402. So that is immaterial.  You mention f3. That is also immaterial. That is a "coupler" sound. And you state that all your QSI f2 are non latching. But mine is latching! THAT IS THE PROBLEM.
Morgan F Bilbo, DCS50, UT4D, UR93, SPROGIIv4, JMRI 4.24, Pennsy modeler 1952


Re: Q

 

I have to reply one at a time. Marcus: I define latching as when you press f2 and the whistle blows and keeps on blowing until you push f2 again. That is what the QSI loco does. On all other locos, when I press f2, the whistle blows and as soon as I release it, the whistle stops. That is NON latching. Correct? Or do I have this backwards? The opposite is what happens with f1, the bell. You press the bell and it just keeps on ringing. When you press it the second time, it stops. That is what I call "latching". The button latches on and stays on until pressed again. And that's why I think the QSI whistle was created backwards.
Now for all. My signature shows what I have. I have Digitrax. Both my DCS50 and the UT4D have only an f2. They do not have a "horn" button. If NCE and/or others do, that don't help me. So, please do not confuse me with what others have. I am confused enough as it is.
Morgan F Bilbo, DCS50, UT4D, UR93, SPROGIIv4, JMRI 4.24, Pennsy modeler 1952


Re: Q

peteski7
 

Morgan,
I have a far-fetched idea about this problem.  Please put the loco on a programming track and read the contents of CV35 and CV36.  Let me know what they are. Make sure to give me the correct value for each CV. That is important.

Peteski


Re: Q

John Burkhardt
 

Morgan,

 

The key in your quote is “some systems….”, read NCE. You don’t have some systems, you have DIGITRAX where latching/non-latching is a function of the throttle setup. Only from the DT402 up could you chose the non-latching to be either F2 or F3, all other F keys are latching period, but to the best of my knowledge not on the DCS50 nor the UT4.

 

I can’t count how many QSI decoders I have installed or have/had in my own locos, but never have come across one that had F2 latching!

 

So I really don’t know where you get that from?

 

Thanks and warm regards,

 

John Burkhardt

South Africa

where the sun always shines,

and steam still reigns!

 

 

 

 

From: QSIndustries@groups.io [mailto:QSIndustries@groups.io] On Behalf Of PennsyNut
Sent: 11 August 2021 04:35 AM
To: QSIndustries@groups.io
Subject: Re: [QSIndustries] Q

 

Peteski: Sorry to bring up this again. But: f2 for the whistle is a problem I need resolved. Was it you? that mentioned that f2 is non-latching. Not so with QSI.

I had asked about different buttons for f2 and "horn". I know horn is diesel and whistle is steam. I only have steam. Please read this from the manual. It specifically states that when f2 is pressed, it is latched. And I don't have a horn button/whatever that means? I don't have a diesel. That indicates that the "horn" is non-latched. So, I'm back to my problem. It's only my QSI loco that f2 is latched. All other locos f2 is non-latched. Is there any way to correct that? With it latched, it's darn near impossible to blow a short whistle sound. The finger can only work so fast. Just not fast enough. LOL So can someone help me out with this? It is a very frustrating thing with QSI - that don't act like other locos. I always thought that f2 was non-latched, but apparently QSI is backwards.
Morgan F Bilbo, DCS50, UT4D, UR93, SPROGIIv4, JMRI 4.24, Pennsy modeler 1952


--
John Burkhardt
South Africa
Where the sun always shines
and Steam still reigns!

181 - 200 of 19172