Date   

Decoder pinout

Banjotrain
 

I bought a Broadway Limited SD40-2 in January 2005.  

Does anyone have a pinout of the decoder that would have been installed in that timeframe?
It is slightly different from the later pre-Revolution decoders - the keep-alive caps are mounted remotely, under the rear light.

Thanks
Erik


Re: Win 10 fix for problems loading QSI drivers

Talmadge C 'TC' Carr
 

Said file is also in the files section. In the 'QSI Driver' folder

Talmadge C 'TC' Carr
Sn42 and Hn42 somewhere in the wilds of the Pacific Northwest
group_list@dapenguin.net

On 07May2021, at 13:30, ffbrehm@gmail.com wrote:

Well bad on me, I didn’t know attachments would work.

Frank

From: QSIndustries@groups.io <QSIndustries@groups.io> On Behalf Of Lou
Sent: Thursday, May 6, 2021 3:38 PM
To: QSIndustries@groups.io
Subject: [QSIndustries] Win 10 fix for problems loading QSI drivers

Attached is a file sent from Frank that he was trying to upload to the files section for the group. He wasn't successful and neither was I so here it is for your own personal use. This is not available in the files section here. Don't be alarmed by the file name - it is a safe file.

Hope this helps someone. Thanks Frank.

Lou


Re: Win 10 fix for problems loading QSI drivers

ffbrehm@...
 

Well bad on me, I didn’t know attachments would work.

 

Frank

 

From: QSIndustries@groups.io <QSIndustries@groups.io> On Behalf Of Lou
Sent: Thursday, May 6, 2021 3:38 PM
To: QSIndustries@groups.io
Subject: [QSIndustries] Win 10 fix for problems loading QSI drivers

 

Attached is a file sent from Frank that he was trying to upload to the files section for  the group. He wasn't successful and neither was I so here it is for your own personal use. This is not available in the files section here. Don't be alarmed by the file name - it is a safe file.

 

Hope this helps someone. Thanks Frank.

 

Lou


Re: Win 10 fix for problems loading QSI drivers

peteski7
 

Thank you TCC!


On Thu, May 6, 2021 at 11:07 PM, Talmadge C 'TC' Carr wrote:
A setting needed redoing.  I fixed it as one of the  owners.
Members can now upload.
TCC:}


Re: Unable to read Mfg ID, Status = 1

citaro_o530
 

I also had this problem with Q1 decoders in my ESU ECOS. I solved this problem by adding a 27 Ohm resistor in series with one of the programming track wires.


Re: Win 10 fix for problems loading QSI drivers

Greg Elmassian
 

I don't want to get into a competition on who's method is right or wrong, but there's more information out there, and as I mentioned, different versions of CVManager can do different things, and the latest version does not have all the special features that were developed for the titan. Also there are different versions of the SiLabs driver that are required for the different versions of CVM and Q2upgrade.

This information and more is at the link I gave in the other topic.

The latest version I have of CVManager is 3.1.0.39, newer than 3.1.0.7

For convenience, I will repeat my entry page for QSI here:

https://elmassian.com/index.php/dcc/specific-manufacturers/qsi-equipment#subpages

There are 10 sub pages on more specific information, one is just for installing Q2Upgrade, CVManager, and the driver.




Greg


Re: Win 10 fix for problems loading QSI drivers

Talmadge C 'TC' Carr
 

OK
I created a folder caller 'QSI Drivers'  I will upload all the drivers I have and maybe some new ones if I can find them.  Does anyone know what SiLab chip is used in the QSI hardware.

TCC:}


File Notifications #file-notice

QSIndustries@groups.io Notification <noreply@...>
 

Talmadge C 'TC' Carr <group_list@...> added folder /QSI Drivers


The following files have been uploaded to the Files area of the QSIndustries@groups.io group.

By: Talmadge C 'TC' Carr <group_list@...>

Description:
Fix for Win10 error "This App Has Been Blocked For Your Protection"


Re: Win 10 fix for problems loading QSI drivers

Talmadge C 'TC' Carr
 

A setting needed redoing.  I fixed it as one of the  owners.
Members can now upload.  If the problem persist send ME another note
TCC:}


On Thu, May 6, 2021 at 06:36 PM, peteski7 wrote:
For some reason members (like me or Frank, or you) are not permitted to modify the Files section in any way.  Can't upload files or even create folders.  Seems very counterproductive.  Not sure what the problem is.


Re: Win 10 fix for problems loading QSI drivers

peteski7
 

For some reason members (like me or Frank, or you) are not permitted to modify the Files section in any way.  Can't upload files or even create folders.  Seems very counterproductive.  Not sure what the problem is.  I just tried again and still, I cannot do any of the above mentioned actions.  I have no problems with Files uploads in other groups on this site.

I contacted the group's owner (directly) about this some time ago, but I never got a reply.  Why are we blocked from uploading items to the Files section?   Maybe the owner will respond here.

Peteski


On Thu, May 6, 2021 at 06:38 PM, Lou wrote:
Attached is a file sent from Frank that he was trying to upload to the files section for  the group. He wasn't successful and neither was I so here it is for your own personal use. This is not available in the files section here. Don't be alarmed by the file name - it is a safe file.
 
Lou


Win 10 fix for problems loading QSI drivers

Lou
 

Attached is a file sent from Frank that he was trying to upload to the files section for  the group. He wasn't successful and neither was I so here it is for your own personal use. This is not available in the files section here. Don't be alarmed by the file name - it is a safe file.

Hope this helps someone. Thanks Frank.

Lou


Re: Unable to read Mfg ID, Status = 1

Greg Elmassian
 
Edited

first, looking for the firmware version of the programmer, in the menu as I describe.

my site is www.elmassian.com, I guess your email cut off the link I sent...

1. the link is fine here on the groups.io site... so perhaps go to https://groups.io/g/QSIndustries/topics

or

2. get to my web site, go under DCC, then under the manufacturers page, pick QSI

3. under QSI there is a menu for the programmer h/w & s/w the page I tried to get you to with the original link...

Bottom line: (in the Q1Upgrade program):

When you RIGHT click on the top left corner of the window (there is nothing special there by eye) an additional menu pops up.

This allows you to verify the connection to the programmer, read PROGRAMMER firmware version, and "base current"..

All this things will help isolate where your problem is. It's really strange and unfortunate that QSI made a "hidden menu" that is really useful.

Greg


Re: Unable to read Mfg ID, Status = 1

John Burkhardt
 

Greg,

 

This is what I get from my QSI PC software:

 

Quantum 1a Firmware Update Application

Version 1.5.0.0

December 29.2009

 

And

 

Quantum 2 and 3 Firmware Update Application

Version 2.5.0.9

April 18.2014

 

And

 

CV Programmer

Version 2.5.0.90

April 20.2014

 

Unfortunately I can’t open the link you provided on my PC (as ancient as myself) though I had a quick look on my smart phone and later will try on my tablet.

 

Thanks and warm regards,

 

John Burkhardt

South Africa

where the sun always shines,

and steam still reigns!

 

 

 

 

From: QSIndustries@groups.io [mailto:QSIndustries@groups.io] On Behalf Of Greg Elmassian
Sent: 05 May 2021 10:59 PM
To: QSIndustries@groups.io
Subject: Re: [QSIndustries] Unable to read Mfg ID, Status = 1

 

[Edited Message Follows]

Actually Q2 works on the revolution and other Q2 decoders and the Titan (Q3).

But I was asking if the QSI programmer diagnostics are in the Q1 software, thus verifying that the programmer is/is not the issue, as opposed to the decoders.

You right click on the top left of the windows title bar and a new menu pops up that lets you verify the programmer..

Procedure outlined on this page: https://elmassian.com/index.php/dcc/specific-manufacturers/qsi-equipment/qsi-programmer-hw-a-sw


Greg


--
John Burkhardt
South Africa
Where the sun always shines
and Steam still reigns!


Re: Unable to read Mfg ID, Status = 1

Greg Elmassian
 
Edited

Actually Q2 works on the revolution and other Q2 decoders and the Titan (Q3).

But I was asking if the QSI programmer diagnostics are in the Q1 software, thus verifying that the programmer is/is not the issue, as opposed to the decoders.

You right click on the top left of the windows title bar and a new menu pops up that lets you verify the programmer..

Procedure outlined on this page: https://elmassian.com/index.php/dcc/specific-manufacturers/qsi-equipment/qsi-programmer-hw-a-sw

Update: I found the Q1Upgrade program, and it indeed has the programmer diagnostic menu just like I described.

Use this to validate the connection to the programmer first is my best advice... when you measure the baseline current, please report the number here (after checking the programmer firmware version)

This technique will zero in on your problem.


Greg


Re: Unable to read Mfg ID, Status = 1

John Burkhardt
 

Greg,

 

I can use Q2 but thought that was only for TITAN projects, will try tomorrow afternoon too late now.

 

Thanks and warm regards,

 

John Burkhardt

South Africa

where the sun always shines,

and steam still reigns!

 

 

 

 

From: QSIndustries@groups.io [mailto:QSIndustries@groups.io] On Behalf Of Greg Elmassian
Sent: 05 May 2021 10:20 PM
To: QSIndustries@groups.io
Subject: Re: [QSIndustries] Unable to read Mfg ID, Status = 1

 

Strange / unlikely that all your Q1 decoders quit.

the 40% is misleading, it could not read the decoder at all.

I've never run Q1 upgrade (just Q2) does it have the facility to read the QSI programmer firmware version, and base current like the Q2 software can?

Greg


--
John Burkhardt
South Africa
Where the sun always shines
and Steam still reigns!


Re: Unable to read Mfg ID, Status = 1

Greg Elmassian
 

Strange / unlikely that all your Q1 decoders quit.

the 40% is misleading, it could not read the decoder at all.

I've never run Q1 upgrade (just Q2) does it have the facility to read the QSI programmer firmware version, and base current like the Q2 software can?

Greg


Unable to read Mfg ID, Status = 1

John Burkhardt
 

Had a frustrating day, trying to get past an error message when programming QSI Q1 decoders. I'm working on a swap for 2 customers, the first want his locos freed of OEM QSI Q1 decoders and replaced by TSU2 while the second is prepared to take them over and for me to fit into his analogue locos. In this process I've found contradictory behaviour/failures and frankly I'm stumped.

Trying to keep two customers satisfied at the same time did, to some extent, prevent me from following the safe route resulting in some locos stripped and storing the salvaged QSI and first completing the TSU replacement, but every one of these locos was test run on DCC before stripping to ensure that the loco operates as expected with the QSI decoder still fitted.  

To complicate matters, the first loco stripped, a Walthers P2K E8 has a decoder fitted with an upgrade CPU sporting the hologram label, which was requested by the new owner for self fitment in his loco. Of course a few days later he returned it stating that it is not working. I connected it up to my ESU test stand connected to the QSI programmer and could read the decoder in Q1 Upgrade to confirm that it was indeed loaded with project 136 E8/9 (Life Like) Diesel, and when switching to QProgrammer I could reprogram the address and run the motor, but still got no sound. Tested the speaker, reloaded the project, but no sound – assuming the amp is blown for some reason or other. The successful reading of the decoder and reloading the project as well as changing the address would suggest that programmer and software is functioning as it should – it has not seen a change/upgrade since years ago I’ve upgraded Q1s, Revolutions and Titans successfully.

Then I took a set of decoders that came out of a brace of P2K GP9 with the original chip and connected it up to the test stand and tried to read the decoder info in Q1 Upgrade and the counter moved up to 40% and then bombed out with the subject line message. I still have some spare upgrade chips so inserted one in the decoder and tried to read that, all bombed out with above error message after 40%. Remove the chip from that decoder fitted it into the E8 decoder and got same result!?  

It feels like these chips are getting or have been bricked – I quite accept that I might be doing something wrong, but I’m sure I’ve not deviated from the method I had success with in past?

--
John Burkhardt
South Africa
Where the sun always shines
and Steam still reigns!


Re: QSI Silabs Installation

Alex Stanojevic
 

Thanks



On May 4, 2021, at 15:56, ffbrehm@... wrote:

I found a way to install the drivers with the latest Win10 updates. I will send it to both Peter and Alex directly as it is a PDF.

 

Frank Brehm

 

From: QSIndustries@groups.io <QSIndustries@groups.io> On Behalf Of peterebherron
Sent: Tuesday, May 4, 2021 5:07 AM
To: QSIndustries@groups.io
Subject: Re: [QSIndustries] QSI Silabs Installation

 

Greg, have you tried installing the drivers lately in a computer that has been updating Windows continuously?  My friend and I used your exact method from your website in two different computers with Windows 10 and encountered the blocking message.  Vinnie fooled with and found the only way around it was to use the command prompt.  Let us know what you find.  Thanks,

Peter 


Re: QSI Silabs Installation

Paul B/Indy
 

Thank you very much!

Paul B/Indy


On May 4, 2021, at 3:55 PM, Greg Elmassian <greg@...> wrote:

Site updated, installs on windows 7 no problem...

Greg


Re: QSI Silabs Installation

ffbrehm@...
 

I found a way to install the drivers with the latest Win10 updates. I will send it to both Peter and Alex directly as it is a PDF.

 

Frank Brehm

 

From: QSIndustries@groups.io <QSIndustries@groups.io> On Behalf Of peterebherron
Sent: Tuesday, May 4, 2021 5:07 AM
To: QSIndustries@groups.io
Subject: Re: [QSIndustries] QSI Silabs Installation

 

Greg, have you tried installing the drivers lately in a computer that has been updating Windows continuously?  My friend and I used your exact method from your website in two different computers with Windows 10 and encountered the blocking message.  Vinnie fooled with and found the only way around it was to use the command prompt.  Let us know what you find.  Thanks,

Peter 

201 - 220 of 19078