Topics

QCX+ Menu Button problem


William Bradley
 

Have just assembled the QCX+ for 30m band, it passed the smoke test, the LCD displays properly, was able to select the band, then I found that the menu button did not work.  I reflowed the solder joints on the button but that made no difference.

Any ideas please?  Thanks

Roger mi0wwb


N3MNT
 

Check the button with a meter with the radio off. Make sure you installed the button with the correct orientation.


@CurtisM
 

Roger

In addition, check the pins at the microcontroller socket that is used by the button. I found it easy to miss the pin when soldering this socket. Its likely one of these simple things, power off and troubleshoot with your dvm.

Curt wb8yyy


GD
 

William, look to the position 3.54 on assembly drawing asking to cut carefully from a strip of angled headers, if when cutting for JP5 and JP4 check you've not cut too close to one section. Too close will remove the tension of one pin mating into the front panel. This is the area to check,for continuity.

G4CAO Geoff 73


Ronald Taylor
 

Roger, one other thing ... check that you've fitted R44 and that it's the correct value, 3K3, and soldered properly. 

73 ... Ron

On Sat, Oct 17, 2020 at 6:50 AM GD <lowemmission@...> wrote:
William, look to the position 3.54 on assembly drawing asking to cut carefully from a strip of angled headers, if when cutting for JP5 and JP4 check you've not cut too close to one section. Too close will remove the tension of one pin mating into the front panel. This is the area to check,for continuity.

G4CAO Geoff 73


Arv Evans
 

Roger mi0wwb
Quick thought...someone posted a few days ago about his addition of a 
front-panel button and later found that his junk-box button was NC type 
instead of NO.  It is something to check if you have added off-board 
switches.

Arv
_._


On Sat, Oct 17, 2020 at 4:59 AM William Bradley via groups.io <w.r.bradley=btinternet.com@groups.io> wrote:
Have just assembled the QCX+ for 30m band, it passed the smoke test, the LCD displays properly, was able to select the band, then I found that the menu button did not work.  I reflowed the solder joints on the button but that made no difference.

Any ideas please?  Thanks

Roger mi0wwb


Shane Justice
 

Roger,
When I assembled the front panel to the panel pcb, I noticed the left push button was sticking- I could press it, but it could not return to its un pressed state. Readjusting the front panel released the side force on the button and allowed it to return to its unpressed state. Make sure the button makes a nice audible click on pressing it and releasing it.

If all this doesn't work, try an ohm meter across the contacts of the switch and make sure it makes and breaks the continuity. If it remains open pressed or in pressed, or remains closed pressed or unpressed, replace the switch.

I hope this helps.

Shane


On Oct 17, 2020 at 03:59, William Bradley via groups.io <w.r.bradley@...> wrote:

Have just assembled the QCX+ for 30m band, it passed the smoke test, the LCD displays properly, was able to select the band, then I found that the menu button did not work.  I reflowed the solder joints on the button but that made no difference.

Any ideas please?  Thanks

Roger mi0wwb