Topics

FST3253 Failure?

Mike Easterbrook
 

Hi All

Managed to resolve the key envelope problem with QCX 20 by replacing Q6.  TX now all OK and envelope looks good.
However at 13v current is now 200mA versus (110mA before the Q6 surgery) and lots of noise in the headset. 

T1 volts @ pins 5-6 (& IC4 pins 7 & 9) all 2.46. 5V rail is 4.91

C43-46 & IC5 all pins except 4 & 8 are approx. 0.9 V

The Q6 job involved some component bending but everything around R1 & R2 looks OK.  Suspect IC4 but looking for some confirmation or less radical suggestions before trying to replace.

Thanks
Mike 9M2LXM

Ronald Taylor
 

Mike it does sound like IC4 needs to be replaced. But as you know there’s no electrical tie between Q6 and IC4, only a physical closeness. Maybe a solder splash got in there during the Q6 change? Anyway If you have a small sharp pair of wire cutters you can snip pin 16 of IC4 and check if the idle current drops back to more normal range. It will probably have to be replaced anyway but that might tell quickly if it’s causing the heavy loading and it can easily be soldered back. I did find one doing that once and the snipped lead proved it. 

Ron

On Sat, Jun 6, 2020 at 22:57 Mike Easterbrook <mike.easterbrook.2012@...> wrote:
Hi All

Managed to resolve the key envelope problem with QCX 20 by replacing Q6.  TX now all OK and envelope looks good.
However at 13v current is now 200mA versus (110mA before the Q6 surgery) and lots of noise in the headset. 

T1 volts @ pins 5-6 (& IC4 pins 7 & 9) all 2.46. 5V rail is 4.91

C43-46 & IC5 all pins except 4 & 8 are approx. 0.9 V

The Q6 job involved some component bending but everything around R1 & R2 looks OK.  Suspect IC4 but looking for some confirmation or less radical suggestions before trying to replace.

Thanks
Mike 9M2LXM

Mike Easterbrook
 

Hi Ron
Good to have your support for the theory. Thanks for the tip re pin16. Too late to try this evening - will give it a go tomorrow with fresh eyesight!
Mike

On Sun, 7 Jun 2020, 21:19 Ronald Taylor, <wa7gil@...> wrote:
Mike it does sound like IC4 needs to be replaced. But as you know there’s no electrical tie between Q6 and IC4, only a physical closeness. Maybe a solder splash got in there during the Q6 change? Anyway If you have a small sharp pair of wire cutters you can snip pin 16 of IC4 and check if the idle current drops back to more normal range. It will probably have to be replaced anyway but that might tell quickly if it’s causing the heavy loading and it can easily be soldered back. I did find one doing that once and the snipped lead proved it. 

Ron

On Sat, Jun 6, 2020 at 22:57 Mike Easterbrook <mike.easterbrook.2012@...> wrote:
Hi All

Managed to resolve the key envelope problem with QCX 20 by replacing Q6.  TX now all OK and envelope looks good.
However at 13v current is now 200mA versus (110mA before the Q6 surgery) and lots of noise in the headset. 

T1 volts @ pins 5-6 (& IC4 pins 7 & 9) all 2.46. 5V rail is 4.91

C43-46 & IC5 all pins except 4 & 8 are approx. 0.9 V

The Q6 job involved some component bending but everything around R1 & R2 looks OK.  Suspect IC4 but looking for some confirmation or less radical suggestions before trying to replace.

Thanks
Mike 9M2LXM