QDX rev 3 and raspberry Pi Fldigi #qdx


Phill
 

Rewinding all the toroids whist I was waiting for parts made me think back to the good old days, Denko coils on an octal base.
My first homebuilt receiver: http://www.wftw.nl/hac.html

Wish I still had it.


Sigh!
--
Phill EA5JHA


Phill
 

Finally working again after a fairly long wait for parts.

Although no parts showed heat or damage marks, the AO3407 and 78M05 were both dead. I know it's been said a 1000 times but you have to have a decent power supply for the QDX. I've been using a 12v 9Ah battery with a FNIRSI converter. Set for 9 volts and 1500mA limit. After damaging the qdx I tested the power supply. On start up it showed 15v before dropping to 9v. All ok if you plug the qdx in after turning on but not worth the risk. Clearly this is why Hans doesn't damage AO3407s. That 15v was probably only what it displayed, it could have been higher.

Man that AO is a pig to solder back in! So damn small. Everytime I approached it with the soldering iron it jumped away like a grasshopper. Finally used some very old solder paste which glued it down long enough.

Looking forward to REV 5 or 6.

73
--
Phill EA5JHA


Phill
 

I've been trying to use my qdx on a raspberry pi 4b for a few weeks.
WSJT-X works fine on the Pi on FT8 and JS8call.

FldigiĀ  not quite so easy. I followed along with Peter's notes but initially thought that the signal wasn't making it to the Pi. The waterfall was just empty.
I tried Hamlib and Flrig with the same results. Green signal level on the bar graph and a green diamond. Neither would put the qdx in to transmit. I ran a short session this afternoon on WSJT-X FT8 on 20m. All good. Without turning the qdx off, I closed WS and opened Fldigi. There on the waterfall was the clear indication of FT8 signals.
Further, it's now clear that not only does Fldigi not transmit it doesn't change the frequency either. So when I tried to get wefax on 7880 the qdx didn't change frequency and just stayed wherever it was.
After dinner I went back to look at the qdx and it's dead! First indications are that there's a short in the power input. The supply is ok as it's running the QCX+ on wspr at the moment. When connected to the qdx the supply hits the limit at 1400mA. No sign of anything hot or damaged so a closer look tomorrow.
I feel the need for beer.

73 Phill
--
Phill EA5JHA