LightAPRS-W Programming Error #kph #lightaprs


Andrew Blessing
 

I keep encountering issues when attempting to sketch the LightAPRS-W tracker.  I'm using an laptop running Windows 11.

I've tried the following items attempting to resolve the issue:

- Uninstall and reinstall Arduino IDE, complete with deleting AppData Arduino folder.
- Uninstall and reinstall CH340G drivers, including trying the native drivers from Windows Update
- Trying different USB cables, including a brand new one I justed ordered.
- Tried different COM baud settings and/or different programmers


Attached are the ino file and sketch logs.  For reference, at the bottom are the board settings in Arduino IDE and the COM setting info as well.

I'm open to any ideas/suggestions at this point.

Thanks









BrianB
 

Andrew,

I don’t see where you state the issue/error you are trying to resolve. Let us know and maybe someone can help.

73,
BrianB
N6CVO


Andrew Blessing
 

I exchanged emails with Mustafa and was able to get the issue resolved.

I was seeing a series error messages when attempting the sketch:

avrdude: stk500v2_getsync(): timeout communicating with programmer avrdude: stk500v2_ReceiveMessage(): timeout avrdude: stk500v2_ReceiveMessage(): timeout An error occurred while uploading the sketch

Once I set the bootloader to UART0, everything worked fine.