QCX original #sidetone problems above 16 WPM #sidetone


 

My old QCX original from 2017 I recently altered LPF coils and capacitors from 30m to 20m.
The RX is fine with great sensitivity.
The TX is fine with 4W out at 12V, 5W at 14V. 
However, when keying either with built in key or in keyer mode with external key, the side tone drops out on every 2nd dah for example, but only if about say 16WPM. Below this speed it sounds a bit clipped or delayed. Above this speed, it just can't keep up and drops in and out. 
Continuity is there from the end of L3 through to the antenna socket.
It is not an RF problem in the traditional sense at least (antenna feedback) because the antenna is a balanced and resonant antenna caused no problems whatsoever on other QCXs before, nor on this one. 
I did as mentioned replace the band dependent capacitors, salvaging them from another broken QCX. If one of those capacitors is not ok after having removed it and put it in (I have no way to test capacitors), could that cause this effect?
There is absolutely no power variation on transmit, even when side tone drops out, power is solid, stable, very steady. 
Everything else on the rig seems to work fine, except for the 3 pots that are tuned via menu 8: the side band rejection and insertion pots: those, have little to no effect when trying to tune them, unlike on all other QCXs i have built, and have been like that also prior to this side-tone problem on this QCX. 
I assume something is wrong with one or more of those blue potentiometers, given little to know variation, or at least with the 2nd and 3rd one. 
That said, strong signals produce opposite sideband not being rejected, but normal signals have little to no opposite side band so there is some effect.
I mention this only as that is the only thing not working as expected on this rig, otherwise everything else is fine.

Any ideas where I should look or what could be causing this side tone drop out which makes sending impractical unless very slowly on the built in key? 


Alan G4ZFQ
 

Any ideas where I should look or what could be causing this side tone drop out which makes sending impractical unless very slowly on the built in key?
Lou.

Does it happen into a dummy load? Any antenna configuration can result in RF in the shack, maybe on just one band.

Why do you assume there is something wrong with the blue pots? The adjustment is critical, other things can affect balance.

73 Alan G4ZFQ