QCX Mini tactile switch not working but encoder does #qcxmini


Sean Walberg
 

I just finished building a QCX mini 40M and it booted up and I could select the band with a long press on the encoder, but the buttons don't work to bring up the menu. I see that the two tactile switches and the encoder button are wired together so if one works, they all should. I also noted that R44/R45 are supposed to form a voltage divider, but I just have blank pads there. And, for that matter, C100/Q100/R100/R48 up top are empty, too (the backlight doesn't work, but I wasn't sure if I need to enable it in the menu first)

Picture below... None of the SMD parts on the control and display boards are populated. Are they supposed to be?

Thanks,

Sean KN4ZMA

 

--
Sean Walberg <sean@...>    http://ertw.com/


KN6HGG
 

Ouch! Looks like you're at least missing the transistor and stuff for the backlight (Q100 and neighbors), and possibly the resistors for the buttons?


Mont Pierce KM6WT
 

On Tue, May 4, 2021 at 09:07 AM, Sean Walberg wrote:
None of the SMD parts on the control and display boards are populated. Are they supposed to be?
Yes...  ALL the SMDs are supposed to be pre-installed by the PCB manufacturer...

73
km6wt


Ed Pflueger
 

Yes R44 and 45 are populated.

 

Ed.. AB4IQ

 

From: QRPLabs@groups.io [mailto:QRPLabs@groups.io] On Behalf Of Sean Walberg
Sent: Tuesday, May 4, 2021 11:04 AM
To: qrplabs@groups.io
Subject: [QRPLabs] QCX Mini tactile switch not working but encoder does #qcxmini

 

I just finished building a QCX mini 40M and it booted up and I could select the band with a long press on the encoder, but the buttons don't work to bring up the menu. I see that the two tactile switches and the encoder button are wired together so if one works, they all should. I also noted that R44/R45 are supposed to form a voltage divider, but I just have blank pads there. And, for that matter, C100/Q100/R100/R48 up top are empty, too (the backlight doesn't work, but I wasn't sure if I need to enable it in the menu first)

 

Picture below... None of the SMD parts on the control and display boards are populated. Are they supposed to be?

 

Thanks,

 

Sean KN4ZMA

 

 

 

--

Sean Walberg <sean@...>    http://ertw.com/


N3MNT
 

It looks like those resistors are oriented wrong.


Mont Pierce KM6WT
 

On Tue, May 4, 2021 at 09:07 AM, Sean Walberg wrote:
I see that the two tactile switches and the encoder button are wired together so if one works, they all should.
Actually, S2 will not work if R44 is missing, and S3 will not work if R45 is missing.

The Rotary Encoder's switch will work as it is not in series with any of the missing resistors.


73
km6wt


Sean Walberg
 

Yes, sorry, what I meant was that they all connect to the same microcontroller pin, so it's unlikely that I made a soldering mistake on the connector or board if at least one of them works. From the schematic I saw the voltage divider and verified with an ohmmeter that S2/S3 don't work because there's nothing at R44/R45.

https://www.qrp-labs.com/images/qcxmini/2/1.jpg is a Rev1 board, but shows a bunch of stuff on the top populated (even though some other pictures on the QCX Mini page have them empty?)

I'm new to the QCX group, is the "Contact Us" link on the home page the best way to get this sorted out? 

Thanks,

Sean KN4ZMA


Mont Pierce KM6WT
 

On Tue, May 4, 2021 at 09:41 AM, Sean Walberg wrote:
is the "Contact Us" link on the home page the best way to get this sorted out? 
Yes :)