Topics

QCX+40 WSPR not working


Dennis Rieger
 

Just completed a QCX+40 and can't get WSPR to work. The kit consists of QCX+, TXCO, and QLG1. The unit was set up and aligned with no problems (Ref oscillator set to 25MHz). CW works with ~4 watts output.   QLG1 was used to calibrate Ref oscillator (25MHz) and System Oscillator (20MHz) with no problems. Went to Beacon mode. Set 6.2 to WSPR, 6.3 to 7,040,100.Set 6.4 frame to 10. Set 6.5 Start to 03. Set6.6 WSPR Call to KK5DB (space in front of call). Set 6.7 locator to DN18. Set Power to 37. 6.9 time set by GPS. Set 6.1 to ON.

I get the correct startup screen: 7,040,0100 WSPR on the top line followed by the time HH:MM:SS followed by <MM on the bottom line. When the transmit time is reached the bottom line goes blank for about 2-4 seconds and the top line does not change. Calibration then occurs as normal and the <MM jumps ahead 10 minutes. There is no transmission. I have run it with the GPS disconnected (after the time is set) and get the same result. I have also gone to the 4-Keyer mode and set the 4.7 Practice mode to both On and OFF, still with no WSPR transmission. I did a 7.11 Factory Reset and started over but still no luck. I did notice that the 6.7 WPSR Locator did not reset with the Factory Reset. Not a real problem, just an observation.

I'm not sure where to go from here. I have considered reloading the firmware (1.05) and even going back to 1.04 to see if that works. Does anyone have any experience with this problem?

Thanks
73
Dennis
KK5DB


Mike Besemer - WM4B
 

Start needs to be on an even minute.

 

Mike

WM4B

 

From: QRPLabs@groups.io [mailto:QRPLabs@groups.io] On Behalf Of Dennis Rieger
Sent: Sunday, July 26, 2020 9:48 PM
To: QRPLabs@groups.io
Subject: [QRPLabs] QCX+40 WSPR not working

 

Just completed a QCX+40 and can't get WSPR to work. The kit consists of QCX+, TXCO, and QLG1. The unit was set up and aligned with no problems (Ref oscillator set to 25MHz). CW works with ~4 watts output.   QLG1 was used to calibrate Ref oscillator (25MHz) and System Oscillator (20MHz) with no problems. Went to Beacon mode. Set 6.2 to WSPR, 6.3 to 7,040,100.Set 6.4 frame to 10. Set 6.5 Start to 03. Set6.6 WSPR Call to KK5DB (space in front of call). Set 6.7 locator to DN18. Set Power to 37. 6.9 time set by GPS. Set 6.1 to ON.

I get the correct startup screen: 7,040,0100 WSPR on the top line followed by the time HH:MM:SS followed by <MM on the bottom line. When the transmit time is reached the bottom line goes blank for about 2-4 seconds and the top line does not change. Calibration then occurs as normal and the <MM jumps ahead 10 minutes. There is no transmission. I have run it with the GPS disconnected (after the time is set) and get the same result. I have also gone to the 4-Keyer mode and set the 4.7 Practice mode to both On and OFF, still with no WSPR transmission. I did a 7.11 Factory Reset and started over but still no luck. I did notice that the 6.7 WPSR Locator did not reset with the Factory Reset. Not a real problem, just an observation.

I'm not sure where to go from here. I have considered reloading the firmware (1.05) and even going back to 1.04 to see if that works. Does anyone have any experience with this problem?

Thanks
73
Dennis
KK5DB


Bob Ballard
 

And your even minute must be accurate.  In other words don’t trust your watch or even your network-connected computer’s time unless you have recently calibrated it with an accurate world time source.

 

Bob – KG5SQJ

 

From: QRPLabs@groups.io <QRPLabs@groups.io> On Behalf Of Mike Besemer - WM4B
Sent: Sunday, July 26, 2020 9:05 PM
To: QRPLabs@groups.io
Subject: Re: [QRPLabs] QCX+40 WSPR not working

 

Start needs to be on an even minute.

 

Mike

WM4B

 

From: QRPLabs@groups.io [mailto:QRPLabs@groups.io] On Behalf Of Dennis Rieger
Sent: Sunday, July 26, 2020 9:48 PM
To: QRPLabs@groups.io
Subject: [QRPLabs] QCX+40 WSPR not working

 

Just completed a QCX+40 and can't get WSPR to work. The kit consists of QCX+, TXCO, and QLG1. The unit was set up and aligned with no problems (Ref oscillator set to 25MHz). CW works with ~4 watts output.   QLG1 was used to calibrate Ref oscillator (25MHz) and System Oscillator (20MHz) with no problems. Went to Beacon mode. Set 6.2 to WSPR, 6.3 to 7,040,100.Set 6.4 frame to 10. Set 6.5 Start to 03. Set6.6 WSPR Call to KK5DB (space in front of call). Set 6.7 locator to DN18. Set Power to 37. 6.9 time set by GPS. Set 6.1 to ON.

I get the correct startup screen: 7,040,0100 WSPR on the top line followed by the time HH:MM:SS followed by <MM on the bottom line. When the transmit time is reached the bottom line goes blank for about 2-4 seconds and the top line does not change. Calibration then occurs as normal and the <MM jumps ahead 10 minutes. There is no transmission. I have run it with the GPS disconnected (after the time is set) and get the same result. I have also gone to the 4-Keyer mode and set the 4.7 Practice mode to both On and OFF, still with no WSPR transmission. I did a 7.11 Factory Reset and started over but still no luck. I did notice that the 6.7 WPSR Locator did not reset with the Factory Reset. Not a real problem, just an observation.

I'm not sure where to go from here. I have considered reloading the firmware (1.05) and even going back to 1.04 to see if that works. Does anyone have any experience with this problem?

Thanks
73
Dennis
KK5DB


Dennis Rieger
 

Thanks for the comments.
The Start time was set to 4 minutes and the time is set by the GPS. I have checked the time compared to another GPS clock and an internet clock and they all agree to the second.

The real problem is that the QCX does not transmit. It gets to the point where it should and instead of transmitting it just rolls over to the next cycle after recalibrating the reference oscillator. It totally skips the 1 minute and 52 second transmission time, The display does not show the current symbol or the tone being transmitted on the top line, just the transmit frequency and WSPR. The second line is totally blank. It does not show my callsign, Maidenhead Locator, or power. It is just totally blank for a few seconds and then it shows the Reference Oscillator being calibrated if the GPS is connected. If I disconnect the GPS then of course even the oscillator calibration does not occur and it immediately starts counting down to the next attempt at transmitting. 

Thanks
73
Dennis KK5DB


Dennis Rieger
 

I finally found the problem. For some reason I don't understand the Beacon - 6.6 WSPR callsign section accepted my call, KK5DB with a space before the callsign as Hans specifies in the manual for a 5 character call. However, that does not work in T1.05. When I put the callsign in with no space prior to the callsign everything worked perfectly. Maybe it is something I am not comprehending about the statement in the manual. Anyhow, it works now.

73
Dennis, KK5DB


AJ4JE
 

I don't have a QCX, yet, but reading the manual, it looks like the space is needed for 1X callsigns, but not 2X callsigns.

James, AJ4JE


Tony McUmber
 

I thought I might need to start a new topic, but this one seems germain.  I have managed to get my QLG1 working with the QCX+ I just put together.  I am pleased to have accurate frequency control finally, having no other calibration tool available.

As to the time, well.. the QLG consistently sets the time about 3 seconds late compared to NIST time, which means that I must set the time manually anyway if I want to use WSPR.  Am I missing something?  Does anyone have a suggestion to fix this?  Also, I am powering the QLG1 from the PTT jack as shown in the latest instruction manual.  If I unplug the QLG when it is done, that action sends the time to 00:00 and I have to reset manually once again.

Tips?

Thanks!
N0BPA
73, 


Dennis Rieger
 

Tony,
My QCX+ paired with a QLG1 matches my QRP-LABS GPS clock and my internet clock within a second. I am using the same method you are using. I am getting power from the PTT port and am feeding the QLG1 information in on the paddle port. I can unplug the QLG1 and the time does not rest to 00:00 but if you turn the QCX off it will not retain the time and will reset to 00:00. I don't think a 3-second difference will prevent you from successfully using WSPR. Right now I have the QLG1 disconnected and the time has drifted about 1 second in the last 8 hours. It is still working and I am still seeing many hits on http://wspr.aprsinfo.com/.Try it, even with the 3-second offset and see what happens. Once you get the time set with the QLG1 try just unplugging it without turning the QCX off and see if the time still reads correctly.

73
Dennis KK5DB


Tony McUmber
 

As noted, I see that the time set by the QLG is about 3-4 seconds late compared to NIST UCT.  This is enough to cause the WSPR monitors to ignore it.  The clock resets whenever I unplug the power line for the QLG from the QCX, not only when I shut off the main power switch.  I puzzlement.

Thanks for the input!

Tony N)BPA


Arv Evans
 

Tony N)BPA

In the past there have been comments regarding polarity of the GPS tick affecting 
clock setting.  Nor sure if that is at work here?

If relying on NIST via a PC using NTP...there could be some errors there in how it 
tracks time on your particular OS and computer hardware.  WWV or WWVB time 
references are probably the most accurate after GPS, but rumor has it that WWV 
transmissions may be discontinued soon.

It might be possible to extract accurate time references from DGPS (Differential GPS) 
which transmits offset strings to make GPS more accurate.  DGPS correction factor 
information are transmitted on various LF transmitters in specific geographic areas.


Arv  K7HKL
_._


On Tue, Jul 28, 2020 at 11:32 AM Tony McUmber <tmcumber@...> wrote:
As noted, I see that the time set by the QLG is about 3-4 seconds late compared to NIST UCT.  This is enough to cause the WSPR monitors to ignore it.  The clock resets whenever I unplug the power line for the QLG from the QCX, not only when I shut off the main power switch.  I puzzlement.

Thanks for the input!

Tony N)BPA


Tony McUmber
 

I have been using WSPR with good success for the past couple of years with my original QCX.  Always have used NIST website for time -- they claim that the time tick is corrected for network delays.  I have no had a problem with the time when doing this.  My old QCX drifts away from the set time after a while, and if off by 2 seconds or more my observed hits diminish to none.

With the new QCX+ I use the same time setting routine and have good luck with it, plus the new rig holds the time better. The problem is this:  when I use the QLG1 to set the time clock on the rig, the result displayed is always about 3 seconds late compared to the NIST reference I have always used with good results.  The three second delay keeps me from getting good results on WSPR.  When I then correct the time manually, I get the usual good results, and the rig holds the time accurately for longer.  The NIST time is not the problem, the QLG1 time seems to be the problem in that it does not match the NIST Standard UTC tick.  I may have made an error in assembly, but I do not see one.  Also, when I unplug the QLG1 power plug from the QCX, this action causes the displayed time to reset to 00:00.

I am unable to access WWV signals because I do not have the equipment to do so, but getting accurate time is not my problem.

Thanks for the feedback.

73 N0BPA


Gregg Myers
 

Hi Tony,

I saw your post and was curious about my QLG1 time compared to a WWVB corrected clock I have. When I first started up the QLG1, I saw a 2-3 second discrepancy between the two but after a few minutes (maybe 5 min), the two times were suddenly in lock step. Did you try leaving the GPS powered up for some time? Also, I don't know if you tried moving the GPS unit where it had an unobstructed view of the sky just to maximize the number of satellites received as a test?

73,
Gregg



On Tue, Jul 28, 2020 at 3:27 PM Tony McUmber <tmcumber@...> wrote:
I have been using WSPR with good success for the past couple of years with my original QCX.  Always have used NIST website for time -- they claim that the time tick is corrected for network delays.  I have no had a problem with the time when doing this.  My old QCX drifts away from the set time after a while, and if off by 2 seconds or more my observed hits diminish to none.

With the new QCX+ I use the same time setting routine and have good luck with it, plus the new rig holds the time better. The problem is this:  when I use the QLG1 to set the time clock on the rig, the result displayed is always about 3 seconds late compared to the NIST reference I have always used with good results.  The three second delay keeps me from getting good results on WSPR.  When I then correct the time manually, I get the usual good results, and the rig holds the time accurately for longer.  The NIST time is not the problem, the QLG1 time seems to be the problem in that it does not match the NIST Standard UTC tick.  I may have made an error in assembly, but I do not see one.  Also, when I unplug the QLG1 power plug from the QCX, this action causes the displayed time to reset to 00:00.

I am unable to access WWV signals because I do not have the equipment to do so, but getting accurate time is not my problem.

Thanks for the feedback.

73 N0BPA


Tony McUmber
 

This seems like a good an helpful suggestion.  No, I have not left it on for an extended period, not realizing that this could make a difference.  I will give it a try.  Thanks!

Now if someone can help me understand why my clock resets to 00:00 when I unplug the QLG1 power plug from the PTT jack...

73, Tony N0BPA


 

If I'm understanding correctly what's going on for you...

As I use the same QLG for two QCX rigs, I leave the power connected to one of them, and move only the signals from the one to the other (using a split ribbon cable). it maybe that removing the power causes a diode pull-down or something that trgiggers a reset. I'll try removing only the power from the actively connected unit when I'm up in my shed where the rigs are, tomorrow.

Julian N4JO

On 7/28/2020 10:19 PM, Tony McUmber wrote:
This seems like a good an helpful suggestion.  No, I have not left it on for an extended period, not realizing that this could make a difference.  I will give it a try.  Thanks!

Now if someone can help me understand why my clock resets to 00:00 when I unplug the QLG1 power plug from the PTT jack...

73, Tony N0BPA


Tony McUmber
 

You understand correctly.

I'll be eager to read your results.  If I am not the only one who experiences this, maybe there is a solution for a future modification.  If it's just me, then all hope is lost :)

Tony N0BPA


Mike Besemer - WM4B
 

My GPS is installed inside the case and permanently hardwired to the qcx. I installed a double pole single throw miniature toggle switch on the back panel to take the GPS Data and 1pps out of line when I'm using CW or editing in the menus. That works fine.

I also installed a toggle switch on the back panel to turn off the backlight.

Mike
WM4B