Topics

Trying to upload new firware to blank atmel #qcx #firmware

naxgal79@...
 

Hello, after a +12v cable touched my lcd screen connections, i burned the lcd and propably something inside the Atmel. I have replaced the LCD and everything in the menu work. The problem is that there is no tone on the 8.7,  8.8 menu no oputput power, etc.
Hans suggest me to write a new Atmel and send me some files, i want please someone to tell me how to do it.
i have an arduino UNO and make some projects but never tried to upload hex and eep filed through a ISP
so for now, i have upload the scetch  arduinoISP to the UNO and made the tools -programmer-  arduino as isp
made a 6 pin cable to connect arduino with isp
changed the fault arduino with a new blank one on the qcx
please give me some help,
Thanks
George SV2SBE

Simas Pudziuvelis
 

Hey, have you tried using AVRDUDESS? It's a GUI for avrdude.exe and it really makes everything simple. There is a tutorial on QCX page: https://www.qrp-labs.com/qcx/qcxfirmware.html

Simas Pudziuvelis
 

But you will also have to select EEPROM Hans gave you, because it won't work otherwise

TrueBlue
 

On Sun, Jun 2, 2019 at 07:36 AM, Simas Pudziuvelis wrote:
There is a tutorial on QCX page: https://www.qrp-labs.com/qcx/qcxfirmware.html
It's worth noting that there's an omission/error on this that has never been corrected:

"e:  Select ATmega328 as the MCU"

This will only work if the chip is 328 and not a 328P.  This is not usually the case...but sometimes it is.  Pick the correct unit or it won't go.

Otherwise, this works OK.  I've tried it a few times with my trusty $3.84 (shipped) generic Uno R3, which has survived numerous coffee and tea spills.

http://img.dxcdn.com/productimages/sku_370842_1.jpg

You can also use a USBasp, usually eBayable for under $2 (shipped).

Good luck!