Date   

Re: QCX Dew can Do you in

Don DeGregori
 

You are probably right. It's been up for a long time, an Alpha-Delta CC set as an Inverted V. Probably never paid much attention running 100 watts. Don't think insulators are ceramic, but ribbed and good quality at the time.


Re: QCX 40 m. Audio but no signal

James Anderson
 

Hello to all. 


I eventually found time to replace IC9 and can report that I now have my QCX40 back up and running. 


hope it helps others. 73, James. 


Re: #qcx Firmware version 1.02 release #qcx

Hans Summers
 

Hello Guido
 
It was very good to meet you in person last Saturday on the VERON day, and thank you very much to have some follow up on the LCD_RS pin sharing topic we discussed and the related woodpecker interference. 

A pleasure to meet you finally, too! 
 
Wow, what an improvement with T1.02, the woodpecker is completely gone. But I also got stuck with a blank screen initially, and it was not because of firmware issues; after replacing the older LCD with a newer one (exactly identical one) the display worked correctly.

Please try T1.02a. It should fix it and work for all displays. 

73 Hans G0UPL


Re: 20 Watt QRPLabs Dummy Load for Sale?

Mark K0ABD
 

Thanks all for the helpful suggestions. I also appreciate those who have contacted me directly via email & taken the time to instruct me.


Re: #qcx Firmware version 1.02 release #qcx

Bill Cromwell
 

Hi,

It is really encouraging to see this resolved so quickly and all of those positive replies rolling in. I learned more about programming than I ever wanted to know just reading between the lines:)

73,

Bill KU8H

--
bark less - wag more


Re: #qcx Firmware version 1.02 release #qcx

Guido PE1NNZ
 

Hi Hans!

It was very good to meet you in person last Saturday on the VERON day, and thank you very much to have some follow up on the LCD_RS pin sharing topic we discussed and the related woodpecker interference. 

Wow, what an improvement with T1.02, the woodpecker is completely gone. But I also got stuck with a blank screen initially, and it was not because of firmware issues; after replacing the older LCD with a newer one (exactly identical one) the display worked correctly.

Are you giving the RS pulse just after the data is settled?

73,
Guido


On Friday, November 8, 2019, Hans Summers <hans.summers@...> wrote:
Hi Aug

You definitely have trouble with at least one of your fingers but I am glad to hear that 1.02a is working fine for you now. 

Awaiting some other reports too please, from anyone who had blank display on 1.02. 

So I imagine what happened, is variations in batches of LCD modules. I make QCX kits these days in batches of 1000 at a time and the LCD modules are custom-manufactured specially for me. If you look at the right side of the module you will see that there are two LEDs. The cheaper blue/white eBay AliExpress etc LCD modules have only one LED. At one point I was considering switching to the common type, to lower my costs. But I compared the two side-by-side under identical conditions and the difference in display quality was quite significant, plenty to convince me to stay with my nice custom-made ones. But... I digress... I expect what happened was just minor variation in components from one batch to another. The aggressive short pulse I used in 1.02 must have been just a bit on the too-aggressive side. So now in 1.02a it is a couple of CPU cycles longer, enough to keep all the LCDs happy. This is my theory :-)

Two points to note:

1) The "woodpecker" is still cured, both with the too short pulse and the less short pulse

2) The shortened pulse was the LCD_E signal which clocks in the data to the LCD. In 1.02a the pulse length on this signal is the same as it was in all previous firmware versions. Therefore if the theory about pulse length is correct, there is NO risk that the length will still not be enough - because now it is the same as it was previously. The LCD_RS signal is put to low after clocking in the data with LCD_E, just the same as in 1.02. 

For anyone who ordered a QCX, or an upgrade chip... don't worry... we didn't send them yet :-D   For some reason age and experience led to slight alterations in default characteristics, including increased levels of PESSIMISM, so I had decided to wait a day or two to see if anything like this happened ;-)

Any other feedback on 1.02a? If nothing else is reported amiss, I will ship out all the orders on Monday. Using 1.02a. 

73 Hans G0UPL

On Fri, Nov 8, 2019 at 6:39 AM August Treubig <atreubig@...> wrote:
Finger Graphical Error  
no longer blank with !.02a..

Aug
AG5AT


Trying to load T1.02 Firmware in QCX

David R. Hassall WA5DJJ
 

Dear Hans,

 

Thank you.   I tried your new T1.02a file this morning and it worked perfectly.   Now to get the 15 QCX’s updated and see what the difference it makes on the WA5DJJ QRSS SUPER GRABBER.  

 

Take care and have fun.

 

73 Dave Hassall WA5DJJ  Las Cruces, New Mexico

Website: http://www.zianet.com/dhassall/

QRSS SUPER GRABBER WEBSITE: http://www.qsl.net/wa5djj/

 


Re: 20 Watt QRPLabs Dummy Load for Sale?

Mark K0ABD
 

I appreciate the response, Alan.

Nice to know I don't have to wait until I get a dummy load/antenna to start practicing. This rig may have been built in 2017 or 2018. I just got it & haven't powered it up yet because I don't have a battery. After I obtain one I'll have to check the firmware to ensure it's the latest.

thanks,

Mark


Re: qsx

Hans Summers
 


Hi Alan
 
Quick question following up on the prior bpf/lpf note.  Will the native frequency of the QSX then allow operating on 6 m as well by simply properly selecting the filters, and sw, or will 6 m require some other hw mods?

Good question. The Quadrature Sampling Detector (QSD) will operate at 6m. The quadrature Local Oscillator (LO) will also work at 6m (I am not using 4x and divide-by-4). Technically the radio would be capable of 6m operation. However, the losses are greater on 6m, and the band noise is much lower. Higher sensitivity is required, generally requiring a pre-amp. Which is already the case for 10m... so whether or not any hardware modifications for 6m will be needed, still remains to be seen. I don't have an exact answer yet. 

73 Hans G0UPL


Re: qsx

alan bohne
 

Greetings
Quick question following up on the prior bpf/lpf note.  Will the native frequency of the QSX then allow operating on 6 m as well by simply properly selecting the filters, and sw, or will 6 m require some other hw mods?
tnx
Alan, K1ARW

On Fri, Nov 8, 2019 at 6:48 AM terry hughes via Groups.Io <terryhugheskirkcudbright=yahoo.co.uk@groups.io> wrote:
hello Hans

is the band determined solely by the bpf and lpf and software settings

if so will it be feasible to change the values to operate on 14 m c/s instead of 7 m c/s

possibly using your bpf and lpf filters from your shop

terry gm4dso



Re: #qcx Firmware version 1.02 release #qcx

Hans Summers
 

Ok Karlis

Good idea... how does this look:

73 Hans G0UPL

On Fri, Nov 8, 2019 at 3:32 PM Kārlis Goba <karlis.goba@...> wrote:
Hi Hans,

just a suggestion - if you'd release the files as archives (.zip), it would save all the trouble with renaming files and automatic extensions, plus the trouble with HTML MIME types and browser interpretation of them.

ZIP files are supported natively in pretty much any OS nowadays, one doesn't have to install any extra software to extract them.

--
Karlis YL3JG


Re: 20 Watt QRPLabs Dummy Load for Sale?

Alan G4ZFQ
 

You're saying that it is totally safe to turn on my QCX40 & practice, without an aerial or dummy load, just as long as I don't transmit?
Mark,

Totally safe if you do not make a mistake and transmit!
The reason a dummy load is recommended is that it has happened in the past. Since then the firmware has been modified to make it less likely, but not impossible.
Also it has been said that alignment sometimes works better if a load is present although that is not so important.

73 Alan G4ZFQ


4 line LCD for the clock kit #clock

Greg Walters
 

Can someone point me in the right direction to find a 4 line LCD that I can use for the clock kit? Is there one that would directly apply, pin for pin?

I am not knowledgeable in LCDs and would find it nice to have a link to where I could purchase one. 

I'm in the United States, so a link to somewhere reasonably close would be wonderful.

Thanks, 
--
73,
Greg
KY4GW


Re: #qcx Firmware version 1.02 release #qcx

Kārlis Goba
 

Hi Hans,

just a suggestion - if you'd release the files as archives (.zip), it would save all the trouble with renaming files and automatic extensions, plus the trouble with HTML MIME types and browser interpretation of them.

ZIP files are supported natively in pretty much any OS nowadays, one doesn't have to install any extra software to extract them.

--
Karlis YL3JG


Re: 20 Watt QRPLabs Dummy Load for Sale?

Mark K0ABD
 

Thanks for replies, all.

I would have responded sooner, except I had no internet yesterday & only partially on Wednesday.

Mark/K0ABD


Re: 20 Watt QRPLabs Dummy Load for Sale?

Mark K0ABD
 

On Thu, Nov 7, 2019 at 08:36 AM, Marty Squicciarini wrote:
QRP Guys
Marty,

Someone else contacted me via email & suggested that. Currently I have no soldering iron. I'd like to wait until I can get a decent one, because from what I now understand I can't skimp on a soldering iron. I'll have a look at that website to see if they offer an assembled one for sale.

thanks,

Mark/K0ABD


Re: 20 Watt QRPLabs Dummy Load for Sale?

Mark K0ABD
 

Hi Richard,

The reason I brought this up is that another QRPLabs Group member told me he fried the output transistor of his QCX40 when turning it on after assembly.

You're saying that it is totally safe to turn on my QCX40 & practice, without an aerial or dummy load, just as long as I don't transmit?

This means I don't need to wait to familiarize myself with my new rig until I obtain one of these.

Although, if I start to build my own from kits it would be a good idea to get one.

thank you,

Mark/K0ABD


Re: #qcx Firmware version 1.02 release #qcx

Jason M.
 

1.02a has resolved the blank screen issue for me as well.


Re: #qcx Firmware version 1.02 release #qcx

Alan G4ZFQ
 

I am aware of the critical difference between k and K and I do strive to
Hans,

Yes, sorry I should not have addressed the post to you!
The last time I looked at Ubuntu I thought how it was attempting to be like Windows so maybe that's the reason for a K:-)

73 Alan G4ZFQ


Re: QCX rotary encoder remote button issue #qcx #problem

Hans Summers
 

Ok Luc, Karlis

So I should make some firmware change to try to more fiercely debounce your crappy buttons. 

If you would send me some ones that show the symptoms, I will do it. 

73 Hans G0UPL

On Fri, Nov 8, 2019 at 2:57 PM Luc ON7DQ <on7dq@...> wrote:
Hans & others,

Just to add some momentum ... I also had this problem, but didn't consider it too serious to report.
But in my QCX20, using the internal buttons, never had any problem.
In my QCX40 I used off-board buttons (also the cheapo chinese ones), see picture (buttons were in the cover and soldered to the wires later).
the wires are somewhat twisted but not shielded.
I just did a test : go into the menu 10 times, then go to menu 4.1, change keyer type , and use the right button to exit.
This failed 6 out of 10, the right button put me back in 4.1 

Luc ON7DQ