Re: Mini 40 Display Issue Restart


Steven Dick
 

"1.  Both mini 20 and mini 40 IC2s work in mini 20 but no backlight. "  Assuming menus in both units are set correctly for enabling backlight, if I understand this statement,  there is a problem with mini 40's IC2 relating to the LCD circuitry if IC2 from the mini 20 works WITH backlight in the mini 20, and IC2 from the mini 40 works but WITHOUT backlight in the mini 20. So IC2 is likely damaged or has a hairpin piece of wire shorting pin 14 to an adjacent pin (unlikely).  Pin 14,  does double duty.  It is used for communication with the LCD during LCD updates and it is used to control turning on Q100, the display switch  Some of the symptoms indicate no communication to the LCD which will occur if pin 14 of IC2 not working properly. Check soldering around pin 14 of the LCD on the mini 40 display module - make sure there are no shorts to adjacent pins such as short between pin 14 to 15 or 14 to 13.   If there is a short, it may have damaged IC2 by applying 12 volts to it through the 560 ohm current setting resistor when the LCD's LED is not activated by Q100.

-Steve K1RF

------ Original Message ------
From: "hamhog1" <gwgrogg@...>
Sent: 2/6/2021 10:19:19 AM
Subject: [QRPLabs] Mini 40 Display Issue Restart

I decided to restart from the beginning in troubleshooting my Mini 40.  All I have is the top row of blocks.
Using the Troubleshooting guide, I did the following:
1.  Adjusted R36.
2.  Made sure IC2 was inserted correctly.
3.  Check to be sure no bent pins.  All were seated correctly.
4.  I heard the 20 mhz crystal at 20.005 mhz on shack receiver.  Also saw on scope.
Next I swapped the display board, IC2, and controllers with my Mini 20 which works well.  What I observed:
1.  Both mini 20 and mini 40 IC2s work in mini 20 but no backlight.  Neither IC2s seem to work in mini 40 but with backlight and top row. of blocks.
2.  Both display boards work in mini 20 but no backlight.  Both display boards show top row of blocks in mini 40 with backlight.
3.  Both controller boards work in mini 20 but no backlight.  Both controller boards show top row of blocks in mini 40 with backlight.
Conclusion:  IC2 in mini 40 appears to be okay.  Display board in mini 40 appears to work okay.  Controller board in mini 40 appears to be okay.
Next I measured voltages with my digital multimeter using the voltage sheet from the manual as a guide.
1.  All readings were nominal down to the reading for left side of C45.  Showed 1.28 v instead of 2.42 v. Also C46 showed .85 v instead of 2.30 v.
2.  I did not check ICs 5-10 at this time.
3.  LCD pin 6 showed .48 v instead of 0 v.
4.  LCD pins 7-11 all showed 4.94 v which is quite high.
5.  LCD pin 14 showed 4.94 v instead of 0 v.
6.  LCD pin 15 showed 3.71 v instead of 4.41 v.
Finally I checked continuity and resistance between LCD and IC2 with IC2 removed.  It showed 0.0 ohms resistance.

Trying not to get frustrated.  It probably is something simple, but where to look?

Thanks for any help.
Gary K4VIG


Virus-free. www.avast.com

Join QRPLabs@groups.io to automatically receive all group messages.