Re: Lost Package?


Tim Boyer
 

Give it some time. USPS is notoriously slow lately. I recently sent a package from Cincinnati to Boston and it took 3 weeks! I too received the same message as you did. That's why I thought I'd share it with you. I was about to file a claim, but then it arrived. Better off using any other delivery service if you can. Best of luck. But be prepared to be patient.


On Wed, Jun 26, 2019, 12:58 AM Dan Rahn <k8ec@...> wrote:
Did anyone else place an order on or about June 12 that shipped from US (Missouri) and has not yet been delivered? It shipped on the 13th and estimated to be delivered on the 17th. The last movement was on June 13th, "Departed Post Office SEDALIA, MO 65301" Here we are, 8 days after the estimated delivery date and the tracking still says: "Your package will arrive later than expected, but is still on its way. It is currently in transit to the next facility." I'm preparing to file a "missing mail search request" for which the USPS wants additional details I do not have and I have not yet heard back from QRP Labs. I place no blame on QRP Labs for this as it was shipped promptly from the US distribution site, but it has been rather disheartening as I was really looking forward to building this kit and I am growing ever more impatient with the USPS. I feel I waited less time for the 40m QCX that shipped from Turkey!

On a side note, does anyone have pictures of an unopened, kitted up 20m QCX  & dummy load they can send me? There is a place to add pictures on the USPS lost mail search site and maybe this will aid in the search.

Join QRPLabs@groups.io to automatically receive all group messages.